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Copyright © Copyright 2007 Willtek Communications GmbH. All rights reserved. Willtek and 
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written permission of the publisher.
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Purpose and scope
The purpose of this guide is to help you successfully use the 9102 Handheld Spec-
trum Analyzer features and capabilities. This guide includes task-based instruc-
tions that describe how to install, configure, use, and troubleshoot the 9102 
Handheld Spectrum Analyzer. Additionally, this guide provides a description of 
Willtek’s warranty, services, license, and repair information as well as the soft-
ware license agreement.

Assumptions
This guide is intended for novice and intermediate users who want to use the 
9102 Handheld Spectrum Analyzer effectively and efficiently. We are assuming 
that you are familiar with basic telecommunication concepts and terminology.

Related information
Use this guide in conjunction with the following information:

Willtek 9100 Handheld Spectrum Analyzer Series: getting started manual, order 
number M 295 204

Willtek 9100 Handheld Spectrum Analyzer Series: applications guide, M 290 504

Willtek also offers a glossary on “Spectrum and network analysis” terms. The 
order number is SPEC/CT812/0105/EN.

Technical assistance
If you need assistance or have questions related to the use of this product, call 
Willtek’s technical support. You can also contact Willtek by e-mail at 
customer.support@willtek.com.

Table 1 Technical assistance centers

Region Phone number Fax number

Europe, Middle East, 
Asia, Africa

+49 (0) 89 996 41 311 +49 (0) 89 996 41 440

Americas +1 973 386 9696 +1 973 386 9191

China +86 21 5836 6669 +86 21 5835 5238
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Conventions
This guide uses naming conventions and symbols, as described in the following 
tables.

Table 2 Typographical conventions

Description Example

User interface actions appear in this 
typeface.

On the Status bar, click Start.

Buttons or switches that you press 
on a unit appear in this TYPEFACE.

Press the ON switch.

Code and output messages appear 
in this typeface.

All results okay

Text you must type exactly as 
shown appears in this typeface.

Type: a:\set.exe in the dialog 
box.

Variables appear in this <typeface>. Type the new <hostname>.

Book references appear in this type-
face. 

Refer to Newton’s Telecom Dictio-
nary

A vertical bar | means “or”: only one 
option can appear in a single com-
mand.

platform [a|b|e]

Square brackets [ ] indicate an 
optional argument.

login [platform name]

Slanted brackets < > group required 
arguments.

<password>

Table 3 Keyboard and menu conventions 

Description Example

A plus sign + indicates simultaneous 
keystrokes.

Press Ctrl+s

A comma indicates consecutive key-
strokes.

Press Alt+f,s

A slanted bracket indicates choos-
ing a submenu from menu.

On the menu bar, click 
Start > Program Files.
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Table 4 Symbol conventions

This symbol represents a general hazard.

This symbol represents a risk of electrical shock.

NOTE

This symbol represents a note indicating related information or tip.
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Safety Notes

This chapter provides the safety notes for the 9102 Handheld Spectrum Analyzer. 



Safety Notes
Safety warnings

xx 9102 Handheld Spectrum Analyzer Software version 5.10

Safety warnings
This product is designed for indoor use. As exposure to water can damage the 
instrument it has to be protected against moisture when used outdoors.

WARNING

This is a safety class A equipment in accordance with EN 61326. It may pro-
duce radio interference affecting household equipment; the user may be 
forced to execute appropriate measures against radiation.

WARNING

Only use a 50 Ω N-type connector to connect to the RF IN port of the 9102. 
Use of any other connector may result in damage of the instrument.

WARNING

Do not cover the ventilation slits (at the bottom left-hand corner and on the 
top). Covering them may result in serious damage and fire.

WARNING

The maximum input power level at the RF IN connector is 30 dBm (1 W). 
Higher input levels may result in serious damage of the instrument.

WARNING

Operate the instrument within the temperature range from 5°C (40°F) to 
45°C (110°F) only. Operation outside this range will lead to invalid results.

Safety advice for the battery

Do not crush. Do not heat or incinerate. Do not short-circuit. Do not disman-
tle. Do not immerse in any liquid, it may vent or rupture! Do not charge below 
0°C (32°F) nor above 45°C (110°F). 

Battery usage

The battery is for use with the 9102 only. Willtek does not accept any liability 
for damage of the battery or other equipment if the battery is used with other 
electric or electronic equipment.

WARNING

The 9162 Insertion Power Sensor may be hot during and after operation.

WARNING

Do not feed more than +47 dBm into the 9162 Insertion Power Sensor, the 
device may be destroyed otherwise.
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Chapter 1 Overview

This chapter provides a general description of the 9102 Handheld Spectrum 
Analyzer. Topics discussed in this chapter include the following: 

– “About the 9102 Handheld Spectrum Analyzer” on page 2

– “What’s new” on page 2

– “Features and capabilities” on page 4

– “Options and accessories” on page 5

– “Physical description” on page 9

– “Maintaining your unit” on page 10
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About the 9102 Handheld Spectrum Analyzer
The 9102 is a lightweight, full-featured spectrum analyzer for many applications:

– Installation troubleshooting, repair and maintenance.

– Acceptance and installation troubleshooting of antenna and cable 
installations.

– Assessment and verification of electromagnetic radiation to verify against 
EMI.

– Production test and alignment of the output of RF modules.

– Field measurements and verification of base station emissions.

– Used to detect and locate faulty mobile phone parts and components.

Typical measurements with the 9102 Handheld Spectrum Analyzer include trans-
mitter testing, alignment of modulators and measuring switch breakthrough. 
Additional options such as a tracking generator option, the 9160 VSWR/DTF 
Bridge and the 9130 VSWR/DTF Reflection Measurement Option expand the 
capabilities of the 9102 towards a scalar network analyzer. The analyzer is fully 
controllable via front panel or by remote control from a PC. 

For base station installation or maintenance engineers the 9102 offers the full 
scope of common performance measurements of the BTS antenna systems: 
Return Loss (Reflection), Tower-Mounted Amplifier (Transmission) and Distance 
to Fault measurement with a standard resolution of 500 points (min. 0.05 m) in 
one lightweight device.

Measurement results and instrument settings can easily be transferred to a PC 
for presentation or post-processing. This rugged instrument is suitable for 
stationary and mobile usage and meets many application needs.

What’s new

Version 5.12 In DTF mode, the VSWR unit is displayed.

Version 5.10 Supports external time base (reference frequency), shown in 9100 Data Exchange 
when active.

Improved remote control commands for Power Sensor mode.

Version 5.00 New options supported:

– 9168 GPS Receiver Option

– 9162 Insertion Power Sensor

– 9151 Frequency Extension 7.5 GHz
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New features in 9100 Data Exchange Software version 5.00

– Marker description with break-out line can be added to the trace

– Trace data or graphics can be copied to the clipboard and pasted into a word 
processor or spreadsheet application

– Printout header can be defined

Version 4.50 In DTF mode, the calibration cable dielectric and length can be entered.

Minor corrections.

Version 4.11 Improvements:

– Trace average function corrected.

– Too low sweep time at 200 kHz RBW now gets an UNCAL warning.

Version 4.10 New features:

– Supports 100 Hz and 300 Hz RBW filters, 10 kHz span and 250 s sweep time 
in 9101B and 9102B models. Those features are not available for older 
instruments.

Improvements:

– SCPI remote control bugfix for marker value.

Version 4.01 New features:

– New EMF (EMI) Measurement Option.
For an extensive description of the new EMF (EMI) measurement mode 
available with this option refer to Chapter 11 “EMF (EMI) Operation”.

– New features within the 9100 Data Exchange Software supporting the new 
EMF (EMI) Measurement Option.
For further details refer to Chapter 14 “9100 Data Exchange Software”.

– New trace finder functionality.
For further details refer to “Trace finder” on page 19 in 
Chapter 1 “Overview”.

Version 3.10 New features:

– New VSWR/DTF Reflection Measurement Option including the measurement 
modes reflection, distance to fault and cable loss

– Marker functionality: six markers for all measurement modes, markers can 
be set on trace A and trace B.
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– New look and feel of the parameter windows

– Direct printing

– New Printer Config menu

– RMS Option with RMS detector

– Absolute and relative display within Transmission mode

– Trace offset by division within Transmission mode

– Trace Memory menu: functions Store Trace and Recall Trace act on both 
traces.

– Channel Power mode: Measure menu moved to main menu.

– Specific backlight display settings for operation on battery to save energy.

Improvements:

– Full support of external device in the Mode window

– Improved frequency counter

– Improved Level StepDown functionality of MinValue

– Improved Color Scheme menu: eight input fields available for all screen 
components

Version 3.01 New feature:

New function in the Trace Function menu: Add A + B → A. For a description of 
these functions refer to the “Setting up the trace” sections of in 
Chapter 3 “Spectrum Analysis Operation” and Chapter 4 “Channel Power Opera-
tion”.

Improvement:

Measure menu improved. Access to Measure menu from Spectrum Analysis main 
menu.

Features and capabilities
– VSWR and DTF measurements supporting antenna installation and verifica-

tion (option) 

– Tracking generator option enables cable measurements in the field 

– Radiation measurements of base stations and broadcast stations (EMF 
option) 

– Scalar network analysis (amplifier gain over frequency or filter characteris-
tics) and antenna measurements 

– Prequalification for EMC (electromagnetic compatibility) tests 

– Displayed average noise level at –117 dBm 

– Dynamic range of 70 dB 
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Options and accessories
The following options and acessories are available:

Table 5 Options for the 9102 Handheld Spectrum Analyzer 

Order number Description

M 897 261 9130 VSWR/DTF Reflection Measurement Option

M 897 274 9131 EMF Measurement Option

M 897 275 9132 RMS Detector Option

M 248 966 9160 VSWR/DTF Bridge

M 248 804 Tracking Generator Upgrade

M 248 811 9168 GPS Receiver Option

M 248 968 9162 Insertion Power Sensor

M 230 035 9151 Frequency Extension 7.5 GHz

Table 6 Accessories for the 9102 Handheld Spectrum Analyzer 

Order number Description

M 205 012 Battery module (rechargeable, 7.2 Ah)

M 241 015 9100 outdoor backpack

M 241 013 9100 soft carrying bag

M 204 097 1500 battery charger

M 248 328 9100 power supply

M 860 389 9100 12 V car adapter

M 867 037 9100 safety lock

M 897 137 9100 Data Exchange Software

M 860 388 9100 serial communication cable

M 248 640 1205 RF Probe 20 dB (includes N to BNC adapter)
frequency range 100 kHz to 4 GHz
RF attenuation (nominal at 50 Ω) 20 dB
including adapter N (male), BNC (female)

M 248 971 1207 Inductive Probe
frequency range 4 MHz to 6 GHz
30 dB amplifier 

M 860 368 9170 Biconical Antenna

M 248 809 9171 Isotropic Antenna

M 860 158 9172 Directional Antenna, 80 to 1000 MHz

M 860 159 9172 Directional Antenna, 300 to 3000 MHz

M 860 264 Antenna, 400 MHz band (TNC)
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M 860 261 Antenna, 900 MHz band (TNC)

M 860 262 Antenna, 1800  MHz band (TNC)

M 860 260 Antenna, 1880 MHz band (BNC)

M 860 146 Antenna, 2400 MHz band (TNC)

M 886 098 Adapter N (male) to TNC (female)

M 886 097 Adapter N (male) to BNC (female)

M 886 205 Matching pad N 50 Ω to N 75 Ω

M 886 204 Matching pad N 50 Ω to F 75 Ω

M 874 061 Attenuator 18 GHz, 6 dB

M 860 548 Calibration set Open/Short/Load,
type DIN 7/16 inch male

M 860 549 Calibration set Open/Short/Load,
type N male

M 860 396 Composite cable 10 m for 9171

M 860 256 Antenna tripod

M 860 395 Bag for antenna tripod

M 897 828 OASIS Spectrum Monitoring Software

9100 battery module

1500 battery charger

Table 6 Accessories for the 9102 Handheld Spectrum Analyzer  

Order number Description



Chapter 1 Overview
Options and accessories

9102 Handheld Spectrum Analyzer Software version 5.10 7

9100 soft carrying bag

9100 outdoor backpack

9100 12 V car adapter

9100 safety lock

9100 serial communication cable

1205 RF Probe 20 dB 
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1207 Inductive Probe

9168 GPS Receiver Option

9162 Insertion Power Sensor

9170 Biconical Antenna

9171 Isotropic Antenna

9172 and 9173 Directional 
Antennas

Antenna 900 MHz band (TNC)
Antenna 1800 MHz band (TNC)
Antenna 1880 MHz band (BNC)
Antenna 2400 MHz band (TNC)
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Physical description
The 9102 Handheld Spectrum Analyzer is delivered with the 9100 Data Exchange 
Software which can also be ordered separately.

The user-accessible parts of the 9102 can be broken down into several sections:

– Front panel with large screen, softkeys, numeric, cursor and function keys.

– Connectors accessible from the top and the left-hand side of the 9102.

– On/off switch, power supply connector and battery shelf.

– Handle which can be turned in steps to serve as a stand, allowing the 9102 
to be operated at an angle.

Adapter N - TNC
Adapter N - BNC

Matching pad N 50 Ohm to 
N 75 Ohm
Matching pad N 50 Ohm to 
F75 Ohm

Attenuator 18 GHz, 6 dB

Calibration Set Open/Short/Load, 
type DIN 7/16 inch male

Calibration Set Open/Short/Load,
type N male
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Maintaining your unit
The 9102 Handheld Spectrum Analyzer is a measurement device. As with all such 
instruments, the 9102 should be calibrated on a regular basis to ensure accuracy. 
Willtek recommends calibration of the 9102 at yearly intervals.

Please take also advantage of our Frequently Asked Questions and our electronic 
newsletter, both available on the Internet.

Further questions regarding the 9102 Handheld Spectrum Analyzer can be 
directed to customer.support@willtek.com.
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Chapter 2 General Operation

This chapter describes the instrument’s functions that are independent of the 
selected mode. Topics discussed in this chapter are as follows:

– “Connecting the 9102 Handheld Spectrum Analyzer” on page 12

– “Powering up the unit” on page 14

– “Starting measurements” on page 15

– “Using the front panel” on page 15

– “Selecting the measurement mode” on page 26

– “Working with the markers” on page 28

– “Using limit lines” on page 31

– “Printing” on page 35

– “Logging the current position (GPS-assisted)” on page 35

– “Controlling the 9102 from a PC” on page 37

– “Returning from remote control to local mode” on page 37

– “Checking general settings” on page 37

– “Working with stored settings” on page 48

– “Restoring factory settings for all modes” on page 49
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Connecting the 9102 Handheld Spectrum Analyzer
 

DC IN connector The 9102 can be operated either from the internal battery or from an external DC 
source such as the power supply which is delivered with the 9102. In addition, 
the battery is loaded when an external DC source is connected. See the specifi-
cations in your getting started manual for details of the required DC source. Here 
you will also find detailed information on installing and maintaining the battery.

Apply the source to the DC IN connector at the top of the 9102.

RF IN connector RF in is a 50 Ω N-type connector (female).  

If you have a 50 Ω shielded RF cable with an N-type connector (male) to connect 
to the device under test, simply screw the connector tightly to the 9102. 

If you have a 50 Ω shielded RF cable with a BNC connector (male), use an N to 
BNC adapter to connect the cable to the 9102. Willtek offers an appropriate 
adapter; see section “Options and accessories” on page 5.

Figure 1 9102 connectors on the top of the instrument

DC in 

 

RF in 

Multi Port Ext. Ref. in/Ext. Trigger Headphone jack

RF out

WARNING

The maximum allowable input power level at the RF IN connector is 30 dBm 
(1 W). Higher levels at this port can damage the instrument!

CAUTION

Only use a 50 Ω N-type connector to connect to the RF IN port of the 9102. 
Use of any other connector may result in damage of the instrument.

Take care of proper termination

Use of cables and sources with an impedance other than 50 Ω results in inac-
curate measurements.
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If you want to test a device with an impedance of 75 Ω, refer to section 
“Changing the input impedance” on page 58 to adapt the 9102 settings.

RF OUT connector RF OUT is a 50 Ω N-type connector (male). 

The link between the device under test and the 9102 Handheld Spectrum 
Analyzer may be attenuated, for example because the link is an antenna or 
includes a power splitter, or a long cable. The effect of the attenuation on the 
measurement results can be compensated by entering the attenuation value in 
the 9102, see section “Compensating gains and losses” on page 57.

EXT. REF. IN/ EXT. TRIG.
connector

Can either be used as an input for an external time base (reference clock) or as 
an input for an external trigger signal for the spectrum analyzer sweep (an 
external device that triggers the measurement by sending an impulse can be 
connected for example). Only one of the two signal types can be connected at 
any one time. 
See “Improving the frequency accuracy” on page 50 on how to make use of the 
external time base input.
More on external trigger signals can be found in sections “Using a trigger” on 
page 59 and on page 119. 

Multi Port In order to provide for external adapters, amplifiers and accessories the instru-
ment offers a multifunction connector. The Multi Port enables the instrument to 
trigger a measurement onto an external signal. Furthermore it can be used to 
read data stored in external devices (e.g. calibration data).

Headphone jack In addition to the build-in loudspeaker the instrument also offers a standard 
3.5 mm headphone jack. When you connect the headphones to the instrument 
the loudspeaker will be disabled automatically.

WARNING

The EXT. TRIG. input is designed for TTL input levels only. Higher levels at 
this port can damage the instrument!

Note

The external time base feature is available in instruments with serial number 
0704001 or higher.
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SERIAL (RS-232)
connector

This 9-pin sub-D connector  on the left-hand side of the 9102 Handheld Spec-
trum Analyzer can be used to control the instrument remotely via serial interface 
(RS-232). The command set and responses are explained in section “SCPI 
Command Reference” on page 245.

Use a null modem (PC to PC) cable to connect the 9102 to a controlling PC.

LAN connector The 9102 can also be controlled via local area network (LAN) using a TCP/IP 
connection. The LAN connector is located on the left side of the instrument. The 
IP address can be set up in the System Configuration menu or via RS-232. The 
9102 can be operated in networks operating at 100 Mbps, but is capable of 
transmitting and receiving at 10 Mbps only.

The command set to control the 9102 and the responses from the 9102 are 
explained in section “SCPI Command Reference” on page 245.

Connect the 9102 to the LAN with a standard LAN cable with RJ-45 connectors.

Powering up the unit
The 9102 is switched on and off using the power switch located at the top of the 
instrument. It takes about 55 seconds for the 9102 to load and start its software.

Figure 2 9102 connectors on the left-hand side of the instrument

                      Serial

       LAN
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Starting measurements
The 9102 starts measuring and displaying results automatically after powering 
the instrument. It starts in the measurement mode last active.

Using the front panel

Overview The front panel is divided into different sections as follows:

Battery status LED This LED has different states:

– The LED lights green when the 9102 is being operated from its battery and 
no external power is supplied.

– The LED lights yellow when the battery is connected to an external power 
supply and being loaded. 

– The LED is off when the loading procedure is completed, the battery is fully 
loaded or when there is no battery in the 9100’s battery compartment.

– When the LED is flashing yellow quickly and permanently, there is a problem 
with the battery or the charger. Please report this problem to a Willtek 
service center.

Figure 3 Front panel elements

display cursor keys function keys

horizontal (menu) softkeysvertical (function) softkeys numeric keys enter keys
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Display The 6.5 inch display is divided into the following sections (see Figure 4):

– Results area

– Marker field

– Input field

– Softkey descriptions

Results area Results area (graph)

The results area utilizes most of the screen and provides you with the measure-
ment results. A grid of ten vertical and eight horizontal rows eases readability of 
results from the axes. There may be one or two graphs, depending on the number 
of traces selected.

NOTE

Signal level measurement results may be impaired when the battery is low, 
that means when the battery has less than 10% of its nominal capacity. See 
Table 7 on page 17 for an indication when the battery is low. For a detailed 
description on installing and charging the battery please refer to your getting 
started manual.

Figure 4 Display sections
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Horizontal axis

The horizontal axis is the frequency axis for the spectral components. The zero 
span mode is an exception, as the horizontal axis is the time axis in this case. 
Another exception is the Distance to Fault mode, as in this mode this axis 
displays the distance in metres or feet depending on the unit you select. The 
values of the frequencies at both ends of the scale are indicated (start and stop 
frequencies).

Vertical axis

The vertical axis reflects the RF power. Depending on your choice of the level 
unit, the RF power is indicated in dBm, dBV, dBmV, or dBμV. The top end of the 
power scale is called the reference level.

Symbols (icons)

Apart from the results graph itself, several icons are available to indicate the 
status of the 9102 as follows:

Other screen elements

The bar to the left of the vertical axis carries some or all of the elements shown 
below:

Table 7 Icons on the display

Symbol Meaning

The 9102 is taking its operating current from the battery. The 
colored area marks how much of the capacity is still available.
For 30% or more, the area is indicated in yellow; from 10% to 
30%, the area is shown in red, and in white for less than 10%. 
The 9102 sounds a double beep when the capacity goes below 
30% of its nominal value and two double beeps below 10%.

The 9102 is connected to an external DC supply.

The 9102 cannot determine the battery charge although the 
battery can still be used and recharged. 
Please contact Willtek service to have your battery checked.

The 9102 cannot determine the battery charge; typically 
appears during the last third of operating time of battery 
operation. Please contact Willtek service to have your battery 
checked.

The battery is not installed and the 9102 is operated from the 
external power supply.

The 9102 is connected to a local area network (LAN).

A video trigger has been set at the power level indicated. The 
icon also displays the slope of the trigger.

Demodulation is switched on so that the 9102 emits the 
demodulated signal at the loudspeaker.
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Table 8 Texts on the left-hand side

Text Meaning

Ref. Level Indicates the top-most level on the vertical (power) axis. Can 
be modified with the REF function key.

dBm
dBμV
dBmV
dBV
V
mV
μV
mW
μW
dBμV/m
dBmV/m
dBV/m
V/m
mW/m2

Shows the unit in which power, is displayed. Can be changed 
in the Level > Units menu. Units can be switched between 
logarithmic and linear by pressing the Units softkey.
Logarithmic units are: dBm, dBμV, dBmV, dBV, dBμV/m, 
dBmV/m, dBVm.
Linear units are: V, mV, μV, mW μW, V/m, mW/m2.

HOLD Indicates when measurements have been halted with a press 
of the HOLD/RUN function key. 

Count The number following shows the progress of the measure-
ments, that means it indicates how many measurements with 
the present configuration have already been taken. The 
counter continues while the trace hold mode is enabled. It is 
reset whenever a parameter affecting the measurements is 
changed, that means frequencies, filters or attenuation.

Ext. Dev. Indicates that the external device compensation is turned on, 
that means the attenuation of any coupling device is taken 
into account. The external device compensation can be set up 
as shown in section “Compensating gains and losses” on 
page 57.

UNCAL When displayed, the filter and sweep time setting do not per-
mit proper measurements.

Pos./Neg.
Pos. Peak
Neg. Peak
Sample
RMS

Shows the current detector setting. The detector can be 
changed as explained in section “Selecting the detection 
method” on page 66. The RMS detector is available if the 
9132 RMS Detector Option is installed and activated on your 
9102.

A/B (ACT)
A/B (HLD)
A/B (MAX)
A/B (MIN)
A/B (AVG)

Shows the currently selected trace mode for the respective 
trace. The background color of the text coincides with the 
color of the graph. For more information on trace modes, see 
section “Selecting the trace mode” on page 62.
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Trace finder

If more than 90 percent of a results trace is not shown onscreen because it is 
above or below screen boundaries, a trace finder icon consisting of an up or 
down arrow and the word “Trace“ shows where the trace can be found. The trace 
finder icon is positioned in the middle of the results display. By modifying the 
reference level accordingly you can bring the trace back into view.

Marker field

If any of the markers is active, the marker field is displayed, showing the 
measurement values at the marker positions. Up to four markers are displayed 
with their level and frequency values. If you use four markers and activate a fifth 
(up to six markers are available) one marker value will be hidden and the new 
one will be displayed instead. By pressing the relevant marker softkey you can 
display the hidden marker value again. A marker can be switched from absolute 
to relative values. The values are then shown relative to those of marker 1 (e.g. 
A1).

Input field

The input field allows you to enter a number or a text, depending on the selected 
function. The meaning of the input value is expressed by the header line. Some 
input fields have an additional explanation of the step size beneath. The step size 
applies when the value is changed using the up/down cursor keys instead of the 
numeric keys.

Softkey descriptions

The softkey descriptions indicate the assignment of a function to a softkey. They 
are aligned to the lower side with the horizontal softkeys and to the right-hand 
side with the vertical softkeys. See “Softkeys” on page 23 for more information.
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Keypad The front panel carries a large number of keys, giving you direct access to func-
tions and menus and allowing you to enter test parameters such as the center 
frequency. The keypad is divided into the following sections:

Function keys

The function keys have specific functions which do not change. Therefore they 
are sometimes also referred to as “hardkeys“ in contrast to the softkeys, whose 
functions change with the description given on the screen.

The function keys are:

Table 9 Function keys

Key Function

Mode Measurement mode selection. This function key allows 
you to select between different predefined types of 
measurements for specific applications. It also provides 
access to system settings.

Preset Presets all the entry fields of the selected mode to the 
factory default settings. It does not affect the settings 
of other modes.
To prevent accidental resets, the preset function does 
not execute after a short keypress. Press this function 
key for at least half a second to return to the defaults. In 
addition to this function key the 9102 Handheld Spec-
trum Analyzer offers the Factory Settings function for 
resetting all modes. See “Restoring factory settings for 
all modes” on page 49 for more information.

Hold/Run Stops and starts sweeps.

Param This function key calls up the parameter pages summa-
rizing the current settings. Press Exit to close the 
parameter window.
Note that the parameter windows differ between the 
measurement modes.
Parameters that lead to an UNCAL warning are marked 
with a diamond.
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Cursor keys

In an input field, the up and down cursor keys are used to increase or decrease 
the current value. The left and right cursor keys move the cursor position by one 
digit.

If a marker field is active, the up and down cursors move the marker by half a 
division up or down, respectively. The left and right cursor keys move the marker 
pixelwise.

Rcl/Store Provides access to the Memory menus.

Clr Trc This function key resets previous results (including aver-
ages), the sweep counter and the failure counter, and 
starts a new sweep.

Cent Direct access to the center frequency input field within 
the Frequency menu.

Span Direct access to the frequency span input field within 
the Frequency menu.

Ref Direct access to the reference level input field.

Mkr Access to the Marker menu. 

Table 9 Function keys

Key Function

Immediate reaction

Any change of an input parameter with the cursor keys has immediate effect. 
With the straight feedback on the screen, you can easily adjust parameters to 
the optimum values with a trial-and-error approach.
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Numeric keys

The numeric keys allow you to enter a value in a way similar to a pocket calcu-
lator. On some input fields, you can enter text instead, as on a mobile phone.

The ± key offers an additional feature. After connecting a PCL printer to the 9102 
you can print screens directly by pressing this key. For details on configuring 
printers and printing refer to “Configuring a printer” on page 46 and “Printing” 
on page 35.

Enter keys Any input of numerical or alphanumerical entries must be closed or can be 
affected by one of the enter keys. The meaning of the individual enter keys is as 
follows:

Escape key If pressed while an input field is open, the ESCAPE key closes 
this input field without changing the previous value.

Invalid entries

If you enter an invalid number or string, the 9102 beeps and corrects the entry 
to the closest valid value.

Table 10 Enter keys

Key Function

GHz/dBm In frequency input fields, closes the entry by applying 
the unit GHz (gigahertz). In power input fields, assigns 
the unit dBm to the entered value.

MHz/dB/μs In frequency input fields, closes the entry by applying 
the unit MHz (megahertz). In power input fields, assigns 
the unit dB to the entered value. In time parameter 
input fields, assigns the unit μs to the value.

kHz/dBμV/ms In frequency input fields, closes the entry by applying 
the unit kHz (kilohertz). In power input fields, assigns 
the unit dBμV to the entered value. In time parameter 
input fields, assigns the unit ms to the value.

Enter Confirms an entry without a unit and with the units 
hertz and seconds.
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Backspace key Deletes the last entered alphanumerical (backspace).

When an input field is entered, all digits are marked. By pressing 
the backspace key, the entire entry is deleted.

Softkeys The functions of the softkeys change with the description on the screen given 
next to the respective key.

Horizontal (menu) softkeys

The horizontal softkeys provide access to the various menus. The name of the 
active menu is highlighted; the functions of a menu are offered on the vertical 
softkeys. Submenus are indicated with three dots (“...”); the menu softkey 
without the dots leads you one level up in the menu hierarchy.

Vertical (function) softkeys

The vertical softkeys allow you to change the settings of the 9102. 

The vertical softkeys in the 9102 carry out one of the following functions:

– Normal settings – by pushing the softkey, an entry field appears on the top 
of the display, allowing you to enter numerical or alphanumerical data. The 
data become valid after pushing one of the enter keys. Some of the softkeys 
for normal settings also describe the currently set value.
Example: The Channel softkey in channel power mode.

– Combined entry and selection – this type of softkey allows you to change a 
value and also to change a related setting, for example changing between 
automatic and manual parameter setting. The first push on the softkey 
opens the entry field like the normal settings softkey. Pushing it several 
times results in the 9102 toggling between the available options. The option 
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currently selected is indicated in blue while the inactive options are shown 
in white.
Example: The RBW softkey.

– Execution – by pushing the softkey, the function described is performed. An 
execution softkey is indicated by an exclamation mark.
Example: Max Peak softkey in the Marker menu.

– Selection – several selection softkeys allow you to choose between different 
options. The selection softkeys for one function are indicated by a vertical 
bar connecting the softkeys, and a text describing the function. The option 
currently active is highlighted, i.e. indicated by inverted colors.
Example: The TrigMode softkeys in the Sweep menu.

Entering numbers and text Whenever an input field is open, it expects you to enter either numbers or char-
acters (where characters may also include numerical digits). You will notice 
immediately what the 9102 expects as the numeric keys have the appropriate 
function.

Filling in a numerical input
field

When the 9102 software expects a numerical entry, pressing a numeric key 
results in the appropriate digit to appear in the input field. The 9102 may or may 
not allow you to enter a decimal number or a signed value, so the keys for the 
decimal point and for changing the sign of the number are either active or not. 
When all digits, the sign and the decimal point have been entered as required, 
one of the enter keys must be pressed. Numbers often carry a unit with them; 
the enter keys provide the appropriate units.
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Acoustical reaction on inputs

After entering a new parameter value, one of two acoustical alarms may appear:

– Short beep (hint): The parameter is out of limits, or the input affects an 
associated parameter; the respective parameter has been corrected by the 
9102 Handheld Spectrum Analyzer. 
Example 1: An invalid stop frequency of 8 GHz has been entered, resulting in 
a short beep and the maximum stop frequency being set.
Example 2: The start frequency is set to 2 GHz, the stop frequency is set to 
4 GHz and the user enters a new span of 3 GHz. For units without the 
frequency extension, this results in the start frequency being changed to 
1 GHz and a short beep to sound because the new span would result in a 
stop frequency beyond the maximum of 4 GHz.

– Long beep (error): A parameter is set to an invalid value and the 9102 Hand-
held Spectrum Analyzer resumes the old value, sounding an error beep.
Example: After entering a new (invalid) attenuation value of 60 dB, the 9102 
Handheld Spectrum Analyzer sounds a long beep and sets the attenuation 
back to the previous value.

Filling in a text input field Some input fields can be filled with alphanumerical text instead. The numeric 
keys can then be used to enter characters. The keys may have several letters or 
numbers assigned. The assignment of the keys in this case is as follows:

To enter a character, push the key rapidly and repeatedly until the desired char-
acter appears in the input field.

Table 11 Keys for alphanumerical text entry

Key Assignment

0 0

1 1

2 A, B, C, 2

3 D, E, F, 3

4 G, H, I, 4

5 J, K, L, 5

6 M, N, O, 6

7 P, Q, R, S, 7

8 T, U, V, 8

9 W, X, Y, Z, 9

. not assigned

± not assigned
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Changing the input Once an input field is open, you can move the cursor with the LEFT/RIGHT 
cursor keys to place it within the number or text. Additional digits or characters 
can be entered, or you can delete the digit or character in front of the cursor 
using the BACKSPACE key.

Selecting the measurement mode
The 9102 provides different measurement modes:

– The spectrum analysis mode is most versatile. It provides most of the options 
included in all other modes. For more information on this mode, refer to 
page 51.

– The channel power mode allows you to measure the radiated power within a 
certain frequency band. Read more about the channel power mode on 
page 75.

– The transmission mode, which is available in the (VSWR/)Tracking ... 
submenu accessible from the Mode menu, allows you to determine the 
frequency characteristics of active and passive devices. Read more about 
this mode on page 109.

– The signal generator mode, which is also available in the (VSWR/)Tracking ... 
submenu, can be used to generate a signal for stimulating an electronic 
circuit. Read more about this mode on page 103.

If the 9130 VSWR/DTF Reflection Measurement Option is installed and activated 
on your 9102, three additional modes are available in the VSWR/Tracking ... 
submenu. If the option is not installed, this submenu has the menu name 
Tracking ... and the additional modes are not available. For details on the 9130 
VSWR/DTF Reflection Measurement Option please refer to Chapter 8: “The 9130 
VSWR/DTF Reflection Measurement Option”. For details on checking installed 
options and installing new ones refer to “Checking installed options” on page 39 
and “Installing a new option” on page 39. 
All three modes can be selected in the VSWR/Tracking ... submenu accessible 
from the Mode menu:

– The reflection mode provides high-precision measurements of the reflection 
of antenna systems via vector measurements on the reflected wave. Read 
more about this mode on page 137.

– The distance to fault mode offers a detailed analysis of antenna feeder 
cables in order to identify causes for faults like weak connectors, cable kinks 
etc. Read more about this mode on page 155.

– The cable loss mode allows you to determine the average cable loss. Read 
more about this mode on page 165.

If the 9131 EMF Measurement Option is installed and activated on your 9102, an 
additional measurement mode is available for selection: 
The EMF (EMI) mode allows you to measure radiation from transmitters, e.g. base 
stations and broadcast stations, easily and efficently. In this mode the 9102 
measures the electromagnetic field over a user-definable frequency range and 
displays field strength or power density. Read more about this mode on 
page 173.
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In addition, the Mode menu provides access to the system settings, e.g. the I/O 
configuration, and to version information. See section “Checking general 
settings” on page 37 for more details.

 

To select the measurement mode, proceed as follows:

1 Push the MODE function key.
The Mode menu appears (see Figure 5).

2 Select a new mode or return to the mode last active by pressing the respec-
tive softkey. To select the modes signal generator, transmission, reflection, 
distance to fault and cable loss select the (VSWR/)Tracking... softkey 
followed by the relevant mode softkey.

The main menu of the selected mode appears. If you select a new mode, all 
parameters are set to the values which were used when the mode was last 
active. If, however, you resume the last active mode, measurements are 
continued.

Figure 5 Selecting a measurement mode

NOTE

The modes reflection, distance to fault and cable loss are available if the 9130 
VSWR/DTF Reflection Measurement Option is installed and activated on your 
9102. The EMF (EMI) mode is available, if the 9131 EMF Measurement Option 
is installed and activated. For details on checking installed options and 
installing new ones refer to “Checking installed options” on page 39 and 
“Installing a new option” on page 39.
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Working with the markers

The 9102 includes powerful and easy-to-use marker functions. Up to six markers 
can be used; up to five of them can be delta markers. Markers are easy to place 
and you can easily affect the center frequency and the reference level upon a 
keypress. If you use two traces you can also use markers on trace A and trace B. 
The markers are named accordingly (e.g. A1, B1). Delta markers are identified by 
D (e.g. DA1).

It is important to note that if you place the cursor on a signal peak and then 
reduce the span, the marker position may be offset a little from the peak. This is 
due to the limited resolution of the displayed frequencies when using a high 
span. After reducing the span, the marker should be readjusted to the new peak.

Enabling and moving a
marker

1 From the main menu, select Marker. Or push the MKR function key in any 
menu.
If you select Marker from the main menu when no marker is active, the 
softkey for marker 1 is highlighted. 
To enable marker 1, toggle the softkey until “ON“ is highlighted. 
The input field for marker 1 appears. 
If you use the MKR function key when no marker is active, marker 1 (A1 or 
B1) will be enabled at the maximum peak. The input field for marker 1 
appears.

2 If you want to enable another marker, push the appropriate softkey (A1 
through A4 or B1 trough B4). If you want to use more than four markers, 
press the Mkr More softkey to display the marker softkeys for marker 5 and 
marker 6 and proceed as described for markers 1 to 4.
The marker is enabled and the input field opens; the selected marker appears 
in the marker field in the top bar of the display.

Figure 6 Example of markers
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3 If required, move the marker to another position using the cursor keys, one 
of the softkeys Max Peak and Next Peak, or by entering the frequency with 
the numeric keys and the appropriate enter key.

Disabling a marker 1 From the main menu, select Marker. Or push the MKR function key in any 
menu.
The Marker menu appears and the input field for marker 1 appears.

2 Push the softkey (one of A1 through A6 or B1 through B6) for the marker 
which you want to disable. If you use more than four markers you can 
display the softkeys for marker 5 and 6 by pressing the Mkr More softkey.
Toggle the softkey until “OFF“ is highlighted. The marker is disabled and the 
respective marker values disappear in the marker field at the top. By 
toggling to “ON“ again the marker will be enabled again.

Enabling a delta marker For delta markers, the power level and frequency relative to marker 1 is displayed 
in the marker field. Marker 1 cannot be a delta marker. If marker 1 is not yet 
enabled when you enable another marker as a delta marker, marker 1 will be 
enabled automatically.

1 From the main menu, select Marker, or push the MKR function key in any 
menu.

2 Select the softkey for the marker which you want to turn into a delta marker 
(A2 through A6 or B2 through B6). If you use more than four markers you 
can display the softkeys for marker 5 and 6 by pressing the Mkr More 
softkey.
If not already enabled, the marker is turned on.

3 Push the softkey until “REL“ is highlighted. The respective marker in the 
marker field is indicated as a delta marker, e.g. DA2 instead of A2.

Disabling a delta marker 1 From the main menu, select Marker, or push the MKR function key in any 
menu.
The Marker menu and the marker 1 input field appear.

2 Select the softkey for the delta marker that you want to disable (e.g. DA2). If 
you use more than four markers you can display the softkeys for marker 5 
and 6 by pressing the Mkr More softkey.

3 To disable the marker completely, push the softkey until “OFF“ is highlighted.
To turn the delta marker into a normal marker displaying absolute values 
again toggle the softkey to “ON“.

Setting a marker on a
frequency relative to

marker 1

1 Enable a delta marker as described in “Enabling a delta marker”.
For the selected delta marker, the input field shows the frequency relative to 
marker 1.
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2 Enter a (signed) frequency relative to the frequency at marker 1, either using 
the numeric keys and the respective enter key, or moving the cursor to that 
frequency with the help of the cursor keys.
The marker field indicates the desired frequency offset for that marker, along 
with the power level relative to the power at marker 1.

Changing the center
frequency with a marker

This function modifies the center frequency, adapting the frequency of a select-
able marker.

1 From the main menu, select Marker, or push the MKR function key in any 
menu.
The Marker menu and the input field for marker 1 appear.

2 If you want to use the frequency at a marker position other than marker 1, 
push the appropriate softkey (A2 through A6 or B2 through B6). If you use 
more than four markers you can display the softkeys for marker 5 and 6 by 
pressing the Mkr More softkey.

3 Push the Marker to Center softkey.
The center frequency changes to the frequency at which the selected marker 
is located. The frequency span only changes if the change in center 
frequency would lead to an invalid start or stop frequency.

Changing the reference
level with the marker

The reference level can be changed to the level at a marker position as follows:

1 From the main menu, select Marker, or push the MKR function key in any 
menu.

2 Select the Mkr Transfer menu.

3 If you want to use the power level at a marker position other than marker 1, 
push the appropriate softkey (A2 through A6 or B2 through B6). If you use 
more than four markers you can display the softkeys for marker 5 and 6 by 
pressing the Mkr More softkey.

4 Push the Marker to Ref. Lvl softkey.
The reference level changes to the level of the selected marker.

Assigning the marker
frequency to FStep

For measurements of harmonics or intermodulation products, it can be useful to 
easily change between frequencies in user-defined steps. The “Marker to FStep” 
function assigns the active marker (or delta marker) frequency to FStep, the step 
width for the selection of center frequency and marker frequency.

Assumption: One of the markers A1 through A6 or B1 to B6 is active.

1 From the main menu, select Marker > Mkr Transfer to access the Marker 
Transfer menu.

2 Push Marker to FStep.
The FStep parameter assumes manual mode. If the currently active marker is 
an absolute marker, the frequency at the marker position becomes the new 
FStep value. 
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Alternatively, if the currently active marker is a relative (delta) marker, the 
difference between the frequencies at the active marker and marker 1 
becomes the new FStep value.
If the new FStep value is higher than 1 GHz, the old FStep value is main-
tained and the 9102 sounds a hint beep.

Using limit lines

Overview A very useful feature of the 9102 is the possibility to set limits for the trace A 
results. These are displayed on the screen and the 9102 can show if the results 
exceed the limits.

Two different limit modes exist in the 9102. In the first case, the limits exist of 
horizontal lines for the upper and lower limit. This method is called “simple 
limits”; the limits can be entered directly in the Limits menus of the 9102.

In the second case, there are more complex limits as shown in the example in 
Figure 7. These limits can be entered with a comfortable tool on a PC and loaded 
to the 9102 via RS-232 or LAN interface. A set of limit lines can be used to define 
a measurement template. There are versatile tools around these limits available 
on the 9102, such as a fail counter, a beep when a failure occurs, or a measure-
ment hold function upon failure. The limits can be used both in the frequency 
and in the time domain.
Up to 99 sets of limits can be stored on the 9102.

The actual limit values must be defined on a PC and loaded to the 9102 using the 
9100 Data Exchange Software. Several limit files can be stored on the 9102. The 
name of the current limit file is indicated in the upper left-hand corner.

Figure 7 Example of limit lines in spectrum analysis
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Note that the limits are defined within a grid, no matter what the units on the 
vertical and horizontal axes are. This way, you can apply the limits to different 
frequency ranges and power levels. It is your responsibility, however, to select a 
useful frequency range, reference level and level scale.

Note that a FAIL indication may occur if the start frequency is 0 Hz and an upper 
limit is set at this frequency.

Using simple limits Simple limits consist of constant upper and lower limits. They must be activated 
to take effect. Once activated, each measurement is accompanied by a Pass/Fail 
verdict indicating whether or not the measurement result was within the limits.

Switching simple limits on and
off

By switching limit lines on, any previously active limit template is disabled.

1 Press Level > Limits Memory.

2 Press the Simple Limits softkey so that the new choice (on or off) is high-
lighted.
When switching limits on, red horizontal lines indicating the upper and 
lower limits appear. A Pass/Fail verdict is displayed with every new measure-
ment in the upper left corner of the screen. The text above the verdict 
(“Simple Limits”) indicates that the verdict applies to simple limits.
When switching limits off, the limit lines and the verdict disappear.

Defining upper and lower limits The limits can be changed only when simple limits are activated. The range of 
valid entries depends on the power scale displayed (vertical axis) as follows:

Follow the steps below to define simple upper and lower limits.

1 Press Level > Limits Memory.

Table 12 Valid entries for upper/lower simple limits (relative to 
reference level)

Scale Valid range

1 dB/division –8 … 0 dB

3 dB/division –24 … 0 dB

5 dB/division –40 … 0 dB

10 dB/division –80 … 0 dB

15 dB/division –120 … 0 dB

20 dB/division –160 … 0 dB
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2 Press the Upper softkey, enter a new value for the upper limit (in dB, rela-
tive to the reference level) (or move the upper limit with the UP/DOWN 
cursor keys) and confirm with MHZ/DB/µS or ENTER.
The upper limit line is moved to the new value.

3 Press the LOWER softkey, enter a new value for the lower limit (in dB) (or 
move the lower limit with the UP/DOWN cursor keys) and confirm with 
MHZ/DB/µS or ENTER.
The lower limit line is moved to the new value.

Using limit templates Limits can be comfortably defined with a PC-based tool and loaded to the 9102. 
This is described in full detail in chapter “9100 Data Exchange Software” on 
page 211. The sections below describe how to recall, delete, activate and deacti-
vate limit templates.

Selecting limit lines within
the 9102

1 From the main menu, select Level > Limits Memory.
The Limits Memory menu appears.

2 Push the Recall Limit Template softkey.
An entry field appears, together with a file selection box.

3 Select a file either by moving the selection to its file name using the UP/
DOWN cursor keys, or by entering the file name in the entry field and 
closing the input field by pressing ENTER.
The file with the limits is loaded and the upper/lower limits are activated 
immediately.

Activating and deactivating
limit templates

1 Select a limits file (see section “Selecting limit lines within the 9102”).

2 Select Level > Limits Evaluation
The Limits Evaluation menu appears.

3 Select the limits option you want by pushing the appropriate softkey from 
the following choice: Off, Upper/Lower, Upper Limit, Lower Limit.
If you selected Off, no limits are displayed. Otherwise, the selected limits 
curve (upper and/or lower limits) appears on the screen. A Pass/Fail indica-
tion is given for each measurement trace in the upper left-hand corner.

Deleting limit files in the 9102 1 From the main menu, select Level > Limits Memory. 

2 a. To delete an individual file, push Delete Limit Template, select a limits 
file with the UP/DOWN cursor keys and push ENTER to delete an individual 
file (pressing ESC aborts the process before the file is deleted).

b. To delete all limit files stored in the 9102, push Delete All Templates. 
Confirm by pressing ENTER, if you really want to delete all limit files.
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Counting limit failures When limit checking is enabled, a failure counter can be activated. The number 
of failures appears below the Pass/Fail verdict. The counter makes particular 
sense for statistical evaluations. For this application, it is important to define the 
number of measurements. The following sequence can be useful to obtain a 
failure count in conjunction with a defined number of measurement traces.

1 Select a limited number of traces (Freq > Sweep, see “Performing a limited 
number of measurements” on page 60).

2 From the main menu, select Level > Limits Evaluation > Fail Count to 
turn the failure counter on; if it was on already it should be switched off and 
on again.
The failure counter is reset to 0.

3 Push the HOLD/RUN softkey to start the measurement.
Both the measurement counter and the failure counter start from 0. When 
the selected number of traces has been reached, the measurements are 
stopped and you can read the failure count.

Resetting the counter The failure counter for the limits check can be reset by turning it off and then on 
again (in the Level > Limits Evaluation menu).

Enabling a beep upon
failures

1 From the main menu, select Level > Limits Evaluation.
The Limits Evaluation menu appears.

2 Push the Fail Beep softkey to activate or deactivate the beep counter:
If activated, a beep sounds each time the measured signal exceeds the 
limits.

Viewing a failed
measurement

This feature can be useful if you want to stop the measurement and view the 
measured signal when it fails the limits. Note that the 9102 should be set to 
continuous measurements.

1 From the main menu, select Level > Limits Evaluation.

2 Push the Fail Hold softkey once or twice to enable or disable the hold-on-
fail function.
The measurements are halted when a failure occurs. The trace of the failed 
signal remains on screen.

Measurements can also be stored and recalled in the 9102 for later analysis or 
comparison. This is shown in “Storing and loading traces” on page 68.

With the 9100 Data Exchange Software, traces can also be transferred to and 
viewed and stored on a PC. For more details, please refer to chapter “9100 Data 
Exchange Software” on page 211.
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Printing
The 9102 offers the possibility of printing measurement results, for example 
traces, directly from the instrument. In order to print results screens on a 
connected printer simply press the ± key on the numeric keypad of the 9102’s 
front panel.

For details on supported printers and configuring a printer refer to “Configuring 
a printer” on page 46.

Logging the current position (GPS-assisted)
The 9102 can show the current location and record measurement data along 
with the actual position at the time of the measurement. This can be useful when 
taking measurements of the electromagnetic immission (EMI) at various points.

All it needs is the 9168 GPS Receiver Option. With the option installed and 
switched on, the 9102 can indicate the coordinates (in minutes or degrees), the 
altitude (in meters or feet), the speed (in kilometers per hour or knots) and date 
and time.

This information is available on the screen of the 9102 Handheld Spectrum 
Analyzer, via remote control applying the set of SCPI commands over RS-232 or 
LAN, or in the measurement trace after data transfer to a PC with the 9100 Data 
Exchange Software.

The option requires Willtek’s GPS receiver for the 9100 series, plus an option key 
installed in the 9100. See “Installing a new option” on page 39 on how to install 
a new software option.

Connecting the GPS
receiver

1 Plug the RS-232 connector of the GPS receiver into the RS-232 jack of the 
9102 Handheld Spectrum Analyzer.

2 Connect the other connector of the GPS receiver to the Multi Port of the 
9102.

Before the current location and be viewed, the GPS receiver must be switched on 
(see below).

Enabling the GPS receiver The GPS Receiver Option is switched on by selecting the MODE > GPS Data 
menu and turning GPS Data on.
The GPS Data menu indicates the current position.

NOTE

If an input field is active while you press the ± key, it has the ± functionality 
assigned to it. In this case printing is not possible. In order to be able to print 
deactivate the input field first by deselecting the respective softkey.
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The location data can also displayed as part of the trace loaded onto the PC with 
the 9100 Data Exchange Software. See section “Viewing the actual trace on the 
PC” on page 216 for more information.

Taking GPS-assisted
location measurements

The coordinates are shown in the GPS Data menu; they are also logged together 
with the trace. The coordinates can be displayed along with the measurements 
in the 9100 Data Exchange Software; see section “Including the GPS position in 
the trace” on page 242.

The GPS Data menu shows one of the following GPS status messages in the 
Quality field:

– “No GPS receiver!”: The 9102 did not find a valid GPS receiver connected.

– “No Signal”: The 9102 found a GPS receiver, but there are no GPS coordi-
nates available as yet.

– “Receiver Warning”: Measurement data are available, but from less than 
four satellites. Four satellites are necessary to determine latitude, longitude 
and altitude.

– “Data OK”: Measurements are available from at least four satellites, 
resulting in the valid display of the information.

Note

GPS receivers work best in outdoor environments with not too many clouds. 
No signal may be received and hence no location presented while the receiver 
is located indoors.

Note

After activation of the GPS receiver, it may take 45 s until the first measure-
ment is displayed. 
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Changing the GPS display
settings

In the MODE > GPS Data menu, use the Coordin. key to toggle between longi-
tude and latitude display in degrees only (decimal scale) or in degrees and 
minutes. 

The altitude can be displayed in either meters or feet. In the MODE > GPS Data 
menu, use the Altitude key to toggle between meters and feet. 

The speed of the measuring device can be displayed in either kilometeres per 
hour (KPH) or in knots. (KTS). In the MODE > GPS Data menu, use the Speed 
key to toggle between KPH and KTS. 

Controlling the 9102 from a PC
The 9102 can be used under remote control from a PC. The interfaces supported 
for this are the serial interface (RS-232) and the LAN (TCP/IP). Please refer to 
section “SCPI Command Reference” on page 245 for more information on remote 
control.

Returning from remote control to local mode
To gain manual control after using the 9102 under remote control, press 
ESCAPE.

Checking general settings
This section covers information about the unit, setting display brightness, time 
and date, and configuring the remote control interfaces of the 9102.

Reading the serial number You can find the serial number of your 9102 as follows:

1 Push the MODE function key.
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2 Select System.
The System Information display appears (see Figure 8), showing the serial 
number, the installed software version and the installed option.

Reading the software
version number

Before loading a new software version or reporting problems, you may want to 
check the currently installed version.

1 Press the MODE function key followed by the System softkey.
The System Information menu appears.

2 Read and note the software version number in the field entitled Application. 

Reviewing the calibration As for all test instruments, the 9102 Handheld Spectrum Analyzer’s accuracy 
should be checked against its specifications. This process is called calibration. If 
the 9102 accuracy falls outside the specified tolerance, it may be necessary to 
correct the instrument.

Willtek recommends a calibration interval of one year. The 9102 stores the date 
of the last calibration by a Willtek-certified lab and the date when the next cali-
bration is due. In addition, you can document when the calibration date has been 
reviewed last.

To check if the 9102 is due for calibration, proceed as follows: 

Press the MODE function key followed by the Calibration Information softkey.
The Calibration Information menu appears.

Figure 8 System Information menu
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1 Here the calibration details for the instrument are displayed.
The Calibration Number area shows the calibration number.
The first line of the Calibration area indicates the date of the last calibration 
and the organization calibrating the 9102.
The second line indicates when and by whom the calibration has been 
checked last.
The third line indicates when the next calibration is due. This date is typi-
cally one year after the last calibration.

2 Push the Date Last Check softkey to change the last check date. It will be 
set to the actual date as set by the built-in real-time clock.

3 Push the Name Last Check softkey to enter the name of the person that 
carried out the last calibration date review.

Checking installed options Willtek provides different application programs and options for the 9102 Hand-
held Spectrum Analyzer. These may or may not be active on your instrument. To 
check which options are actually installed on your 9102, take the following steps:

1 Press the MODE function key followed by the System softkey.
The System Information menu appears.

2 Select Options.
The Options menu appears, indicating the installed options in bold print with 
a tick in front; the options not installed are shown in grey.

Installing a new option Software options can be installed by entering an activation key which you can 
purchase from Willtek or one of its representatives. To install a new option:

1 Press the MODE function key followed by the System softkey.
The System Information menu appears.

Figure 9 Calibration Information menu
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2 Select Options and press Activate Options.

3 Enter the activation key and press ENTER.
If the code is valid, the appropriate option is shown in bold print with a tick 
in front, indicating that the option is accessible now.

Changing the display
brightness

1 Push the MODE function key.

2 Select System > Settings.
The general settings display appears (see Figure 10), showing the current 
display backlight setting as a percentage.

3 Press the Display Extern softkey to change the backlight setting for usage 
while the 9102 is connected to an external power supply
Press the Display Battery softkey to change the backlight setting for 
running the 9102 on battery. Here, you can specify a reduced backlight 
setting for battery usage in order to save energy.
In both cases the backlight input field is highlighted.

4 Enter a new value in the field for the backlight setting you intend to change 
and confirm with ENTER, or change the current value with the UP/DOWN 
cursor keys.
The 9102 display uses the new brightness values.

Figure 10 General Settings menu

NOTE

The display setting for adjusting the brightness is not affected by a press on 
the PRESET function key but by a push on the Back to Defaults softkey.
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Enabling and disabling
beeps

Warning and error beeps can be turned off and on in the General Settings menu: 

1 Push the MODE function key.

2 Select System > Settings.
The general settings display appears, showing the current setting for beeps 
(on or off).

3 Press the Beep softkey several times until the desired setting is highlighted 
(on or off).
The beep input field shows the current setting.

Assigning a device name
to the instrument

A device name for the 9102 can be useful if you have several units of the 9102 
Handheld Spectrum Analyzer. They can be identified if you choose different 
names for them. The name also appears on traces transferred to the PC with the 
9100 Data Exchange Software.

You can enter a new name as follows:

1 Push the MODE function key.

2 Select System > General Settings.
The general settings display appears, showing the current device name.

3 Press the Device Name softkey.
The device name input field is active so you can overwrite the current name.

4 Enter a new name (max. 11 characters; see section “Filling in a text input 
field” on page 25 to learn how to do this) and close the entry field by 
pressing ENTER.
The new name is displayed in the device name field.

Adjusting date and time in
the instrument

The 9102 Handheld Spectrum Analyzer includes a real-time clock. It can be used 
to show the actual date and time or to compare it with the date when the next 
calibration is due.

In order to change the date and time, proceed as follows:

1 Push the MODE function key.

2 Select System > Settings > Time/Date.
The time/date display appears showing the current date and time.

NOTE

This parameter is not affected by a press on the PRESET function key but by 
a push on the Back to Defaults softkey.

NOTE

This parameter is not affected by a press on the PRESET function key but by 
a push on the Back to Defaults softkey.
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3 Press the Time softkey.
The time input field is active so you can move the cursor with the LEFT/
RIGHT cursor keys behind a digit that needs to be changed, push the BACK-
SPACE key to erase it and enter a new digit.

4 Press the Date softkey.
The date input field is active so you can overwrite the old date with a new 
one or move the cursor with the LEFT/RIGHT cursor keys behind a digit 
that needs to be changed, push the BACKSPACE key to erase it and enter a 
new digit.

5 Press ENTER or another function key to confirm the entry.
The new date and time are shown on the Time/Date menu.

Changing the baud rate on
the RS-232 port

1 Push the MODE function key.

2  Select System > I/O Config > RS 232 Config.
The RS 232 Config menu is displayed (see Figure 12), showing the current 
RS-232 bit rate (or baud rate) and interface settings.

3 To change the data rate, push the Baudrate softkey and select a new rate 
with the UP/DOWN cursor keys.
The change takes effect immediately.

Figure 11 Time/Date menu

NOTE

These parameters are affected neither by a press on the PRESET function key 
nor by a push on the Back to Defaults softkey.

NOTE

This parameter is not affected by a press on the PRESET function key but by 
a push on the Back to Defaults softkey.
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Changing the IP address of
the 9102

The IP address should be adapted to the address space in use in your environment 
and should be unique for each device on that network.

1 Push the MODE function key.

2 Select System > I/O Config
The TCP/IP Config menu is displayed, showing the current TCP/IP settings.

Figure 12 RS 232 Configuration

NOTE

The described procedure for changing the baud rate applies to serial numbers 
5004001 and higher.
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3 Select System > I/O Config.
The port configuration display appears, showing the current TCP/IP settings.

4 To change the IP address of the 9102, press the Target IP softkey.
The address field is highlighted.

5 Overwrite the entire IP address or select a field with the LEFT/RIGHT cursor 
keys, enter a new IP address and press ENTER.

6 To change the subnet mask press the Subnet Mask softkey. The Subnet 
Mask field is highlighted.

7 Overwrite the entire subnet mask or select a field with the LEFT/RIGHT 
cursor keys, enter a new one and press ENTER.

8 To change the gateway press the Gateway softkey. The Gateway field is 
highlighted.

9 Overwrite the entire gateway or select a field with the LEFT/RIGHT cursor 
keys, enter a new one and press ENTER.

10 For the change to take effect, switch the 9102 off and then on again.

11 Ensure that your application on the PC addresses the 9102 using this IP 
address so that the two units can communicate with each other.

Changing the IP address of
the PC

For remote control of the 9102 Handheld Spectrum Analyzer from a PC, the IP 
address of that PC can be entered on the instrument.

1 Push the MODE function key.

2 Select System > I/O Config
The TCP/IP Config menu is displayed (see Figure 13), showing the current 
TCP/IP settings.

Figure 13 TCP/IP Configuration
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3 Select System > I/O Config.
The port configuration display appears, showing the current TCP/IP settings.

4 To change the IP address of the 9102, press the Host IP softkey.
The address field is highlighted.

5 Overwrite the entire IP address or select a field with the LEFT/RIGHT cursor 
keys, enter a new IP address and press ENTER.

6 Reboot the 9102 (that means, switch it off and on again) for the new 
settings to work.

Changing the IP port used
by the 9102

When the 9102 Handheld Spectrum Analyzer is to be controlled remotely from a 
PC, the PC must address the remote control application within the 9102 with an 
IP port number. The 9102 uses a default of 49200 which can be changed easily 
as follows:

1 Push the MODE function key.

2 Select System > I/O Config 
The TCP/IP Config menu is displayed, showing the current TCP/IP settings.

3 To change the IP port of the 9102, push the Port softkey.
The address field is highlighted.

4 Overwrite the entire IP address or select a field with the LEFT/RIGHT cursor 
keys, enter a new IP address and press ENTER.

5 Reboot the 9102 (that means, switch it off and on again) for the new 
settings to work.

The Back to Default softkey resets the parameter to its default value.
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Configuring a printer You can connect a printer for direct printing via the ± key on the 9102’s front 
panel. 

1 Push the MODE function key.

2 Select System > I/O Config > Printer Config
The printer settings are displayed.

3 In order to configure a connected PCL 5 printer for direct printing press the 
softkey Printer Type and toggle it to PCL by pressing it until this option is 
highlighted.

4 In order to specify the baud rate of the printer press the Printer Baudrate 
softkey. The Printer Rate input field is highlighted. The default is 19200. 

Selecting user interface
colors You can change the colors of some of the user interface elements in the Color 

Scheme menu. The available colors are shown in the color palette at the top of 
the display and in Table 13.

Figure 14 Printer Configuration menu

NOTE

Direct printing works with PCL 5 printers with integrated drivers. Pure GDI 
printers are not supported.

Table 13 Color palette in the 9102 user interface

Color number Color

1 black

2 grey

3 blue
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The colors of the traces, the grid and the limit lines can be modified as follows:

1 Push the MODE function key.

2 Select System > Color Scheme.
The color scheme display appears (see Figure 15), showing the current color 
settings.

3 To change the color of a user interface element, push the appropriate 
softkey (Trace A, Trace B, Grid, Limits or Trace Offset Color).
The input field on the left is activated.

4 To select a new color, enter a number corresponding to the colors in the 
color palette and press ENTER, or use the UP/DOWN cursor keys to change 
the color.
The color field to the left of the input field changes according to the selec-
tion made.

5 Press the Last Mode softkey to return to the measurement screen.
The new color scheme takes effect immediately.

4 green

5 violet

6 yellow

7 red

8 brown

Figure 15 Color scheme menu

Table 13 Color palette in the 9102 user interface

Color number Color
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Working with stored settings
The 9102 Handheld Spectrum Analyzer provides the capability of storing all the 
parameters for a particular measurement, allowing to recall these parameters 
whenever the measurement shall be repeated under the same conditions, and 
this includes the measurement mode. A large number of parameter sets can be 
stored under different names that allow fast and easy identification; each 
parameter set name may consist of up to 11 characters.

In addition to using these files of parameter sets on the same 9102, you can also 
transfer them to a PC for backup, easy modification and amendment using a 
standard text editor, or for using the same parameters on multiple 9102 instru-
ments. This is described in more detail in sections “Working with settings” on 
page 239 and “Managing files on the PC and on the 9102” on page 240.

Storing instrument
settings

You can store the instrument settings as a whole under a name with up to 
11 characters. The procedure to enter text in alphanumerical input fields is 
explained in section “Entering numbers and text” on page 24.

1 From the main menu, select RCL/STORE > Settings > Store Setting.
An input field opens, allowing you to enter a name for the instrument 
settings. Below the input field, a list of existing settings fies is indicated.

2 Enter a name for the settings. To use and modify an existing name, you can 
move the cursor to a suitable settings name with the UP/DOWN cursor keys. 
The selected trace name also appears in the input field; use the LEFT/
RIGHT cursor keys to move the cursor to the appropriate position within the 
settings name to enter additional characters or delete existing ones.

3 Confirm your choice by pressing ENTER.
The input field closes and the instrument settings are stored under the 
selected name.
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Reusing an instrument
settings name

You cannot overwrite an existing settings file using the same settings name. If 
you want to reuse a settings name, you will have to delete the old one first.

Reloading instrument
settings

1 From the main menu, select RCL/STORE > Settings > Recall Setting.
An input field opens, allowing you to enter the settings name. Below the 
input field, a list of existing settings is indicated.

2 Enter the name of the settings file to load, or choose one with the UP/
DOWN cursor keys.

3 Confirm your choice by pressing ENTER.
The input field closes and the selected settings are loaded. The previously 
active settings are not stored automatically but discarded.

Deleting a settings file Stored settings files can be deleted. Note that there will be no warning; once you 
have selected and requested a file to be deleted, this will occur immediately.

1 From the main menu, select RCL/STORE > Settings > Delete Setting.
An input field for the name of the settings file to be deleted appears, 
together with a file selection box.

2 Select the settings file to be deleted using the UP/DOWN cursor keys. Alter-
natively, enter the settings name with the numeric keys.

3 Confirm your choice by pressing ENTER.
The settings file is deleted from the list.

4 Select another instrument settings file for deletion, or press ESCAPE to 
leave the entry field and the file selection box.

Deleting all intrument
settings files

Instead of deleting settings files individually, all files can be deleted in one step. 
You will be asked to confirm this step.

1 From the main menu, select RCL/STORE > Settings > Delete All 
Settings.
A query appears, asking you to confirm your selection.

2 Press ENTER to have all settings files deleted.
The query disappears. All settings files are deleted.

Restoring factory settings for all modes
In addition to the PRESET function key (see “Using the front panel” on page 15), 
which resets the mode currently selected to its factory default settings, the 
9102’s Mode menu offers the Factory Settings function. This function resets all 
modes to their factory default settings and returns you to the spectrum analysis 
mode. In order to restore the factory settings for all modes proceed as follows:
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1 Press the MODE function key.
The Mode menu is displayed.

2 Press the Factory Settings softkey. The Factory Settings menu appears.

3 Press the Preset All softkey. A message will be displayed asking you to 
confirm that all modes should be reset.

4 Press ENTER to confirm the process. All modes will now be reset to their 
factory settings.

Improving the frequency accuracy
The 9102 Handheld Spectrum Analyzer has an internal time base that is used to 
generate the internal frequencies for both the receiver and the optional tracking 
generator. The accuracy of the internal time base is specified in the data sheet 
for the 9102. 

If necessary, the frequency accuracy can be further improved by using an 
external, high-precision time base. The time base should consist of a stable 
frequency of either 5, 10 or 13 MHz. This reference clock signal should have a 
power level of at least 0 dBm and should be fed to the EXT. REF. IN/ EXT. 
TRIG. BNC connector (see “Ext. Ref. in/ Ext. Trig. connector” on page 13). 
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Chapter 3 Spectrum Analysis Operation

This chapter describes the instrument’s functions that are specific to the spec-
trum analysis mode. Topics discussed in this chapter are as follows:

– “Selecting the measurement mode” on page 52

– “Changing the frequency settings” on page 52

– “Selecting RBW, VBW and SWT” on page 55

– “Setting up the level parameters” on page 55

– “Changing the input impedance” on page 58

– “Applying special functions on the signal” on page 59

– “Setting up the trace” on page 62

– “Storing and loading traces” on page 68

– “Special measurement functions” on page 70

– “Viewing the spectrum analysis mode parameters” on page 74
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Selecting the measurement mode
The 9102 provides different measurement modes. To select spectrum analysis 
mode, proceed as follows:

1 Push the MODE function key.
The Mode menu appears.

2 Select Spectrum Analysis.
The Spectrum Analysis main menu appears.

Changing the frequency settings

There are different methods to set the frequency range to be measured; the range 
can be expressed by either the start and stop frequencies (i.e. first and last 
frequencies on the display), or by center frequency and span (i.e. the center and 
the frequency range), or by other combinations of center frequency, span, start 
and stop frequencies. 

All four parameters are accessible in the Freq menu. On the main menu, 
however, only one of the combinations mentioned above is shown, depending on 
the parameter last entered.

Figure 16 Frequency menu

NOTE

Changing a frequency parameter may affect an associated parameter.
Example: If you change the span to the maximum of 4 GHz (without the fre-
quency extension being installed), the start and stop frequencies are changed 
to 0 and 4 GHz, respectively.
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Setting start and stop
frequency

1 Push the CENT function key (or the Freq softkey in the main menu).
The vertical softkeys include Start and Stop softkeys.

2 Push the Start softkey.
An entry field appears, indicating the start frequency currently set and the 
step size for the UP/DOWN cursor keys.

3 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

4 Conclude the entry by pushing an enter key for the unit (GHZ or MHZ).
If the start frequency entered is lower than the stop frequency, the hori-
zontal axis will display the range from the new start to the stop frequency.
If the new start frequency is higher than or equal to the stop frequency, the 
start frequency is used as the center frequency with zero span, i.e. the signal 
at the selected frequency will be shown in the time domain.

5 Push the Stop softkey and enter the frequency for the right end of the 
display.

You can also place softkeys for the start and stop frequencies available on the 
main menu by changing the frequency mode, see page 53.

Setting center frequency
and span

1 Push the CENT function key (or the Freq softkey in the main menu).
The vertical softkeys include Center and Span. An entry field appears, indi-
cating the center frequency currently set and the step size for the UP/
DOWN cursor keys.

2 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

3 Conclude the entry by pushing an enter key for the unit (GHZ or MHZ).

4 Push the Span softkey and enter the frequency for the range from the left 
to the right end of the display.

You can also place softkeys for the center frequency and the span available on 
the main menu by changing the frequency mode, see section “Changing the main 
menu for different frequency parameters” below.

Changing the main menu
for different frequency

parameters

The main menu shows two softkeys for the definition of the frequency range on 
the display. Different methods exist to define the range as depicted above; you 
can configure these softkeys to one of the two allowable combinations as 
follows:

1 From the main menu, select Freq > Freq Mode.

2 Select the combination of softkeys that you want to see in the main menu 
(Start/Stop or Center/Span).

3 Return to the main menu by pushing the Main ... softkey.
The main menu appears and displays the selected combination of keys.

Note that the description of the horizontal frequency axis changes with the 
selected parameter set.
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Viewing the complete
frequency band

To change the frequency range to the full bandwidth supported by the 9102, 
proceed as follows:

1 From the main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Full Span softkey.
The leftmost frequency changes to 0 Hz and the rightmost frequency to 
4 GHz, or to 7.5 GHz if the Frequency Extension 7.5 GHz option is installed.

Performing measurements
in the time domain

Measurements on a selected center frequency can also be displayed in the time 
domain.

1 From the main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Center softkey and enter the desired center frequency; close the 
input field by selecting the appropriate unit with one of the enter keys.

3 Push the Zero Span softkey.
The horizontal axis becomes the time axis. The scale width is identical to the 
sweep time. See Figure 17 on page 60 for an example.

Selecting the step size for
the frequency input

The center, start and stop frequencies can be set by either entering a new value 
with the numeric keys, or by using the arrow keys (UP, DOWN) to increase or 
decrease the current setting. The step size for an arrow keypress can be either 
automatically selected by the 9102, or manually adjusted.

Manually setting the frequency step size

1 From the main menu, select Freq. 

2 Push the FStep key.
The Freq Step entry field opens.

3 Enter a new frequency step value and close the entry field by pressing the 
appropriate enter key determining the unit (GHZ/DBM for gigahertz, MHZ/
DB/µS for megahertz, KHZ/DBµV/MS for kilohertz, or ENTER for hertz).
The auto/manual selection switches to manual and the selected frequency 
step size is displayed on the softkey.

Setting the frequency step size selection to automatic

1 From the main menu, select Freq.

2 Push the FStep softkey several times until the “auto” selection is high-
lighted.
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Selecting RBW, VBW and SWT
The resolution bandwidth (RBW) is the 3 dB bandwidth of the IF filter for 
selecting the signal to be measured. The resolution bandwidth describes the 
ability of the spectrum analyzer to discriminate between adjacent signals of 
similar amplitude. Only signals spaced at a frequency of more than the RBW can 
be discriminated from one another.
The 9102 can be set to automatically select the resolution bandwidth, depending 
on the frequency span.

The video bandwidth (VBW) is the lowpass bandwidth over which several results 
for one frequency point are smoothened. The lower the video bandwidth, the 
smoother the signal curve and the less variations there are.
The 9102 can be set to select the video bandwidth automatically as a function 
of the resolution bandwidth.

The sweep time (SWT) determines how long it takes for a complete sweep over 
the measured frequency range (span).
The 9102 can be set to automatically select the sweep time, depending on RBW 
and VBW. If manually set, the sweep time should be selected long enough for the 
filtered signal to reach steady state. The 9102 will output an “UNCALibrated” 
warning if the sweep time is too low.

To set the resolution bandwidth, the video bandwidth or the sweep time, proceed 
as follows:

1 In the main menu, select the appropriate softkey (RBW, VBW, or SWT).

2 Enter the value and complete the entry with the appropriate enter key for 
the unit, select a new value with the help of the UP/DOWN cursor keys, or 
switch to auto to leave the setting to the 9102.

Changing between automatic and manual mode

Push the appropriate softkey (RBW, VBW, or SWT) several times until the 
desired selection (auto or manual) is highlighted.

Setting up the level parameters
The accuracy and the dynamic range between the measured signal and the noise 
floor depend on the proper setting of the level settings. These consist of the 
reference level and the attenuation.

The reference level basically determines the level at the top of the display. The 
vertical axis is divided into eight horizontal lines; you can adjust the scale (which 
defaults to 10 dB per line) to your preferences.

The attenuation setting can be coupled to automatically follow the reference 
level setting. For reference levels of –20 dBm and lower, the attenuation is set to 
10 dB; the maximum attenuation is 50 dB.
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Attenuation or gain due to external coupling can be compensated by frequency-
dependent coupling factors, so that the displayed measurement values reflect 
the power at the device under test.

Setting the reference level 1 In the main menu, push the Ref. softkey or select Level followed by Ref. 
Alternatively, push the REF function key.
The reference level input field opens.

2 Enter the new reference level either using the numeric keys, closing the 
input field with the appropriate enter key, or with the UP/DOWN arrow 
keys.
The new reference level appears at the top of the vertical axis. The reference 
is based on the actually set output power.

Setting the hardware
attenuation

1 In the main menu, push the Attenuation softkey.
The Attenuation input field opens.

2 Enter a new attenuation value in the range from 0 to 50 dB (in 10 dB steps) 
and close the input field with one of the enter keys, or use the UP/DOWN 
arrow keys to select the attenuation value in the range 10 to 50 dB.
If the attenuation value is changed, the attenuation option will change to 
“manual”.

Changing the vertical
scale

The scale for the vertical axis (power) can be changed in the range from 1 to 
20 dB per division (vertical line in the displayed grid) in 1-3-5 steps as follows:

1 From the main menu, select Level.

2 Push the Scale softkey.
The Scale input field opens.

3 Select a new scale by entering a new number of dB per division numerically 
and pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

WARNING

The maximum input power level at the RF IN connector is 30 dBm (1 W). 
Higher input levels may result in serious damage of the instrument.

NOTE

The attenuation value of 0 dB can be set only with the numeric keys to avoid 
accidental deactivation. The 0 dB setting should be selected carefully because 
too high input levels at the input may damage the instrument.

NOTE

For precision measurements, the input level subtracted by the attenuation 
should not exceed –23 dBm.
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Selecting the level unit for
input and output

1 In the main menu, select Level > Units.

2 You can use logarthmic or linear units. In order to toggle the display 
between logarithmic and linear units press the Unit softkey in the lower 
right corner of the display and select log or lin.

3 You can now choose between the following units via the Unit softkey in the 
upper right corner of the display.
Logarithmic units: dBM, dBμV, dBmV and dBV
Linear units: V, mV, μV, mW, μW.

Compensating gains and
losses

If the device under test is connected to the 9102 Handheld Spectrum Analyzer 
via an amplifier or a device attenuating the signal, such as an antenna or a long 
cable, the measurement results are wrong by the gain or loss factor. This factor 
may be a constant or even frequency-dependent.

To view the correct measurement results, the gain or loss can be compensated. 
The 9102 can even compensate a frequency-dependent factor; a correction curve 
or table can be entered on an external PC using the 9100 Data Exchange Soft-
ware and loaded to the 9102. The section “Defining and loading external 
coupling parameters” on page 231 explains this part in more detail.

Enabling external device
compensation

Once correction values are stored in the 9102, they can be selected and activated 
as follows:

1 From the main menu, select Level > Ext. Dev. Memory.

2 Push Recall Ext. Dev. Comp.
A pull-down menu appears with a list of names for the compensation tables 
available in the 9102.

3 Select a compensation table using the UP/DOWN cursor keys and confirm 
your choice by pressing ENTER.
Compensation is still off, but the 9102 changes automatically to the Level 
menu.

4 Push the Ext. Dev. Comp. softkey until “on” is highlighted.
The text “Ext. Dev.”, together with the name of the file loaded, appears on 
the upper left-hand corner of the results display.

Turning external device
compensation off

1 From the main menu, select Level.

2 Press Ext. Dev. Comp. until “off” is highlighted.
The text “Ext. Dev.” to the left of the results display disappears.

NOTE

If a file was selected previously, steps 1 thru 3 can be omitted. In this case, 
select Level and continue with step 4.
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Deleting files for external
device compensation

You can delete files containing compensation parameters as follows:

1 From the main menu, select Level > Ext. Dev. Memory.

2 a. To delete an individual compensation file from the 9102 memory, push 
Delete Ext. Dev. Comp. Select a file name and press ENTER.
The compensation file is deleted from the list. Note that there will be no 
warning; once you have selected and requested a file to be deleted, this will 
occur immediately.

b. To delete all the compensation files from the 9102, push Delete All and 
confirm with ENTER.
All compensation files are deleted.

Changing the input impedance
Most RF applications are using an impedance of 50 Ω; other applications such 
as cable TV apply 75 Ω. The 9102 is designed with an input impedance of 50 Ω; 
it can, however, be used for testing a device with an impedance of 75 Ω by using 
the software impedance switch. The measurement results from the 50 Ω input 
are recalculated to fit the different impedance.

On the 9102, simply select the correct impedance value so that the 9102 can 
translate the internal measurement values to the power before the coupler.

1 Connect the device under test to the 9102 Handheld Spectrum Analyzer. 

2 From the main menu, select Level.

3 In the vertical menu, select the impedance of the device, that means select 
Impedance: 50 Ω or Impedance: 75 Ω, respectively.
New measurement results are presented with the new impedance value 
taken into account. In addition, if the impedance is changed to 75 Ω and the 
power had been displayed in dBm, the new measurements are shown in 
dBμV. If the impedance is changed to 50 Ω and the power had been 
displayed in dBμV, the new measurements are shown in dBm.

NOTE

Signal reflections on the cable between the 50 Ω and the 75 Ω device affect 
the measurement accuracy of the 9102 Handheld Spectrum Analyzer. For 
more accurate results, Willtek recommends using an impedance converter; 
such a converter will cause attenuation affecting the results. This attenuation 
can be compensated as explained in section “Compensating gains and losses” 
on page 57.
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Applying special functions on the signal
This section shows how the measurement can be triggered, how the number of 
measurements can be limited and how you can listen to the sound of the demod-
ulated signal.

Using a trigger The 9102 can either start signal analysis at a random point in time, or start the 
measurement when a given signal threshold is passed. Starting measurements 
depending on the actual signal level is only supported in zero span mode.

Selecting untriggered signal analysis

1 From the main menu push Freq > Trigger.
The Trigger menu appears.

2 Push the Free Run softkey.
The softkey is highlighted and the 9102 is ready for measurements at 
random times.

Selecting a trigger threshold in the RF signal

1 From the main menu push Freq > Trigger.
The Trigger menu appears.

2 Push the Video softkey.
The Video softkey is highlighted and an input field for the trigger level 
appears.

3 Enter the trigger level (in dBm) and complete the entry by pushing either the 
GHZ/DBM or the ENTER key.
The trigger threshold is displayed at the power axis; the symbol also indi-
cates the slope (direction in which the signal passes the threshold to start 
the measurement).

4 If necessary, change the slope between positive and negative direction by 
pushing the Slope softkey.
The active slope is indicated at the power axis by the following symbol (see 
also Figure 17): 

NOTE

The Video trigger is available in zero span mode only, otherwise the softkey 
description is grayed out.
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.

Using an external trigger

In order to use a TTL trigger signal generated by an external device, proceed as 
follows:

1 Connect the external device to the EXT. TRIG. connector on the top of the 
instrument (see “Ext. Ref. in/ Ext. Trig. connector” on page 13).

2 In the the main menu, enter the Sweep menu by pushing Freq > Trigger.
The Trigger menu appears.

3 Push the Extern softkey.
The softkey is highlighted.
After activating the external trigger the instrument waits to receive an 
impulse. When an impulse is detected on the external trigger entrance one 
sweep is performed. Afterwards the instrument waits for the next trigger 
event.

Performing a limited
number of measurements

The 9102 can run measurements continuously or a defined number of times. 
Limiting the number of measurements can be useful for statistical analyses.

1 From the main menu, select Freq > Sweep.
The Sweep menu appears.

2 Select the trigger mode: Push Cont. for continuous measurements or Single 
for a limited number of measurements.
The selected trigger mode is highlighted.

3 To enter the number of measurements, push the Single Count softkey, 
enter a number in the range from 1 to 1000 and press ENTER.
If Trigger Mode is set to Single, the 9102 performs the defined number of 
measurements and enters Hold mode.

Figure 17 Triggered measurement (in the time domain)
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– To restart single-mode measurements, push the HOLD/RUN function key or 
the Single softkey.

– To stop a continuous measurement, push the HOLD/RUN function key. Push 
it again to resume measurements.

Demodulating an AM or
FM signal

The 9102 has the ability to demodulate an AM (amplitude modulation) or FM 
(frequency modulation) signal and to output the signal at the built-in loud-
speaker. The signal should have a signal strength of at least –50 dBm; the 
demodulation bandwidth is about 10 kHz.

The 9102 can be set to either demodulate one signal permanently, or to toggle 
between the different frequencies. When set to permanently demodulate one 
signal, the 9102 demodulates the signal at the center position. 

When the 9102 is set to toggle between frequencies, it uses the marker frequen-
cies (marker M1 is enabled if not already active). After performing and displaying 
a new measurement, the 9102 demodulates and outputs the received signal for 
a short duration. This duration is selectable in the range from 1 to 10 seconds. 
The 9102 demodulates the carrier at the marker position; the demodulated signal 
is output for the selected duration. If more than one marker is active, demodu-
lation is resumed at the next marker frequency and so on until a piece of the 
signal at all active markers has been demodulated. The process starts anew with 
a new measurement.

The speaker volume can be selected as a percentage of the speaker’s maximum 
capacity.

1 Set a marker to the center frequency of the signal to be demodulated (see 
section “Setting up the trace” on page 62).

2 From the main menu, select Freq > Demod.
The Demodulation menu appears.

3 Select the demodulation method (AM, FM, or Off).
The selected method is highlighted.

4 Choose between permanent demodulation and intermittent demodulation at 
multiple markers by pressing the respective Demod softkey.

5 If demodulation at marker is selected, you can change the duration of the 
output of the demodulated signal: 

– Push the Duration softkey. 
The Demod Duration input field opens.

– Enter the new duration using the numeric keys. Conclude the entry with 
a push on one of the enter keys with the appropriate unit: push KHZ/
DBµV/MS for milliseconds or ENTER for seconds.

6 To adjust the speaker volume, push the Volume softkey, enter a new volume 
level from 0 to 100% and press ENTER.
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Setting up the trace

The trace functions provide different views of the measurements, for example 
the actual measurement or an average over the last couple of measurements. 
You can even select two different views of the measurement. Another possibility 
is to compare the actual measurement with an older measurement which has 
been stored in the 9102 and loaded to one of the trace views (see section 
“Storing and loading traces” on page 68).

The 9102 samples many measurements for each frequency point. With the 
detector functions, you can define the method to select which of the samples is 
displayed.

Selecting the trace mode The 9102 has five different modes to display a trace:

– In actual mode, the 9102 shows a complete new measurement in each trace. 
Subsequent traces are independent of each other.

– In hold mode, the last measurement is kept on the display; measurements 
continue but are not displayed.

– In max hold mode, the 9102 takes new measurements and, for each 
frequency point, compares the new measurement with the previous result. If 
the new measurement value is higher than the previous result, the new 
measurement value becomes the new result value; otherwise the old result 
value is kept. This way, the highest result since the start of the Max hold 
measurement (or a parameter change) is kept and displayed.

Figure 18 Example of two traces
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– Similarly, in min hold mode, the 9102 takes new measurements and 
compares the new measurement with the previous result. If the new 
measurement value is lower than the previous result, the new measurement 
value becomes the new result value; otherwise the old result value is kept. 
This way, the lowest result since the start of the Min hold measurement (or a 
parameter change) is kept and displayed.

– In average mode, the new measurement and previous ones are averaged for 
each frequency point displayed. The 9102 uses a recursive algorithm for 
averaging.

To select whether you want to view an actual measurement, stop and hold the 
last measurement, see the lowest or highest data for each frequency or an 
average value, proceed as follows:

1 In the main menu, select Trace.

2 Select the trace you want to modify (Trace A or Trace B) using the hori-
zontal softkeys.

3 Select the trace mode with the vertical softkeys (Actual, Hold, Max hold, 
Min hold, Average).
The trace mode is shown at the left-hand side of the vertical axis, e.g. 
A (ACT).

NOTE

For fastest valid results it is advisable to briefly activate the actual mode 
before selecting any other mode.

NOTE

When the trace is on hold, the measurement and failure counters continue 
counting. A second trace, if active, continues updating.
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Turning the second trace
on and off

You can define two different trace views, e.g. one with the actual values and one 
with the maximum values. While the first view (Trace A) is always active, the 
second can be switched off. The functions of turning Trace B on or off and 
selecting the trace mode are combined as follows:

1 From the main menu, select Trace > Trace B.

2 To turn trace B on, select the trace mode (Actual, Hold, Max hold, Min 
hold, or Average). To turn trace B off, select Off.
If activated, the trace mode is displayed left to the vertical axis, e.g. 
B (MAX).

Subtracting trace B from
trace A

If you have used two different trace views as described above, you can show the 
difference between trace A and trace B by subtracting trace B from trace A as 
follows:

1 In the Trace menu select the softkey Trace Function followed by the 
softkey Subtract A – B → A.

2 Select on to subtract trace B from trace A. On the left-hand side of the 
result area the term “Subtract“ will now be displayed to indicate that a 
mathematical function is being performed.

3 The result is displayed in trace A.

NOTE

If trace A is on Hold, this function is not available and thus the 
Subtract A – B → A softkey is greyed out.
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Adding trace B to trace A
If you have used two different trace views, you can also show the sum of 
trace A and trace B by adding the two traces as follows:

1 In the Trace menu select the softkey Trace Function followed by the 
softkey Add A + B → A.

2 Select on to add B to trace A. On the left-hand side of the result area the 
term “Add“ will now be displayed to indicate that a mathematical function is 
being performed.

3 The result is displayed in trace A.

Figure 19 Subtract A – B → A on
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Defining the number of
measurements for

averaging

When the trace mode is set to averaging, it may be useful to adjust the number 
of measurements over which the 9102 averages the results. The average count 
value that can be defined in the Trace menus applies to both traces alike.

The 9102 uses a recursive algorithm in which a new result is added to the older 
averages with a weighting factor; the description below indicates how to change 
this weighting factor.

1 Enter the Trace menu (select Trace > Trace A or Trace B from the main 
menu).

2 Push the Average Count softkey.
The Average input field opens.

3 Enter the number of measurements over which to average the results, in the 
range from 2 to 128.

4 Press ENTER.

Selecting the detection
method

For each new measurement, the 9102 selects one or two values from a number 
of measurements for each frequency value. The method is user-definable; the 
following methods are available (see also Figure 20): 

– Positive/negative peak: Both the largest and smallest values are taken and 
displayed as a vertical bar.

– Positive peak: Only the largest value is displayed. 

– Negative peak: The smallest value is shown.

– Sample: A sample measurement value is picked.

– If the 9132 RMS Detector Option is installed and activated on your 9102, the 
root mean square detector showing the RMS-effective level of the measured 
signal is also available. If the 9132 RMS Detector Option is not installed on 
your instrument, the RMS detector will be greyed out.

Figure 20 Trace detectors
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The detection method applies to both traces. Select the detection method as 
follows:

1 From the main menu, select Trace > Detect.

2 Select the trace method from the Detector section of the vertical softkeys.
The selected detection method is indicated at the left-hand side of the 
display.

Copying traces inside the
9102

You can copy an actual measurement from trace A to trace B or vice versa; this 
way you can keep the last measurement results on the screen and at the same 
time continue measuring or change the settings of the 9102 Handheld Spectrum 
Analyzer. The previous results in the target trace will be erased; the target trace 
will assume hold mode. 

To copy the measurement data from one trace to another, proceed as follows:

1 From the main menu, select Trace > Trace Function.

2 To copy the measurement results in trace A to trace B, press 
Copy A → B.
To copy results from trace B to trace A, press Copy B → A.

Figure 21 Trace Function menu

NOTE

If you first press Copy A → B, then Copy B → A (or vice versa), both traces 
will display the same results and will be in hold mode.
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Storing and loading traces

The 9102 provides the capability to store up to 99 traces in the 9102 and load 
them again at random. The stored trace can then be examined or compared to a 
recent measurement. In addition, stored traces can also be transferred to a PC 
using the 9100 Data Exchange Software which is delivered with the 9102. For 
details on the software refer to Chapter 15 “9100 Data Exchange Software”.

Storing a trace You can store either trace A and trace B. Any trace can be stored under a name 
with up to 11 characters. The procedure to enter text in alphanumerical input 
fields is explained in section “Entering numbers and text” on page 24. Note that 
along with the trace, the instrument settings such as frequency range, level 
range and markers are stored.

1 From the main menu, select Trace > Trace Memory.

2 Push either Store Trace.
An input field opens, allowing you to enter a name for the trace. Below the 
input field, a list of existing traces is indicated.

3 Enter a name for the trace. To use a modified trace name, you can move the 
cursor to a suitable trace name with the UP/DOWN cursor keys. The 
selected trace name also appears in the input field; use the LEFT/RIGHT 
cursor keys to move the cursor to the appropriate position within the trace 
name to enter additional characters or delete existing ones.

4 Confirm your choice by pressing ENTER.
The input field closes and the trace is stored under the selected name.

Figure 22 Trace A menu
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Reusing a trace name You cannot overwrite an existing trace using the same trace name. If you want 
to reuse a trace name, you will have to delete the old trace first.

Reloading a trace 1 From the main menu, select Trace > Trace Memory.

2 Push Recall Trace.
An input field opens, allowing you to enter the trace name. Below the input 
field, a list of existing traces is indicated.

3 Enter the name of the trace to load, or choose one with the UP/DOWN 
cursor keys.

4 Confirm your choice by pressing ENTER.
The input field closes and the trace is displayed.

Deleting a trace Stored traces can be deleted. Note that there will be no warning; once you have 
selected and requested a file to be deleted, this will occur immediately.

1 From the main menu, select Trace > Trace Memory.

2 Push Delete Trace.
An input field for the name of the trace to be deleted appears, together with 
a trace selection box.

3 Select the trace to be deleted using the UP/DOWN cursor keys. Alterna-
tively, enter the trace name with the numeric keys.

4 Confirm your choice by pressing ENTER.
The trace is deleted from the trace list.

5 Select another trace for deletion, or press ESCAPE to leave the entry field 
and the trace selection box.

Deleting all traces Instead of deleting traces individually, all traces can be deleted in one step. You 
will be asked to confirm this step.

1 From the main menu, select Trace > Trace Memory.

2 Press Delete All.
A query appears, asking you to confirm your selection.

3 Press ENTER to have all traces deleted.
The query disappears. All traces are deleted.

NOTE

Along with the trace, the 9102 also loads the settings that were used when 
the trace was saved. These will overwrite the current settings such as fre-
quency range, reference level and markers.
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Special measurement functions
Within spectrum analysis mode, three different frequency-selective types of 
power measurements are supported: 

– Channel power

– Adjacent channel power ratio (ACPR)

– Occupied bandwidth (OBW)

These are similar to the measurement types in channel power mode (see chapter 
“Channel Power Operation” on page 75), without the restrictions that the 
channel power mode poses with predefined parameters such as span and reso-
lution bandwidth.

Channel power This measurement includes the power of the selected channel. A channel is 
defined by center frequency and channel width (not the span in this case); see 
“Changing the channel width” on page 73. 

The 9102 displays the numerical result of the channel power measurement on the 
top-left. The measured bandwidth is indicated graphically with bandwidth 
boundaries shown in red.

Adjacent channel power
ratio (ACPR)

ACPR is the relation between the power transmitted in a neighboring (upper and/
or lower) channel and that in the communication channel used. The measure-
ment can be used to assess the quality of the modulator and the transmitter. The 
higher the result, the worse the transmitter because transmission in other chan-
nels may interfere with another ongoing communication. 
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The 9102 determines the adjacent channels by the channel width and channel 
spacing input parameters (see sections “Changing the channel spacing” and 
“Changing the channel width” on page 73). It displays the numerical results of 
the adjacent channel power ratio measurements for the left (lower) and right 
(upper) channels on the top-left. The measured bands are indicated graphically 
with bandwidth boundaries shown in red.

Occupied bandwidth
(OBW)

The occupied bandwidth identifies the frequency range into which a given 
percentage of the signal power falls. The frequency range is not necessarily 
symmetric around the center frequency but is selected so that the bandwidth to 
hold a certain user-defined OBW percentage is minimized. See section 
“Changing the occupied bandwidth percentage” on page 73.

OBW is indicated as an absolute value in the upper left-hand corner of the 
display, together with the OBW percentage; marker A1 and delta marker DA2 are 
assigned the lower and upper frequencies characterizing the frequency range. 
The power is measured over three times the normal channel bandwidth. The red 
boundary indicators mark the normal channel bandwidth as selected in the 
Channel System menu.
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Selecting the
measurement type

To select the type of measurement within spectrum analysis mode, proceed as 
follows:

1 From the Spectrum Analysis main menu, select Measure.

2 Select a measurement type using the vertically aligned softkeys in the 
Measure section.
The numerical result for the selected measurement appears in the upper 
left-hand corner of the display.

Switching special
measurement functions

off

To return to normal spectrum analysis measurements without special measure-
ment functions, simply press the softkey of the selected measurement type 
again. This will deactivate the special measurements.

NOTE

If the selected resolution bandwidth is high and the occupied bandwidth very 
low, there may be rare cases in which all the power for the occupied band-
width is mapped to one point in the spectrum display. In such a case, the 9102 
displays “N/A” (not available) instead of the bandwidth, and the markers usu-
ally indicating the bandwidth boundaries are invisible.
Increase the occupied bandwidth or decrease the resolution bandwidth to 
receive results.
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Changing the channel
width

The channel width is the bandwidth which the transmission is expected to 
occupy. It can be set for channel power and ACPR measurements as follows:

1 From the Spectrum Analysis main menu, select Measure.

2 Press Channel Width, enter a new value and press the respective enter key 
for the unit.
The new measurement bandwidth for channel power and ACPR is displayed 
with the softkey.

Changing the channel
spacing

The channel spacing is distance in frequency between two adjacent channels. It 
can be set for the ACPR measurements as follows:

1 From the Spectrum Analysis main menu, select Measure.

2 Press Channel Spacing, enter a new value and press the respective enter 
key for the unit.
The new channel spacing for ACPR is displayed with the softkey.

Reading the channel
power

In addition to the display elements explained on page 15, the channel power 
mode also includes a large display of the channel power, along with the channel, 
resolution bandwidth and sweep time. Please see the graphs on page 70 and the 
following for typical measurements. 

Changing the occupied
bandwidth percentage

OBW measurements identify the frequency range in which a certain percentage 
of the transmit power falls. The percentage value can be changed as follows:

1 From the Spectrum Analysis main menu, select Measure. 

2 Press % OBW and enter a new percentage value in the range from 5 to 99.

3 Push ENTER to close the input field.
If the OBW measurement type is selected, the new OBW percentage value is 
indicated in the upper left-hand corner of the display.
The 9102 recalculates the frequency range based on the new percentage 
value.
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Changing general analyzer
parameters

For the channel power, ACPR and OBW measurements within the spectrum 
analysis mode, the general settings such as center frequency, span, resolution 
bandwidth, can be changed as usual. A single-button approach to adjusting 
span, resolution bandwidth, video bandwidth, detector and trace mode is 
described below.

1 From the Spectrum Analysis main menu, select Measure. 

2 Press Adjust Settings.
Resolution bandwidth and video bandwidth are automatically set to 
optimum values (automatic mode). The trace detector is set to sample and 
the trace mode is set to actual.
If channel power measurements are selected, the span is set to 120% of the 
selected channel width. For ACPR measurements, the span is adjusted to 
1.2 × channel width + 2 × channel spacing. The OBW span is three times the 
channel width.

Viewing the spectrum analysis mode parameters
You can get an overview of all parameters set for this mode in the Parameter 
Window. To view the parameters, press the PARAM function key. To close the 
Parameter Window and return to the menu you opened it from, press the 
ESCAPE function key, the Exit softkey or the PARAM function key. To close the 
parameter page and change to the relevant main menu press the Main softkey.

Figure 23 Spectrum analysis mode parameters
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Chapter 4 Channel Power Operation

This chapter describes the instrument’s functions in channel power measurement 
mode. Topics discussed in this chapter are as follows:

– “About the channel power mode” on page 76

– “Selecting the measurement mode” on page 79

– “Operating in channel power mode” on page 80

– “Reading the channel power” on page 81

– “Changing the occupied bandwidth percentage” on page 81

– “Working with communication systems and frequency settings” on page 81

– “Setting up the level parameters” on page 84

– “Changing the input impedance” on page 87

– “Setting up the trace” on page 88

– “Storing and loading traces” on page 93

– “Viewing the channel power mode parameters” on page 95
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About the channel power mode
The 9102 offers different measurement modes, e.g. spectrum analysis and 
channel power measurements. The channel power mode allows you to measure 
the radiated power within a certain frequency band with a single button press. 
This mode reduces the complexity of all the setup possibilities for defined 
communication systems. Several communication systems are predefined in the 
9102 or can be downloaded from a PC using the 9100 Data Exchange Software; 
see section “Managing communication systems for channel power measure-
ments” on page 233 for more details.

Within channel power mode, three different frequency-selective types of power 
measurements are supported, for details on selecting the measurement type 
refer to “Selecting the measurement mode” on page 79:

– Channel power

– Adjacent channel power ratio (ACPR)

– Occupied bandwidth (OBW)

These measurement types are available both in channel power and in spectrum 
analysis mode. However, in contrast to the spectrum analysis mode, which looks 
at the power level at a certain frequency, the channel power mode uses a system 
approach. A system consists of several channels, each channel has a unique 
channel number assigned to it. Within a system the channels have the same 
bandwidth and channel spacing. Depending on the system the channels may 
overlap, follow each other directly or be separated by spaces.

In order to distinctly specify a system the following parameters have to be set on 
the 9102:

– First channel

– Last channel

– Channel width

– Channel spacing

– First frequency
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You can define systems and store them on the 9102. However, you can also make 
use of predefined systems available on the instrument. For a complete listing of 
the communication systems preinstalled on the instrument refer to “Preinstalled 
systems on the 9102” on page 343.

Channel power This measurement includes the power of the selected channel. The channel can 
be selected in the main menu whereas parameters like channel width (the 
measurement bandwidth) and channel spacing can be viewed and changed in 
the Channel System menu.

The 9102 displays the numerical result of the channel power measurement on the 
top-left. The measured bandwidth is indicated graphically with bandwidth 
boundaries shown in red.
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Adjacent channel power
ratio (ACPR)

ACPR is the relation between the power transmitted in a neighboring (upper or 
lower) channel and that in the channel used for communication. The measure-
ment can be used to assess the quality of the modulator and the transmitter; the 
higher the result, the worse the transmitter because transmission in other chan-
nels may interfere with another ongoing communication. 

The 9102 displays the numerical results of the adjacent channel power ratio 
measurements for the left (lower) and right (upper) channels on the top-left. The 
measured bands are indicated graphically with bandwidth boundaries shown in 
red.

For further details on the selection and availability of the ACPR measurement 
type refer to “Selecting the measurement mode” on page 79.

Occupied bandwidth
(OBW)

The occupied bandwidth identifies the frequency range into which a given 
percentage of the signal power falls. The frequency range is not necessarily 
symmetric around the center frequency but is selected so that the bandwidth to 
hold a certain user-defined OBW percentage is minimized. See section 
“Changing the occupied bandwidth percentage” on page 81.

OBW is indicated as an absolute value in the upper left-hand corner of the 
display, together with the OBW percentage; marker A1 and delta marker DA2 are 
assigned the lower and upper frequencies characterizing the frequency range. 
The power is measured over three times the normal channel bandwidth. The red 
boundary indicators mark the normal channel bandwidth as selected in the 
Channel System menu.
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Selecting the measurement mode
To select the channel power mode, proceed as follows:

1 Push the MODE function key.

2 Select the Channel Power softkey.
The main menu of the channel power mode appears. If you select a new 
mode, all parameters are set to the values used when the mode was last 
active. If, however, you resume the last active mode, the measurements 
continue without any changes to the parameters.

To select the type of measurement within the channel power mode, proceed as 
follows:

1 Push the Measure softkey.

2 Select a measurement type using the vertically aligned function softkeys 
(Channel Power, ACPR, or OBW).

NOTE

If the selected resolution bandwidth is high and the occupied bandwidth very 
low, there may be rare cases in which all the power for the occupied band-
width is mapped to one point in the spectrum display. In such a case, the 9102 
displays “N/A” (not available) instead of the bandwidth, and the markers usu-
ally indicating the bandwidth boundaries are invisible.
Increase the occupied bandwidth to receive results.
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Operating in channel power mode

This mode provides a measurement of the integral power within a given band-
width. The measurement mode can be selected as described on page 79.

In channel power mode, the frequency parameters, filters and sweep time cannot 
be selected individually. Instead, a communication system can be selected or 
defined in which the 9102 shall measure the channel power; the frequency 
parameters are stored with the communication system settings.

A few communication systems such as GSM are predefined in the 9102. More 
predefined system settings are available in the 9100 Data Exchange Software 
and can be downloaded to the 9102. In addition, the settings for an alternative 
communication system can be defined by the user, stored in the 9102 and 
recalled for channel power measurements.

NOTE

Adjacent Channel Power Ratio (ACPR) measurements are available only in 
those communication systems where the channel bandwidth does not exceed 
the channel spacing; otherwise, the measurement range of the adjacent 
channel would overlap with that in the selected channel.
As an alternative, use the ACPR measurements within the spectrum analysis 
mode (page 70).

Figure 24 Example of a channel power measurement
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Reading the channel power
In addition to the display elements explained on page 16, the channel power 
mode also includes a large display of the channel power, along with the channel, 
resolution bandwidth and sweep time. In the example in Figure 24 on page 80, 
the 9102 indicates the frequency range over which the channel power is 
measured between red vertical bars.

Changing the occupied bandwidth percentage
OBW measurements identify the frequency range in which a certain percentage 
of the transmit power falls. The percentage value can be changed as follows:

1 From the Channel Power main menu, select Channel System. 

2 Press % OBW and enter a new percentage value in the range from 5 to 99.

3 Press ENTER to close the input field.
If the OBW measurement type is selected, the new OBW percentage value is 
indicated in the upper left-hand corner of the display.
The 9102 recalculates the frequency range based on the new percentage 
value.

Working with communication systems and frequency settings

Selecting a
communication system on

the 9102

You can activate communication system settings stored on the 9102 as follows:

1 In the main menu of the channel power mode, select Ch. System > System 
Memory.
The System Memory menu appears.

2 Press Recall System. 
A scroll box appears, showing the available communication systems. Enter 
the system name as stored in the 9102, or move the UP/DOWN cursor keys 
to move the cursor to the system to be measured.

3 Press ENTER to confirm.
The input field and the scroll box disappear and the spectrum of the selected 
band is measured. The channel power of the first channel is displayed in the 
upper left-hand corner.

NOTE

The occupied bandwidth can also be changed via the Measure menu.
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The 9102 comes with preinstalled communication systems. For a listing of all the 
channel systems preinstalled on the 9102 refer to “Preinstalled systems on the 
9102” on page 343.

Setting up a new
communication system

A new communication system can be defined in terms of frequency range, 
channel bandwidth and spacing, and channel numbering; channels can then be 
addressed easily by their channel number rather than the carrier or center 
frequency. You can set up a new communication system as follows:

1 In the main menu, select Ch. System.
The Channel System menu appears.

2 Press First Channel and enter the first channel number in use by the 
system, then close the input field by pressing ENTER.

3 Press Last Channel to enter the number of the last channel in use by the 
system; close the input field by pressing ENTER.

4 Press Channel Width to change the measurement bandwidth; ensure to 
select the right unit (e.g. kHz).

5 Select the Channel Spacing softkey, enter the spacing between channel 
numbers and close the input field by pressing the enter key for the appro-
priate frequency unit.

6 Press the 1st Ch. Center softkey and enter the carrier frequency for the 
first channel in use (channel number defined with the first softkey). Close 
the input field using the enter key for the appropriate unit (e.g. MHZ).

7 For occupied bandwidth (OBW) measurements, select % OBW and enter the 
percentage value. Confirm the value by pressing ENTER.

8 Select System Memory > Store System, enter a new name for the system 
and press ENTER.

NOTE

Apart from the channel width the parameters for preinstalled configuration 
systems cannot be modified.

NOTE

Existing systems cannot be overwritten; you must delete the old system first.

If you delete a predefined system that is delivered with the 9102, it can be 
restored as depicted in section “Undeleting default communication systems” 
on page 83.
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Deleting a communication
system

To delete a the communication system settings stored on the 9102, take the 
following steps.

1 From the main menu, select Ch. System > System Memory.
The System Memory menu appears.

2 Push the Delete System softkey.
A scroll box with the list of available communication systems appears.

3 Select the system settings to be deleted by moving the UP/DOWN cursor 
keys to the respective system settings name, and confirm by pressing 
ENTER.
The system settings are deleted from the list.

4 Press ESCAPE to close the input field and the scroll box.

Deleting all
communication systems

You can clean up previously stored communication systems and easily delete all 
of them, including those that were originally delivered with the 9102.

1 From the main menu, select Ch. System > System Memory.
The System Memory menu appears.

2 Push the Delete All softkey.
A box appears, asking you to confirm that you want to delete all communi-
cation system settings.

3 Press ENTER to confirm deletion or ESCAPE to prevent the 9102 from 
deleting all the communication systems.
If confirmed, all the communication systems are deleted, that means the list 
of communication systems will be empty.

Undeleting default
communication systems

If you have deleted communication systems that were delivered with the 9102, 
you can restore these system settings. 

1 From the main menu, select Ch. System > System Memory.
The System Memory menu appears.

2 Push the Restore Default Systems softkey.
The 9102 creates all the communication systems that were originally deliv-
ered with the 9102.

Using the 9100 Data
Exchange Software with
communication systems

With the 9100 Data Exchange Software, more communication systems can be 
defined, loaded to the 9102 and selected for use. See section “Managing commu-
nication systems for channel power measurements” on page 233 for more infor-
mation. Furthermore, within the 9100 Data Exchange Software fruther 
predefined communication systems are available for transfer to your 9102. For a 
listing of the communication systems available refer to “Predefined systems in 
the 9100 Data Exchange Software” on page 344.
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Defining the frequency
span

The 9102 can display either the full spectrum used by the system, or the channel 
to be measured. Select the frequency span as desired:

In the main menu, select either Full System or Single Channel.
If you select Full System, the full frequency band as defined for the commu-
nication system will be displayed. If you select Single Channel, only the 
frequency range of the currently selected channel will be shown.

Changing the channel 1 In the main menu, push the Channel softkey.
The Channel input field opens.

2 Enter the desired channel number within the communication system at 
hand, or select the channel number with the UP/DOWN cursor keys.

3 Press ENTER to confirm.
The channel power for the selected channel is indicated in the upper left-
hand corner.

Changing the sweep time
The sweep time (SWT) determines how long it takes for a complete sweep over 
the measured frequency range (span).
By default, the 9102 automatically selects the sweep time depending on other 
measurement parameters such as the span. In some cases it may be an advantage 
to manually select a different sweep time. This is the case with pulsed signals 
where a longer sweep time may increase the measurement accuracy. If manually 
set, the sweep time should be selected long enough for the filtered signal to 
reach steady state. The 9102 will output an “UNCALibrated” warning if the sweep 
time is too low.

To change the sweep time in channel power mode, proceed as follows:

1 From the main menu, select Measure.

2 Push the SWT softkey.

3 Enter the new sweep time and confirm with the appropriate enter key for 
the unit.

Setting up the level parameters
The accuracy and the dynamic range between the measured signal and the noise 
floor depend on the proper setting of the level settings. These consist of the 
reference level and the attenuation.

The reference level basically determines the level at the top of the display. The 
vertical axis is divided into eight horizontal rows; you can adjust the scale (which 
defaults to 10 dB per line) to your preferences.
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The attenuation setting can be coupled to automatically follow the reference 
level setting. For reference levels of –20 dBm and lower, the attenuation is set to 
10 dB; the maximum attenuation is 50 dB.

Attenuation or gain due to external coupling can be compensated by frequency-
dependent coupling factors, so that the displayed measurement values reflect 
the power at the device under test.

Setting the reference level 1 In the main menu, push the Ref. softkey or select Level followed by Ref. 
Alternatively, push the REF function key.
The Reference Level input field opens.

2 Enter the new reference level either using the numeric keys, closing the 
input field with the appropriate enter key, or with the UP/DOWN arrow 
keys.
The new reference level appears at the top of the vertical axis. The reference 
is based on the actually set output power.

Setting the hardware
attenuation

1 In the main menu, push the Attenuation softkey.
The Attenuation input field opens.

2 Enter a new attenuation value in the range from 0 to 50 dB (in 10 dB steps) 
and close the input field with one of the enter keys, or use the UP/DOWN 
arrow keys to select the attenuation value in the range from 10 to 50 dB.
If the attenuation value is changed, the attenuation option will change to 
“auto”.

WARNING

The maximum allowable input power level at the RF IN connector is 30 dBm 
(1 W). Higher input levels may result in serious damage of the instrument.

NOTE

The attenuation value of 0 dB can be set only with the numeric keys to avoid 
accidental deactivation. The 0 dB setting should be selected carefully because 
input levels that are too high at the input may damage the instrument.

NOTE

For precision measurements, the input level subtracted by the attenuation 
should not exceed –23 dBm.
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Changing the vertical
scale

The scale for the vertical axis (power) can be changed in the range from 1 to 
20 dB per division (vertical line in the displayed grid) in 1-3-5 steps as follows:

1 In the main menu, select Level.

2 Push the Scale softkey.
The Scale input field opens.

3 Select a new scale by entering a new number of dB per division numerically 
and pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

Selecting the level unit for
input and output

1 In the main menu, select Level > Units.

2 You can use logarthmic or linear units. In order to toggle the display 
between logarithmic and linear units press the Unit softkey in the lower 
right corner of the display and select log or lin.

3 You can now choose between the following units via the Unit softkey in the 
upper right corner of the display.
Logarithmic units: dBm, dBμV, dBmV and dBV
Linear units: V, mV, μV, mW, μW.

Compensating gains and
losses

If the device under test is connected to the 9102 Handheld Spectrum Analyzer 
via an amplifier or a device atttenuating the signal, such as an antenna or a long 
cable, the measurement results are wrong by the gain or loss factor. This factor 
may be a constant or even frequency-dependent.

To view the correct measurement results, the gain or loss can be compensated. 
The 9102 can even compensate a frequency-dependent factor; a correction curve 
or table can be entered on an external PC using the 9100 Data Exchange Soft-
ware and loaded to the 9102. Section “Defining and loading external coupling 
parameters” on page 231 explains this part in more detail.

Enabling external device
compensation

Once correction values are stored in the 9102, these can be selected and acti-
vated as follows:

1 In the main menu, select Level > Ext. Dev. Memory.

2 Press Recall Ext. Dev. Comp.
A pull-down menu appears with a list of names for the compensation tables 
available in the 9102.

3 Select a compensation table using the UP/DOWN cursor keys and confirm 
your choice by pressing ENTER.

4 Select the Level menu and push the Ext. Dev. Comp. softkey until “On” is 
highlighted.
The text “Ext. Dev.” appears to the left of the results display.
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Turning external device
compensation off

1 In the main menu, select Level.

2 Push Ext. Dev. Comp. until “Off” is highlighted.
The text “Ext. Dev.” to the left of the results display disappears.

Deleting files for external
device compensation

You can delete files containing compensation parameters as follows:

1 In the main menu, select Level > Ext. Dev. Memory.

2 a. To delete an individual compensation file from the 9102 memory, press 
Delete Ext. Dev. Comp. Select a file name and press ENTER.
The compensation file is deleted from the list. Note that there will be no 
warning; once you have selected and requested a file to be deleted, this will 
occur immediately.
b. To delete all the compensation files from the 9102, push Delete All and 
confirm by pressing ENTER.
All compensation files are deleted.

Changing the input impedance
Most RF applications are using an impedance of 50 Ω; other applications such 
as cable TV apply 75 Ω. The 9102 is designed with an input impedance of 50 Ω; 
it can, however, be used for testing a device with an impedance of 75 Ω by using 
the software impedance switch. The measurement results from the 50 Ω input 
are recalculated to fit the different impedance.

On the 9102, simply select the correct impedance value so that the 9102 can 
translate the internal measurement values to the power before the coupler.

1 To connect a 75 Ω device, connect the device under test to the 9102 Hand-
held Spectrum Analyzer. 

2 In the main menu, select Level.

3 In the vertical menu, select the impedance of the device, that means select 
Impedance: 50 Ω or Impedance: 75 Ω, respectively.
New measurement results are presented with the new impedance value 
taken into account. In addition, if the impedance is changed to 75 Ω and the 
power had been displayed in dBm, the new measurements are shown in 
dBμV. If the impedance is changed to 50 Ω and the power had been 
displayed in dBμV, the new measurements are shown in dBm.

NOTE

Signal reflections on the cable between the 50 Ω and the 75 Ω device affect 
the measurement accuracy of the 9102 Handheld Spectrum Analyzer. For 
more accurate results, Willtek recommends using an impedance converter; 
such a converter will cause attenuation affecting the results. This attenuation 
can be compensated as explained in section “Compensating gains and losses” 
on page 86.
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Setting up the trace

The trace functions provide different views of the measurements, for example 
the actual measurement or an average over the last couple of measurements. 
You can even select two different views of the measurement. Another possibility 
is to compare the actual measurement with an older measurement which has 
been stored in the 9102 and loaded to one of the trace views (see section 
“Storing and loading traces” on page 93).

The 9102 samples many measurements for each frequency point. With the 
detector functions, you can define the method to select which of the samples is 
displayed.

Selecting the trace mode The 9102 has five different modes to display a trace:

– In Actual mode, the 9102 shows a complete new measurement in each trace. 
Subsequent traces are independent of each other.

– In hold mode, the last measurement is kept on the display; measurements 
continue but are not displayed.

– In max hold mode, the 9102 takes new measurements and, for each 
frequency point, compares the new measurement with the previous result. If 
the new measurement value is higher than the previous result, the new 
measurement value becomes the new result value; otherwise the old result 
value is kept. This way, the highest result since the start of the max hold 
measurement (or a parameter change) is kept and displayed.

Figure 25 Example of two traces in channel power mode
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– Similarly, in min hold mode, the 9102 takes new measurements and 
compares the new measurement with the previous result. If the new 
measurement value is lower than the previous result, the new measurement 
value becomes the new result value; otherwise the old result value is kept. 
This way, the lowest result since the start of the min hold measurement (or a 
parameter change) is kept and displayed.

– In average mode, the new measurement and previous ones are averaged for 
each frequency point displayed. The 9102 uses a recursive algorithm for 
averaging.

To select whether you want to view an actual measurement, stop and hold the 
last measurement, see the lowest or highest data for each frequency or an 
average value, proceed as follows:

1 In the main menu, select Trace.

2 Select the trace you want to modify (Trace A or Trace B) using the hori-
zontal softkeys.

3 Select the trace mode with the vertical softkeys (Actual, Hold, Max hold, 
Min hold, Average).
The trace mode is shown at the left-hand side of the vertical axis, e.g. 
A (ACT).

NOTE

For fastest valid results it is advisable to briefly activate the actual mode 
before selecting any other mode.

NOTE

When the trace is on hold, the measurement and failure counters continue 
counting. A second trace, if active, continues updating.
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Turning the second trace
on and off

You can define two different trace views, e.g. one with the actual values and one 
with the maximum values. While the first view (Trace A) is always active, the 
second can be switched off. The functions of turning Trace B on or off and 
selecting the trace mode are combined as follows:

1 From the main menu, select Trace > Trace B.

2 To turn trace B on, select the trace mode (Actual, Hold, Max hold, Min 
hold, or Average). To turn trace B off, select Off.
If activated, the trace mode is displayed left to the vertical axis, e.g. 
B (MAX).

Subtracting trace B from
trace A

If you have used two different trace views as described above, you can show the 
difference between trace A and trace B by subtracting trace B from trace A as 
follows:

1 In the Trace menu select the softkey Trace Function followed by the 
softkey Subtract A – B → A.

2 Select on to subtract trace B from trace A. On the left-hand side of the 
result area the Term “Subtract“ will now be displayed to indicate that a 
mathematical function is being performed.

3 The result is displayed in trace A.

NOTE

If trace A is on Hold, this function is not available and thus the 
Subtract A – B → A softkey is greyed out.
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Adding trace B to trace A If you have used two different trace views, you can also show the sum of trace A 
and trace B by adding the two traces as follows:

1 In the Trace menu select the softkey Trace Function followed by the 
softkey Add A + B → A.

2 Select on to add B to trace A. On the left-hand side of the result area the 
term “Add“ will now be displayed to indicate that a mathematical function is 
being performed. The result is displayed in trace A.

Defining the number of
measurements for

averaging

When the trace mode is set to averaging, it may be useful to adjust the number 
of measurements over which the 9102 averages the results. The average count 
value that can be defined in the Trace menus applies to both traces alike.

The 9102 uses a recursive algorithm in which a new result is added to the older 
averages with a weighting factor; the description below indicates how to change 
this weighting factor.

1 Enter the Trace menu (select Trace > Trace A or Trace B from the main 
menu).

2 Push the Average Count softkey.
The Average input field opens.

3 Enter the number of measurements over which to average the results, in the 
range from 2 to 128.

4 Press ENTER.

Selecting the detection
method

In channel power mode, the detection method is set to Sample by default. If the 
9132 RMS Detector Option is installed and activated on your 9102, the root mean 
square detector showing the RMS-effective level of the measured signal is also 
available. In order to set the detection method to RMS proceed as follows:

1 From the main menu, select Trace > Detect.

2 Select the RMS from the Detector section of the vertical softkeys.
The selected detection method is indicated at the left-hand side of the 
display.

NOTE

If the 9132 RMS Detector Option is not installed on your 9102, the RMS 
detector is greyed out.
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Copying traces inside the
9102

You can copy an actual measurement from trace A to trace B or vice versa; this 
way you can keep the last measurement results on the screen and at the same 
time continue measuring or change the settings of the 9102 Handheld Spectrum 
Analyzer. The previous results in the target trace will be erased; the target trace 
will assume hold mode. 

To copy the measurement data from one trace to another, proceed as follows:

1 From the main menu, select Trace > Trace Function.

2 To copy the measurement results from trace A to trace B, press 
Copy A → B.
To copy results from trace B to trace A, press Copy B → A.

Figure 26 Detect menu with activated 9132 RMS Detector Option

NOTE

If you first press Copy A → B, then Copy B → A (or vice versa), both traces 
will display the same results and will be in hold mode.
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Storing and loading traces

The 9102 provides the capability to store up to 99 traces in the 9102 and load 
them again at random. The stored trace can then be examined or compared to a 
recent measurement. In addition, stored traces can also be transferred to a PC 
using the 9100 Data Exchange Software which is delivered with the 9102. For 
details on the software refer to Chapter 15 “9100 Data Exchange Software”.

Storing a trace You can store either trace A and B. Any trace can be stored under a name with 
up to 11 characters. The procedure to enter text in alphanumerical input fields is 
explained in section “Entering numbers and text” on page 24. Note that along 
with the trace, the instrument settings such as frequency range, level range and 
markers are stored.

1 Activate the trace you want to store by pushing Trace > Trace A or 
Trace B.

2 From the main menu, select Trace > Trace Memory.

3 Push Store Trace.
An input field opens, allowing you to enter a name for the trace. Below the 
input field, a list of existing traces is indicated.

4 Enter a name for the trace. To use a modified trace name, you can move the 
cursor to a suitable trace name with the UP/DOWN cursor keys. The 
selected trace name also appears in the input field; use the LEFT/RIGHT 
cursor keys to move the cursor to the appropriate position within the trace 
name to enter additional characters or delete existing ones.

5 Confirm your choice by pressing ENTER.
The input field closes and the trace is stored under the selected name.

Figure 27 Trace A menu
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Reusing a trace name You cannot overwrite an existing trace using the same trace name. If you want 
to reuse a trace name, you will have to delete the old trace first.

Reloading a trace 1 From the main menu, select Trace > Trace Memory.

2 Push Recall Trace.
An input field opens, allowing you to enter the trace name. Below the input 
field, a list of existing traces is indicated.

3 Enter the name of the trace to load, or choose one with the UP/DOWN 
cursor keys.

4 Confirm your choice by pressing ENTER.
The input field closes and the trace is displayed.

Deleting a trace Stored traces can be deleted. Note that there will be no warning; once you have 
selected and requested a file to be deleted, this will occur immediately.

1 From the main menu, select Trace > Trace Memory.

2 Push Delete Trace.
An input field for the name of the trace to be deleted appears, together with 
a trace selection box.

3 Select the trace to be deleted using the UP/DOWN cursor keys. Alterna-
tively, enter the trace name with the numeric keys.

4 Confirm your choice by pressing ENTER.
The trace is deleted from the trace list.

5 Select another trace for deletion, or press ESCAPE to leave the entry field 
and the trace selection box.

Deleting all traces Instead of deleting traces individually, all traces can be deleted in one step. You 
will be asked to confirm this step.

1 From the main menu, select Trace > Trace Memory.

2 Press Delete All.
A query appears, asking you to confirm your selection.

3 Press ENTER to have all traces deleted.
The query disappears. All traces are deleted.

NOTE

Along with the trace, the 9102 also loads the settings that were used when 
the trace was saved. These will overwrite the current settings such as fre-
quency range, reference level and markers.
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Viewing the channel power mode parameters
You can get an overview of all parameters set for this mode in the Parameter 
Window. To view the parameters, press the PARAM function key. To close the 
Parameter Window and return to the menu you opened it from, press the 
ESCAPE function key, the Exit softkey or the PARAM function key. To close the 
parameter page and change to the relevant main menu press the Main softkey.

Figure 28 Channel power mode parameters
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Chapter 5 Power Sensor Operation

This chapter describes the instrument’s functions in power sensor mode. Topics 
discussed in this chapter are as follows:

– “About the power sensor mode” on page 98

– “Connecting the 9162 Insertion Power Sensor” on page 99

– “Setting up the 9102 for insertion power measurements” on page 100

– “Reading the power measurement” on page 101
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About the power sensor mode

The 9102 offers different measurement modes, e.g. spectrum analysis and 
channel power measurements. The power sensor mode allows you to perform a 
broadband measurement of the power of a radio frequency signal. The mode uses 
the 9162 Insertion Power Sensor which measures the power in both directions, 
i.e. the transmitted and the reflected power on the way between the source and 
the sink. No direct RF connection to the 9102 is required.

The power sensor mode further reduces the complexity of all the setup possibil-
ities; all you need to enter is the frequency, the expected signal type and the 
desired measurement unit.

WARNING

The 9162 Insertion Power Sensor may be hot during and after operation.
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Connecting the 9162 Insertion Power Sensor
The insertion power sensor takes measurements on RF signals in the range from 
70 to 2700 MHz at power levels from 1 mW to 50 W. Proper measurements are 
achieved if the impedance at the input and output power is 50 Ω.
To perform measurements with the power sensor and read the results on the 
9102, the following connections need to be made:

1 Connect the cable from the 9162 Insertion Power Sensor to the Multi Port 
connector of the 9102.

2 Connect the cable coming from the signal source to the RF In port (N-type 
connector) of the power sensor.

3 Connect the cable going to the signal sink (e.g. an antenna) to the RF Out 
port (N-type connector) of the power sensor. If you do not have a sink, the 
RF Out connector should be terminated with 50 Ω.

WARNING

Do not feed more than +47 dBm into the 9162 Insertion Power Sensor, the 
device may be destroyed otherwise.
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Setting up the 9102 for insertion power measurements

Starting the insertion
power mode

To select the insertion power mode, proceed as follows:

1 Push the MODE function key.

2 Select the Insertion Power softkey.
The insertion power menu appears. If you select a new mode, all parameters 
are set to the values used when the mode was last active. If, however, you 
resume the last active mode, the measurements continue without any 
changes to the parameters.

Setting up the signal type
and frequency

The insertion power sensor is a broadband measuring device. However, to ensure 
the best measurement accuracy, it is advisable to provide information about the 
signal type and the frequency of the signal:

1 Select one of the Signal function softkeys (CW, GSM, TETRA, UMTS, 
CDMA or DVB-T).
The appropriate function softkey is highlighted, and the Frequency input 
field opens.

2 Enter the center frequency of the signal to be measured (in the range 70 to 
2700 MHz) and conclude the entry by pushing an enter key for the unit 
(GHZ or MHZ).

Note

Although the frequency can be entered at a higher accuracy, it is sufficient to 
supply it in full megahertz.
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Defining the displayed
measurement unit

The 9102 can display results either in Watts (linear unit) or in dBm (logarithmic 
unit). 
To select the desired unit, press the Display function softkey once or twice until 
the desired display mode (log or lin) is highlighted.

Reading the power measurement
The 9162 Insertion Power Sensor performs broadband measurements of the 
forward and reverse power. The results are shown as follows:

Forward power The 9102 displays a bar indicating the power to the scale shown below the bar, 
either in Watts (linear display) or in dBm (logarithmic display). The numerical 
value is also shown on the right-hand side.

The forward power is the amount of power being transmitted into the RF In port 
and further from the RF Out port to the signal sink, without being reflected.

Reverse power The 9102 displays a bar indicating the power to the scale shown below the bar, 
either in Watts (linear display) or in dBm (logarithmic display). The numerical 
value is also shown on the right-hand side.

The reverse power is the amount of power being transmitted (or reflected by the 
sink) into the RF Out port and further from the RF Out port to the signal sink, 
without being reflected.
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Chapter 6 Signal Generator Operation

This chapter describes the instrument’s functions that are specific to the signal 
generator mode. Topics discussed in this chapter are as follows:

– “About the signal generator mode” on page 104

– “Switching the signal generator on and off” on page 104

– “Changing the frequency” on page 104

– “Setting the level” on page 107

– “Applying special functions on the signal” on page 107
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About the signal generator mode
In this mode the instrument can be used to generate a signal in order to stimu-
late an electronic circuit with a set frequency and a set level. As this mode is only 
used for sending out a signal and no actual measurement takes place on the 
instrument there is no trace display. Depending on the application of the signal 
the result of the process could be for example the booting of a processor.

Selecting the measurement mode
To select signal generator mode, proceed as follows:

1 Push the MODE function key.
The Mode menu appears.

2 Select (VSWR/)Tracking ... > Signal Generator.
The Signal Generator main menu appears (see Figure 30 and Figure 29).

Switching the signal generator on and off
When you select the signal generator mode as described above, the signal gener-
ator is switched on by default. To switch it off press the Output softkey until off 
is highlighted. If you switch the signal generator off and select another mode, it 
will be automatically switched on again as soon as you return to signal generator 
mode.

Changing the frequency
The main menu shows softkeys for the definition of the frequency range on the 
display. The softkeys available for setting frequency parameters depend on the 
frequency mode you select. The modes available are: CW (Continuous Wave) and 
SWP (Sweep).

Selecting the frequency
mode

To configure the softkeys available for setting the frequency you can choose 
between the two frequency modes CW and SWP. The CW mode is active by 
default. To change between CW and SWP, press the Mode softkey until the 
required option is highlighted. The main menu display will change accordingly.
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Setting the center
frequency

1 In the main menu, select the CW mode by pressing the Mode softkey until 
CW is highlighted. The CW main menu as shown above appears.

2 Push the CENT function key (or the Frequency softkey in the main menu).
An entry field appears, indicating the center frequency currently set and the 
step size for the UP/DOWN cursor keys.

3 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

Conclude the entry by pressing the appropriate enter key determining the unit 
(GHZ/DBM for gigahertz, MHZ/DB/µS for megahertz).

Figure 29 Signal Generator main menu in CW mode
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Setting start and stop
frequency

1 In the main menu select the SWP mode by pressing the Mode softkey until 
SWP is highlighted. The SWP main menu as shown above appears.

2 In the main menu, push the Start softkey.
An entry field appears, indicating the start frequency currently set and the 
step size for the UP/DOWN cursor keys.

3 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

4 Push the Stop softkey and enter the frequency.

Selecting the step size for
the frequency input

The center, start and stop frequencies can either be set by entering a new value 
with the numeric keys, or by using the arrow keys (UP, DOWN) to increase or 
decrease the current setting. The step size for an arrow keypress can be either 
automatically selected by the 9102, or manually adjusted.

Manually setting the frequency step size

1 In the Signal Generator main menu select the frequency mode (CW or SWP) 
for which you want to set the frequency step size as described in “Selecting 
the frequency mode” on page 104.

2 Push the FStep key.
The Freq Step entry field opens.

3 Enter a new frequency step value and close the entry field by pressing Enter.
The auto/manual selection switches to manual and the selected frequency 
step size is displayed on the softkey.

Figure 30 Signal Generator main menu in SWP mode
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Setting the frequency step size selection to automatic

1 In the Transmission main menu, select Freq.

2 Push the FStep softkey several times until the “auto” selection is high-
lighted.

Setting the level
1 In the main menu, push the Level softkey.

The level input field opens.

2 Enter the new level either using the numeric keys, closing the input field 
with the appropriate enter key, or with the UP/DOWN arrow keys. The level 
can be entered in the range of –10 dBm and –30 dBm in 1 dB steps.

Applying special functions on the signal
This section shows how the number of measurements can be limited.

Performing a limited
number of measurements

The 9102 can run measurements continuously or a defined number of times. 
Limiting the number of measurements can be useful for statistical analyses.

1 In the main menu, select Sweep.
The Sweep menu appears.

2 Select the sweep mode: Push Cont. for continuous signal generation or 
Single for a single sweep.
The selected sweep mode is highlighted.
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Chapter 7 Transmission Operation

This chapter describes the instrument’s functions that are specific to the trans-
mission mode. Topics discussed in this chapter are as follows:

– “About the transmission mode” on page 110

– “Selecting the measurement mode” on page 110

– “Switching the tracking generator on and off” on page 111

– “Normalizing the trace” on page 111

– “Setting the tracking output power” on page 112

– “Changing the frequency settings” on page 113

– “Selecting RBW, VBW and SWT” on page 116

– “Setting up the level parameters” on page 116

– “Applying special functions on the signal” on page 119

– “Setting up the trace” on page 121

– “Storing and loading traces” on page 126

– “Viewing the transmission mode parameters” on page 129
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About the transmission mode
The transmission mode allows you to determine the frequency characteristics of 
passive (e.g. bandpass filters) or active devices under test (e.g. amplifiers). In this 
mode the 9102 Handheld Spectrum Analyzer uses a tracking generator – a signal 
generator which is synchronous with the receive frequency of the spectrum 
analyzer – to measure e.g. reflection and the transmission characteristics of 
devices under test. The tracking generator has an output frequency from 1 MHz 
to 4 GHz. Its level is adjustable from –10 to –30 dBm which allows adaptation of 
the output signal to the demands of devices under test. In the 9100 applications 
guide contained on the documentation CD delivered with your instrument you 
will find an application example for this mode.

Selecting the measurement mode
To select transmission mode, proceed as follows:

1 Push the MODE function key.
The Mode menu appears.

2 Select (VSWR/)Tracking ... > Transmission.
The Transmission main menu appears.

Figure 31 Example of a transmission measurement
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Switching the tracking generator on and off
When you select the transmission mode as described in “Selecting the measure-
ment mode”, the tracking generator is switched on by default. To switch it off, 
proceed as follows:

1 In the Transmission main menu, press the Tracking Generator softkey.

2 Press the Tracking softkey until “off“ is highlighted. 

If you switch the tracking generator off and select the spectrum analysis or 
channel power mode, it will be automatically switched on again as soon as you 
return to transmission mode.

Normalizing the trace
In order to eliminate slight ripples in the trace display the Normalize function 
should be used before taking measurements. There are two softkeys available for 
normalizing the display for trace A and trace B. The following figure shows trace 
A with normalization deactivated (off).

In order to achieve a normalized trace proceed as follows:

1 Establish a cable connection between the RF IN and the RF OUT 
connector.

2 In the Transmission main menu, press the Tracking Generator softkey.

3 Press the Normalize A or B softkey until “on“ is highlighted.

Figure 32 Normalize A off
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The message “Normal.’d“ on the left-hand side of the results area indicates that 
the display is normalized. If you change measurement parameters, e.g. tracking 
output, frequency settings or attenuation, it may be necessary to repeat the 
normalizing procedure. If this is the case, the message “Normalize“ will be 
displayed against a red background on the left-hand side of the results area.

The following figure shows trace A after normalization has been activated.

Setting the tracking output power
The tracking generator’s output power can be set in a range from –10 to 
–30 dBm. In order to change the output power proceed as follows:

1 In the Transmission main menu, press the Tracking Generator softkey.

2 Press the Tracking Output Power softkey. The Tracking Output Power input 
field appears.

3 Use the UP/DOWN cursor keys to enter a new output power value in 1 dBm 
steps or enter the new value using the numeric keypad.

4 Press ENTER.

NOTE

If trace B is not active, the Normalize B softkey will be greyed out.

Figure 33 Normalize A on
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Changing the frequency settings

There are different methods to set the frequency range to be measured; the range 
can be expressed by either the start and stop frequencies (i.e. first and last 
frequencies on the display), or by center frequency and span (i.e. the center and 
the frequency range), or by other combinations of center frequency, span, start 
and stop frequencies. 

All four parameters are accessible in the Freq menu. On the main menu, however, 
only one of the combinations mentioned above is shown, depending on the 
parameter last entered.

Setting start and stop
frequency

1 Push the CENT function key (or the Freq softkey in the Transmission main-
menu).
The vertical softkeys include Start and Stop softkeys.

2 Push the Start softkey.
An entry field appears, indicating the start frequency currently set and the 
step size for the UP/DOWN cursor keys.

3 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

Figure 34 Frequency menu

NOTE

Changing a frequency parameter may affect an associated parameter.
Example: If you change the span to the maximum of 4 GHz, the start and stop 
frequencies are changed to 0 and 4 GHz, respectively.
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4 Conclude the entry by pushing an enter key for the unit (GHZ/DBM for 
gigahertz, MHZ/DB/µS for megahertz).
If the start frequency entered is lower than the stop frequency, the hori-
zontal axis will display the range from the new start to the stop frequency.
If the new start frequency is higher than or equal to the stop frequency, the 
start frequency is used as the center frequency with zero span, i.e. the signal 
at the selected frequency will be shown in the time domain.

5 Push the Stop softkey and enter the frequency for the right end of the 
display.

You can also place softkeys for the start and stop frequencies available on the 
main menu by changing the frequency mode, see “Changing the main menu for 
different frequency parameters”.

Setting center frequency
and span

1 Push the CENT function key (or the Freq softkey in the Transmission main 
menu).
The vertical softkeys include Center and Span. An entry field appears, indi-
cating the center frequency currently set and the step size for the up/down 
cursor keys.

2 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

3 Conclude the entry by pushing an enter key for the unit (GHZ/DBM for 
gigahertz, MHZ/DB/µS for megahertz, KHZ/DBµV/MS for kilohertz, or 
ENTER for hertz).

4 Push the Span softkey and enter the frequency for the range from the left 
to the right end of the display.

You can also place softkeys for the center frequency and the span available on 
the main menu by changing the frequency mode, see section “Changing the main 
menu for different frequency parameters” below.

Changing the main menu
for different frequency

parameters

The Transmission main menu shows two softkeys for the definition of the 
frequency range on the display. Different methods exist to define the range as 
depicted above; you can configure these softkeys to one of the two allowable 
combinations as follows:

1 From the Transmission main menu, select Freq > Freq Mode.

2 Select the combination of softkeys that you want to see in the main menu 
(Start/Stop or Center/Span).

3 Return to the main menu by pushing the Main ... softkey.
The main menu appears and displays the selected combination of keys.

Note that the description of the horizontal frequency axis changes with the 
selected parameter set.
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Viewing the complete
frequency band

To change the frequency range to the full bandwidth supported by the 9102 for 
transmission measurements, proceed as follows:

1 From the Transmission main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Full Span softkey.
The leftmost frequency changes to 0 Hz and the rightmost frequency to 
4 GHz.

Performing measurements
in the time domain

Measurements on a selected center frequency can also be displayed in the time 
domain.

1 From the Transmission main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Center softkey and enter the desired center frequency; close the 
input field by selecting the appropriate unit with one of the enter keys.

3 Push the Zero Span softkey.
The horizontal axis becomes the time axis. The scale width is identical to the 
sweep time. See Figure 35 on page 120 for an example.

Selecting the step size for
the frequency input

The center, start and stop frequencies can be set either by entering a new value 
with the numeric keys, or by using the arrow keys (UP, DOWN) to increase or 
decrease the current setting. The step size for an arrow keypress can either be 
selected automatically by the 9102, or manually adjusted.

Manually setting the frequency step size

1 From the Transmission main menu, select Freq. 

2 Push the FStep softkey.
The Freq Step entry field opens.

3 Enter a new frequency step value and close the entry field by pressing Enter.

Setting the frequency step size selection to automatic

1 From the Transmission main menu, select Freq.

2 Push the FStep softkey several times until the “auto” selection is high-
lighted.
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Selecting RBW, VBW and SWT
The resolution bandwidth (RBW) is the 3 dB bandwidth of the IF filter for 
selecting the signal to be measured. The resolution bandwidth describes the 
ability of the spectrum analyzer to discriminate between adjacent signals of 
similar amplitude. Only signals spaced at a frequency of more than the RBW can 
be discriminated from one another.
The 9102 can be set to automatically select the resolution bandwidth, depending 
on the frequency span.

The video bandwidth (VBW) is the lowpass filter over which several results for 
one frequency point are smoothened. The lower the video bandwidth, the 
smoother the signal curve and the less variations there are.
The 9102 can be set to select the video bandwidth automatically as a function 
of the resolution bandwidth. A typical value for the video bandwidth should be 
equal or 10 times lower than the radio bandwidth value.

The sweep time (SWT) determines how long it takes for a complete sweep over 
the measured frequency range (span).
The 9102 can be set to automatically select the sweep time, depending on RBW 
and VBW. If manually set, the sweep time should be selected long enough for the 
filtered signal to reach steady state. The 9102 will output an “UNCALibrated” 
warning if the sweep time is too low.

To set the resolution bandwidth, the video bandwidth or the sweep time, proceed 
as follows:

1 In the main menu, select the appropriate softkey (RBW, VBW, or SWT).

2 Enter the value and complete the entry with the appropriate enter key for 
the unit, select a new value with the help of the UP/DOWN cursor keys, or 
switch to auto to leave the setting to the 9102.

Changing between automatic and manual mode

Push the appropriate softkey (RBW, VBW, or SWT) until the desired selection 
(auto or manual) is highlighted.

Setting up the level parameters
The dynamic range between the measured signal and the noise floor depend on 
the proper setting of the level settings. These consist of the reference level and 
the attenuation.

The reference level basically determines the level at the top of the display. The 
vertical axis is divided into eight horizontal rows. You can adjust the scale (which 
defaults to 10 dB per line) to your preferences.

The attenuation setting can be coupled to automatically follow the reference 
level setting. For reference levels of –20 dBm and lower, the attenuation is set to 
10 dB; the maximum attenuation is 50 dB.
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Attenuation or gain due to external coupling can be compensated by frequency-
dependent coupling factors, so that the displayed measurement values reflect 
the power at the device under test.

Switching the display You can switch the display between absolute and relative as follows:

1 In the main menu select Level. The Level menu is displayed.

2 Toggle the display to absolute or relative by pressing the Display softkey 
until the required display option is highlighted. If you select abs, reference 
level and the unit dBm will be shown in the results display. If you select rel, 
reference and the unit dB will be shown.

Setting the reference level 1 In the main menu, push the Ref. softkey or select Level followed by Ref. 
Alternatively, push the REF function key.
The Reference Level input field opens.

2 Enter the new reference level either using the numeric keys, closing the 
input field with the appropriate enter key, or with the UP/DOWN arrow 
keys.
The new reference level appears at the top of the vertical axis. The reference 
is based on the actual set output power.

Setting the hardware
attenuation

1 In the main menu, push the ATTN. softkey.
The Attenuation input field opens.

2 Enter a new attenuation value in the range from 0 to 50 dB (in 10 dB steps) 
and close the input field with one of the enter keys, or use the UP/DOWN 
arrow keys to select the attenuation value in the range from 10 to 50 dB.

WARNING

The maximum input power level at the RF IN connector is 30 dBm (1 W). 
Higher input levels may result in serious damage of the instrument.

NOTE

The attenuation value of 0 dB can be set only with the numeric keys to avoid 
accidental deactivation. The 0 dB setting should be selected carefully because 
too high input levels may damage the instrument.

NOTE

For precision measurements, the input power level subtracted by the attenua-
tion should not exceed –23 dBm.
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Changing the vertical
scale

The scale for the vertical axis (power) can be changed in the range from 1 to 
20 dB per division (vertical line in the displayed grid) in 1-3-5 steps as follows:

1 In the main menu, select Level.

2 Push the Scale softkey.
The Scale input field opens.

3 Select a new scale by entering a new number of dB per division numerically 
and pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

Compensating gains and
losses

If the device under test is connected to the 9102 Handheld Spectrum Analyzer 
via an amplifier or a device attenuating the signal, such as an antenna or a long 
cable, the measurement results are wrong by the gain or loss factor. This factor 
may be a constant or even frequency-dependent.

To view the correct measurement results, the gain or loss can be compensated. 
The 9102 can even compensate a frequency-dependent factor; a correction curve 
or table can be entered on an external PC using the 9100 Data Exchange Soft-
ware and loaded to the 9102. The section “Defining and loading external 
coupling parameters” on page 231 explains this part in more detail.

Enabling external device
compensation

Once correction values are stored in the 9102, these can be selected and acti-
vated as follows:

1 In the main menu, select Level > Ext. Dev. Memory.

2 Press Recall Ext. Dev. Comp.
A pull-down menu appears with a list of names for the compensation tables 
available in the 9102.

3 Select a compensation table using the UP/DOWN cursor keys and confirm 
your choice by pressing ENTER.
Compensation is still off, but the 9102 changes automatically to the Level 
menu.

4 Push the Ext. Dev. Comp. softkey until “on” is highlighted.
The text “Ext. Dev.”, together with the name of the file loaded, appears on 
the upper left-hand corner of the results display.

Turning external device
compensation off

1 In the main menu, select the Level menu.

2 Press Ext. Dev. Comp. until “off” is highlighted.
The text “Ext. Dev.” to the left of the results display disappears.

NOTE

Steps 1 thru 3 may be omitted if a file had been previously selected. In this 
case, select the Level menu and continue with step 4.
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Deleting files for external
device compensation

You can delete files containing compensation parameters as follows:

1 From the main menu, select Level > Ext. Dev. Memory.

2 a. To delete an individual compensation file from the 9102 memory, push 
Delete Ext. Dev. Comp. Select a file name and press ENTER.
The compensation file is deleted from the list. Note that there will be no 
warning; once you have selected and requested a file to be deleted, this will 
occur immediately.

b. To delete all the compensation files from the 9102, push Delete All and 
confirm by pressing ENTER.
All compensation files are deleted.

Applying special functions on the signal
This section shows how the measurement can be triggered and how the number 
of measurements can be limited.

Using a trigger The 9102 can either start signal analysis at a random point in time, or start the 
measurement when a given signal threshold is passed. Starting measurements 
depending on the actual signal level is only supported in zero span mode.

Selecting untriggered signal analysis

1 In the the main menu push Freq > Trigger.
The Trigger menu appears.

2 Push the Free Run softkey.
The softkey is highlighted and the 9102 is ready for measurements at 
random times.

Selecting a trigger threshold in the RF signal

1 In the main menu push Freq > Trigger.
The Trigger menu appears.

2 Push the Video softkey.
The Video softkey is highlighted and an input field for the trigger level 
appears.

3 Enter the trigger level (in dBm) and complete the entry by pushing either the 
GHZ/DBM or the ENTER key.
The trigger threshold is displayed at the power axis; the symbol also indi-
cates the slope (direction in which the signal passes the threshold to start 
the measurement).

NOTE

The Video trigger is available in zero span mode only, otherwise the softkey 
description is grayed out.
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4 If necessary, change the slope between positive and negative direction by 
pushing the Slope softkey.
The active slope is indicated at the power axis by the following symbol (see 
also Figure 35): 

Using an external trigger

In order to use a trigger signal generated by an external device, proceed as 
follows:

1 Connect the external device to the EXT. TRIG. connector on the top of the 
instrument (see “Ext. Ref. in/ Ext. Trig. connector” on page 13).

2 In the the main menu, enter the Sweep menu by pushing Freq > Trigger.
The Trigger menu appears.

3 Push the Extern softkey.
The softkey is highlighted.
After activating the external trigger the instrument waits to receive an 
impulse. When an impulse is detected on the external trigger entrance one 
sweep is performed. Afterwards the instrument waits for the next trigger 
event.

Figure 35 Triggered measurement (in the time domain)
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Performing a limited
number of measurements

The 9102 can run measurements continuously or a defined number of times. 
Limiting the number of measurements can be useful for statistical analyses.

1 In the main menu, select Freq > Sweep.
The Sweep menu appears.

2 Select the trigger mode: Push Cont. for continuous measurements or Single 
for a limited number of measurements.
The selected trigger mode is highlighted.

3 To enter the number of measurements, push the Single Count softkey, 
enter a number in the range from 1 to 1000 and press ENTER.
If Trigger Mode is set to Single, the 9102 performs the defined number of 
measurements and enters hold mode.

– To restart single-mode measurements, push the HOLD/RUN function key or 
the Single softkey.

– To stop a continuous measurement, push the HOLD/RUN function key. Push 
it again to resume measurements.

Setting up the trace

The trace functions provide different views of the measurements, for example 
the actual measurement or an average over the last couple of measurements. 
You can even select two different views of the measurement. Another possibility 
is to compare the actual measurement with an older measurement which has 
been stored in the 9102 and loaded to one of the trace views (see section 
“Storing and loading traces” on page 126).

The 9102 samples many measurements for each frequency point. With the 
detector functions, you can define the method to select which of the samples is 
displayed.

Figure 36 Example of two traces
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Selecting the trace mode The 9102 has five different modes to display a trace:

– In actual mode, the 9102 shows a complete new measurement in each trace. 
Subsequent traces are independent of each other.

– In hold mode, the last measurement is kept on the display; measurements 
continue but are not displayed.

– In max hold mode, the 9102 takes new measurements and, for each 
frequency point, compares the new measurement with the previous result. If 
the new measurement value is higher than the previous result, the new 
measurement value becomes the new result value; otherwise the old result 
value is kept. This way, the highest result since the start of the Max hold 
measurement (or a parameter change) is kept and displayed.

– Similarly, in min hold mode, the 9102 takes new measurements and 
compares the new measurement with the previous result. If the new 
measurement value is lower than the previous result, the new measurement 
value becomes the new result value; otherwise the old result value is kept. 
This way, the lowest result since the start of the Min hold measurement (or a 
parameter change) is kept and displayed.

– In average mode, the new measurement and previous ones are averaged for 
each frequency point displayed. The 9102 uses a recursive algorithm for 
averaging.

To select whether you want to view an actual measurement, stop and hold the 
last measurement, see the lowest or highest data for each frequency or an 
average value, proceed as follows:

1 In the main menu, select Trace.

2 Select the trace you want to modify (Trace A or Trace B) using the hori-
zontal softkeys.

3 Select the trace mode with the vertical softkeys (Actual, Hold, Max hold, 
Min hold, Average).
The trace mode is shown at the left-hand side of the vertical axis, e.g. 
A (ACT).

NOTE

For fastest valid results it is advisable to briefly activate the actual mode 
before selecting any other mode.

NOTE

When the trace is on hold, the measurement and failure counters continue 
counting. A second trace, if active, continues updating.
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Turning the second trace
on and off

You can define two different trace views, e.g. one with the actual values and one 
with the maximum values. While the first view (Trace A) is always active, the 
second can be switched off. The functions of turning Trace B on or off and 
selecting the trace mode are combined as follows:

1 In the main menu, select Trace > Trace B.

2 To turn trace B on, select the trace mode (Actual, Hold, Max hold, Min 
hold, or Average). To turn trace B off, select Off.
If activated, the trace mode is displayed left to the vertical axis, e.g. 
B (MAX).

Subtracting trace B from
trace A

If you have used two different trace views as described above, you can show the 
difference between trace A and trace B by subtracting trace B from trace A as 
follows:

1 In the Trace menu select the softkey Trace Function followed by the 
softkey Subtract A – B –> A.

2 Select on to subtract trace B from trace A. On the left-hand side of the 
result area the Term “Subtract“ will now be displayed to indicate that a 
mathematical function is being performed.

3 The result is displayed in trace A.

NOTE

If trace A is on Hold, this function is not available and thus the 
Subtract A – B –> A softkey is greyed out.
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Adding trace B to trace A If you have used two different trace views, you can also show the sum of 
trace A and trace B by adding the two traces as follows:

1 In the Trace menu select the softkey Trace Function followed by the 
softkey Add A + B –> A.

2 Select on to add B to trace A. On the left-hand side of the result area the 
term “Add“ will now be displayed to indicate that a mathematical function is 
being performed.

3 The result is displayed in trace A.

Trace Offset As soon as you use one of the two mathematical functions, Subtract A + B → A 
or Add A + B → A, the Trace Offset function is activated. You can use this func-
tion to adjust the trace display, if the mathematical calculation performed 
causes the resulting trace to move outside the display area. In order to bring the 
trace back into view, use the Trace Offset softkey to modify the offset value until 
the trace moves back into the display area.

Defining the number of
measurements for

averaging

When the trace mode is set to averaging, it may be useful to adjust the number 
of measurements over which the 9102 averages the results. The average count 
value that can be defined in the Trace menus applies to both traces alike.

The 9102 uses a recursive algorithm in which a new result is added to the older 
averages with a weighting factor; the description below indicates how to change 
this weighting factor.

1 Select the Trace menu (select Trace > Trace A or Trace B from the main 
menu).

2 Push the Average Count softkey.
The Average input field opens.

3 Enter the number of measurements over which to average the results, in the 
range from 2 to 128.

4 Press ENTER.
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Selecting the detection
method

For each new measurement, the 9102 selects one or two values from a number 
of measurements for each frequency value. The method is user-definable; the 
following methods are available (see also Figure 37): 

– Positive/negative peak: Both the largest and smallest values are taken and 
displayed as a vertical bar.

– Positive peak: Only the largest value is displayed. 

– Negative peak: The smallest value is shown.

– Sample: A sample measurement value is picked.

– If the 9132 RMS Detector Option is installed and activated on your 9102, the 
root mean square detector showing the RMS-effective level of the measured 
signal is also available. If the 9132 RMS Detector Option is not installed on 
your instrument the RMS detector will be greyed out.

The detection method applies to both traces. Select the detection method as 
follows:

1 From the main menu, select Trace > Detect.

2 Select the trace method from the Detector section of the vertical softkeys.
The selected detection method is indicated at the left-hand side of the 
display.

Copying traces inside the
9102

You can copy an actual measurement from trace A to trace B or vice versa; this 
way you can keep the last measurement results on the screen and at the same 
time continue measuring or change the settings of the 9102 Handheld Spectrum 
Analyzer. The previous results in the target trace will be erased; the target trace 
will assume hold mode. 

To copy the measurement data from one trace to another, proceed as follows:

1 From the main menu, select Trace > Trace Function.

2 To copy the measurement results from trace A to trace B, press 
Copy A → B.
To copy results from trace B to trace A, press Copy B → A.

Figure 37 Trace detectors
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Storing and loading traces

Figure 38 Trace function menu

NOTE

If you first press Copy A → B, then Copy B → A (or vice versa), both traces 
will display the same results and will be in hold mode.

Figure 39 Trace A menu
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The 9102 provides the capability to store up to 99 traces in the 9102 and load 
them again at random. The stored trace can then be examined or compared to a 
recent measurement. In addition, stored traces can also be transferred to a PC 
using the 9100 Data Exchange Software which is being delivered with the 9102. 
For details on the software refer to Chapter 15 “9100 Data Exchange Software”.

Storing a trace You can store either trace A or B. Any trace can be stored under a name with up 
to 11 characters. The procedure to enter text in alphanumerical input fields is 
explained in section “Entering numbers and text” on page 24. Note that along 
with the trace, the instrument settings such as frequency range, level range and 
markers are stored.

1 In the main menu, select Trace > Trace Memory.

2 Press either Store Trace
An input field opens, allowing you to enter a name for the trace. Below the 
input field, a list of existing traces is indicated.

3 Enter a name for the trace. To use a modified trace name, you can move the 
cursor to a suitable trace name with the UP/DOWN cursor keys. The 
selected trace name also appears in the input field; use the LEFT/RIGHT 
cursor keys to move the cursor to the appropriate position within the trace 
name to enter additional characters or delete existing ones.

4 Confirm your choice by pressing ENTER.
The input field closes and the trace is stored under the selected name.

Reusing a trace name You cannot overwrite an existing trace using the same trace name. If you want 
to reuse a trace name, you will have to delete the old trace first.

Reloading a trace 1 In the main menu, select Trace > Trace Memory.

2 Push either Recall Trace.
An input field opens, allowing you to enter the trace name. Below the input 
field, a list of existing traces is indicated.

3 Enter the name of the trace to load, or choose one with the UP/DOWN 
cursor keys.

4 Confirm your choice by pressing ENTER.
The input field closes and the trace is displayed.

Deleting a trace Stored traces can be deleted. Note that there will be no warning; once you have 
selected and requested a file to be deleted, this will occur immediately.

NOTE

Along with the trace, the 9102 also loads the settings that were used when 
the trace was saved. These will overwrite the current settings such as fre-
quency range, reference level and markers.
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1 In the main menu, select Trace > Trace Memory.

2 Press Delete Trace.
An input field for the name of the trace to be deleted appears, together with 
a trace selection box.

3 Select the trace to be deleted using the UP/DOWN cursor keys. Alterna-
tively, enter the trace name with the numeric keys.

4 Confirm your choice by pressing ENTER.
The trace is deleted from the trace list.

5 Select another trace for deletion, or press ESCAPE to leave the input field 
and the trace selection box.

Deleting all traces Instead of deleting traces individually, all traces can be deleted in one step. You 
will be asked to confirm this step.

1 In the main menu, select Trace > Trace Memory.

2 Press Delete All.
A query appears, asking you to confirm your selection.

3 Press ENTER to have all traces deleted.
The query disappears. All traces are deleted.
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Viewing the transmission mode parameters
You can get an overview of all parameters set for this mode in the Parameter 
Window. To view the parameters, press the PARAM function key. To close the 
Parameter Window and return to the menu you opened it from, press the 
ESCAPE function key, the Exit softkey or the PARAM function key. To close the 
parameter page and change to the relevant main menu press the Main softkey

Figure 40 Transmission mode parameters
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Chapter 8 The 9130 VSWR/DTF Reflection 
Measurement Option

This chapter gives a general overview on the 9130 VSWR/DTF Reflection 
Measurement Option. Topics discussed in this chapter are as follows:

– “About the 9130 VSWR/DTF Reflection Measurement Option” on page 132

– “Specifications” on page 132

– “Measurement modes” on page 133

– “Hardware requirements” on page 134

– “Connecting the 9160 VSWR/DTF Bridge” on page 134

– “Calibration” on page 135
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About the 9130 VSWR/DTF Reflection Measurement Option
The 9130 VSWR/DTF Reflection Measurement Option, in conjunction with the 
9160 VSWR/DTF Bridge, turns the 9102 into a full-featured reflection test set. 
The functionality of the 9130 VSWR/DTF Reflection Measurement Option is 
tailored to the testing requirements involved in the acceptance and maintenance 
of professional antenna systems, e.g. cellular base stations. This measurement 
option is especially suitable for field applications. However, it also offers lab and 
service applications, e.g. reflection measurements at passive RF devices (such as 
attenuators, matching pads and filters) are possible.
During reflection measurements the 9102’s tracking generator works as a test 
signal generator while the sprectrum analyzer measures the level of the reflected 
signal. In the 9100 applications guide contained on the documentation CD deliv-
ered in your instrument you will find detailed application examples for the 9130 
VSWR/DTF Reflection Measurement Option. 

Specifications

Table 14 9130 VSWR/DTF Reflection Measurement Option 
specifications

Measurement range  ≥ 70 dB

Measurement units dB, VSWR, mRho

Measurement sample points 501

Cable parameter edit Auto or manual

Measurement method Vector or scalar

Table 15 9160 VSWR/DTF Bridge specifications

Frequency range 1 MHz to 4 GHz

Directivity (10 MHz to 3 GHz) Typ. 30 dB

Insertion Loss ≤ 2 x 10 dB

Impedance 50 Ohm

DUT port return loss ≥ 18 dB
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Measurement modes
The 9130 VSWR/DTF Reflection Measurement Option offers three additional 
measurement modes: reflection, distance to fault and cable loss. If the 9130 
VSWR/DTF Reflection Measurement Option is installed and activated on your 
9102, three additional submenus besides signal generator and transmission are 
available in the VSWR/Tracking... submenu:

– Reflection
This mode enables you to test performance and match of antenna systems 
over the desired frequency range in one view.
For a description of measurements using the reflection mode refer to 
“Reflection Operation” on page 137.

– Distance to Fault
This mode puts the attention on the cable and offers a detailed analysis of 
feeder cables. Cable-related problems can be easily detected and located.
For a description of measurements using the distance to fault mode refer to 
“Distance to Fault Operation” on page 155.

– Cable Loss
The cable loss mode allows you to determine the average cable loss.
For a description of measurements using the distance to fault mode refer to 
“Cable Loss Operation” on page 165.

For details on selecting a measurement mode refer to “Selecting the measure-
ment mode” on page 26.

Figure 41 VSWR/Tracking menu
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Hardware requirements
Following are the hardware requirements and recommendations for performing 
measurements using the 9130 VSWR/DTF Reflection Measurement Option:

– 9160 VSWR/DTF Bridge

– 9150 Tracking Generator

– Calibration set for N or 7/16“

– Test port extension cable N or 7/16“.

For details on options and accessories for the 9102 please refer to “Options and 
accessories” on page 5

Connecting the 9160 VSWR/DTF Bridge
For reflection measurements a measurement bridge is necessary. The 9160 
VSWR/DTF Bridge is used to measure the load impedance of an antenna or 
another device very precisely. It covers the full operational frequency range of 
the 9102.

In order to set up the 9102 for VSWR/DTF reflection measurements simply 
connect the 9160 VSWR/DTF Bridge to the RF in and RF out connectors as well 
as to the Multi Port connector on the top of the instrument.

For details on the 9102’s connectors refer to “Connecting the 9102 Handheld 
Spectrum Analyzer” on page 12.

NOTE

The test port extenstion cable is especially recommended for reflection mea-
surements. A direct connection to antenna feeder cables is in this case often 
not practicable as these cables are usually very rigid. The test port extension 
cable can have a minimal influence on measurement results. However, test 
results are not influenced in a decisive way, so this effect can be disregarded.



Chapter 8 The 9130 VSWR/DTF Reflection Measurement Option
Calibration

9102 Handheld Spectrum Analyzer Software version 5.10 135

Calibration
Before starting VSWR/DTF measurement the instrument needs to be calibrated. 
For reference calibration a calibration standard with an open, short and load 
reference connector has to be connected. Willtek offers calibration sets Open/
Short/Load Type 7/16“ male and Type N male as well as test port extension cables 
with different connector standards (N and 7/16“ DIN). For ordering information 
refer to “Options and accessories” on page 5. For a description of the calibration 
procedure within the measurement modes reflection, distance to fault and cable 
loss refer to Chapter 9, Chapter 10 and Chapter 11.
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Chapter 9 Reflection Operation

This chapter describes the instrument’s functions that are specific to the 
reflection mode. Topics discussed in this chapter are as follows:

– “About the reflection mode” on page 138

– “Selecting the measurement mode” on page 139

– “Preparative steps” on page 139

– “Changing the frequency settings” on page 140

– “Reflection calibration” on page 143

– “Changing the units settings” on page 144

– “Setting up the level parameters” on page 145

– “Performing a limited number of measurements” on page 147

– “Setting up the trace” on page 147

– “Storing and loading traces” on page 150

– “Using limits” on page 152

– “Viewing the reflection mode parameters” on page 153
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About the reflection mode
Modern antenna systems for professional applications are characterised by a low 
reflection and a good match. All components of the antenna system should be 
matched to 50 Ohm, the standard impedance for professional wireless equip-
ment. If all components are matched, the system’s efficiency is at its maximum 
level. The better the match the better the ratio between radiated and lost RF 
energy.
The reflection mode enables you to test performance and match of antenna 
systems over the desired frequency range in one view and to validate perfor-
mance for acceptance and maintenance. 
During reflection measurements the 9102’s tracking generator generates a test 
signal. The 9102 measures the signal level reflected by the antenna. For 
measuring the load impedance of an antenna very precisely with a linear 
behavior over 4 GHz, the 9160 VSWR DTF bridge is used. The reflection measure-
ment modes offers scalar and vector reflection measurements and displays all 
common reflection measurement units such as return loss, rho, VSWR and the 
reflected power ratio.
Figure 42 shows an example for a return loss measurement results display.

On the measurement results screen markers are usually set on the limits of the 
uplink and downlink band. These are the ranges which are the interesting parts 
of the spectrum displayed. Two further markers are set on the maximum reflec-
tion within those bands to indicate whether the antenna system under test 
performs within the usual reflection limits of 17 to 20 dB return loss. For a 
detailed application example for the reflection measurement mode refer to the 
applications guide contained on the documentation CD delivered with your 
instrument.

Figure 42 Example of a return loss measurement
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Selecting the measurement mode
To select the reflection mode, proceed as follows:

1 Push the MODE function key.
The Mode menu appears.

2 Select VSWR/Tracking ... > Reflection.
The reflection main menu appears.

Preparative steps
Before starting the measurement the following preparative steps are necessary:

– Connecting the 9160 VSWR/DTF Bridge
For details on this procedure refer to “Connecting the 9160 VSWR/DTF 
Bridge” on page 134.

– Selecting the desired frequency band

– Calibration

The next section section shows how to change the frequency settings on the 
9102. This section is followed by a description of the calibration process.

NOTE

This mode is available for selection, if the 9130 VSWR/DTF Reflection Mea-
surement Option is installed and acitivated on your instrument.
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Changing the frequency settings

There are different methods to set the frequency range to be measured; the range 
can be expressed by either the start and stop frequencies (i.e. first and last 
frequencies on the display), or by center frequency and span (i.e. the center and 
the frequency range), or by other combinations of center frequency, span, start 
and stop frequencies.

All four parameters are accessible in the Freq menu. On the main menu, however, 
only one of the combinations mentioned above is shown, depending on the 
parameter last entered.

Setting start and stop
frequency

1 Push the CENT function key (or the Freq softkey in the Reflection main 
menu).
The vertical softkeys include Start and Stop softkeys.

2 Push the Start softkey.
An entry field appears, indicating the start frequency currently set and the 
step size for the UP/DOWN cursor keys.

3 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

Figure 43 Frequency menu

NOTE

Changing a frequency parameter may affect an associated parameter.
Example: If you change the span to the maximum of 4 GHz, the start and stop 
frequencies are changed to 0 and 4 GHz, respectively.
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4 Conclude the entry by pushing an enter key for the unit (GHZ/DBM for 
gigahertz, MHZ/DB/µS for megahertz).
If the start frequency entered is lower than the stop frequency, the hori-
zontal axis will display the range from the new start to the stop frequency.
If the new start frequency is higher than or equal to the stop frequency, the 
start frequency is used as the center frequency with zero span, i.e. the signal 
at the selected frequency will be shown in the time domain.

5 Push the Stop softkey and enter the frequency for the right end of the 
display.

You can also place softkeys for the start and stop frequencies available on the 
main menu by changing the frequency mode, see “Changing the main menu for 
different frequency parameters”.

Setting center frequency
and span

1 Push the CENT function key (or the Freq softkey in the Reflection main 
menu).
The vertical softkeys include Center and Span. An entry field appears, indi-
cating the center frequency currently set and the step size for the up/down 
cursor keys.

2 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

3 Conclude the entry by pushing an enter key for the unit (GHZ/DBM for 
gigahertz, MHZ/DB/µS for megahertz, KHZ/DBµV/MS for kilohertz, or 
ENTER for hertz).

4 Push the Span softkey and enter the frequency for the range from the left 
to the right end of the display.

You can also place softkeys for the center frequency and the span available on 
the main menu by changing the frequency mode, see section “Changing the main 
menu for different frequency parameters” below.

Changing the main menu
for different frequency

parameters

The Reflection main menu shows two softkeys for the definition of the frequency 
range on the display. Different methods exist to define the range as depicted 
above; you can configure these softkeys to one of the two allowable combina-
tions as follows:

1 From the Reflection main menu, select Freq > Freq Mode.

2 Select the combination of softkeys that you want to see in the main menu 
(Start/Stop or Center/Span).

3 Return to the main menu by pushing the Main ... softkey.
The main menu appears and displays the selected combination of keys.

Note that the description of the horizontal frequency axis changes with the 
selected parameter set.
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Viewing the complete
frequency band

To change the frequency range to the full bandwidth supported by the 9102 for 
reflection measurements, proceed as follows:

1 From the Reflection main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Full Span softkey.
The leftmost frequency changes to 0 Hz and the rightmost frequency to 
4 GHz.

Performing measurements
in the time domain

Measurements on a selected center frequency can also be displayed in the time 
domain.

1 From the Reflection main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Center softkey and enter the desired center frequency; close the 
input field by selecting the appropriate unit with one of the enter keys.

3 Push the Zero Span softkey.
The horizontal axis becomes the time axis. The scale width is identical to the 
sweep time.

Selecting the step size for
the frequency input

The center, start and stop frequencies can be set either by entering a new value 
with the numeric keys, or by using the arrow keys (UP, DOWN) to increase or 
decrease the current setting. The step size for an arrow keypress can either be 
selected automatically by the 9102, or manually adjusted.

Manually setting the frequency step size

1 From the Reflection main menu, select Freq. 

2 Push the FStep softkey.
The Freq Step entry field opens.

3 Enter a new frequency step value and close the entry field by pressing Enter. 
The auto/manual selection switches to manual and the selected frequency 
step size is displayed on the softkey.

Setting the frequency step size selection to automatic

1 From the Reflection main menu, select Freq.

2 Push the FStep softkey several times until the “auto” selection is high-
lighted.
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Reflection calibration
Before starting the measurement the instrument needs to be calibrated with a 
reference match resistor. For details on available calibration sets refer to 
“Options and accessories” on page 5 and “Calibration” on page 135. On the left 
handside of the results display a red icon reading “Calibrate“ informs you that a 
calibration needs to be performed. You can perform a vector or scalar calibration 
for your measurement. In order to calibrate the instrument for your reflection 
measurement proceed as follows:

1 Connect the test port extension cable to the 9160 VSWR/DTF Bridge.

2 In the Reflection main menu press Reflection Cal. softkey. the Reflection 
Calibration menu is displayed.

3 In this menu you can select the mode to be used for your measurement by 
pressing the Scalar or Vector softkey. The scalar measurement measures 
the level of the reflected signal. The vector measurement is even more 
precise and also measures the phase of the reflected signal. It increases 
measurement accuracy as well as the return loss measurement range.
The 9102 will guide you through the calibration process by onscreen 
messages as shown in Figure 44. When prompted as shown connect the cali-
bration set to the test port extension cable and press Continue. You can 
abort the calibration process by pressing the Cancel ! softkey.

4 When calibration is completed the Reflection main menu will be displayed 
again. On the left handside of the results display the calibration icon will 
now be displayed in green and read “Calib’d“ (Calibrated).

The measurement graph shows full reflection (0 dB return loss) as soon as the 
calibration set is removed. The instrument is now ready for starting the reflection 
measurement.

Figure 44 Reflection Calibration menu
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Changing the units settings
The reflection mode supports all common reflection measurement units:

– Return loss
The most common reflection measurement unit. Using this unit the attenua-
tion of the reflected signal against the test signal power is measured. Due to 
the fact that the return loss is linked to the signal power this measurement 
unit is very easy to handle. A return loss of 20 dB for example, means that 
1/100 of the transmitted power is reflected back to the radio. Usually a 
return loss of around 17 dB is required to accept an antenna as functional.

– VSWR
This unit is based on the RF signal voltage. It represents a ratio of trans-
mitted and received voltage. Using special alignment charts all units can be 
easily compared to each other. A return loss of 20 dB for example is equiva-
lent to a VSWR of 1.22.

– Reflection factor
This unit is also based on the RF signal voltage and shows the reflection in 
mRho. 

– Reflection power
This unit shows the reflected power ratio as a percentage.

In order to select the measurement unit for your reflection measurement proceed 
as follows:

1 In the Reflection main menu select Level > Units. The Unit menu is 
displayed on the right-hand side of the screen.

2 Select Return Loss, VSWR, Refl. Factor or Refl. Power by pressing the respec-
tive softkey followed by ENTER. The selected unit will be displayed on the 
left-hand side of the results display.

NOTE

When performing a number of measurements it can be necessary to repeat 
the calibration process due to temperature changes etc. This is regular behav-
iour. Furthermore if you change the frequency band, calibration has to be 
repeated. As soon as calibration is necessary the 9102 will inform you by dis-
playing the red “Calibrate“ icon.
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Setting up the level parameters
After specifying the unit for your reflection measurement you can adjust the 
level parameters. Depending on the unit you specified via the Units menu the 
display of the Level menu changes to enable you to set the level parameters for 
the individual units as follows:

Setting the reference level
for return loss

1 In the main menu, push the Ref. softkey or select Level followed by Ref. 
Alternatively, push the REF function key.
The Reference Level input field opens.

2 Enter the new reference level either using the numeric keys, closing the 
input field with the appropriate enter key, or with the UP/DOWN arrow 
keys.
The new reference level appears at the top of the vertical axis. The reference 
is based on the actual set output power.

Changing the vertical
scale for return loss

The scale for the vertical axis (power) can be changed in the range from 1 to 
20 dB per division (vertical line in the displayed grid) in 1-3-5 steps as follows:

1 In the main menu, select Level.

2 Push the Scale softkey.
The Scale input field opens.

3 Select a new scale by entering a new number of dB per division numerically 
and pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

Setting the maximum for
VSWR

1 In the main menu, push the Max VSWR softkey or select Level followed by 
Ref. Alternatively, push the REF function key.
The Reference Level input field opens.

2 Enter the new maximum VSWR either using the numeric keys, closing the 
input field with the appropriate enter key, or with the UP/DOWN arrow 
keys.
The new maximum level appears at the top of the vertical axis.

Changing the scale for
VSWR

The scale for the vertical axis (power) can be changed in the range from 1 to 1000 
per division (vertical line in the displayed grid) as follows:

1 In the main menu, select Level.

2 Push the VSWR Scale softkey.
The VSWR Scale input field opens.

3 Select a new scale by entering a new number per division numerically and 
pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.



Chapter 9 Reflection Operation
Setting up the level parameters

146 9102 Handheld Spectrum Analyzer Software version 5.10

Setting the maximum for
reflection factor

1 In the main menu, push the Max Refl Factor softkey or select Level 
followed by Max Refl Factor. Alternatively, push the REF function key.
The Reference Level input field opens.

2 Enter the new maximum reflection factor either using the numeric keys, 
closing the input field with the appropriate enter key, or with the UP/DOWN 
arrow keys.
The new maximum reflection factor appears at the top of the vertical axis.

Changing the scale for
reflection factor

The scale for the vertical axis (power) can be changed in the range from 0 to 
2000 mRho per division (vertical line in the displayed grid) as follows:

1 In the main menu, select Level.

2 Push the Refl. Factor Scale softkey.
The Refl. Factor Scale input field opens.

3 Select a new scale by entering a new number per division numerically and 
pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

Setting the maximum for
reflection power

1 In the main menu, push the Max Refl Power softkey or select Level 
followed by Max Refl Power. Alternatively, push the REF function key.
The Reference Level input field opens.

2 Enter the new maximum reflection factor either using the numeric keys, 
closing the input field with the appropriate enter key, or with the UP/DOWN 
arrow keys.
The new maximum reflection factor appears at the top of the vertical axis.

Changing the scale for
reflection power

The scale for the vertical axis (power) can be changed in the range from 1 to 
200 % per division (vertical line in the displayed grid) as follows:

1 In the main menu, select Level.

2 Push the Refl. Power Scale softkey.
The Refl. Power Scale input field opens.

3 Select a new scale by entering a new number per division numerically and 
pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.
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Performing a limited number of measurements
The 9102 can run measurements continuously or a defined number of times. 
Limiting the number of measurements can be useful for statistical analyses.

1 In the main menu, select Freq > Sweep.
The Sweep menu appears.

2 Select the trigger mode: Push Cont. for continuous measurements or Single 
for a limited number of measurements.
The selected trigger mode is highlighted.

3 To enter the number of measurements, push the Single Count softkey, 
enter a number in the range from 1 to 1000 and press ENTER.
If Trigger Mode is set to Single, the 9102 performs the defined number of 
measurements and enters hold mode.

– To restart single-mode measurements, push the HOLD/RUN function key or 
the Single softkey.

– To stop a continuous measurement, push the HOLD/RUN function key. Push 
it again to resume measurements.

Setting up the trace
The trace functions provide different views of the measurements, for example 
the actual measurement or an average over the last couple of measurements. 
You can even select two different views of the measurement. Another possibility 
is to compare the actual measurement with an older measurement which has 
been stored in the 9102 and loaded to one of the trace views (see section 
“Storing and loading traces” on page 150).

Selecting the trace mode The 9102 has five different modes to display a trace:

– In actual mode, the 9102 shows a complete new measurement in each trace. 
Subsequent traces are independent of each other.

– In hold mode, the last measurement is kept on the display; measurements 
continue but are not displayed.

– In max hold mode, the 9102 takes new measurements and, for each 
frequency point, compares the new measurement with the previous result. If 
the new measurement value is higher than the previous result, the new 
measurement value becomes the new result value; otherwise the old result 
value is kept. This way, the highest result since the start of the Max hold 
measurement (or a parameter change) is kept and displayed.

– Similarly, in min hold mode, the 9102 takes new measurements and 
compares the new measurement with the previous result. If the new 
measurement value is lower than the previous result, the new measurement 
value becomes the new result value; otherwise the old result value is kept. 
This way, the lowest result since the start of the Min hold measurement (or a 
parameter change) is kept and displayed.
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– In average mode, the new measurement and previous ones are averaged for 
each frequency point displayed. The 9102 uses a recursive algorithm for 
averaging.

To select whether you want to view an actual measurement, stop and hold the 
last measurement, see the lowest or highest data for each frequency or an 
average value, proceed as follows:

1 In the main menu, select Trace.

2 Select the trace you want to modify (Trace A or Trace B) using the hori-
zontal softkeys.

3 Select the trace mode with the vertical softkeys (Actual, Hold, Max hold, 
Min hold, Average).
The trace mode is shown at the left-hand side of the vertical axis, e.g. 
A (ACT).

Turning the second trace
on and off

You can define two different trace views, e.g. one with the actual values and one 
with the maximum values. While the first view (Trace A) is always active, the 
second can be switched off. The functions of turning Trace B on or off and 
selecting the trace mode are combined as follows:

1 In the main menu, select Trace > Trace B.

2 To turn trace B on, select the trace mode (Actual, Hold, Max hold, Min 
hold, or Average). To turn trace B off, select Off.
If activated, the trace mode is displayed left to the vertical axis, e.g. 
B (MAX).

NOTE

For fastest valid results it is advisable to briefly activate the actual mode 
before selecting any other mode.

NOTE

When the trace is on hold, the measurement and failure counters continue 
counting. A second trace, if active, continues updating.
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Subtracting trace B from
trace A

If you have used two different trace views as described above, you can show the 
difference between trace A and trace B by subtracting trace B from trace A as 
follows:

1 In the Trace menu select the softkey Trace Function followed by the 
softkey Subtract A – B –> A.

2 Select on to subtract trace B from trace A. On the left-hand side of the 
result area the Term “Subtract“ will now be displayed to indicate that a 
mathematical function is being performed.

3 The result is displayed in trace A.

Adding trace B to trace A If you have used two different trace views, you can also show the sum of 
trace A and trace B by adding the two traces as follows:

1 In the Trace menu select the softkey Trace Function followed by the 
softkey Add A + B –> A.

2 Select on to add B to trace A. On the left-hand side of the result area the 
term “Add“ will now be displayed to indicate that a mathematical function is 
being performed.

3 The result is displayed in trace A.

Trace Offset As soon as you use one of the two mathematical functions, Subtract A + B → A 
or Add A + B → A, the Trace Offset function is activated. You can use this func-
tion to adjust the trace display, if the mathematical calculation performed 
causes the resulting trace to move outside the display area. In order to bring the 
trace back into view, use the Trace Offset softkey to modify the offset value until 
the trace moves back into the display area.

Defining the number of
measurements for

averaging

When the trace mode is set to averaging, it may be useful to adjust the number 
of measurements over which the 9102 averages the results. The average count 
value that can be defined in the Trace menus applies to both traces alike.

The 9102 uses a recursive algorithm in which a new result is added to the older 
averages with a weighting factor; the description below indicates how to change 
this weighting factor.

1 Select the Trace menu (select Trace > Trace A or Trace B from the main 
menu).

2 Push the Average Count softkey.
The Average input field opens.

NOTE

If trace A is on Hold, this function is not available and thus the 
Subtract A – B –> A softkey is greyed out.
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3 Enter the number of measurements over which to average the results, in the 
range from 2 to 128.

4 Press ENTER.

Copying traces inside the
9102

You can copy an actual measurement from trace A to trace B or vice versa; this 
way you can keep the last measurement results on the screen and at the same 
time continue measuring or change the settings of the 9102 Handheld Spectrum 
Analyzer. The previous results in the target trace will be erased; the target trace 
will assume hold mode. 

To copy the measurement data from one trace to another, proceed as follows:

1 From the main menu, select Trace > Trace Function.

2 To copy the measurement results from trace A to trace B, press 
Copy A → B.
To copy results from trace B to trace A, press Copy B → A.

Storing and loading traces

The 9102 provides the capability to store up to 99 traces in the 9102 and load 
them again at random. The stored trace can then be examined or compared to a 
recent measurement. In addition, stored traces can also be transferred to a PC 
using the 9100 Data Exchange Software which is being delivered with the 9102. 
For details on the software refer to Chapter 15 “9100 Data Exchange Software”.

Storing a trace You can store trace A and trace B. Any trace can be stored under a name with up 
to 11 characters. The procedure to enter text in alphanumerical input fields is 
explained in section “Entering numbers and text” on page 24. Note that along 
with the trace, the instrument settings such as frequency range, level range and 
markers are stored.

1 In the main menu, select Trace > Trace Memory.

2 Press either Store Trace..
An input field opens, allowing you to enter a name for the trace. Below the 
input field, a list of existing traces is indicated.

3 Enter a name for the trace. To use a modified trace name, you can move the 
cursor to a suitable trace name with the UP/DOWN cursor keys. The 
selected trace name also appears in the input field; use the LEFT/RIGHT 
cursor keys to move the cursor to the appropriate position within the trace 
name to enter additional characters or delete existing ones.

NOTE

If you first press Copy A → B, then Copy B → A (or vice versa), both traces 
will display the same results and will be in hold mode.
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4 Confirm your choice by pressing ENTER.
The input field closes and the trace is stored under the selected name.

Reusing a trace name You cannot overwrite an existing trace using the same trace name. If you want 
to reuse a trace name, you will have to delete the old trace first.

Reloading a trace 1 In the main menu, select Trace > Trace Memory.

2 Push either Recall Trace.
An input field opens, allowing you to enter the trace name. Below the input 
field, a list of existing traces is indicated.

3 Enter the name of the trace to load, or choose one with the UP/DOWN 
cursor keys.

4 Confirm your choice by pressing ENTER.
The input field closes and the trace is displayed.

Deleting a trace Stored traces can be deleted. Note that there will be no warning; once you have 
selected and requested a file to be deleted, this will occur immediately.

1 In the main menu, select Trace > Trace Memory.

2 Press Delete Trace.
An input field for the name of the trace to be deleted appears, together with 
a trace selection box.

3 Select the trace to be deleted using the UP/DOWN cursor keys. Alterna-
tively, enter the trace name with the numeric keys.

4 Confirm your choice by pressing ENTER.
The trace is deleted from the trace list.

5 Select another trace for deletion, or press ESCAPE to leave the input field 
and the trace selection box.

Deleting all traces Instead of deleting traces individually, all traces can be deleted in one step. You 
will be asked to confirm this step.

1 In the main menu, select Trace > Trace Memory.

2 Press Delete All.
A query appears, asking you to confirm your selection.

3 Press ENTER to have all traces deleted.
The query disappears. All traces are deleted.

NOTE

Along with the trace, the 9102 also loads the settings that were used when 
the trace was saved. These will overwrite the current settings such as fre-
quency range, reference level and markers.
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Using limits
When activating limit lines prepared for the band to be measured, the band’s 
ends as well as the reflection limit can be identified in on view: the 9102 provides 
a simple Pass/Fail verdict and displays the limit lines on screen:

If the reflection is higher than the limit, the test result is displayed as “Fail“. For 
details on defining and using limit lines refer to “Using limit lines” on page 31.

Figure 45 Example of a results display
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Viewing the reflection mode parameters
You can get an overview of all parameters set for this mode in the Parameter 
Window. To view the parameters, press the PARAM function key. To close the 
Parameter Window and return to the menu you opened it from, press the 
ESCAPE function key, the Exit softkey or the PARAM function key. To close the 
parameter page and change to the relevant main menu press the Main softkey

Figure 46 Reflection mode parameters
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Chapter 10 Distance to Fault Operation

This chapter describes the instrument’s functions that are specific to the reflec-
tion mode. Topics discussed in this chapter are as follows:

– “About the distance to fault mode” on page 156

– “Selecting the measurement mode” on page 157

– “Preparative steps” on page 157

– “Selecting the measurement unit” on page 157

– “Specifying the cable length” on page 158

– “Specifying cable settings” on page 158

– “Setting center frequency and span” on page 159

– “Distance to fault calibration” on page 160

– “Specifying the level parameters” on page 161

– “Setting up the trace” on page 162

– “Using limits” on page 162

– “Viewing the distance to fault parameters” on page 163
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About the distance to fault mode
The distance-to-fault measurement is essential for antenna installations. It 
focuses on the cable measuring the reflection arising along it in order to detect 
and locate weak connectors, cable kinks, water ingress and other cable-related 
problems. This measurement is also called structural return loss and it displays 
reflection arising at a certain cable position precisely in the location domain. 
Thereby cable problems can be easily identified. The 9102 supports a detailed 
analysis of the antenna feeder cable with a total length of up to 2000 m. The 
high 501 points measurement resolution ensures quick and efficient trouble-
shooting by detecting even small reflections which result in a displayed distance 
to fault.

Figure 47 shows an example of a distance-to-fault results display. As in the other 
measurement modes you can use markers to label all peaks. In the distance to 
fault mode the markers appear in line style. For a detailed application example 
for the distance to fault measurement mode refer to the applications guide 
contained on the documentation CD delivered with your instrument.

Figure 47 Example of a distance-to-fault measurement
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Selecting the measurement mode
To select distance to fault mode, proceed as follows:

1 Push the MODE function key.
The Mode menu appears.

2 Select VSWR/Tracking ... > Distance to Fault.
The Distance to Fault main menu appears.

Preparative steps
Before starting the measurement the following preparative steps are necessary:

– Connecting the 9160 VSWR/DTF Bridge
For details on this procedure refer to “Connecting the 9160 VSWR/DTF 
Bridge” on page 134.

– Selecting the unit for reflection

– Specifying the cable settings, e.g. cable length

– Setting center frequency and span

– Calibration

The following sections describe unit selection, cable setting specification, 
frequency selection and calibration.

Selecting the measurement unit
The first preparative step for your distance-to-fault measurement is selecting 
the unit. The distance to fault mode offers the units dB, mRho and VSWR (voltage 
standing wave ratio, the ratio does not have a unit and the results are higher 
than or equal to 1). For DTF measurements a linear scale unit like the reflection 
factor Rho is of advantage. Therefore the unit mRho is the default setting.

In order to select the measurement unit for your distance-to-fault measurement 
proceed as follows:

1 In the Distance to Fault main menu select Level > Units. The Unit menu is 
displayed on the right handside of the screen.

2 Select dB or mRho or VSWR by pressing the respective softkey followed by 
ENTER. 
The selected unit will be displayed on the left-hand side of the results 
display: “Ref.“ and “dB“, if you select dB. “Refl. factor“ and “mRho“, if you 
select Rho. “VSWR” without a unit if you select VSWR.

NOTE

This mode is available for selection, if the 9130 VSWR/DTF Reflection Mea-
surement Option is installed and acitivated on your instrument.
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Specifying the cable length
One of the most important DTF measurement parameters is the cable length. In 
order to achieve a practical results display it is recommended to set the cable 
length to a value approximately 10 % higher than the actual cable length. The 
cable length can be specified in metres or feet.

Selecting the distance unit To select the distance unit proceed as follows:

1 In the Distance to Fault main menu press the Distance Unit Softkey.

2 Toggle the softkey to the required unit, metre or feet, and press ENTER. The 
unit will be displayed in the cable length field of the results display as well 
as on the Cable Length input field.

Setting the length In order to set the cable length proceed as follows:

1 In the Distance to Fault main menu press the Cable Length softkey. The 
Cable Length input field is displayed.

2 Enter the cable length in the unit specified and press ENTER.

Specifying cable settings
Willtek provides predefined cable parameter files for most known coaxial cables 
used for antenna installations whithin the 9100 Data Exchange Software. These 
parameter files can easily be uploaded to the 9102. However, the parameters for 
rare cable types can be set step by step on the instrument.

Using predefined
parameter files

You can upload files containing predefined cable types via the 9100 Data 
Exchange Software. For details on the upload procedure refer to “9100 Data 
Exchange Software” on page 211. For a complete listing of the predefined cable 
types available in the 9100 Data Exchange Software refer to “Predefined cable 
types” on page 346. After uploading the files the cable types are stored on your 
9102 and available for selection.

To select a cable type for a DTF measurement proceed as follows:

1 In the Distance to Fault main menu select Cable > Cable Memory. The 
Cable Memory menu is displayed

2 Press the Recall Cable Type softkey. A dropdown list containing all cable 
types stored on the system is displayed.

3 Select the required cable type using the UP/DOWN arrow keys and press 
ENTER. The settings of the selected cable type are now automatically used 
for the DTF measurement.
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Specifying parameters
step by step

For measurements on rare cable types the parameters can be set up via the Cable 
Setting menu. For the values to be entered refer to the manufactuer’s informa-
tion for the cable to be measured. In order to manually specify the cable param-
eters proceed as follows:

1 In the Distance to Fault main menu select Cable > Cable Setting. The 
Cable Setting menu is displayed.

2 To specify the dielectric of the cable to be measured, which is linked to the 
velocity factor, press the Cable Dielec. softkey. The Cable Dielectric input 
field is displayed. Enter the cable dielectric and press ENTER.

3 To specify the propagation velocity of the cable to be measured, which is in 
turn linked to the dielectric, press the Cable Velocity Factor softkey. The 
Cable Velocity Factor input field is displayed. Enter the velocity factor and 
press ENTER.

4 To specify the cable’s cut off frequency in GHz, which is the maximum 
frequency up to which the cable transmitts, press the Cut Off Freq. softkey. 
The Cut Off Frequency input field is displayed. Enter the frequency and press 
ENTER.

5 To specify the cable attenuation in dBm per 100m or dBm per 100 ft at 
1 GHz of the cable to be measured press the Cable Attn. softkey. This 
softkey can be toggled between dB/100m and dB/100 ft. After pressing the 
softkey the Cable Attenuation input field will be displayed accordingly. Enter 
the attenuation and press Enter.

Setting center frequency and span

1 Push the CENT function key or the Center softkey in the Distance to Fault 
main menu.
The vertical softkeys include Center and Span. An entry field appears, indi-
cating the center frequency currently set and the step size for the up/down 
cursor keys.

2 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

3 Conclude the entry by pushing an enter key for the unit (GHZ/DBM for 
gigahertz, MHZ/DB/µS for megahertz, KHZ/DBµV/MS for kilohertz, or 
ENTER for hertz).

4 Push the Span softkey. If you intend to set the span manually, enter the 
frequency for the range from the left to the right end of the display. If you 
want the span to be set automatically, toggle the Span softkey to auto.

NOTE

If you specify the same value for the center frequency as for the cable cutoff 
frequency, your measurement becomes invalid as the cutoff frequency is the 
maximum frequency up to which the cable transmitts signals. In this case the 
measurement would not make any sense. For details on specifying the cable 
cutoff frequency refer to “Specifying cable settings” on page 158.
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Distance to fault calibration
Before starting the measurement the instrument needs to be calibrated with a 
reference match resistor. For details on available calibration sets refer to 
“Options and accessories” on page 5 and “Calibration” on page 135. On the left-
hand side of the results display a red icon reading “Calibrate“ informs you that a 
calibration needs to be performed. 

In order to calibrate the instrument for your distance-to-fault measurement 
proceed as follows:

1 Connect the test port extension cable to the 9160 VSWR/DTF Bridge.

2 In the Distance to Fault main menu press DTF Cal. softkey. The distance to 
fault Calibration menu is displayed.

3 Push the Cal. Cab. Dielec. key to enter the dielectric constant, εr. See 
Table 16 for the dielectric of cables delivered by Willtek for this purpose.

4 Push the Cal. Cab. Length key to enter the length of the calibration cable. 
See Table 16 for the length of cables delivered by Willtek for this purpose.

NOTE

To ensure that the calibration results in better rather than worse measure-
ment accuracy, it is important that you know and enter the correct cable 
parameters for the cable between the instrument and the calibration set. See 
Table 16 for the parameters of cables delivered by Willtek for this purpose.

Figure 48 Distance to fault Calibration menu
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5 The 9102 will guide you through the calibration process by onscreen 
messages as shown in Figure 48. When prompted as shown connect the cali-
bration set to the test port extension cable and press Continue. You can 
abort the calibration process by pressing the Cancel ! softkey.

6 When calibration is completed the Distance to Fault main menu will be 
displayed again. On the left handside of the results display the calibration 
icon will now be displayed in green and read “Calib’d“ (Calibrated).

Specifying the level parameters
After specifying the unit for your reflection meausrement you can adjust the 
level parameters. Depending on the unit you specified via the Units menu the 
display of the Level menu changes to enable you to set the level parameters for 
the individual units as follows:

Setting the reference level
for dB

1 In the main menu, push the Ref. softkey or select Level followed by Ref. 
Alternatively, push the REF function key.
The Reference Level input field opens.

2 Enter the new reference level either using the numeric keys, closing the 
input field with the appropriate enter key, or with the UP/DOWN arrow 
keys.
The new reference level appears at the top of the vertical axis. The reference 
is based on the actual set output power.

Changing the vertical
scale for dB

The scale for the vertical axis (power) can be changed in the range from 1 to 
20 dB per division (vertical line in the displayed grid) in 1-3-5 steps as follows:

1 In the main menu, select Level.

2 Push the Scale softkey.
The Scale input field opens.

NOTE

When performing a number of measurements it can be necessary to repeat 
the calibration process due to temperature changes etc. This is a regular 
behaviour. Furthermore, if you change the frequency band, calibration has to 
be repeated. As soon as calibration is necessary the 9102 will inform you by 
displaying the red “Calibrate“ icon.

Table 16 Parameters for Willtek-supplied cables

Cable description Dielectric 
constant εr

Length

Test port extension cable 2.3 1.0 m (3.3 ft)

SilverLine-TGTM TuffGripTM cable 2.04 1.5 m (4.9 ft)
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3 Select a new scale by entering a new number of dB per division numerically 
and pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

Setting the maximum for
reflection factor

1 In the main menu, push the Max Refl Factor softkey or select Level 
followed by Max Refl Factor. Alternatively, push the REF function key.
The Reference Level input field opens.

2 Enter the new maximum reflection factor either using the numeric keys, 
closing the input field with the appropriate enter key, or with the UP/DOWN 
arrow keys.
The new maximum reflection factor appears at the top of the vertical axis.

Changing the scale for
reflection factor

The scale for the vertical axis (power) can be changed in the range from 0 to 
2000 mRho per division (vertical line in the displayed grid) as follows:

1 In the main menu, select Level.

2 Push the Refl. Factor Scale softkey.
The Refl. Factor Scale input field opens.

3 Select a new scale by entering a new number per division numerically and 
pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

Setting up the trace
The trace functions provide different views of the measurements, for example 
the actual measurement or an average over the last couple of measurements. 
You can even select two different views of the measurement. Another possibility 
is to compare the actual measurement with an older measurement which has 
been stored in the 9102 and loaded to one of the trace views. For details on 
setting up traces refer to “Setting up the trace” on page 147 in 
Chapter 9 “Reflection Operation”.

Using limits
As in the reflection mode you can also use limit lines for distance to fault 
measurements. For details on the usage of limits refer to “Using limit lines” on 
page 31 in Chapter 2 “General Operation”.
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Viewing the distance to fault parameters
You can get an overview of all parameters set for this mode in the Parameter 
Window. To view the parameters, press the PARAM function key. To close the 
Parameter Window and return to the menu you opened it from, press the 
ESCAPE function key, the Exit softkey or the PARAM function key. To close the 
parameter page and change to the relevant main menu press the Main softkey

Figure 49 Distance to fault parameters
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Chapter 11 Cable Loss Operation

This chapter describes the instrument’s functions that are specific to the reflec-
tion mode. Topics discussed in this chapter are as follows:

– “About the cable loss mode” on page 166

– “Selecting the measurement mode” on page 166

– “Preparative steps” on page 167

– “Changing the frequency settings” on page 167

– “Cable loss calibration” on page 170

– “Setting up the level parameters” on page 171

– “Performing a limited number of measurements” on page 171

– “Using limits” on page 172

– “Viewing the cable loss parameters” on page 172



Chapter 11 Cable Loss Operation
About the cable loss mode

166 9102 Handheld Spectrum Analyzer Software version 5.10

About the cable loss mode
The cable loss mode is an additional measurement mode for determining the 
transmission quality of cables. It displays the average cable loss in dB. For 
measurement similar parameters and procedures as for the other VSWR/DTF 
measurement modes as well as cable calibration are necessary.

Selecting the measurement mode
To select the cable loss mode, proceed as follows:

1 Push the MODE function key.
The Mode menu appears.

2 Select VSWR/Tracking ... > Cable Loss.
The Cable Loss main menu appears.

Figure 50 Cable loss measurement screen

NOTE

This mode is available for selection, if the 9130 VSWR/DTF Reflection Mea-
surement Option is installed and acitivated on your instrument.
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Preparative steps
Before starting the measurement the following preparative steps are 
necessary:

– Connecting the 9160 VSWR/DTF Bridge
For details on this procedure refer to “Connecting the 9160 VSWR/DTF 
Bridge” on page 134.

– Selecting the desired frequency band

– Calibration

The next section section shows how to change the frequency settings on the 
9102. It is followed by a description of the calibration process.

Changing the frequency settings

There are different methods to set the frequency range to be measured; the range 
can be expressed by either the start and stop frequencies (i.e. first and last 
frequency on the display), or by center frequency and span (i.e. the center and 
the frequency range), or by other combinations of center frequency, span, start 
and stop frequencies.

All four parameters are accessible in the Freq menu. On the main menu, however, 
only one of the combinations mentioned above is shown, depending on the 
previously entered parameter.

Figure 51 Frequency menu
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Setting start and stop
frequency

1 Push the CENT function key (or the Freq softkey in the Reflection main 
menu).
The vertical softkeys include Start and Stop softkeys.

2 Push the Start softkey.
An entry field appears, indicating the start frequency currently set and the 
step size for the UP/DOWN cursor keys.

3 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

4 Conclude the entry by pushing an enter key for the unit (GHZ/DBM for 
gigahertz, MHZ/DB/µS for megahertz).
If the start frequency entered is lower than the stop frequency, the hori-
zontal axis will display the range from the new start to the stop frequency.
If the new start frequency is higher than or equal to the stop frequency, the 
start frequency is used as the center frequency with zero span, i.e. the signal 
at the selected frequency will be shown in the time domain.

5 Push the Stop softkey and enter the frequency for the right end of the 
display.

You can also place softkeys for the start and stop frequencies available on the 
main menu by changing the frequency mode, see “Changing the main menu for 
different frequency parameters”.

Setting center frequency
and span

1 Push the CENT function key (or the Freq softkey in the Reflection main 
menu).
The vertical softkeys include Center and Span. An entry field appears, indi-
cating the center frequency currently set and the step size for the up/down 
cursor keys.

2 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

3 Conclude the entry by pushing an enter key for the unit (GHZ/DBM for Giga 
Hertz, MHZ/DB/µS for Mega Hertz, KHZ/DBµV/MS for Kilo Hertz, or 
ENTER for Hertz).

4 Push the Span softkey and enter the frequency for the range from the left 
to the right end of the display.

You can also place softkeys for the center frequency and the span available on 
the main menu by changing the frequency mode, see section “Changing the main 
menu for different frequency parameters” below.

NOTE

Changing a frequency parameter may affect an associated parameter.
Example: If you change the span to the maximum of 4 GHz, the start and stop 
frequencies are changed to 0 and 4 GHz, respectively.
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Changing the main menu
for different frequency

parameters

The Reflection main menu shows two softkeys for the definition of the frequency 
range on the display. Different methods exist to define the range as depicted 
above; you can configure these softkeys to one of the two allowable combina-
tions as follows:

1 From the Reflection main menu, select Freq > Freq Mode.

2 Select the combination of softkeys that you want to see in the main menu 
(Start/Stop or Center/Span).

3 Return to the main menu by pushing the Main ... softkey.
The main menu appears and displays the selected combination of keys.

Note that the description of the horizontal frequency axis changes with the 
selected parameter set.

Viewing the complete
frequency band

To change the frequency range to the full bandwidth supported by the 9102 for 
cable loss measurements, proceed as follows:

1 From the Reflection main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Full Span softkey.
The leftmost frequency changes to 0 Hz and the rightmost frequency to 
4 GHz.

Performing measurements
in the time domain

Measurements on a selected center frequency can also be displayed in the time 
domain.

1 From the Reflection main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Center softkey and enter the desired center frequency; close the 
input field by selecting the appropriate unit with one of the enter keys.

3 Push the Zero Span softkey.
The horizontal axis becomes the time axis. The scale width is identical to the 
sweep time.

Selecting the step size for
the frequency input

The center, start and stop frequencies can be set either by entering a new value 
with the numeric keys, or by using the arrow keys (UP, DOWN) to increase or 
decrease the current setting. The step size for an arrow keypress can either be 
selected automatically by the 9102, or manually adjusted.

Manually setting the frequency step size

1 From the Reflection main menu, select Freq. 

2 Push the FStep softkey.
The Freq Step entry field opens.
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3 Enter a new frequency step value and close the entry field by pressing Enter. 
The auto/manual selection switches to manual and the selected frequency 
step size is displayed on the softkey.

Setting the frequency step size selection to automatic

1 From the Reflection main menu, select Freq.

2 Push the FStep softkey several times until the “auto” selection is high-
lighted.

Cable loss calibration
Before starting the measurement the instrument needs to be calibrated with a 
reference match resistor. For details on available calibration sets refer to 
“Options and accessories” on page 5 and “Calibration” on page 135. On the left-
hand side of the results display a red icon reading “Calibrate“ informs you that a 
calibration needs to be performed. In order to calibrate the instrument for your 
cable loss measurement proceed as follows:

1 Connect the test port extension cable to the 9160 VSWR/DTF Bridge.

2 In the reflection main menu press Cable Loss Cal. softkey. The cable loss 
Calibration menu is displayed.

3 The 9102 will guide you through the calibration process by onscreen 
messages as shown in Figure 52. When prompted as shown connect the cali-
bration set to the test port extension cable and press Continue. You can 
abort the calibration process by pressing the Cancel ! softkey.

4 When calibration is completed the Reflection main menu will be displayed 
again. On the lefthand side of the results display the calibration icon will 
now be displayed in green and read “Calib’d“ (Calibrated).

Figure 52 Cable Loss Calibration menu
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The measurement graph shows full reflection (0 dB cable loss) as soon as the 
calibration set is removed. The instrument is now ready for starting the cable loss 
measurement.

Setting up the level parameters

Setting the reference level 1 In the main menu, push the Ref. softkey or select Level followed by Ref. 
Alternatively, push the REF function key.
The Reference Level input field opens.

2 Enter the new reference level either using the numeric keys, closing the 
input field with the appropriate enter key, or with the UP/DOWN arrow 
keys.
The new reference level appears at the top of the vertical axis. The reference 
is based on the actual set output power.

Changing the vertical
scale

The scale for the vertical axis (power) can be changed in the range from 1 to 
20 dB per division (vertical line in the displayed grid) in 1-3-5 steps as follows:

1 In the main menu, select Level.

2 Push the Scale softkey.
The Scale input field opens.

3 Select a new scale by entering a new number of dB per division numerically 
and pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

Performing a limited number of measurements
The 9102 can run measurements continuously or a defined number of times. 
Limiting the number of measurements can be useful for statistical analyses. For 
details on limiting the number of measurements refer to “Performing a limited 
number of measurements” on page 147 in Chapter 9 “Reflection Operation”.

NOTE

When performing a number of measurements it can be necessary to repeat 
the calibration process due to temperature changes etc. This is a regular 
behaviour. Furthermore, if you change the frequency band, calibration has to 
be repeated. As soon as calibration is necessary the 9102 will inform you by 
displaying the red “Calibrate“ icon.
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Using limits
As in the reflection mode you can also use limit lines for distance to fault 
measurements. For details on the usage of limits refer to “Using limit lines” on 
page 31 in Chapter 2 “General Operation”.

Viewing the cable loss parameters
You can get an overview of all parameters set for this mode in the Parameter 
Window. To view the parameters, press the PARAM function key. To close the 
Parameter Window and return to the menu you opened it from, press the 
ESCAPE function key, the Exit softkey or the PARAM function key. To close the 
parameter page and change to the relevant main menu press the Main softkey

Figure 53 Cable loss parameters
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Chapter 12 EMF (EMI) Operation

This chapter describes the instrument’s functions that are specific to the EMF 
(EMI) mode. Topics discussed in this chapter are as follows:

– “EMF measurements” on page 175

– “Measurement methods” on page 177

– “Measurement antennas” on page 179

– “EMF measurements with the 9102” on page 185

– “Connecting the antenna” on page 186

– “Selecting the measurement mode” on page 187

– “Selecting the unit” on page 187

– “Selecting the frequency range” on page 188

– “Selecting RBW, VBW and SWT” on page 191

– “Specifying the display calculation” on page 192

– “Specifying level settings” on page 192

– “Performing automatic measurements” on page 193

– “Performing manual measurements” on page 196

– “Using limits” on page 199

– “Using Markers” on page 199

– “Viewing the EMF (EMI) mode parameters” on page 200
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About the EMF (EMI) mode
More and more sources of electromagnetic fields, mostly transmitters for mobile 
radio, broadcasting and other radio services, are being created and installed. 
Equipment for home and office communication and other technical devices also 
contribute to the exposure to electromagnetic fields in the working environment 
and at home. For health protection regulatory bodies have implemented limit 
recommendations which were turned into national laws. Network operators, 
companies installing transmitters for broadcasting and regulatory bodies are 
faced by the challenge of verifying that limits specified for electromagnetic 
fields are observed by the sources at hand.

The 9102 in conjunction with the 9131 EMF Measurement Option offers the EMF 
(EMI) measurement mode allowing you to perform radiation measurements 
easily and efficiently. All you need to effectively record electromagnetic fields is 
the 9102 with the 9131 EMF Measurement Option installed and the appropriate 
antenna for your measurement method. Willtek offers a range of antennas for 
different purposes. For further details on different measurement antenna types 
refer to “Measurement antennas” on page 179. The following picture shows a 
typical application example, an EMF measurement performed using the 9102 in 
conjunction with an isotropic antenna, the Willtek 9171 Isotropic Antenna, 
mounted on a tripod.

The EMF (EMI) measurement mode enables you to perform automatic EMF 
measurements upon the press of a button. In this mode, the 9102 measures the 
electromagnetic field over a user-definable frequency range and displays the 
field strength in V/m or the power density in W/m2. All necessary functions, e.g. 
detecting the peak value over a given time period or integrating the broadband 
signal power over a given frequency range, are available. You can compare the 
recorded measurement values with the relevant threshold values.
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Results can be displayed in logarithmic or linear format, the displayed range 
quickly and easily being adapted to the measured signal. The measured signals 
can be displayed both graphically and numerically in logarithmic or linear terms 
as shown in the following example.

EMF measurements
Electromagnetic fields are usually measured over a defined frequency range to 
determine the amount of radiation emitted by certain sources, such as broadcast 
stations or mobile phone base stations. Thus, measurements should be performed 
on a frequency where radiation is expected, e.g. on a broadcast or cellular radio 
frequency. For precise measurements a frequency-selective receiver with high 
sensitivity, a large dynamic range and precise measurements of the field strength 
is required. These are the prerequisites for accurate and reproducible measure-
ment results.

Basically, there are two different measurement approaches in EMF verification:

– Radiation emission and

– radiation immission

The equipment and the methods used vary according to measurement type. With 
the 9102 Handheld Spectrum Analyzer in conjunction with the 9131 EMF 
Measurement Option and the appropriate accessories, i.e. antennas, Willtek 
offers a measurement solution covering the different approaches and require-
ments.

In the following two sections the radiation emission and immission concepts are 
explained. Furthermore these sections provide you with an overview on the 
equipment needed in order to perform EMF measurements depending on the 
measurement approach.

Figure 54 EMF (EMI) measurement
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Radiation emission Using this measurement type operators of cellular networks and broadcast 
stations verify that the radiation of a particular transmitter installed is within 
the limits specified by law and regulatory bodies. In many countries worldwide 
regulatory bodies stipulate a proof of regulation adherence. The radiation emis-
sion measurement is a directional measurement determining the electromag-
netic field emitted by a transmitter. Within the measurement setup a directional 
antenna helps to measure the emitted radiation. 

Measurement setup for
emission measurements

For performing emission measurements according to ICNIRP (International 
Commission on Non-Ionizing Radiation Protection) standard with the 9102 you 
just need the following two pieces of equipment:

– 9102 Handheld Spectrum Analyzer equipped with the 
9131 EMF Measurement Option and the 9132 RMS Detector Option

– A directional antenna

Willtek offers two different directional antennas for performing radiation emis-
sion measurements. For a detailed description of these two antennas refer to 
“Directional antennas” on page 184.

This measurement setup consisting of the 9102 and the directional antenna 
provides a handheld solution for performing radiation emission measurements 
easily and efficiently.

Radiation immission For engineering offices and regulatory bodies the specific radiation exposure 
caused by all radiation sources in a particular place is of special interest. During 
an immission measurement the electromagnetic field exposure is measured at 
different locations within a designated area to identify minimum and/or 
maximum radiation. Typical applications for this kind of measurement are for 
example:

– Measurements for defining security zones in close proximity of transmitter 
sites

– Measurements for determining radiation exposure of representative and 
especially sensitive facilities, e.g. schools, nursery schools and hospitals 
situated in proximity of transmitter sites

– Long-term measurements for determining immission fluctuations

Measurement setup for
immission measurements

As for emission measurements you just need two pieces of equipment for 
performing immission measurements with the 9102:

– 9102 Handheld Spectrum Analyzer equipped with the 
9131 EMF Measurement Option and the 9132 RMS Detector Option

– 9170 Biconical Antenna (for a detailed description refer to “9170 Biconical 
Antenna” on page 180)
or

– 9171 Isotropic Antenna (for a detailed description refer to “9171 Isotropic 
Antenna” on page 182)
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The type of antenna you use depends on your measurement requirements. The 
detailed descriptions of the two different antenna types in “Measurement 
antennas” on page 179 provide you with useful information for selecting the 
appropriate measurement antenna for your EMF measurement.

In this measurement setup the 9102 captures the electromagnetic waves from 
all directions and displays the overall field strength in the desired frequency 
range.

Measurement methods
The location for performing EMF measurements is usually predefined. A main 
goal of performing EMF measurements is determining the radiation people are 
exposed to in their everyday life, so the measurements are usually done at loca-
tions where people stay for a while, e.g. their work place, home, but also restau-
rants or sidewalks etc. At the measurement locations a search for the maximum 
field strength has to be performed in order to determine the radiation exposure 
caused for example by mobile network base stations. For longterm EMF measure-
ments first the maximum field strength is determined and then the antenna is 
placed on the location of maximum exposure. Basically there are two methods 
for determining the maximum field strength within a designated measurement 
area:

– The stirring method or

– the multipoint method

Using each of the two methods the user will move with the antenna within the 
area to be measured as shown in the following graphic depicting a user deter-
mining the maximum field strength using a measurement setup involving an 
isotropic antenna.
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Stirring method Using the stirring method the user sets the measurement instrument to 
maximum hold and moves the antenna within the designated measurement area. 
Depending on the antenna used the user has to be very thorough in covering the 
designated measurement area in order to capture the different locations, direc-
tions of incidence, and polarisations equally. Using an isotropic antenna direc-
tions of incidence and polarisations can be neglected, thus an isotropic antenna 
provides a more comfortable solution for using the stirring method. For further 
details on the characteristics of different antennas refer to “Measurement 
antennas” on page 179. After completing the coverage of the designated 
measurement area the measurement instrument provides the maximum field 
strength value.

Multipoint method The multipoint approach involves a predefined multipoint matrix providing the 
user with designated measurement points. For this purpose the dimensions of the 
measurement area first have to be determined and the measurement points have 
to be specified. At each measurement point a measurement has to be taken. As 
three measurements are required at each point (one for each direction, x y, z), it 
is recommended to use an isotropic antenna for performing measurements using 
the multipoint method. For further details on the characteristics of different 
antennas refer to “Measurement antennas” on page 179. The user performs the 
measurement at each of the measurement points and documents the individual 
measurement results.

Another possibility is to use a simplified approach to the multipoint method. As 
for the stirring method the user sets the measurement instrument to maximum 
hold and moves within the designated measurement area covering all predefined 
measurement points using an isotropic antenna.

Compared to the stirring method the multipoint method, whether in its pure or 
in its simplified form, has the advantage of offering a guideline to the user 
performing the measurements and thus constitutes a more structured approach. 
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Measurement antennas
The antenna is one of the most important factors in EMF measurements. There 
are different types of antennas which can be used for measuring field strength 
depending on your measurement requirements. Willtek offers a range of 
antennas for different measurement requirements:

– The 9170 Biconical Antenna with a frequency range from 60 to 2500 MHz 
for immission measurements 

– The 9171 Isotropic Antenna with a frequency range from 50 to 3000 MHz 
for immission measurements

– The 9172 and 9173 Directional Antennas, two antennas with a frequency 
range of 80 to 1000 MHz and 300 to 3000 MHz respectively for emission 
measurements

For ordering details for Willtek antennas and antenna accessories refer to 
“Options and accessories” on page 5.

During measurements the antenna converts the free progressive wave into a line 
wave. For antenna calibration a correction table containing k factors is required. 
These factors are proportionality factors which correct the antenna’s frequency 
response and help to convert the measured power or voltage to field strength or 
power density. Using the k factor table the measured level is converted into the 
relevant quantities, the field strength measured in V/m and the power density 
measured in W/m2.

Willtek delivers its measurement antennas in conjunction with the appropriate 
correction factor tables. Using the 9100 Data Exchange Software you can 
transfer the k factor tables delivered to your instrument. With the 9171 Isotropic 
antenna this step is not neccessary as the factors are stored in a memory inside 
the antenna interface. You can also use the 9100 Data Exchange Software to 
collect the correction data for antennas from other vendors and transfer them to 
your 9102. For further details on using the 9100 Data Exchange Software refer 
to Chapter 15 “9100 Data Exchange Software”. After transferring the correction 
tables to the instrument they will be available for selection for EMF measure-
ments.

Willtek also offers antenna accessories like a tripod as well as calibrated cables. 
Thus you will be able to master any situation in the field using the 9102 and its 
accessories. If you use a tripod and cable setup for your measurements, cable 
attenuation is taken into account by activating the appropriate cable factor on 
the instrument.

Following is a general technical description of the different measurement 
antenna types providing information on the relevant measurement purpose as 
well as technical details. For a detailed description of all individual steps to be 
taken during EMF measurements using the different measurement antenna types 
refer to “Performing automatic measurements” on page 193 and “Performing 
manual measurements” on page 196.
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9170 Biconical Antenna

Biconical antennas are characterised by their dipole-like structure. The two 
reception lobes are highly symmetrical and provide the biconical antenna with 
two main reception directions with an opening angle of 120° each. 

When manually turning the biconical antenna during measurements into three 
main panes (x, y, z) the same antenna element is used for the measurements in 
each of the different directions. This leads to an unmatched isotropy and thus 
makes biconical antennas most suitable for high-precision measurements. 
Mounting the antenna on a turning device you can easily turn the antenna in the 
directions indicated on the device and perform the measurements for each pane. 
Thereby a globe-like coverage for the measurement, comparable to the one using 
an isotropic antenna, is achieved as shown in the following graphic.

The 9102 supports consecutive measurements in three axes and automatically 
calculates the resulting field strength. 

Willtek offers the 9170 Biconical Antenna for EMF immission measurements 
with the 9102 and the 9131 EMF Measurement Option. 
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The delivery includes:

– Antenna

– Clip with a 1/4 inch thread for an optional tripod and stops in 120° steps

– 10 m calibrated ferrite beaded coaxial cable 

– Calibration certificate and k factor table 

Following are the 9170 Biconical Antenna’s technical specifications:

Antenna type Biconical (linear passive device)

Frequency range 60 MHz to 2.5 GHz

Sensitivity > 0.5 mV/m

Maximum applicable field strength > 300 V/m

Dipole balun symmetry
60 to 80 MHz
80 MHz to 3 GHz

±0.6 dB
±0.2 dB

Isotropy error
up to 1.5 GHz
1.5 to 2.2 GHz
2.2 to 3 GHz

< 0.5 dB
< 0.9 dB
< 1.2 dB

Dimensions
Width
Length
Weight

200 mm
250 mm
2.4 kg

RF connector N type

Operational temperature range -30°C to +55°C

Environmental protection class IP44

RoHS-compliant
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9171 Isotropic Antenna

The most comfortable and fastest solution for performing EMF immission 
measurements comprises using an isotropic antenna. In an isotropic antenna 
three antennas or dipole elements, one for each direction (x, y and z), are 
arranged orthonogally and combined by interconnection as shown in the 
following graphic.

Willtek offers the 9171 Isotropic Antenna for EMF immission measurements with 
the 9102 equipped with the 9131 EMF Measurement Option. The 9171 Isotropic 
Antenna is controlled by the 9102 Handheld Spectrum Analyzer, rendering 
manual rotation of the antenna during measurements unnecessary. This antenna 
enables you to perform fast automatic measurements. Remote control is 
achieved by way of a circuit integrated into the antenna. The circuit is connected 
to the 9102’s Multi Port connector via an additional shielded cable with a high-
precision connector. Via this connection the 9102 also reads the calibration data, 
i.e. the k factor correction information, automatically from the EPROM within 
the circuit. 
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As soon as you connect the cable to the 9102’s Multiport the instrument auto-
matically detects the antenna and loads a set of individual calibration values 
from the antenna. On starting the measurement the instrument automatically 
controls the antenna’s receiving direction, performs the measurements in each 
direction and calculates the isotropic total value from the three individual 
measurement values.

The delivery includes:

– Antenna

– Clip with 1/4 inch thead for an optional tripod

– 6 m combined remote control cable and a calibrated ferrite-beaded coaxial 
cable

– Antenna interface (control and calibration data)

– Calibration certificate and k factor table

Following are the 9171 Isotropic Antenna’s technical specifications:

NOTE

The 9171 Isotropic Antenna is delivered in a case. Please retain this case for 
proper packing in case you want to dispatch the antenna to Willtek for cali-
bration.

Antenna type Isotropic transducer with 3 
orthogonal dipole antennas

Frequency range 30 MHz to 3 GHz

Sensitivity < 5 mV/m

Maximum applicable field strength < 300 V/m

Dipole balun symmetry
50 to 80 MHz
80 MHz to 3 GHz

±0.6 dB
±0.2 dB

Isotropy error vertical polarization
up to 1.7 GHz
1.7 to 2.1 GHz
2.1 to 3 GHz

±0.5 dB
±1.0 dB
±0.5 dB

Isotropy error horizontal 
polarization
up to 1.2 GHz
1.2 to 1.7 GHz
1.7 to 2.1 GHz
2.1 to 3 GHz

±0.5 dB
±1.0 dB
±0.5 dB
±1.0 dB

Dimensions
Radome diameter
Length
Weight

200 mm
520 mm
0.5 kg

RF connector N type

Operational temperature range -20°C to +60°C
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Directional antennas

Directional antennas are log-periodic broadband antennas covering a wide spec-
trum of applications. They are typically used for measuring the emission from a 
specific antenna site. 

Willtek offers two different directional antennas of 1 m length each accommo-
dating different frequency ranges:

– 9172 Directional Antenna - 80 to 100 MHz

– 9173 Directional Antenna - 300 to 3000 MHz

Thanks to their small angle of beam and their excellent frequency response, these 
two directional antennas can also be used for EMF prequalification and for 
finding interferers. With these two antenna types and their overlapping 
frequency ranges, the whole range of commercial range of radio services is 
covered.

The delivery includes:

– Antenna

– Clip with 5/8 thread for an optional tripod

Following are the 9172 and 9173 Directional Antenna’s technical specifications:

Environmental protection class IP 54

RoHS-compliant

Frequency range 80 to 100 MHz and 
300 MHz to 3000 MHz

Maximum transmission power (CW) > 0.5 mV/m

Maximum applicable field strengh > 300 V/m

Nominal impedance 50 Ω

VSWR (typically) < 2.0

RF connector N female

Polarisation Linear (vertical/horizontal)

Calibration CISPR
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EMF measurements with the 9102
As explained the 9102 in conjunction with the 9131 EMF Measurement Option 
and it’s antenna acessory range provides you with a measurement solution suit-
able for performing EMF measurements according to your specific measurement 
requirements.

In EMF (EMI) mode the 9102 measures the electrical field strength (E) as well as 
the power density (S) to enable you to compare the measured EMF with the 
binding limits specified by the responsible regulatory bodies. You can specify 
which result should be displayed. For further details on specifying the value to 
be displayed in your EMF measurement refer to “Specifying the display calcula-
tion” on page 192.

The display unit for the electrical field strength is V/m. 
The electrical field strength is calculated as the square root taken from S × R0, 
with R0 being the air wave resistance of 377 Ω. 
The 9102 displays the total electrical field strength by adding all measurement 
values measured for the three directions x, y, z. 
Eresult is calculated as the square root taken from Exresult

2+ Eyresult
2+ Ezresult

2.

The display unit for the power density is W/m2. 
It is calculated as S = Er

2 ÷ R0. R0 again being the air wave resistance of 377 Ω.

The following sections explain how to perform EMF measurements with the 9102 
differentiating between auto and quick mode used for automatic measurements 
involving the 9171 Isotropic Antenna and manual mode used for manual 
measurements involving the 9170 Biconical Antenna. The preparative steps 
which have to be performed before starting the actual measurement, e.g. 
selecting the EMF (EMI) measurement mode, setting the required frequency 
range, selecting the measurement unit and specifying the measurement result to 
be displayed (power density or field strength) are identical for both measure-
ments with the exception of connecting the antennas to the 9102. The steps 
involved in this procedure depend on the antenna used.

Pole clamp 5/8“ UNC thread 37 mm round 
flange

Size (length x width) 1 m x 0.55 m

Weight 2.4 kg

NOTE

Due to the physical nature of EMF measurements the following has to be 
taken into account.
When performing measurements on broadband signals the electrical field 
strength or the power density displayed may show deviations. In this case the 
measurement has to be performed via a channel power measurement. 
Furthermore a very big or very small relation between span and RBW may lead 
to false measurements or invalid measurement results.
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Connecting the antenna
As a first step you establish the appropriate hardware setup for the EMF 
measurement according to measurement type. As explained before the type of 
antenna you use depends on measurement type and measurement method. For 
further details on which antenna to use refer to “EMF measurements” on 
page 175 and “Measurement antennas” on page 179.

Connecting the 9170
Biconical Antenna

To establish a connection between the 9102 and the 9170 Biconical Antenna 
simply connect the antenna via an RF cable to the 9102’s RF in connector.

Connecting the 9171
Isotropic Antenna

To establish a connection between the 9102 and the 9171 Isotropic Antenna 
connect the antenna directly to the 9102’s RF in connector and connect the 
controller cable to the 9102’s Multi Port connector. As soon as you have 
connected the antenna to both connectors the 9102 automatically detects the 
antenna and loads the correction data.

After the antenna is detected and the correction data are loaded the 9102 
switches to the Level menu and the Antenna Factor softkey is highlighted. To 
activate the antenna factor press the Antenna Factor softkey until on is high-
lighted.

Connecting a directional
antenna

To establish a connection between the 9102 and one of the two directional 
antennas, the 9172 or 9173 Directional Antenna, simply connect the antenna via 
an RF cable to the RF 9102’s RF in connector.

Using a tripod As a measurement antenna accessory Willtek offers a wooden tripod. For 
ordering details refer to “Options and accessories” on page 5. Using this tripod 
you can for example set the 9170 Biconical Antenna up for turning. For setting 
up the appropriate antenna on the tripod, first fix the appropriate adapter on the 
tripod and then fix the antenna to the adapter. Then you can use the appropriate 
extension cable to connect the antenna to the 9102. In case of the 9171 Isotropic 
Antenna you also have to connect the controller cable to the 9102’s Multi Port 
as described in “Connecting the 9171 Isotropic Antenna” on page 186. 

NOTE

If you connect the antenna controller to the instrument with the EMF (EMI) 
mode already running, it takes about 10 seconds for the 9102 to detect the 
antenna. In order to avoid any disturbance of the process do not press any 
buttons on the instrument during this time.
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Selecting the measurement mode
To select the EMF (EMI) mode, proceed as follows:

1 Push the MODE function key.
The Mode menu appears.

2 Select EMF (EMI). 
The EMF (EMI) main menu appears.

Selecting the unit
After selecting the EMF (EMI) measurement mode the next step is to select the 
unit.

1 In the main menu, select Level > Units.

2 You can use logarithmic or linear units. In order to toggle the display 
between logarithmic and linear units press the Unit softkey in the lower 
right corner of the display and select log or lin.

3 You can now choose between the following units via the Unit softkey in the 
upper right corner of the display.
Logarithmic units: dBμV/m, dBmV/m and dBV/m
Linear units: V/m, mW/m2

NOTE

This mode is available for selection, if the 9130 EMF Measurement Option is 
installed and activated on your instrument.



Chapter 12 EMF (EMI) Operation
Selecting the frequency range

188 9102 Handheld Spectrum Analyzer Software version 5.10

Selecting the frequency range

There are different methods to set the frequency range to be measured; the range 
can be expressed by either the start and stop frequencies (i.e. first and last 
frequencies on the display), or by center frequency and span (i.e. the center and 
the frequency range), or by other combinations of center frequency, span, start 
and stop frequencies.

All four parameters are accessible in the Freq menu. On the main menu, however, 
only one of the combinations mentioned above is shown, depending on the 
parameter last entered.

The following section concentrate on the different methods of setting the 
frequency, which is one of the preparative steps for EMF measurements. For 
descriptions of further Frequency menu functions (e.g. Trigger) refer to 
Chapter 3 “Spectrum Analysis Operation”.

Figure 55 Frequency menu

NOTE

Changing a frequency parameter may affect an associated parameter.
Example: In a unit without the frequency extension option installed, if you 
change the span to the maximum of 4 GHz, the start and stop frequencies are 
changed to 0 and 4 GHz, respectively.
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Setting start and stop
frequency

1 Push the CENT function key (or the Freq softkey in the Reflection main 
menu).
The vertical softkeys include Start and Stop softkeys.

2 Push the Start softkey.
An entry field appears, indicating the start frequency currently set and the 
step size for the UP/DOWN cursor keys.

3 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

4 Conclude the entry by pushing an enter key for the unit (GHZ/DBM for 
gigahertz, MHZ/DB/µS for megahertz).
If the start frequency entered is lower than the stop frequency, the hori-
zontal axis will display the range from the new start to the stop frequency.
If the new start frequency is higher than or equal to the stop frequency, the 
start frequency is used as the center frequency with zero span, i.e. the signal 
at the selected frequency will be shown in the time domain.

5 Push the Stop softkey and enter the frequency for the right end of the 
display.

You can also place softkeys for the start and stop frequencies available on the 
main menu by changing the frequency mode, see “Changing the main menu for 
different frequency parameters”.

Setting center frequency
and span

1 Push the CENT function key (or the Freq softkey in the Reflection main 
menu).
The vertical softkeys include Center and Span. An entry field appears, indi-
cating the center frequency currently set and the step size for the up/down 
cursor keys.

2 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

3 Conclude the entry by pushing an enter key for the unit (GHZ/DBM for 
gigahertz, MHZ/DB/µS for megahertz, KHZ/DBµV/MS for kilohertz, or 
ENTER for hertz).

4 Push the Span softkey and enter the frequency for the range from the left 
to the right end of the display.

You can also place softkeys for the center frequency and the span available on 
the main menu by changing the frequency mode, see section “Changing the main 
menu for different frequency parameters” below.
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Changing the main menu
for different frequency

parameters

The Reflection main menu shows two softkeys for the definition of the frequency 
range on the display. Different methods exist to define the range as depicted 
above; you can configure these softkeys to one of the two allowable combina-
tions as follows:

1 From the Reflection main menu, select Freq > Freq Mode.

2 Select the combination of softkeys that you want to see in the main menu 
(Start/Stop or Center/Span).

3 Return to the main menu by pushing the Main ... softkey.
The main menu appears and displays the selected combination of keys.

Note that the description of the horizontal frequency axis changes with the 
selected parameter set.

Viewing the complete
frequency band

To change the frequency range to the full bandwidth supported by the 9102, 
proceed as follows:

1 From the Reflection main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Full Span softkey.
The leftmost frequency changes to 0 Hz and the rightmost frequency to 
4 GHz, or 7.5 GHz if the frequency extension option is installed

Performing measurements
in the time domain

Measurements on a selected center frequency can also be displayed in the time 
domain.

1 From the Reflection main menu, push the Freq softkey.
The Frequency menu is displayed.

2 Push the Center softkey and enter the desired center frequency; close the 
input field by selecting the appropriate unit with one of the enter keys.

3 Push the Zero Span softkey.
The horizontal axis becomes the time axis. The scale width is identical to the 
sweep time.

Selecting the step size for
the frequency input

The center, start and stop frequencies can be set either by entering a new value 
with the numeric keys, or by using the arrow keys (UP, DOWN) to increase or 
decrease the current setting. The step size for an arrow keypress can either be 
selected automatically by the 9102, or manually adjusted.

Manually setting the frequency step size

1 From the Reflection main menu, select Freq. 

2 Push the FStep softkey.
The Freq Step entry field opens.
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3 Enter a new frequency step value and close the entry field by pressing Enter. 
The auto/manual selection switches to manual and the selected frequency 
step size is displayed on the softkey.

Setting the frequency step size selection to automatic

1 From the Reflection main menu, select Freq.

2 Push the FStep softkey several times until the “auto” selection is high-
lighted.

Selecting RBW, VBW and SWT
The resolution bandwidth (RBW) is the 3 dB bandwidth of the IF filter for 
selecting the signal to be measured. The resolution bandwidth describes the 
ability of the spectrum analyzer to discriminate between adjacent signals of 
similar amplitude. Only signals spaced at a frequency of more than the RBW can 
be discriminated from one another.
The 9102 can be set to automatically select the resolution bandwidth, depending 
on the frequency span. The EMF (EMI) measurement mode offers two special 
RBW filters requried for EMC prequalification tests: 120 kHz and 9 kHz at 6 dB.

The video bandwidth (VBW) is the lowpass bandwidth over which several results 
for one frequency point are smoothened. The lower the video bandwidth, the 
smoother the signal curve and the less variations there are.
The 9102 can be set to select the video bandwidth automatically as a function 
of the resolution bandwidth.

The sweep time (SWT) determines how long it takes for a complete sweep over 
the measured frequency range (span).
The 9102 can be set to automatically select the sweep time, depending on RBW 
and VBW. If manually set, the sweep time should be selected long enough for the 
filtered signal to reach steady state. The 9102 will output an “UNCALibrated” 
warning if the sweep time is too low.

To set the resolution bandwidth, the video bandwidth or the sweep time, proceed 
as follows:

1 In the main menu, select the appropriate softkey (RBW, VBW, or SWT).

2 Enter the value and complete the entry with the appropriate enter key for 
the unit, select a new value with the help of the UP/DOWN cursor keys, or 
switch to auto to leave the setting to the 9102.

Changing between automatic and manual mode

Push the appropriate softkey (RBW, VBW, or SWT) several times until the 
desired selection (auto or manual) is highlighted.
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Specifying the display calculation
The 9102 measures electrical field strength (E) in V/m as well as the power 
density (S) in W/m2. For further information about these two values and their 
interdependence refer to “EMF measurements with the 9102” on page 185. You 
can switch the display between these two results values.

To switch the display between electrical field strength and power density 
proceed as follows:

1 In the EMF (EMI) main menu select Measure > Display Calculation. 

2 Toggle the Display softkey until the required option, E for electrical field 
strength and S for power density, is highlighted. In the upper left corner of 
the display the appropriate value will be displayed during your measurement 
in the relevant unit: electrical field strength in V/m and power density in 
W/m2.

Specifying level settings
The accuracy and the dynamic range between the measured signal and the noise 
floor depend on the proper setting of the level settings. These consist of the 
reference level and the attenuation.

The reference level basically determines the level at the top of the display. The 
vertical axis is divided into eight horizontal lines; you can adjust the scale (which 
defaults to 10 dB per line) to your preferences.

Attenuation or gain due to external coupling can be compensated by frequency-
dependent coupling factors, so that the displayed measurement values reflect 
the power at the device under test.

Setting the reference level 1 In the main menu, push the Ref. Level softkey. You can also select Level 
followed by Ref. Level Alternatively, push the REF function key.
The reference level input field opens.

NOTE

This step is preparative and has to be taken before you start your actual 
measurement in automatic or manual mode.

NOTE

Depending on the unit you use and the specified display calculation the Ref. 
Level softkey changes to Ref. Power or Ref. Voltage. Furthermore the input 
field name and the display on the left-hand side of the screen changes 
accordingly.
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2 Enter the new reference power or voltage either using the numeric keys, 
closing the input field with the appropriate enter key, or with the UP/DOWN 
arrow keys.
The new reference level appears at the top of the vertical axis. The reference 
is based on the actually set output power.

Setting the hardware
attenuation

1 In the main menu, push the Attenuation softkey.
The Attenuation input field opens.

2 Enter a new attenuation value in the range from 0 to 50 dB (in 10 dB steps) 
and close the input field with one of the enter keys, or use the UP/DOWN 
arrow keys to select the attenuation value in the range 10 to 50 dB.
If the attenuation value is changed, the attenuation option will change to 
“manual”.

Performing automatic measurements
When using the 9171 Isotropic Antenna you can perform measurements in auto-
matic mode. A prerequisite for performing automatic measurements is that the 
9171 Isotropic Antenna’s controller cable is connected to the 9102’s multiport. 
Via this connection the 9102 reads the relevant correction data from the antenna 
and controls the measurement. However, if you use a tripod measurement setup 
in conjunction with an extension cable, the cable attenuation also has to be 
taken into account by using cable correction data.

There are two different options selectable from the Measure menu for 
performing automatic measurements: Auto and Quick. The two different modes 
are described in “Auto measurements” on page 195 and “Quick measurements” 
on page 196.

Activating the antenna
factor settings

As soon as you have connected the antenna to the RF In connector and the 
antenna controller to the Multi Port connector of the 9102, the instrument auto-
matically detects the antenna and loads the correction data.

NOTE

If the 9171 Isotropic Antenna is not connected via its controller cable to the 
9102’s Multi Port, the two softkeys Auto and Quick will be greyed out in the 
EMF (EMI) Measure menu.

NOTE

If you connect the antenna controller to the instrument with the EMF (EMI) 
mode already running, it takes about 10 seconds for the 9102 to detect the 
antenna. In order to avoid any disturbance of the process do not press any 
buttons on the instrument during this time.
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After the antenna is detected and the correction data are loaded the 9102 
switches to the Level menu and the Antenna Factor softkey is highlighted. To 
activate the antenna factor press the Antenna Factor softkey until on is high-
lighted.

Specifying cable factor
settings for extension

cables

If you are using an extension cable to connect the 9171 Isotropic Antenna to your 
9102, for example for mounting it on a tripod, cable attenuation has to be taken 
into account by activating the appropriate cable correction factor. Cable factors 
are maintained and edited within the 9100 Data Exchange Software. You can 
transfer them to your 9102 for usage within EMF measurements. For further 
details refer to “Managing cable factors for EMF measurements” on page 238 in 
Chapter 15 “9100 Data Exchange Software”.

In order to employ cable correction data for your measurement proceed as 
follows:

1 In the EMF (EMI) main menu select Level > Ant. Factor Memory. The 
Antenna Factor Memory is displayed.

2 Press the Recall Cable Factor softkey. A dropdown list showing all cable 
factors stored on the system is displayed. 

3 Select the cable factor you intend to use and press ENTER. Now the Level 
menu is displayed again with the Cable Factor softkey highlighted.

4 To activate the cable factor selected toggle the Cable Factor softkey until 
on is highlighted.

Figure 56 Antenna Factor menu
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Auto measurements Auto measurements provide you with the comfort of the 9102 controlling the 
measurement process for all three measurement panes. Once you start your Auto 
measurement the 9102 will run automatically through all measurements and 
calculate and display the overall measurement result from the individual results 
for x, y and z. However, you can specify the measurement time.

To start an Auto measurement proceed as follows:

1 In the EMF (EMI) main menu select Measure. The EMF (EMI) Measure menu 
is displayed.

2 In the Measure menu select Meas. Time. An input field for the measure-
ment time will be displayed.

3 Enter the time intervall to be used for measuring on each of the measure-
ment panes. The default is 360 seconds, the maximum value is 600 seconds. 
Press ENTER to set the measurement time.

4 Now select the Auto softkey and press Continue ! to start the Auto 
measurement.

5 On the right-hand side of the display the red Measure indicator shows that a 
measurement is in progress: .
Above this indicator the direction measured is shown (x as the first one): 

.
You can abort the measurement by pressing the Cancel ! softkey.

6 On completing the measurement for the x measurement pane the Measure 
indicator disappears and the 9102 automatically switches to y followed by z.

Figure 57 Measure menu
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7 On completion of the measurement the measurement result is displayed 
with the graph automatically put on hold and the overall calculated elec-
trical field strength or power density, depending on the selection you have 
made via Measure > Display Calculation (see “Specifying the display 
calculation” on page 192) is displayed. You can now save your results trace 
on the instrument.

To clear the trace and start a new measurement press the HOLD/RUN function 
key or the Auto softkey. You can also press the Quick or Manual softkey, if you 
intend to perform a measurement of one of these types.

Quick measurements Quick measurements are a convenient way of quickly determining the maximum 
field strength by fast measurements with a predefined measurement duration of 
one single sweep per measurement pane (x, y, z). Apart from the predefined 
measurement duration the measurement process is identical.

To start a quick measurement proceed as follows:

1 In the EMF (EMI) main menu select Measure. Now, the EMF (EMI) Measure 
menu is displayed.

2 Select the Quick softkey and press Continue ! to start the quick measure-
ment. You can abort the measurement by pressing Cancel !. From now on 
the measurement process is identical with the process described for Auto 
measurements.

Performing manual measurements
The manual measurement mode provides you with a comfortable way of 
performing EMF measurements using the 9170 Biconical Antenna. For this type 
of EMF measurement the 9170 Biconical Antenna is turned manually in each of 
the measurement directions (x, y and z), usually mounted on a turning device. 
For each direction the 9102 performs the measurement of electrical field 
strength or power density depending on the selection you have made via 
Measure > Display Calculation (see “Specifying the display calculation” on 
page 192). You start the individual measurements manually after turning the 
antenna in the relevant direction. As for automatic measurements you can also 
specify the measurement time for each direction. On completing all three 
measurements the 9102 calculates the total result value.

As the k factor correction data are not automatically loaded and activated when 
using a biconical antenna you have to activate the appropriate correction table 
manually on your instrument. Also, as the biconical antenna will often be 
mounted on a tripod and connected to the 9102 via an extension cable, the cable 
factor has to be activated manually.
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The following sections describe all steps which are specific to manual measure-
ments. The preparative steps which have to be performed before starting the 
actual measurement, e.g. selecting the EMF (EMI) measurement mode, setting 
the required frequency range, selecting the measurement unit and specifying the 
measurement result to be displayed (power density or field strength) are iden-
tical for both manual and automatic measurements.

Specifying antenna factor
settings

The scope of delivery of the 9170 Biconical Antenna includes the appropriate 
k factor correction table. The data are available within the 9100 Data Exchange 
Software. For details on downloading the data to the 9102 and managing 
antenna factors within the 9100 Data Exchange Software refer to “Managing 
antenna factors for EMF measurements” on page 236 in Chapter 15 “9100 Data 
Exchange Software”.

To activate the appropriate antenna factor for your EMF measurement proceed 
as follows:

1 In the EMF (EMI) main menu select Level > Ant. Factor Memory. The 
Antenna Factor Memory is displayed (see Figure 56 on page 194).

2 Press the Recall Antenna Factor softkey. A dropdown list showing all 
antenna factors stored on the system is displayed. 

3 Select the appropriate antenna factor and press ENTER. Now the Level 
menu is displayed again.

To activate the antenna factor selected toggle the Antenna Factor softkey until 
on is highlighted.

Specifying cable factor
settings for extension

cables

If you are using an extension cable to connect the 9172 Biconic Antenna to your 
9102, for example for mounting it on a tripod, cable attenuation has to be taken 
into account by activating the appropriate cable correction factor. Cable factors 
are maintained and edited within the 9100 Data Exchange Software. You can 
transfer them to your 9102 for usage within EMF measurements. For further 
details refer to “Managing cable factors for EMF measurements” on page 238 in 
Chapter 15 “9100 Data Exchange Software”. The procedure of specifying cable 
factor settings for manual measurements is identical to the one described for 
automatic measurements. For details refer to “Performing manual measure-
ments” on page 196.

Performing the
measurement

To perform a manual measurement proceed as follows:

1 In the Measure menu select Meas. Time. An input field for the measure-
ment time will be displayed.

2 Enter the time interval to be used for measuring on each of the measure-
ment panes. The default is 360 seconds, the maximum value is 600 seconds. 
Press ENTER to set the measurement time.
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3 Now select the Manual softkey. The softkeys for the three different 
measurement directions (x, y and z) are available on the right-hand side 
with x highlighted as the first measurement direction and the x direction 
indicator displayed on the left-hand side as shown in the following picture.

4 Press Continue ! to start the first measurement. On the right-hand side of 
the display the red Measure indicator shows that a measurement is in 
progress: . 
You can abort the measurement by pressing the Cancel ! softkey. After 
completion of the measurement the Measure indicator disappears.

5 Now press the Y softkey followed by Continue ! to start the measurement 
for the y direction. The procedure is identical to the one described for the x 
direction above.

6 After completion of the y measurement press the Z softkey followed by 
Continue !. The procedure is identical to the one described for the x direc-
tion above.

7 On completion of the measurement the measurement result is displayed 
with the graph automatically put on hold and the overall calculated elec-
trical field strength or power density, depending on the selection you have 
made via Measure > Display Calculation (see “Specifying the display 
calculation” on page 192) is displayed. You can now save your results trace 
on the instrument.

To clear the trace and start a new measurement press the HOLD/RUN function 
key or the Manual softkey.

Figure 58 Softkeys for manual measurements
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Setting up the trace
The trace functions provide different views of the measurements, for example 
the actual measurement or an average over the last couple of measurements. 
You can even select two different views of the measurement. Another possibility 
is to compare the actual measurement with an older measurement which has 
been stored in the 9102 and loaded to one of the trace views. For details on 
setting up traces refer to “Setting up the trace” on page 62 in 
Chapter 3 “Spectrum Analysis Operation”.

Using limits
As in the reflection mode you can also use limit lines for distance to fault 
measurements. For details on the usage of limits refer to “Using limit lines” on 
page 31 in Chapter 2 “General Operation”.

Using Markers
The 9102 includes powerful and easy-to-use marker functions. To further analyze 
your measurement result display you can employ up to six markers. For a detailed 
description of the usage of markers refer to “Working with the markers” on 
page 28.
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Viewing the EMF (EMI) mode parameters
You can get an overview of all parameters set for this mode in the Parameter 
Window. To view the parameters, press the PARAM function key. To close the 
Parameter Window and return to the menu you opened it from, press the 
ESCAPE function key, the Exit softkey or the PARAM function key. To close the 
parameter page and change to the relevant main menu press the Main softkey

Figure 59 EMF (EMI) parameters
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Chapter 13 Troubleshooting

This chapter provides information on handling errors and problems related to the 
9102 Handheld Spectrum Analyzer. 
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Recharging problems with the 9102B
If a 9102B (serial number 0604001 and higher) is completely discharged then it 
may happen that the 9102B does not automatically re-charge the battery while 
connected to an external power supply.

In such a case, to reset the "safety power-off switch", please carry out the 
following steps:

1 Switch off the 9102B.

2 Remove the power connector from the 9102B.

3 Remove the battery.

4 Wait a few seconds.

5 Insert the battery again.

6 Re-connect the power connector and provide external power.
The LED on the front will show that the battery is charged again.
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Handling system errors
Should an error or problem occur that prevents you from controlling the instru-
ment and thus requires the instrument software to be set up again, the 9102 
offers the Setup Application Software menu. This menu provides you with access 
to the instrument without starting the instrument software and enables you to 
perform a software update.

Chapter 14 “Updating the Instrument Software” contains a detailed description 
of the processes involved in updating the instrument’s software via the Setup 
Application Software menu.
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Chapter 14 Updating the Instrument Software

This chapter describes how to perform an update of the instrument’s software 
via the 9102 Handheld Spectrum Analyzer’s Setup Application Software menu. 
Topics discussed in this chapter include the following:

– “Entering the Setup Application Software menu” on page 206

– “Setting a password” on page 206

– “Performing a serial update” on page 207

– “Performing a LAN update” on page 209

– “Determining the Host IP address” on page 210
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Entering the Setup Application Software menu
The 9102 Handheld Spectrum Analyzer’s Setup Application Software menu can 
be entered instead of automatically loading the instrument software. This menu 
provides you with access to the instrument in case an error or problem should 
occur that prevents you from controlling it and requires the instrument software 
to be set up again. The menu offers two options for the update process: Serial 
update and LAN update. To enter the Setup Application Software menu, proceed 
as follows:

1 Turn on the 9102 Handheld Spectrum Analyzer.
The boot-up screen appears.

2 When the message “Press 0 to enter Setup” appears, press the numeric 
key 0.
The Setup Application Software menu appears.

Setting a password
In order to ensure that software updates are only performed by authorized users 
you can set a password to protect the software update option. If a password is 
set, the user performing the software update via the Setup Application Software 
menu will be asked to enter it before data are loaded.

In order to set a password proceed as follows:

1 Switch on the 9102. In order to enter the Setup Application Software menu 
press the numeric key 0 when the input request message is displayed on the 
boot-up screen. Now the Setup Application Software menu is displayed.

2 Press the numeric key 3 to open a password input field.

3 Enter a 6-digit numeric string as your password. For each digit you enter an 
asterisk (*) will be displayed in the input field.

4 Press ENTER to submit your input. You will now be asked to reenter your 
passwort for confirmation.

5 Press ENTER to submit your input. If your input is not identical to the pass-
word entered in the first input field, an error message will be displayed and 
you can enter the password again. Otherwise your new password will be 
saved.

You can also change a previously defined password. In order to do so proceed as 
described above. If a password has already been defined, you will be asked auto-
matically to enter the old password before you can enter a new one.

NOTE

This password only affects the software update options available on the Setup 
Application Software menu. It does not affect the usage of the instrument’s 
application software.
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Performing a serial update
The software update requires a 9100 software update file, which is an executable 
file running on a Windows PC that also includes the software update for your 
9102 Handheld Spectrum Analyzer. Such a file can be downloaded from Willtek’s 
website, e.g. the file Willtek_9100Setup_4_50.exe. 

Take the following steps to perform a serial update of the instrument software 
via the Setup Application Software menu:

1 Connect the 9102 to an external power supply.

2 Connect the 9102 to the PC. See section “Connecting the 9102 Handheld 
Spectrum Analyzer” on page 12 for further details. 

3 Switch on the 9102. 
The boot-up screen is displayed.

4 In order to enter the Setup Application Software menu press the numeric 
key 0 when the input request message is displayed on the boot-up screen.
Now the Setup Application Software menu is displayed.

NOTE

If you have forgotten your password, please contact one of Willtek’s Technical 
Assistance Centers. For contact information please refer to section “Technical 
assistance” on page xvi.

Willtek 9100 Handheld Spectrum Analyzer
© Copyright 2005 Willtek Communications GmbH
All rights reserved.
U.S. patent pending

Press “0” to enter Setup…
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5 Press numeric key 1 to open the Serial Update menu.

6 In order to upload the application files from the PC to the instrument start 
the installation program on your PC. This will open the Update window as 
shown below.

7 In the Connection section, select Serial.

8 To start the serial update press the numeric key 1 on the instrument.
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Performing a LAN update
The software update requires a 9100 software update file, which is an executable 
file running on a Windows PC that also includes the software update for your 
9102 Handheld Spectrum Analyzer. Such a file can be downloaded from Willtek’s 
website, e.g. the file Willtek_9100Setup_4_50.exe. 

Take the following steps to perform a LAN update of the instrument’s software 
via the Setup Application Software menu:

1 Connect the 9102 to an external power supply.

2 Connect the 9102 to the PC. See section “Connecting the 9102 Handheld 
Spectrum Analyzer” on page 12 for further details.

3 Switch on the 9102. In order to enter the Setup Application Software menu 
press the numeric key 0 when the input request message is displayed on the 
boot-up screen. Now the Setup Application Software menu is displayed.

4 Press the numeric key 2 to open the LAN Update menu.

5 Here the IP adresses of the instrument (Target IP) and the PC (Host IP) are 
displayed. Press the numeric key 1 to change or enter the Host IP and 2 to 
change the Target IP. See section “Determining the Host IP address” on 
page 210 for information on determining the Host PC’s IP address.

6 In order to upload the application files from the PC to the instrument start 
the installation program on your PC. This will open the Update window (see 
“Performing a serial update” on page 207).

7 In the Connection section, select LAN.

8 In order to start the update press the numeric key 6 on the instrument.
A message prompts you to press any key to start the update or to hit the ESC 
key to abort the update.

9 Press the ENTER key to start the update.
Both the instrument and the installation program on the PC display the 
progress of the software update.

NOTE

You do not have to click on Start in the Update window on your PC. The 
update process will be started without any further input on the PC.

NOTE

You do not have to click on Start in the Update window on your PC. The 
update process will be started without any further input on the PC.
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Determining the Host IP address
In order to determine your host PC’s IP address proceed as follows:

1 On the status bar, click Start and select Run to open an input window.

2 On the input line, type cmd to open a command prompt.

3 Type IPconfig -all to display the network settings for the PC. In this 
list you will find its IP address. To close the command prompt type exit.
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Chapter 15 9100 Data Exchange Software

This chapter describes how to install and use the 9100 Data Exchange Software. 
The topics discussed in this chapter are as follows:

– “About the 9100 Data Exchange Software” on page 212

– “Installation requirements” on page 212

– “Understanding the license conditions” on page 212

– “Installing the software” on page 212

– “Starting the software” on page 213

– “Connecting the PC to the 9102” on page 214

– “Loading measurement results from the 9102” on page 215

– “Saving, loading and printing results on the PC” on page 219

– “Creating screen shots” on page 223

– “Working with measurement results” on page 224

– “Defining and loading limit templates” on page 227

– “Defining and loading external coupling parameters” on page 231

– “Managing communication systems for channel power measurements” on 
page 233

– “Managing cable types for distance-to-fault measurements” on page 234

– “Managing antenna factors for EMF measurements” on page 236

– “Managing cable factors for EMF measurements” on page 238

– “Working with settings” on page 239

– “Managing files on the PC and on the 9102” on page 240

– “Including the GPS position in the trace” on page 242



Chapter 15 9100 Data Exchange Software
About the 9100 Data Exchange Software

212 9102 Handheld Spectrum Analyzer Software version 5.10

About the 9100 Data Exchange Software
The 9102 is delivered with a software product, the 9100 Data Exchange Software. 
This is a tool to load and display measurements from the 9102 to the PC and to 
install software updates on the 9102.

Installation requirements
To install the 9100 Data Exchange Software, you need

– a PC with Pentium processor or equivalent

– Windows 98SE, Windows NT or later versions

– a minimum of 32 megabytes of RAM

– 50 megabytes of free space on the hard disk

– a free serial interface or a LAN connection

Understanding the license conditions
Before installing the 9100 Data Exchange Software, ensure that you understand 
the license terms which can be found in the appendix “Software License” on 
page 361. The software may only be installed on one computer at any one time!

Installing the software
If you received the software on a CD, just insert the CD in the CD drive of your PC.

Run 9100DataExchange.exe.
This will start the install wizard which will copy the required files onto your PC.

Follow the instructions given by the install wizard.
By default, the install wizard will store the program files in the following direc-
tory (assuming an English Windows installation): 
C:\Program files\Willtek\9100 Data Exchange.
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Starting the software
Click Start > Programs > Willtek > 9100 Data Exchange to run the 9100 Data 
Exchange Software. 
The following box appears:

To connect to the 9102 via serial connection (RS-232 interface on a COM port of 
the PC), select Serial Connection.

To connect to the 9102 via a local area network (LAN) over TCP/IP, select LAN 
Connection.

If you do not want to connect to the 9102 but rather open a measurement trace 
file that has been previously stored on the PC, select Open existing Trace or 
Cancel.
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Connecting the PC to the 9102
In order to connect the PC to the 9102, you need to configure the 9100 Data 
Exchange Software first. 

From the menu bar, select Connection Settings > Serial / LAN for 9100...
This will open the Connect pull-up menu as shown below:

Using a predefined
configuration for the

connection

If you have previously stored configuration data for a successful connection with 
the 9102, you can proceed as follows:

1 Connect the 9102 with the PC using a serial interface cable or the LAN, 
depending on the configuration you want to use.

2 In the Connect dialog box of the 9100 Data Exchange Software (see above), 
load the configuration by selecting a name from the drop-down list box or in 
the upper left-hand corner of the Connect menu. Click on OK to load this 
configuration.
The PC will now attempt to exchange messages with the 9102 over the 
interface defined in the configuration file. The Connect dialog box will 
disappear and if a connection has been set up successfully, the status bar of 
the PC software will indicate CONNECTED.

Serial interface
connection

1 Select the Serial radio button.

2 Select the baudrate (bit rate) that is set up in the 9102 as well.

3 Select a serial port (e.g. COM1).

4 Switch on the 9102 and connect it to the PC using a null modem cable as 
specified in “Connecting the PC to the 9102” on page 214.
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5 Click on Check Connection to verify that the connection is working over 
the selected COM port. 
The PC will now attempt to exchange messages with the 9102 over the cable 
attached to the selected serial port. The Connect dialog box will disappear 
and if a connection has been set up successfully, the status bar of the PC 
software will indicate CONNECTED.

LAN (TCP/IP) connection 1 In the Connect pull-up menu, select the LAN radio button.

2 Enter the IP address of the 9102. The IP address of the 9102 can be read and 
modified over an RS-232 link using the SCPI command; see “Changing the IP 
address of the 9102” on page 43 for information on changing the IP address 
of the 9102.

3 Enter the IP port number in the Port input field. Valid entries are in the range 
from 1024 to 65535; the default is 49200.

4 Switch on the 9102 and connect both 9102 and PC to the computer network 
with a normal patch cable, or connect them directly with each other using a 
cross patch cable.

5 Click on Check Connection to verify that the connection is working over 
the selected LAN connection. 
The PC will now attempt to exchange messages with the 9102 over the 
network. The Connect dialog box will disappear and if a connection has been 
set up successfully, the status bar of the PC software will indicate 
CONNECTED.

Saving the configuration You can save the configuration in a file for later use so that you do not have to 
reenter the configuration each time you are using 9100 Data Exchange Software.

1 In the entry field at the upper left-hand corner, enter a configuration name 
that allows you to identify the configuration that you have made. Several 
configurations can be stored under individual names.

2 Press Store to save the current configuration.

Loading measurement results from the 9102
The 9100 Data Exchange Software can load and display a measurement (trace) 
from the 9102 in two different ways. The software can load either the trace 
currently displayed or a trace that is saved in the 9102 memory. Using the Live 
Trace command available in the Instrument menu you can also display a live 
trace in real mode with updates continuously performed. Note that the 9100 
Data Exchange Software can hold multiple windows, each with a trace.
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Viewing the actual trace
on the PC

1 Connect the PC to the 9102 as described on page 214.

2 In the 9100 Data Exchange Software, select Instrument > Display Trace, 
or press Ctrl+T, or click on the icon: 

The trace is displayed in the program window (see example below). You can 
resize or maximize the trace within the program window.

3 To store the results on a local PC drive, select File > Save or File > Save as 
and choose a directory and file name. 
The trace file is stored on your PC.

Toggling the view mode You can switch the trace display from landscape to portrait and vice versa. In 
order to toggle the view mode proceed as follows:

1 Select View > View Mode. You can also right-click on the screen to open a 
right-click menu and select View Mode.

2 Select the view mode Landscape or Portrait. The display changes accordingly.

NOTE

The trace will also display any active limits. When working in channel power 
mode, the trace will include the communication system name.

NOTE

In signal generator mode you cannot load a trace via Display Trace as there 
are no suitable data available. If you select Display Trace in the signal 
generator mode a dialog will be displayed informing you that no data are 
available and asking you to select a different mode.
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Showing and hiding
parameters

You can display and hide trace parameters by selecting View > Show All 
Parameters or View > Hide All Parameters.

Showing and hiding
markers

You can display and hide markers by selecting and deselecting View > Markers 
Trace A or View > Markers Trace B. On selecting to show the markers a tick is 
displayed next to Markers Trace A or Markers Trace B.

Continually loading live
traces

You can also continually load live traces from the instrument in real-time mode 
which is particulary useful for monitoring ongoing measurements on your PC. To 
continuosly download traces displayed on the 9102’s screen proceed as follows:

1 Select Instrument > Live Trace, press Ctrl+L, or click on the icon in the 
menu bar: . The Live Trace Screen is displayed. On this screen you can 
specify several settings for the live trace process.

2 In the Updates frame select Continuous mode, if you want the live trace to 
be updated continuously until you stop the process manually. If you want to 
specify a fixed number of update cycles after which the process will be 
stopped automatically, select the second control box and enter the number 
of updates to be performed. In the Time between updates field, enter the 
number of seconds between each update cycle.

3 In the View frame select Open new trace window, if you want to display 
the live trace in a separate new window. If you want to overwrite the active 
trace, select Overwrite active trace window.

4 If you intend to save the live trace in a file on completion of the live trace 
update process, select Save as in the Save frame. Now the Save fields are 
activated enabling you to select a directory, a file name and the file type for 
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saving your trace on your PC. You can save the traces as *.9tm or graphic 
files (e.g. *.bmp, *.jpg etc.). For further details on saving traces on your PC 
refer to “Saving, loading and printing results on the PC” on page 219.

Transferring a saved trace
to the PC

To load the data saved in the 9102 proceed as follows:

1 On the 9102, save the desired measurements in trace files.

2 Connect the PC to the 9102 as described on page 214.

3 In the 9100 Data Exchange Software, select Instrument > Get Trace, or 
press Ctrl+G, or click on the icon: 

This will load and display a list of trace files that reside on the 9102 (see 
example below).

4 Select the desired trace file(s) and click View.
The trace is displayed in the program window. You can resize or maximize 
the trace within the program window.

5 To store the results on a local PC drive, select the window with the trace to 
be stored, select File > Save or File > Save as and choose a directory and 
file name. The default directory is Traces inside your 9100 Data Exchange 
installation directory.
The trace file is stored on your PC with the extension *.9tm differentiating it 
from the original trace saved on the 9102 and obtained by the Get Trace 
procedure. These trace files have the extension *.9tr.

NOTE

*9tr trace files can also be transferred in both directions using the Traces tab 
in the Instrument > Data Transfer... menu.
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Saving, loading and printing results on the PC
Once a measurement trace has been transferred to the PC, it can be stored on 
the hard disk, printed or exported to a graphics or text file.

Storing results on the PC The trace, along with the 9102 settings and markers, can be saved in a file and 
loaded again in a trace file. This way, information about settings and individual 
result values will not be lost.

1 Select File > Save or File > Save As ....
A window with a file selection box appears.

2 Select a directory and a file name to save the trace data, and confirm by 
pressing ENTER.
The trace data are saved in a file.

Loading a trace file on the
PC

Results previously stored on the PC can be retrieved and displayed in the 
9100 Data Exchange Software.

1 Select File > Open. 
A window with a file selection box appears.

2 Select the directory and the file name containing the trace data, and 
confirm by pressing ENTER.
The trace data are loaded to the 9100 Data Exchange Software.

Printing measurement
results

Affecting the layout The following steps help you to choose the best format for your print-out:

1 Select File > Print Setup... and set up the correct printer, the paper orien-
tation and printer-dependent settings. Confirm the changes made by 
pressing ENTER.

2 Select Edit > Additional Information... to enter text for two columns of 
header information that is to be printed with the trace. The trace is printed 
with the filename; use the check box “Show File Path” to include complete 
information about the folder where the trace file is located.
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3 You can check the layout before printing by selecting File > Print Preview.

Printing a trace Go to the File > Print menu to select the pages to print, and start printing by 
pressing ENTER. 

Printing several traces If you have opened several documents and you intend to print them in one go, 
select File > Print Open Documents....
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Saving results to a
graphics file

If you save the results in a graphics file, you can load them in other applications 
such as a word processor and include them in your documentation in graphical 
format. File formats supported are:

– Windows Bitmap (BMP)

– JPEG (JPG/JPEG)

– JPEG2000 (J2K/JP2)

– Tagged Image File Format (TIF/TIFF)

– Zsoft Paintbrush (PCX)

– Portable Network Graphics (PNG)

– Sun Raster (RAS)

– Truevision Targa (TGA)

– Portable Bitmaps (PPM/PGM)

1 Select File > Export > Image.
A file selection box appears (“Save image file”).

2 Select a directory, a file name to save the measurement trace and a file 
format, and confirm by pressing ENTER.
The trace data are stored as a graphics file in the selected location.

Saving results to a text
file

You can use the numerical results and include them in other applications for 
postprocessing, e.g. in Microsoft Excel.

1 Select File > Export > ASCII file. 
A file selection box appears (“Save Trace as ASCII File...”).

2 Select a directory and a file name to save the measurement data, and 
confirm by pressing ENTER.
The data are stored in a text file (*.TXT) in the selected location.

Each line in the resulting text file contains a parameter from the settings; the 
parameter name is separated from its value by a semicolon.

Copying the trace into a
document

The 9100 Data Exchange Software offers two different methods to copy the trace 
into a document. The best method depends on how you intend to process the 
trace in that document.

Graphics copy and paste This method is appropriate if you want to use the graphic image as is, e.g. in a 
document.

1 Select the trace you want to copy by selecting the apppopriate number in 
the Window menu.

2 Select Edit > Copy Graph.
The displayed window is copied into the Windows clipboard.

3 Press Alt+Tab or the mouse to change to the application where you want to 
insert the graph (e.g. Microsoft Word).
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4 Move the cursor to the position where to insert the graph.

5 Press Ctrl+V or select Edit > Paste to insert the graph.

Data copy and paste You will want to copy the data rather than the graphics if you want to post-
process the data, e.g. in a spreadsheet.

1 Select the trace you want to copy by selecting the apppopriate number in 
the Window menu.

2 Select Edit > Copy Data.
All the relevant measurement data and instrument settings are copied as 
text into the Windows clipboard.

3 Press Alt+Tab or the mouse to change to the application where you want to 
insert the data (e.g. Microsoft Excel).

4 Move the cursor to the position where to insert the data.

5 Press Ctrl+V or select Edit > Paste to insert the data.
The data is copied into the document. Measurement data and instrument 
settings are separated by a comma, so most spreadsheet programs will 
nicely place the data in individual columns.

Note

If you want to resize the graph in Microsoft Word, select Format > Picture and 
change to the Size tab to resize it.

Note

The 9100 Data Exchange Software copies the window in the size it currently 
has on the screen. You can resize the window to copy the graph in a different 
size or aspect ratio.

Note

You can even have Microsoft Excel (or another spreadsheet program) draw the 
trace: Mark the table containing the measurement data (e.g. frequency and 
level points) and call up the Chart Wizard.
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Creating screen shots
The 9100 Data Exchange Software also offers a Tool for directly producing screen 
shots of the software screen displayed on the 9102. Using the Screen Dump tool 
you can easily create screen shots, save them as image files, copy them to the 
clipboard as well as print them directly.

In order to create screen shots proceed as follows:

1 Select Instrument > Screen Dump, or press Ctrl+N, or click on the icon in 
the menu bar: . The Screen Dump window is displayed.

2 In order to display the screen currently shown on the 9102 in the Screen 
Dump window click on Read Screen. The screen originating from the 9102 
will be displayed in the Screen Dump window as follows.

3 In order to save the screen shot as an image file click on Save as Image. A 
file selection box appears (“Save image file”).

4 Select a directory, a file name to save the measurement trace and a file 
format, and confirm by pressing ENTER.
The trace data are stored as a graphics file in the selected location.

5 In order to copy the screen shot for further usage in other applications click 
on Copy to Clipboard.

6 In order to print the screen shot directly from the Screen Dump tool click on 
Print.

NOTE

For best results it is recommended to use a local printer as opposed to a 
printer connected to a network.
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7 If you intend to create another screen shot, click on Clear Display and 
proceed as described.

8 To close the Screen Dump tool click on Exit.

Working with measurement results
To open a measurement trace that has been previously loaded from the PC, select 
File > Open.
This will open a file selector box from which you can select a directory and a 
trace file. 

Adding markers The 9102 already provides up to six markers; the marker positions are stored and 
transferred together with the trace. You can use markers on trace A and trace B.

In addition to these static markers, you can use additional dynamic markers on 
the PC to read out the level values at any displayed frequency. Up to ten markers 
per trace are possible.
In order to enable or disable markers on the PC proceed as follows:

1 Select View > Select Trace Markers. You can also right-click on the screen 
to open a right-click menu and choose Select Trace Markers.
The Select Trace Marker window is displayed.
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– Carry out one or several of the following steps:

– To enable a marker select the required marker by checking the relevant 
control box in the Marker area (A1 to A10 or B1 to B10). To enable a 
delta marker check the relevant control box in the Delta Marker area 
(DA2 to DA10 or DB2 to DB10).

– To put a marker on the maximum peak click on Max Peak.

– To put a marker on the next peak click on Next Peak.

– To put a marker on all peaks (up to the 10 supported markers) click on 
Label All Peaks.

– To set a threshold for the Label All Peaks function click on Set 
Threshold.   The button label changes to Clear Threshold. Specify your 
threshold in the field below by clicking on the up and down arrows. the 
threshold will be displayed as a read line. If you want to remove the limit, 
click on Clear Threshold. After specifying the threshold only peaks 
above the threshold will be labeled.

– To enter descriptions for the markers click on Marker Description. A 
Marker Description window is displayed. Enter the descriptions for the 
markers set and click on OK. Deselect the text in the Show in Trace box 
on the right-hand side if you do not want the text to appear in the graph.
The descriptions will be displayed in the graph with a line connecting the 
text with the appropriate marker position.
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– To move the marker to another frequency, drag it with the mouse. Alterna-
tively, use the LEFT/RIGHT (slow movement) or UP/DOWN (larger steps) 
cursor keys on the keyboard.

Change the reference level
and scale

In order to change the reference level and scale proceed as follows:

1 Select View > Level. The Level window is displayed.

2 Use the up and down arrows of the Ref. field to specify the reference level.

3 Specify the scale in the Scale field

4 In the Level Unit field you can select a unit from the dropdown list.
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Using a grid

The grid of vertical and horizontal lines can be switched on and off with 
View > Grid. You can also right-click on the screen to open a right-click menu 
and select Grid. The grid is the same as on the 9102, i.e. it consists of eight hori-
zontal and ten vertical rows.

Entering text You can add text to the trace and store it with the measurement. This way, you 
can add valuable information about the conditions of the measurement. The 
comment text will be printed and saved with the graph but not exported to a 
graphics or text file.

1 Select View > Comment.
A “Comment” window opens, allowing you to enter text.

2 Enter your text (three lines maximum), then click on Save to have the 
9100 Data Exchange Software store the text along with the measurements.

Defining and loading limit templates
One of the powerful features of the 9102 is its capability to compare the 
measurements with predefined limits. The limits are set in the form of a template 
that the actual measurement passes or fails. The template can be defined on the 
PC using the 9100 Data Exchange Software and then loaded to the 9102; the 
9102 can hold up to 99 templates.

Editing a template may be easier when an example of a typical result trace is 
available. The Limits Editing menu of the 9100 Data Exchange Software cannot 
only show the actual limit curve (template) but also an example trace that is 
stored on the PC.

Templates can be applied to measurements in both the spectrum and the time 
domain. An example of a limit template in the time domain is the power/time 
template for GSM phones.
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The limits are expressed relative to the grid on the 9102 display, not as absolute 
values in terms of frequency (or time) and power. This way, you can apply the 
same template to different power levels and frequencies provided that the scales 
are as intended.

Defining limits Limits can be defined as a template with an upper and and a lower limit curve. 
Each curve consists of a number of straight lines between points. The Limits 
menu of the 9100 Data Exchange Software allows you to enter and display such 
lines.

The limits are expressed relative to the grid on the screen, with eight horizontal 
and ten vertical lines. The coordinates of each point (in x/y coordinates) corre-
spond to these lines.

To define a new template, proceed as follows:

1 In the 9100 Data Exchange Software, select Tools > Limit Editor... or click 
on the icon in the menu bar: .
The Limit Lines window is displayed, with a limits coordinates table on the 
left and the limit lines on the right-hand side.

2 To enter a new limit line, press Insert.
A window appears, allowing you to enter the x/y coordinates for two points.

3 Select whether you wish to define an upper or lower limit by selecting one 
of the Upper Level and Lower Level radio buttons.

4 Enter the coordinates for the first point of the limit line (x1, y1).
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5 Enter the coordinates for the second point determining the limit line (x2, 
y2). You can also move the limit lines afterwards by dragging them with 
your mouse.

6 Confirm your choice and close the window by selecting OK.
The window disappears. The values are entered in the limits table on the left 
and the limit line is shown in the limit lines graph on the right. 

7 Enter more limit lines as described above to complete the template 
according to your requirements.

Changing limit lines You can change the template by modifying or deleting individual limit lines:

1 In the table within the Limit Lines window, click on the line that you want to 
modify or delete.
The line within the table is highlighted and the corresponding limit line in 
the graph is shown in red.

2 To modify the limits, click on Edit or double-click on the row. A dialog box 
appears, allowing you to change the limits.
To delete a limit line, click on Delete. 

Alternatively, to change the starting or ending point for an existing limit line, 
proceed as follows:

1 In the graph within the Limit Lines window, click on the starting point of a 
limit line that you want to modify.

2 Point the mouse to the starting or ending point of the limit line, keep the 
left mouse button pressed and drag the point to its new position and release 
it there.

Displaying an example
trace in the Limits Editing

menu

1 In the Limit Lines window, select Overlay Trace. 
A file selection box appears.

2 Select a trace file from the default or any other directory, and click on Open.
The file selection box disappears and the trace data is displayed in the limit 
lines box on the right-hand side of the Limit Lines window.

Storing a template on the
PC

A template can be stored on the PC, e.g. to allow modifications later or to down-
load it to different 9102 analyzers at any time.

1 In the Limit Lines window, select Save.
A window opens (“Save Limit Lines”).

2 Choose a directory and enter a file name to save your limits template.

3 Confirm your choice by pressing ENTER.
The limits are saved in a file.
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Loading a template from
the PC

To modify or to load a template to a 9102 that has previously been stored on the 
PC, proceed as follows:

1 In the Limit Lines window, select Open.
A file selection window appears (“Open Limits File...”).

2 Select the directory and the file containing a template file previously stored 
with the 9100 Data Exchange Software.

3 Confirm your choice by pressing ENTER.
The limits are loaded to the limits table and the graph. You can now modify 
the limits (see section “Changing limit lines” above), or download the limits 
to the 9102.

Transferring a template to
the 9102

1 Define a template or load it from the PC’s hard disk as described above.

2 Ensure that the PC is connected to the 9102 either via RS-232 or LAN.

3 Select Data Transfer.
If the template (characterized by its limit lines) is not yet stored you will be 
asked if you want to save it on the PC harddisk. If you choose not to store 
the template, your changes will be lost.
The Data Transfer window is displayed with the Limits tab active.

4 Choose a limits file (or multiple files) on the PC side (right-hand side) of the 
Data Transfer window, and click on < copy. 
The 9102 will, if not done so previously, ask whether to connect to the 9102. 
In that case, follow the instructions in section “Connecting the PC to the 
9102” on page 214.

The file name on the 9102 will only carry the first 11 characters of the file 
name that was used on the PC.
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If a limits file on the PC has been selected for transfer and a limits file with 
the same name already exists on the 9102, the 9100 Data Exchange 
Software will display a pop-up box with the file name in question in the 
header bar, and offer several possibilities:

– Click on Yes if you want to overwrite the file in question.

– Click on No to cancel transmission of the file in question.

– Click on Yes to All to copy all files to the 9102, irrespective of duplicate 
file names.

– Click on No to All to prevent overwriting of all files with duplicate file 
names.

– Click on Rename to enter a new file name applying to that file when 
downloaded to the 9102. 

– Click on Cancel to cancel transmission of all files, no matter whether file 
names already exist on the 9102 or not.

The 9100 Data Exchange Software will indicate when the download has 
been completed successfully. 

5 On the 9102, press ESCAPE to return to local mode. You can then start 
using the limits template.

Defining and loading external coupling parameters
The 9102 Handheld Spectrum Analyzer can compensate a defined gain or 
attenuation introduced by external equipment between the device under test 
and the 9102. The coupling can be specified in the 9100 Data Exchange Software; 
several files for different devices can be defined, stored and downloaded to the 
9102. Furthermore, on installing the 9100 Data Exchange Software two files with 
external coupling parameters are automatically saved to the Extdev directory of 
your 9100 Data Exchange directory on the PC. Once downloaded, the 
compensation of effects from external devices can be switched on and off at any 
time. The 9102 takes the coupling factor into account before presenting the 
measurement result. 

Gain and attenuation are frequency-dependent in most cases; therefore the 
9100 Data Exchange Software allows you to enter interpolation points to cover 
the frequency-dependent coupling factor over the whole frequency range of 
interest.
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Defining the external
coupling factor

1 Open the External Device Compensation menu by selecting Tools > 
External Device Editor... or by pressing Alt+E or by clicking on the icon: 

2 To enter an interpolation point, select Insert. 
A dialog box appears, allowing you to enter frequency and level.

3 Enter the frequency, select a unit (from hertz to gigahertz) and enter the 
coupling factor (in dB). Positive factors indicate signal attenuation, nega-
tive factors indicate gain in the signal line.

4 Close the box by pressing OK and repeat the last two steps with as many 
interpolation points as available.
The frequency-dependent compensation curve appears on the right-hand 
side as values are entered.

5 If you want to change a factor, either select a line from the table on the left-
hand side and click on Edit to change the values numerically, or point with 
the mouse to an interpolation point in the graph on the right and drag it to 
a new position.

6 To move the whole interpolation curve up or down in steps of 1 dB, click on 
the Level Offset arrow buttons.

7 When completed, save the device compensation values in a file on the PC: 
Click on Save, enter a file name and confirm by clicking on Save. 

8 Press Cancel to close the External Device Compensation window.

Loading an external
coupling loss file to the

9102

One or more files with external coupling loss data can be transferred to the 9102 
and reside in the internal memory of the 9102. They will not be taken into 
account until they are activated (see “Compensating gains and losses”).

1 Select Instrument > Data Transfer (Ctrl-D), or in the External Device 
Compensation menu, select Data Transfer.
The Data Transfer menu opens.
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2 In the External Devices tab, select a directory and file(s) on the right-hand 
side and press < copy.
The selected files are transferred to the 9102. 

Managing communication systems for channel power measurements
Measurements in channel power mode imply that a communication system with 
predefined channel numbers and associated frequencies has been defined. The 
9102 comes with a few systems preinstalled; more systems are available for 
download to the 9102 in the 9100 Data Exchange Software, for example Wireless 
LAN, Bluetooth and TETRA. For a complete listing of the communication systems 
available in the 9100 Data Exchange Software refer to “Predefined channel 
power communication systems” on page 343. Here you will also find a listing of 
the communication systems preinstalled on the 9102. Other systems’ data can be 
easily entered on the PC using the 9100 Data Exchange Software. Each set of 
system data can be stored in a separate file; one or multiple files can be down-
loaded to the 9102. For downloading and copying system files between the PC 
and the 9102, see section “Managing files on the PC and on the 9102” below. 
Once data are stored in the 9102, they can be used as described in section “Oper-
ating in channel power mode” on page 80.

Editing communication
system parameters on the

PC

1 Select Tools > Channel System Editor... or by pressing Alt+C or by 
clicking on the icon in the menu bar: .
The Channel System menu appears.

2 If you want to edit a communication system that is already stored on the PC, 
press Open, select the appropriate directory and file, and press ENTER or 
click on Save.

3 Enter the first and the last valid channel number of the system.

4 In the Channel Width line, enter the measurement bandwidth (separate 
input fields for value and unit).

5 In the Channel Spacing line, enter the frequency spacing (including the unit) 
between consecutive channel numbers.

6 Enter the carrier frequency (including the unit) corresponding to the first 
channel number in the 1st Ch. Center line.

7 Click on Save.
A dialog box appears, allowing you to enter a name for the file in which the 
channel system parameters of the communication system shall be stored.
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8 Enter a file name and press ENTER or click on Save.
The data are stored and the dialog box disappears.

9 To transfer the data to the 9102, press Data Transfer. To close the Channel 
System window, press Cancel.

Managing cable types for distance-to-fault measurements
If the 9130 VSWR/DTF Reflection Measurement Option is installed and activated 
on your 9102 the VSWR/Tracking... menu offers the additional measurement 
modes reflection, distance to fault and cable loss. Distance-to-fault measure-
ments focus on the cables whithin an antenna system, measuring the reflection 
arising along it in order to detect and locate weak connectors, cable kins, water 
ingress and other cable-related problems. 

For these measurements Willtek provides predefined cable parameter files for 
most known coaxial cables used für antenna installations. These parameter files 
come with the 9100 Data Exchange Software and can easily be uploaded to the 
9102. For rare cable types you can also define the cable settings manually and 
transfer them to the 9102.

For further details on distance-to-fault measurements refer to 
Chapter 10 “Distance to Fault Operation”.

Uploading predefined
cable types to the

instrument

In order to upload the predefined paramter files delivered with your 9100 Data 
Exchange Software to the 9102 proceed as follows:

1 Select Instrument > Data Transfer and select the Cable Type register. 
You can also select Tools > DTF Cable Type Editor... and click on the Data 
Transfer button. A selection window for the cable type transfer is displayed.

NOTE

The functionality described in the following sections is specifically dedicated 
to the usage of the 9130 VSWR/DTF Reflection Measurement Option. If this 
option is not installed and activated on your 9102 this functionality is of no 
practical use as cable types cannot be transferred to the instrument in this 
case.
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2 In the PC area on the righthand side the cable types stored on the PC are 
displayed. Select the cable types you intend to upload to the instrument and 
click on < copy. The selected cable types will be transferred to your 9102.

Defining cable types In order to define a new cable type not available in the predefined parameter 
files proceed as follows:

1 Select Tools > DTF Cable Type Editor ... or Alt+C or click on the icon in 
the menu bar: . The Cable Type window is displayed.

2 Enter the cable characteristics: cable dielectric, cable velocity factor, cable 
attenuation and cable cutoff frequency. For details on the values to be 
entered here refer to the manufacturer’s information. For general informa-
tion on cable parameters refer to “Specifying cable settings” on page 158.

3 Click on Save to save the cable type on your PC. A file selection window is 
displayed. The file will be saved with the file extension *.ct.

You can now transfer the defined cable type to your 9102 using the same proce-
dure as described in “Uploading predefined cable types to the instrument” on 
page 234.

Transferring cable types
from the 9102

You can also transfer cable types defined on the 9102 to your PC. The procedure 
is virtually identical to the one described in “Uploading predefined cable types to 
the instrument” on page 234. The cable types stored on the 9102 are displayed 
in the Instrument area on the lefthand side of the data transfer screen. Simply 
select the required cable types and click on copy >.

NOTE

It is recommended to transfer only the cable types needed for measurements 
to the 9102 for practical reasons. If you have too many cable types stored on 
your 9102 finding the one requrired for your distance-to-fault measurement 
could be time-consuming.



Chapter 15 9100 Data Exchange Software
Managing antenna factors for EMF measurements

236 9102 Handheld Spectrum Analyzer Software version 5.10

Managing antenna factors for EMF measurements
The antenna is one of the most important factors for EMF measurements. For 
antenna calibration a correction table containing k factors is required. These 
factors are proportionality factors which correct the antenna’s frequency 
response and help to convert the measured power or voltage to field strength or 
power density. Using the k factor table the measured level is converted into the 
relevant quantities.

Willtek delivers its measurement antennas in conjunction with the appropriate 
correction factor tables. Using the 9100 Data Exchange Software you can 
transfer the k factor tables delivered to your instrument. You can also use the 
9100 Data Exchange Software to collect the correction data for antennas from 
other vendors and transfer them to your 9102.

For a detailed description of EMF measurements and the relevant antenna types 
refer to Chapter 12 “EMF (EMI) Operation”.

NOTE

The functionality described in the following sections is specifically dedicated 
to the usage of the 9131 EMF Measurement Option. If this option is not 
installed and activated on your 9102 this functionality is of no practical use.
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Defining an antenna
factor

1 Open the EMF Antenna Factor menu by selecting Tools > EMF Antenna 
Factor Editor... or by pressing Alt+A or by clicking on the icon in the menu 
bar: .

2 To enter an interpolation point, select Insert. 
A dialog box appears, allowing you to enter frequency and level.

3 Enter the frequency, select a unit (from hertz to gigahertz) and enter the 
coupling factor (in dB). Positive factors indicate signal attenuation, nega-
tive factors indicate gain in the signal line.

4 Close the box by pressing OK and repeat the last two steps with as many 
interpolation points as available.
The frequency-dependent compensation curve appears on the right-hand 
side as values are entered.

5 If you want to change a factor, either select a line from the table on the left-
hand side and click on Edit to change the values numerically, or point with 
the mouse to an interpolation point in the graph on the right and drag it to 
a new position.

6 To move the whole interpolation curve up or down in steps of 1 dB, click on 
the Level Offset arrow buttons.

7 When completed, save the antenna factor values in a file on the PC: Click on 
Save, enter a file name and confirm by clicking on Save. 

8 Press Cancel to close the EMF Antenna Factor Editor window.

Loading antenna factor
files to the 9102

One or more antenna factor files can be transferred to the 9102 and reside in the 
internal memory of the 9102. They will not be taken into account until they are 
activated.

1 Select Instrument > Data Transfer (Ctrl-D), or in the EMF Antenna Factor 
Editor  menu, select Data Transfer.
The Data Transfer menu opens.

2 In the EMF Antenna Factors tab, select a directory and file(s) on the right-
hand side and press < copy.
The selected files are transferred to the 9102. 
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Managing cable factors for EMF measurements
If you are using an extension cable for your EMF measurement setup, for example 
in order to mount an antenna on a tripod and turning device, cable attenuation 
has to be taken into account by using the appropriate cable correction factors 
on the 9102. You maintain and edit these cable factors within the 9100 Data 
Exchange software. In order to employ them during EMF measurements on the 
9102 you can then transfer them to your instrument.

For further details on the usage of cable factors during EMF measurements refer 
to Chapter 12 “EMF (EMI) Operation”.

Defining a cable factor 1 Open the EMF Cable Factor menu by selecting Tools > EMF Cable Factor 
Editor... or by pressing Alt+F or by clicking on the icon in the menu bar: 

.

2 To enter an interpolation point, select Insert. 
A dialog box appears, allowing you to enter frequency and level.

3 Enter the frequency, select a unit (from hertz to gigahertz) and enter the 
coupling factor (in dB). Positive factors indicate signal attenuation, nega-
tive factors indicate gain in the signal line.

4 Close the box by pressing OK and repeat the last two steps with as many 
interpolation points as available.
The frequency-dependent compensation curve appears on the right-hand 
side as values are entered.

5 If you want to change a factor, either select a line from the table on the left-
hand side and click on Edit to change the values numerically, or point with 
the mouse to an interpolation point in the graph on the right and drag it to 
a new position.

NOTE

The functionality described in the following sections is specifically dedicated 
to the usage of the 9131 EMF Measurement Option. If this option is not 
installed and activated on your9102 this functionality is of no practical use.
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6 To move the whole interpolation curve up or down in steps of 1 dB, click on 
the Level Offset arrow buttons.

7 When completed, save the antenna factor values in a file on the PC: Click on 
Save, enter a file name and confirm by clicking on Save.

8 Press Cancel to close the EMF Cable Factor Editor window.

Loading cable factor files
to the 9102

One or more cable factor files can be transferred to the 9102 and reside in the 
internal memory of the 9102. They will not be taken into account until they are 
activated.

1 Select Instrument > Data Transfer (Ctrl-D), or in the EMF Cable Editor 
menu, select Data Transfer.
The Data Transfer menu opens.

2 In the EMF Cable Factors tab, select a directory and file(s) on the right-hand 
side and press < copy.
The selected files are transferred to the 9102. 

Working with settings
The 9102 allows to store and recall settings (see section “Working with stored 
settings” on page 48). This can be useful when you want to perform measure-
ments under exactly the same conditions as at an earlier time. With the 9100 
Data Exchange Software, you can transfer the settings from a 9102 to the PC for 
backup purposes or to replicate the settings to another 9102. Another useful 
application is to manipulate settings on the PC; this is easily done because the 
settings file is editable and the format consists of SCPI commands. Changing or 
adding a setting is equivalent to changing or adding a line in the settings file.

Exchanging a settings file
between 9102 and PC

The settings stored on the 9102 can be copied to the PC with the 9100 Data 
Exchange Software. Use the Settings tab within the Data Transfer utility to copy 
files between the PC and the 9102. See section “Managing files on the PC and on 
the 9102” on page 240 for more details.

Changing 9102 settings on
the PC

Take the following steps to change and amend a settings file for later transfer 
and usage on the 9102.

1 In the 9100 Data Exchange Software, select Tools > Setting Editor or press 
Alt+S.
The 9100 Settings box appears.

2 Click on Open to open an existing settings file on the PC. The Open Settings 
File... dialog box appears.

3 Select the directory and settings file that you want to modify, and click on 
Open. An additional program window with the Microsoft Windows text 
editor Notepad opens, and the selected file is displayed.
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4 Modify or add lines with SCPI commands for the desired settings. Refer to 
chapter “SCPI Command Reference” on page 245 for correct syntax and 
value range of the parameters.

5 Save and close the file within Notepad, and return to 9100 Data Exchange 
Software to transfer the file to the 9102.

Managing files on the PC and on the 9102
There are various types of settings which can be maintained from the PC using 
the 9100 Data Exchange Software. This section explains how data can be trans-
ferred between the 9102 and the PC, maintained and deleted.

File types and directory
structure

Each type of setting stored on the PC has a preferred file name extension and 
directory for different sets of parameters. The table below summarizes this file 
structure.

Table 17 Configuration file types

Type File names Directory

Traces *.9tr 9100 Data Exchange\Traces

Modified traces 
saved on the PC

*.9tm 9100 Data Exchange\Traces

Settings *.9st 9100 Data Exchange\Settings

Limits *.9lm 9100 Data Exchange\Limits

Systems *.9sy 9100 Data Exchange\Systems
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Starting the File Manager The files on the PC and on the 9102 can easily be selected, copied and deleted 
via the Data Transfer window.

1 In the 9100 Data Exchange Software, select Instrument > Data Transfer 
(or Ctrl-D).
The Data Transfer window is displayed.

2 Select the appropriate tab (Traces, Settings, Limits, Systems, Ext. Device) 
either by clicking on it with the mouse, or by moving the tab selection with 
the << and >> buttons.
The window displays the appropriate files available on the 9102 on the left-
hand side, and the appropriate files available on the PC on the right-hand 
side. Files on the PC have a file extension and can be stored on any drive and 
in any directory; there are no directories available on the 9102.

External device *.9ed 9100 Data Exchange\Extdev

DTF cable type *.9ct 9100 Data Exchange\Cable Types

EMF antenna factor *.9af 9100 Data Exchange\Antenna Factor

EMF cable factor *.9cf 9100 Data Exchange\Cable Factor

Table 17 Configuration file types

Type File names Directory

NOTE

File names on the 9102 only carry 11 characters. When copying a file from the 
PC to the 9102 that has more than 11 characters, the file name will be trun-
cated. Only trace files with the extension *.9tr can be transferred to the 9102.
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Copying configuration
files from the 9102 to the

PC

Files can be copied in both directions. 

1 Select a PC directory where the file shall be stored or from which it shall be 
copied.

2 Select one or several files for copying, either on the PC or on the 9102. 

3 Press < copy to transfer the files from the PC to the 9102.
or
Press copy > to transfer files to the PC.
If a file on one side has been selected for transfer and a file with the same 
name already exists on the other, the 9100 Data Exchange Software will 
display a pop-up box with the file name in question in the header bar, and 
offer several possibilities:

– Click on Yes if you want to overwrite the file in question.

– Click on No to cancel transmission of the file in question.

– Click on Yes to All to copy all files, irrespective of duplicate file names.

– Click on No to All to prevent overwriting of all files with duplicate file 
names.

– Click on Rename to enter a new file name applying to that file when 
transferred. 

4 Click on Cancel to cancel transmission of all files, no matter whether file 
names already exist on the receiving side or not.

Deleting files 1 To delete a file either on the 9102 or on the PC, select (highlight) the file 
name first. Several files may be selected concurrently by holding the Shift or 
Ctrl key pressed while selecting individual files.

2 Click on the Delete button  above the files marked for deletion.
A box appears asking, “Are you sure to delete the selected items?”

3 Click on Yes to confirm deletion.
The selected files are removed.

Including the GPS position in the trace
The location at the time of the measurement can be recorded and viewed using 
the 9168 GPS Receiver Option. This requires the option to be installed; see also 
“Connecting the GPS receiver” on page 35. 

For the location to be calculated, the GPS receiver must be switched on as 
described in “Enabling the GPS receiver” on page 35.
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In the trace display of the 9100 Data Exchange Software, the display of the GPS 
coordinates can be enabled or disabled. Select View > GPS to toggle between 
GPS coordinates being displayed or not. Longitude, latitude and altitude are 
displayed on the lower right-hand side.

The resulting trace display looks about as follows:

See also notes in section “Logging the current position (GPS-assisted)” on 
page 35.
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Chapter 16 SCPI Command Reference

This chapter provides a reference list of commands for remote control of the  
9102 Handheld Spectrum Analyzer. Topics discussed in this chapter are as 
follows:

– “Overview” on page 246

– “General commands” on page 246

– “System commands” on page 252

– “Sense commands” on page 258

– “Input commands” on page 284

– “MMemory commands” on page 286

– “Instrument commands” on page 297

– “Display commands” on page 303

– “Calculate commands” on page 307

– “Format commands” on page 316

– “Service commands” on page 316

– “SCPI errors” on page 320
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Overview
The command set of the 9102 Handheld Spectrum Analyzer follows the SCPI 
standard and is broken down into the following subsystems:

– General commands

– System commands

– Sense commands

– Input commands

– Memory commands

– Display commands

– Calculate commands

– Format commands

Each keyword in the command can be used either in its long or its short form. 
Uppercase letters are used to indicate the short-form command syntax. Within 
one keyword, either the short form or the full version can be used, but not a mix.

The syntax can be used to form either a command or a query (with a question 
mark behind the command form). Many SCPI commands have either a command 
form or a query form, but not both.

Please refer to the “Index of SCPI Commands” on page 335 for an alphabetical 
list of commands.

General commands

:REBoot

:HCOPy[:IMMediate]

Syntax :REBoot

Parameters There are no parameters.

Command Reboots the 9102. The current settings are not affected by this command.

Query There is no query form of this command available.

Example :REBoot

Syntax :HCOPy[:IMMediate]

Parameters There are no parameters.

Command Starts a printout over the serial port. For further informations see command 
:SYSTem:PRINter:TYPe.

Query There is no query form of this command available.

Example :HCOPy
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*CAL

*OPT

*CLS

*IDN

Syntax *CAL?

Parameters There are no parameters.

Command The command form is not available.

Query Returns the date of the last calibration by Willtek in the format yyyy, mm,dd.

Example *CAL?
Returns 2004,04,01.

Syntax *OPT?

Parameters There are no parameters.

Description The command form is not available.

Query

Example *OPT?

Syntax *CLS 

Parameters There are no parameters.

Command Resets the entire status reporting system:
– The service register will be cleared (all bits will be set to 0).
– The event status register will be cleared (all bits will be set to 0).
– The error message queue will be emptied.
– All event-type registers will be cleared.

Query There is no query form of this command available.

Syntax *IDN? 

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Returns a string, containing the following information:
– manufacturer's name
– name of the device
– serial number
– software revision number
All parameters are separated by commas.
Note: In times of company mergers and acquisitions, it is a good idea to check the 
name of the device, not the manufacturer's name which may change between soft-
ware updates. This does not preclude any name changes at Willtek but rather applies 
to instrumentation in general.

Example *IDN?
returns: "WILLTEK, 9102, 0104012, 1.00"



Chapter 16 SCPI Command Reference
General commands

248 9102 Handheld Spectrum Analyzer Software version 5.10

*RST

*WAI

*OPC

Commands affecting the
event status register

The event status register contains eight bits. The meaning of these bits is 
outlined in the table below.
The commands working on the event status register are described below the 
table.

Syntax *RST

Parameters There are no parameters.

Command Resets the entire test set. All parameters, limits etc. will be set to the internally pre-
defined default values.

Query There is no query form available.

Syntax *WAI 

Parameters There are no parameters.

Description Postpones the execution of a command until all commands issued previously have 
been completed

Query There is no query form of this command available.

Syntax *OPC?

Parameters There are no parameters.

Command Only the query form is available.

Query Waits until the previous command is completed. In addition, the query returns the 
Operation Complete flag which is 1 in the successful case.

Bit Decimal Meaning

7 128 Power on – this bit is always set.

6 64 User Request – a 1 on this position indicates that the 
9102 is no longer controlled by remote commands 
but by user interaction.

5 32 Command error – this bit indicates that a SCPI com-
mand error occurred (SCPI error codes 100 to 199).

4 16 Execution error – is set after a SCPI execution error 
did occur (SCPI error codes 200 to 299).

3 8 Device-dependent error – this bit indicates that a 
device-specific SCPI error did occur (SCPI error codes 
300 to 399).

2 4 Query error – is set after a SCPI query error occurred 
(SCPI error codes 400 to 499).
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*ESE

*ESR

Commands affecting the
service register

The service register represents the highest level within the report structure of the 
9102.
The service register contains eight bits.
If any of the bits 0 to 5 or 7 is set, the summary status bit (bit 6) of the service 
register will be set as well.

1 2 Request control – this bit is reserved for future use.

0 1 Operation complete flag – is set as soon as the exe-
cution of a command has been completed.

Syntax *ESE <int1>

Parameters int1 is an integer.
The valid range is from 0 to 255 (8 bits).

Command Sets the enable filter (mask) of the event status register.
int1 is the decimal representation of the binary mask.
The mask and the current contents of the event status register will be ANDed. If the 
result is not zero, then bit 5 of the Service register will be set.

Query The query form reads out the enable filter (mask) currently set and returns its binary 
representation in a string.

Example *ESE 128
As soon as power has been switched on, bit 7 (Power on) will be set. ANDed with the 
mask 128, a binary 1 will occur and thus bit 5 of the service register will be set.

Syntax *ESR? 

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Returns the decimal representation of the current contents of the event status regis-
ter in a string.
Note: This register is self-destructive, i.e. its contents will be cleared after reading.

Example After power-on, the *ESR? query will return "128". This means that bit 7 is set 
and all the other bits of the event status register are 0.
The command will clear the event status register and a subsequent *ESR? query will 
return "0".

NOTE

The service register is self-destructive. This means that its contents will be 
cleared after reading.
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*SRE

*STB

Bit Decimal Meaning

7 128 OPERational status summary. When this bit is set, an 
event within the general operation register group 
(e.g. the 9102 is waiting for a trigger) passed all fil-
ters.

6 64 Summary status bit. This bit will always be set as 
soon as any other bit of the service register has been 
set.

5 32 Event status summary. When this bit is set, an event 
within the event status register group (e.g. an error 
occurred) passed all filters.

4 16 Message available. This bit will be set to 1 as soon as 
a query has been completed and measurement 
results are available.

3 8 QUESTionable status summary. If this bit is set, an 
event within the general questionable status register 
group (e.g. 'value out of range') passed all filters.

2 4 Error queue status. When this bit is set, the error 
queue contains error messages. Up to 10 error mes-
sages can be logged in the error queue. The error 
queue can be read out, using the :SYSTem:ERRor? 
query.

1 2 Remote command completed. This bit will be set to 
1 after a remote (SCPI) command has been com-
pleted.
Note: When the 9102 receives a SCPI command, it 
will block any further input readings until the com-
mand has been completed.

Syntax *SRE <int1>

Parameters int1 is an integer.
The valid range is from 0 to 255 (8 bits).

Command Sets the enable filter (mask) for the service register.
int1 is the decimal representation of this binary mask.
The mask and the current contents of the service register will be ANDed. 

Query The query form reads out the mask currently set and returns its binary representation 
in a string.

Example *SRE 68
As soon as an error occurs, bits 2 and 6 of the service register will be set. ANDed with 
the mask (68), a binary 1 will be the result.

Syntax *STB?

Parameters There are no parameters.
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Command There is only a query form of this command available.

Query Returns the decimal representation of the current contents of the service register in a 
string.
Note: This register is self-destructive, i.e. its contents will be cleared after reading.

Example A *STB? command returns "68".
The return value of 68 (= 64 + 4) means that an error occurred (4).
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System commands
With the system commands, the internal settings of the 9102 Handheld Spec-
trum Analyzer can be changed.

:SYSTem:DATE

:SYSTem:TIME

:SYSTem:COMMunicate:LOCal

Syntax :SYSTem:DATE <int1>,<int2>,<int3>

Parameters intx are three integers.
The minimum value for int1 is 1998, the maximum is 2100. The default value is 
1998.
The minimum value for int2 is 1, the maximum is 12. The default value is 1.
The minimum value for int3 is 1, the maximum is 31. The default value is 1.

Command Sets the system date. This command uses the following format: yyyy,mm,dd 
where
yyyy stands for the four digits of the year (int1),
mm gives the current month (int2),
dd represents the day of the current month (int3).

Query Reads and returns the current system date in a string, using the format explained 
above.

Example :SYST:DATE 2001,7,6
Sets the system date to the July 6, 2001.

Syntax :SYSTem:TIME <int1>,<int2>,<int3>

Parameters intx are three integers.
The minimum value for int1 is 0, the maximum is 23. The default value is 0.
The minimum value for int2 is 0, the maximum is 59. The default value is 0.
The minimum value for int3 is 0, the maximum is 59. The default value is 0.

Command Sets the system time. This command uses the following format: hh,mm,ss where
hh stands for the two digits of the current hour, using a 24 hour time format (int1),
mm gives the current minute (int2) and,
ss represents the seconds of the system time (int3).

Query Reads and returns the current system time in a string, using the format explained 
above.

Example :SYST:TIME?
String returned in this example: "14,56,05" meaning roughly four minutes to 
3 pm.

Syntax :SYSTem:COMMunicate:LOCal 

Parameters There are no parameters.

Command Sets up the 9102 to allow manual operation on the front panel during SCPI operation.
Notes: 
– This command may be used e.g. to allow interactive alignment procedures in a 

production flow.
– The instrument can also be set to local mode by pressing the Escape function key 

on the front panel.
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:SYSTem:COMMunicate:ECHO

:SYSTem:COMMunicate:ETHernet?

:SYSTem:COMMunicate:ETHernet:IPADdress

Query There is no query form of this command available.

Example :SYSTem:COMM:LOC

Syntax :SYSTem:COMMunicate:ECHo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command This command determines how the Willtek 9102 acts after executing a SCPI com-
mand.
If echo is set to ON, there will be a response. Either "ok", if the execution was suc-
cessful or "ERR" if an error occured. The echo-on mode is preferred for entering 
interactive commands.
If echo is set to OFF, there will be no response to a SCPI command. In this case it is 
possible to check with the *OPC? query, when the SCPI command is finished and the 
Willtek 9102 is ready to receive the next command.

Query Reads and returns the current echo setting.

Example :SYST:COMM:ECH ON
Returns the following string: "ok"
All subsequent commands returns "ok" or "ERR".
:SYST:COMM:ECH?
Returns the following string: "ON"
:SYST:COMM:ECH OFF
Returns nothing, all subsequent commands return nothing.

Syntax :SYSTem:COMMunicate:ETHernet?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns ON, if the Willtek 9102 is connected to a local area network (LAN) via TCP/IP 
connector, otherwise returns OFF.

Example :SYSTem:COMM:ETH?
String returned in this example: "OFF"

Syntax :SYSTem:COMMunicate:ETHernet:IPADdress 
<int1>,<int2>,<int3>,<int4> 

Parameters intx are four integers.
The minimum value for all integers is 0, the maximum is 255. The default value is 0.

Command This command sets the IP address of the Willtek 9102 to the parameter values. 

Query Reads and returns the current setting of the IP address as explained above.

Example SYST:COMM:ETH:IPAD 192,16,16,114 sets the IP address to a defined 
value.
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:SYSTem:COMMunicate:ETHernet:TNAMe

:SYSTem:COMMunicate:ETHernet:SUBNetmask

:SYSTem:COMMunicate:ETHernet:PORT

:SYSTem:COMMunicate:ETHernet:TERMinator

Syntax :SYSTem:COMMunicate:ETHernet:TNAMe <string> 

Parameters string is a string only containing the device name of the Willtek 9102.

Command This command sets the device name of the Willtek 9102. It can be used to announce a 
symbolic device name for the 9102, if the network supports DHCP (Dynamic Host 
Configuration Protocol).

Query Reads and returns the current setting of the device name as explained above.

Example SYST:COMM:ETHernet:TNAMe "TARGET9104" sets the device name to a 
defined value.

Syntax :SYSTem:COMMunicate:ETHernet:SUBNetmask 
<int1>,<int2>,<int3>,<int4> 

Parameters intx are four integers.
The minimum value for all integers is 0, the maximum is 255. The default value is 0.

Command This command sets the subnet mask of the Willtek 9102 to the parameter values.  
Setting a subnet mask may speed up the traffic on the Ethernet.
Note: This command is supported from software version 2.00 on.

Query Returns the current setting of the subnet mask as explained above.

Example SYST:COMM:ETH:SUBN 255,255,255,255 sets the subnet mask to a 
defined value.

Syntax :SYSTem:COMMunicate:ETHernet:PORT <int> 

Parameters int defines the TCP/IP port address of the Willtek 9102. The address must be in the 
range from 1024 to 65535. Default value is 49200.

Command This command sets the port address on which the Willtek 9102 can be controlled via 
LAN to a new value.

Query Reads and returns the current setting of the port used by TCPIP as explained above.

Example SYST:COMM:ETHernet:PORT 49200 sets the TCP/IP port address to its 
default.

Syntax :SYSTem:COMMunicate:ETHernet:TERMinator <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: CRLF|LF|CR.
Default is CRLF.

Command Sets the terminator characters, which are appended to every SCPI respond from the 
Willtek 9102 LAN interface.

Query Reads and returns the current terminator setting for the LAN interface.

Example :SYST:COMM:ETH:TERM CR
:SYST:COMM:ETH:TERM?
Returns the following string: "CR"
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:SYSTem:COMMunicate:SER:BAUDrate

:SYSTem:COMMunicate:SER:TERMinator

:SYSTem:ERRor[:NEXT]?

:SYSTem:ERRor:COUNt?

Syntax :SYSTem:COMMunicate:SER:BAUDrate <int1>

Parameters int1 is an integer.
The minimum value for int1 is 300, the maximum value is 57600. The default 
value for int1 is 57600. Valid values are 
300,1200,2400,4800,9600,19200,38400 and 57600.

Command Sets the data rate for the serial port. Only the data rate can be changed; all other 
parameters are fixed. The number of bits per character is set to 8, the number of stop 
bits is set to 1 and parity is set to NO.

Query Reads and returns the serial interface data rate currently set.

Example :SYST:COMM:SER:BAUD 9600
:SYST:COMM:SER:BAUD?
String returned in this example: "9600".

Syntax :SYSTem:COMMunicate:SER:TERMinator <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: CRLF|LF|CR.
Default is CRLF.

Command Sets the terminator characters, which are appended to every SCPI response from the 
Willtek 9102 serial interface.

Query Reads and returns the current terminator setting for the serial interface.

Example :SYST:COMM:SER:TERM LF
:SYST:COMM:SER:TERM?
Returns the following string: "LF"

Syntax :SYSTem:ERRor[:NEXT]? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the oldest unread error message from the internal error queue of the Willtek 
9102. The queue entry returned will be a string (text). The maximum length of the 
text is 255 characters.
Note: A list of error messages can be found in section “SCPI errors” on page 320.

Example *RESET
:SYSTem:ERRor:NEXT?
String returned in this example: -113,"Undefined header"

Syntax :SYSTem:ERRor:COUNt? 

Parameters There are no parameters.

Command There is solely a query form of this command available.
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:SYSTem:ERRor:CODE[:NEXT]?

:SYSTem:ERRor:CODE:ALL?

:SYSTem:DNAMe

Query Returns the number of unread error messages in the internal error queue of the 
Willtek 9102. The string returned will contain one integer. The maximum number of 
errors stored internally is 10.

Example :SYSTem:ERRor:COUNt?
String returned in this example: "0"
This means that there are no unread error messages in the error queue.

Syntax :SYSTem:ERRor:CODE[:NEXT]? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the code of the oldest unread error message in the internal error queue of the 
Willtek 9102. The string returned will contain one integer (and no text).
Note: A list of error messages can be found in section “SCPI errors” on page 320.

Example *RESET
:SYSTem:ERRor:CODE?
String returned in this example: "-113"
This means that an undefined header (*RESET) was received.

Syntax :SYSTem:ERRor:CODE:ALL? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the error codes of all unread error messages in the internal error queue of the 
Willtek 9102. The string returned will contain a maximum of 100 integers, separated 
by commas.
Note: A list of error messages can be found in section “SCPI errors” on page 320.

Example :SYSTem:ERRor:CODE:ALL?
String returned in this example: "-113,-112,0,0,0,0,0,0,0,0"
This means that there were two unread error messages in the error queue.

Syntax :SYSTem:DNAMe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Sets a user-definable device name for the 9102 to use this unique name on protocols.

Query Reads and returns the device name set on this 9102.

Example :SYSTem:DNAMe "Develop5"
:SYST:DNAM?
String returned in this example: "Develop5"
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:SYSTem:OPTions

:SYSTem:SCReendump:COLor?

:SYSTem:SCReendump:LINe?

:SYSTem:SCReendump:REMote

Syntax :SYSTem:OPTions <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 25 char-
acters.

Command Enables or disables a software option on the Willtek 9102 with the appropriate option 
key string1.

Query There is no query form available.

Example :SYSTem:OPTions "00172663845433"
Enables the option corresponding to the key.

Syntax :SYSTem:SCReendump:COLor? <int1>

Parameters int1 is a integer in the range of 0 to 255.

Command There is only the query form available.

Query Returns the RGB color value (in hexadecimal) of the given color palette entry. Max. 
256 palette entries are available.

Example :SYST:SCR:COL? 5
String returned in this example:
"a800a8"

Syntax :SYSTem:SCReendump:LINe? <int1>

Parameters int1 is a integer in the range of 0 to 479.

Command There is only the query form available.

Query Returns one pixel line (of 480) of the screen as pairs of hexadecimal values.

Example :SYST:SCR:LIN? 345
String returned in this example:
"0201420fff00f600010f0201080b1e0f1e0b"

Syntax :SYSTem:SCReendump:REMote <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command This command removes the Remote display when it is set to OFF. This is useful for 
screen dumps.

Query Reads and returns the current setting.

Example :SYST:SCR:REM OFF
:SYST:SCR:REM?
Returns the following string: "OFF"
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:SYSTem:PRINter:TYPe

:SYSTem:PRINter:BAUDrate

Sense commands
These commands affect the spectrum analyzer settings, start measurements and 
return results.

:SENSe:BANDwidth:RESolution

Syntax :SYSTem:PRINter:TYPe <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: OFF|PCL.
Default is OFF.

Command This command set the printer type for a hardcopy of the display. At the moment, only 
PCL capable printer like HP Laserjet are supported. The printer has to be connected to 
the serial port (normaly with a RS232/Centronics converter), therefore remote control 
of printer output is only possible via TCP/IP. The serial interface has to be set to the 
maximum possible baudrate of the printer/converter with command SYSTem:COM-
Municate:SER:BAUDrate. The output to the printer is started with command 
HCOPy[:IMMediate].

Query Reads and returns the current setting.

Example :SYSTem:PRINter:TYPe PCL
:SYSTem:PRINter:TYPe?
Returns the following string: "PCL"

Syntax :SYSTem:PRINter:BAUDrate <int1>

Parameters int1 is an integer.
The minimum value for int1 is 300, the maximum value is 57600. The default 
value for int1 is 19200. Valid values are 
300,1200,2400,4800,9600,19200,38400 and 57600.

Command Sets the data rate for the serial port if a printer is connected. The print output can be 
started with HCOPy. Only the data rate can be changed; all other parameters are 
fixed. The number of bits per character is set to 8, the number of stop bits is set to 1 
and parity is set to NO.

Query Reads and returns the serial interface data rate currently set.

Example :SYST:PRINter:BAUD 9600
:SYST:PRINter:BAUD?
String returned in this example:
9600.

Syntax :SENSe:BANDwidth:RESolution <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 100, the maximum value 1000000. real1 can 
be set as 1∗10n or 3∗10n. The default value for real1 is 1000000.

Command This command sets the resolution bandwidth of the 9102, in Hertz.

Query Reads and returns the current setting.
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:SENSe:BANDwidth:RESolution:AUTo

:SENSe:BANDwidth:VIDeo

:SENSe:BANDwidth:VIDeo:AUTo

Example :SENSe:BANDwidth:RESolution 300000
:SENSe:BANDwidth:RESolution?
The value returned in this example is: "300000".

Syntax :SENSe:BANDwidth:RESolution:AUTo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Switches the automatic selection of the bandwidth resolution on or off. If switched 
on, the 9102 selects the resolution bandwidth depending on the current span, video 
bandwidth, and sweep time.

Query Reads and returns the current setting.

Example :SENSe:BANDwidth:RESolution:AUTo ON
:SENSe:BANDwidth:RESolution:AUTo?
Returns the following string: "ON"

Syntax :SENSe:BANDwidth:VIDeo <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 10, the maximum value 1000000. 
Possible values are: 
10,100,300,1000,3000,10000,30000,100000,300000,1000000. 
The default value for real1 is 1000000.

Command Sets the video bandwidth of the 9102. The unit of real1 is Hertz.

Query Reads and returns the current setting.

Example :SENSe:BANDwidth:VIDeo 300000
:SENSe:BANDwidth:VIDeo?
The value returned in this example is: "300000".

Syntax :SENSe:BANDwidth:VIDeo:AUTo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF|.
Default is ON.

Command Switches the automatic selection of the video bandwidth on or off. If switched on, 
the 9102 selects the video bandwidth depending on the current span, resolution 
bandwidth, and sweep time.

Query Reads and returns the current setting.

Example :SENSe:BANDwidth:VIDeo:AUTo OFF
:SENSe:BANDwidth:VIDeo:AUTo?
Returns the following string: "OFF"
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:SENSe:FREQuency:CENTer

:SENSe:FREQuency:SPAN

:SENSe:FREQuency:SPAN:FULL

Syntax :SENSe:FREQuency:CENTer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 5000, the maximum value 7500000000. 
real1 can be set in multiples of 1000. The default value for real1 is 
1800000000.

Command Sets the center frequency of the 9102, in Hertz. When a new center frequency is 
selected, this affects the start and stop frequencies, leaving the span unchanged so 
long as the new start and stop frequencies do not exceed the limits of the 9102.

Query Returns the current setting.

Example :SENSe:FREQuency:CENTer 1500000000
:SENSe:FREQuency:CENTer?
The value returned in this example is: "1500000000".

Syntax :SENSe:FREQuency:SPAN <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0, the maximum value 7500000000. The mini-
mum resolution possible for real1 is 1000. The default value for real1 is 
3600000000.

Command Sets the frequency span, i.e. the measured bandwidth, in Hertz. A new frequency span 
setting will leave the center frequency unchanged but affect start and stop frequen-
cies; only if the new start or stop frequency exceeds a limit of the 9102, the center 
frequency will be changed accordingly.

Query Reads and returns the current setting.

Example :SENSe:FREQuency:SPAN 1500000000
:SENSe:FREQuency:SPAN?
The value returned in this example is: "1500000000".

Syntax :SENSe:FREQuency:SPAN:FULL

Parameters There are no parameters.

Command Sets the 9102 to the maximum supported frequency span. This command affects 
start, stop and corresponding center frequency.
Note: If you set the span to 0, the 9102 will perform measurements in the time rather 
than the frequency domain.

Query There is no query form of this command available.

Example :SENS:FREQ:SPAN:FULL
Sets the start frequency of the 9102 to 0 and the stop frequency to 4 GHz (or 7.5 GHz 
if the frequency extension option is installed).
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:SENSe:FREQuency:STARt

:SENSe:FREQuency:STOP

:SENSe:FREQuency:STOP:MAX

:SENSe:FREQuency:MODE

Syntax :SENSe:FREQuency:STARt <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0, the maximum value 7500000000. The mini-
mum resolution possible for real1 is 1000. The default value for real1 is 0.

Command Sets the start frequency of the 9102, in Hertz. This command leaves the span as is but 
affects the center frequency and the stop frequency.

Query Reads and returns the current setting.

Example :SENSe:FREQuency:STARt 1500000000
:SENSe:FREQuency:STARt?
The value returned in this example is: "1500000000".

Syntax :SENSe:FREQuency:STOP <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 10000, the maximum value 7500000000. The 
minimum resolution possible for real1 is 1000. The default value for real1 is 
3600000000.

Command Sets the stop frequency of the measured bandwidth, in Hertz. This command leaves 
the span unchanged but affects the center frequency and the start frequency.

Query Reads and returns the current setting.

Example :SENSe:FREQuency:STOP 2500000000
:SENSe:FREQuency:STOP?
The value returned in this example is: "2500000000".

Syntax :SENSe:FREQuency:MAX?

Parameters There are no parameters.

Command There is only the query form available.

Query Returns the maximum stop frequency supported by the instrument at hand.

Example :SENS:FREQ:STOP:MAX?

Syntax :SENSe:FREQuency:MODE <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
CSPan|SSTop|SSPAN. Default is CSPan.

Command Defines which frequency mode is active.
Three modes are available: Center-Span, Start-Stop, Start-Span.

Query Returns the current setting.

Example :SENSe:FREQuency:MODe CSPan
:SENSe:FREQuency:MODe?
Returns the following string: "CSPan"
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:SENSe:FREQuency:FSTep

:SENSe:FREQuency:FSTep:AUTo

:SENSe:CPOWer:SPAN

:SENSe:CPOWer:CHANnel

Syntax :SENSe:FREQuency:FSTep <real1>

Parameters real1 is a floating point real number. The minimum value for real1 is 0, the max-
imum value 1000000000. The minimum resolution possible for  real1 is 1000. 
The default value for real1 is 360000000.

Command Sets the step size for the center frequency setting using the cursor keys in manual 
mode.

Query Reads and returns the current setting.

Example :SENSe:FREQuency:FSTep 2.5E6
:SENSe:FREQuency:FST?
Value returned in this example: 2500000

Syntax :SENSe:FREQuency:FSTep:AUTo <PredefExp>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF. Default is 
ON.

Command Enables or disables the automatic selection of the step size for the center frequency 
setting using the cursor keys in manual mode.

Query Reads and returns the current setting.

Example :SENSe:FREQuency:FSTep:AUTo ON
:SENSe:FREQuency:FSTep:AUTo?
Returns the following string: "ON"

Syntax :SENSe:CPOWer:SPAN <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: FULL|SINGle.
Default is FULL.

Command Sets the channel power display mode of the 9102.
FULL selects the whole system spectrum. SINGle displays the spectrum of the 
selected channel.

Query Reads and returns the current setting.

Example :CPOWer:SPAN SINGle
:SENSe:CPOWer:SPAN?
Returns the following string: "SINGle"

Syntax :SENSe:CPOWer:CHANnel <int1>

Parameters int1 is an integer. The minimum value for int1 is 0, the maximum is 1000000. 
The default value is 0.

Command Sets the actual channel number which is displayed in SINGle and FULL mode.

Query Reads and returns the current setting.



Chapter 16 SCPI Command Reference
Sense commands

9102 Handheld Spectrum Analyzer Software version 5.10 263

:SENSe:CPOWer:OBW

:SENSe:CPOWer:MEASure

:SENSe:SWEep:TIME

:SENSe:SWEep:TIME:AUTO

Example :SENSe:CPOWer:CHANnel 50
:SENSe:CPOWer:CHANnel?
The value returned in this example is: "50".

Syntax :SENSe:CPOWer:OBW <int1>

Parameters int1 is a integer. The minimum value for int1 is 5, the maximum is 99. The 
default value for int1 is 90.

Command Sets the percentage value for which the 9102 shall determine the occupied band-
width (channnel power mode).

Query Reads and returns the current setting.

Example :SENSe:CPOWer:OBW 20
:SENSe:CPOWer:OBW?
The value returned in this example is: "20"

Syntax :SENSe:CPOWer:MEASure <PredefExp>

Parameters PredefExpr is one of the following predefined expressions: 
CPOWer|ACPR|OBW. Default is CPOWer.

Command Starts measurements of the type described by PredefExpr.

Query Reads and returns the current setting.

Example :SENSe:CPOWer:MEASure ACPR
:SENSe:CPOWer:MEASure?
Returns the following string: "ACPR".

Syntax :SENSe:SWEep:TIME <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0.0, the maximum value 250.0. The minimum 
resolution possible for real1 is 0.0001. The default value for real1 is 0.0432.

Command Sets the sweep time, i.e. the measurement time to cover the full frequency span. 
real1 is the time in seconds.

Query Reads and returns the current setting.

Example :SENSe:SWEep:TIME 0.3
:SENSe:SWEep:TIME?
The value returned in this example is: "0.3".

Syntax :SENSe:SWEep:TIME:AUTO <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.
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:SENSe:SWEep:STATe

:SENSe:TRIGger

:SENSe:TRIGger:LEVel

Command Switches the automatic selection of the sweep time on or off. If turned on, the 9102 
will decide on the best sweep time depending on the current settings of span, resolu-
tion bandwidth and video bandwidth.

Query Reads and returns the current setting.

Example :SENSe:SWEep:TIME:AUTO ON
:SENSe:SWEep:TIME:AUTO?
Returns the following string: "ON".

Syntax :SENSe:SWEep:STATe <PredefExpr>[,<int1>]

Parameters PredefExpr is one of the following predefined expressions: 
CONTinuous|SINGle|HOLD. Default is CONTinuous.
int1 is an optional integer. It is only valid for SINGle sweeps. The minimum value 
for int1 is 1, the maximum is 999. The default value is 1.

Command Sets the measurement display mode of the 9102.
CONTinuous selects repetitive measurements.
SINGle lets the 9102 perform and display one (or a limited number of) measure-
ment(s). The optional second parameter indicates how often a sweep will be per-
formed.
HOLD immediately stops any ongoing measurement.

Query Reads and returns the current setting.

Example :SENSe:SWEep:STATe SINGle
:SENSe:SWEep:STATe?
Returns the following string: "SINGle".

Syntax :SENSe:TRIGger <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: OFF|VIDeo. Default 
is OFF.

Command Sets the trigger mode of the 9102.
OFF means no trigger is active. VIDeo activates the trigger at choosen level.

Query Reads and returns the current setting.

Example SENSe:TRIGger VIDeo
:SENSe:TRIGger?
Returns the following string: "VIDeo".

Syntax :SENSe:TRIGger:LEVel <real1>

Parameters real1 is a floating point real number. 
The minimum value for real1 is -100, the maximum value 30.0. The minimum 
resolution possible for real1 is 0.1. The default value is -40.

Command Sets the trigger level which is active, if SENSe:TRIGger is set to VIDeo. 
real1 is the level in dBm.

Query Reads and returns the current setting.
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:SENSe:TRIGger:EDGE

:SENSe:DEMod[:MODulation]

:SENSe:DEMod:DEMod

:SENSe:DEMod:VOLume

Example :SENSe:TRIGger:LEVel -10
:SENSe:TRIGger:LEVel?
The value returned in this example is: "-10".

Syntax :SENSe:TRIGger:EDGE <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
POSitive|NEGative. Default is POSitive.

Command Sets either the positive or the negative slope for the trigger.

Query Reads and returns the current setting.

Example SENSe:TRIGger:EDGe NEGative
:SENSe:TRIGger?
Returns the following string: "NEGative".

Syntax :SENSe:DEMod[:MODulation] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: OFF|AM|FM.
Default is OFF.

Command Sets the demodulation mode, which can be off, AM (amplitude modulation) or FM 
(frequency modulation). FM demodulation is performed in a 30 kHz bandwidth.

Query Reads and returns the current setting.

Example :SENSe:DEMod FM
:SENSe:DEMod:MODulation?
Returns the following string: "FM"

Syntax :SENSe:DEMod:DEMod <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
PERManent|ATMarker.
Default is PERManent.

Command Sets the demodulation permanent to center frequency or at marker.

Query Reads and returns the current setting.

Example :SENSe:DEMod:DEMod PERManent
:SENSe:DEMod:DEMod?
Returns the following string: "PERManent"

Syntax :SENSe:DEMod:VOLume <int1>

Parameters int1 is an integer. The minimum value for int1 is 0, the maximum is 100. The 
default value for int1 is 50.

Command Sets the volume of the demodulated signal in percent.

Query Reads and returns the current setting.
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:SENSe:DEMod:DURation

:SENSe:DETector:FUNCtion

:SENSe:TRACe:A[:STATe]

Example :SENSe:DEMod:VOLume 20
:SENSe:DEMod:VOLume?
The value returned in this example is:  "20".

Syntax :SENSe:DEMod:DURation <real1>

Parameters real1 is a floating point real number. The minimum value for real1 is 0, the max-
imum value 10. The minimum resolution is 0.001. The default value is 2.

Command Sets the duration of the demodulated signal in seconds.

Query Reads and returns the current setting.

Example :SENSe:DEMod:DURation 10
:SENSe:DEMod:DURation?
The value returned in this example is: "10".

Syntax :SENSe:DETector:FUNCtion <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
POSNeg|SAMPle|POSitive|NEGative|.
Default is POSNeg.

Command Defines which measurement values shall be displayed.
The 9102 takes far more measurements than can be displayed on the screen, so sev-
eral results are summarized into one.
POSNeg indicates both the maximum and minimum values for each frequency point 
in the form of a straight vertical line between these values.
SAMPle lets the 9102 randomly select one of the measurement values for each fre-
quency point.
POSitive lets the 9102 pick the highest value.
NEGative lets the 9102 select the lowest value.

Query Reads and returns the current setting.

Example :SENSe:DETector:FUNCtion SAMPle
:SENSe:DETector:FUNCtion?
Returns the following string: "SAMPle".

Syntax :SENSe:TRACe:A[:STATe] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ACTual|MAX-
Hold|MINHold|HOLD|AVG|OFF. Default is ACTual.

Command Sets the display mode for Trace A.
ACTual shows measurement by measurement.
MAXHold displays the maximum value for each frequency point over all the mea-
surements.
MINHold shows the minimum value for each frequency point over all the measure-
ments.
HOLD stops the measurement immediately.
AVG displays, for each frequency point, an average value over all the measurements.
OFF switches the trace off.
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:SENSe:TRACe:A:FETCh?

:SENSe:TRACe:B[:STATe]

Query Reads and returns the current settings.

Example :SENSe:TRACe:A MAXHold
:SENSe:TRACe:A:STATe?
Returns the following string: "MAXHold".

Syntax :SENSe:TRACe:A:FETCh? <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
ALL|MINimum|MAXimum|FREQuency|FMINimum|FMAXimum.

Command There is solely a query form of this command available.

Query Reads and returns the data of trace A depending on the parameter:
Param ALL returns: <min>,<max>,<freq>,<min>,<max>,<freq>, ... . 
Param MIN returns: <min>,<min>, ... . 
Param MAX returns: <max>,<max>, ... .
Param FREQ returns: <freq>,<freq>, ... . 
Param FMIN returns: <min>,<freq>,<min>,<freq>, ... . 
Param FMAX returns: <max>,<freq>,<max>,<freq>, ... .

Example :SENSe:TRACe:A:FETCh? ALL
Returns the following string:
"1000000.0,-50.3,-45.5,1001000.0,-53.4,-48.2,...".

Syntax :SENSe:TRACe:B[:STATe] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
ACTual|MAXHold|MINHold|HOLD|AVG|OFF.
Default is OFF.

Command Sets the display mode for Trace B.
ACTual shows measurement by measurement.
MAXHold displays the maximum value for each frequency point over all the mea-
surements.
MINHold shows the minimum value for each frequency point over all the measure-
ments.
HOLD stops the measurement immediately.
AVG displays, for each frequency point, an average value over all the measurements.
OFF switches Trace B off.

Query Reads and returns the current settings.

Example :SENSe:TRACe:B MAXHold
:SENSe:TRACe:B?
Returns the following string: "MAXHold".
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:SENSe:TRACe:B:FETCh?

:SENSe:TRACe:AVGFactor

:SENSe:TRACe:CLEar

:SENSe:TRACe:COPY

Syntax :SENSe:TRACe:B:FETCh? <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
ALL|MINimum|MAXimum|FREQuency|FMINimum|FMAXimum.

Command There is solely a query form of this command available.

Query Reads and returns the data of trace B depending on the parameter:
Param ALL returns: <min>,<max>,<freq>,<min>,<max>,<freq>, ... . 
Param MIN returns: <min>,<min>, ... . 
Param MAX returns: <max>,<max>, ... .
Param FREQ returns: <freq>,<freq>, ... . 
Param FMIN returns: <min>,<freq>,<min>,<freq>, ... . 
Param FMAX returns: <max>,<freq>,<max>,<freq>, ... .

Example :SENSe:TRACe:B:FETCh? ALL
Returns the following string:
"1000000.0,-50.3,-45.5,1001000.0,-53.4,-48.2,..."

Syntax :SENSe:TRACe:AVGFactor <int1>

Parameters int1 is an integer. The minimum value for int1 is 1, the maximum is 125. The 
default value for int1 is 5.

Command Sets the trace averaging factor.

Query Reads and returns the current setting.

Example :SENSe:TRACe:AVGFactor 10
:SENSe:TRACe:AVGFactor?
Value returned in this example: "10".

Syntax :SENSe:TRACe:CLEar

Parameters There are no parameters.

Command Clears the current trace.

Query There is no query form of this command available.

Example :SENSe:TRACe:CLEar

Syntax :SENSe:TRACe:COPY <PredefExpr>[,<int>]

Parameters PredefExpr is one of the following predefined expressions: ATOB|BTOA.

Command Copies trace A to B or vice versa.

Query There is no query form of this command available.

Example :SENSe:TRACe:COPY ATOB
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:SENSe:TRACe:DATa?

:SENSe:TRACe:DATa:LIMit

:SENSe:TRACe:MATH

:SENSe:TRACe:MATH:[A|B]

Syntax :SENSe:TRACe:DATa? <PredefExpr>[,<int>]

Parameters PredefExpr is one of the following predefined expressions: A|B which returns 
Trace A or Trace B.

Command There is solely a query form of this command available.

Query First return string: "ALL" or "MINM". "ALL" returns, if minimum and maximum 
values are identical, e.g. "Max hold" or "Min hold". 501 values returned, no 
redundant data is sent. "MINM" returns, if minimum and maximum Values are NOT 
identical, e.g. "ACTUAL" or "Average". 1002 Values returned, the first 501 values 
are the minimum values and after them follow the maximum values. Second return 
string: the trace data. Every level value is represented by 3 bytes. The following for-
mula is used to calculate the level value in dBm: Level = Hexvalue / 10 - 200.

Example :SENSe:TRACe:DATa? A
The values returned in this example are: 
"ALL","38D36F37238B38D3A63A73BC4103A63E33A13CB..."

Syntax :SENSe:TRACe:DATa:LIMit?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Reads and returns the Pass/Fail criteria for the recently received trace with 
SENSe:TRACe:DATa?. There will be returned one of the predefined expressions: 
PASS|FAIL

Example :SENSe:TRACe:DATa:LIMit?
Returns the following string: "PASS"

Syntax :SENSe:TRACe:MATH?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Reads and returns the normalized criteria for the current trace. There will be returned 
one of the predefined expressions: NA|UNNormalized|NORMalized

Example :SENSe:TRACe:MATH?
Returns the following string: "NORM"

Syntax :SENSe:TRACe:MATH:[A|B] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: OFF|SUB-
tract|NORMalize.
Default is OFF.

Command Switches math. function for traces A and B off or to Subtraction or to Normalize.

Query Reads and returns the current setting.
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:SENSe:TRACe:MATH:OFFSet

:SENSe:REFLevel

:SENSe:REFLevel:UNIT

Example :SENSe:TRACe:MATH:A SUB
:SENSe:TRACe:MATH:A?
Returns the following string: "SUB"

Syntax :SENSe:TRACe:MATH:OFFSet <real1>

Parameters real1 is a floating point real number.

Command This command sets the trace offset for the subtracted trace (A-B->A trace).

Query Reads and returns the current setting.

Example :SENSe:TRACe:MATH:OFFSet -20
:SENSe:TRACe:MATH:OFFSet?
The value returned in this example is: "-20".

Syntax :SENSe:REFLevel <real1>

Parameters real1 is a floating point real number.
The minimum and maximum value for real1 depend on the unit set by 
SENS:REFLevel:UNIT. When the unit is set to dBm, the minimum value is 
-100, the maximum value is 30. When the unit is set to dBuV, the minimum value 
is 7, the maximum value is 137. When the unit is set to dBmV, the minimum value is 
-53, the maximum value is 77. When the unit is set to dBV, the minimum value is 
-113, the maximum value is 17. The default value for real1 is 0 dBm.

Command This command sets the reference level of the 9102 (0 dB line), in the unit selected 
with the :SENS:REFLevel:UNIT command.

Query Reads and returns the current setting.

Example :SENSe:REFLevel -50
:SENSe:REFLevel?
The value returned in this example is: "-50".

Syntax :SENSe:REFLevel:UNIT <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
DBM|DBUV|DBMV|DBV|V|MV|UV|MW|UW|.
Default is DBM.

Command Defines the unit for the reference level to logarithmic units (dBm, dBμV, dBmV or 
dBV) or linear units (V, mV, μV, mW, μW). It also affects the unit in which results (on 
the vertical axis) are displayed.

Query Reads and returns the current setting.

Example :SENSe:REFLevel:UNIT DBMV
:SENSe:REFLevel:UNIT?
Returns the following string: "DBMV"
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SENSe:REFLevel:OFFSet

:SENSe:STATe

:SENSe:MEASure

:SENSe:MEASure:OBW

Syntax :SENSe:REFLevel:OFFSet <PredefExpr>

Parameters real1 is a floating point real number.
The minimum value for real1 is -113.0, the maximum value 9999999.9. 
real1 can be set in multiples of 1000. The default value for real1 is 5000000.

Command Defines the reference level offset.

Query Returns the current setting.

Example :SENSe:REFLevel:OFFset -10
:SENSe:REFLevel:OFFSet?
Returns the following string: "-10"

Syntax :SENSe:STATe?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Reads and returns the Uncal state.

Example :SENSe:STATe?
Returns the following string: "ON". 

Syntax :SENSe:MEASure <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
NONe|CPOWer|ACPR|OBW. Default is NONe.

Command Starts measurements of the type described by PredefExp.

Query Reads and returns the current setting.

Example :SENSe:MEASure ACPR
:SENSe:MEASure?
Returns the following string: "ACPR"

Syntax :SENSe:MEASure:OBW <int1>

Parameters int1 is an integer. The minimum value for int1 is 5, the maximum is 99. The 
default value for int1 is 90.

Command Sets the percentage value for which the 9102 shall determine the occupied band-
width (spectrum analyzer mode).

Query Reads and returns the current setting.

Example :SENSe:MEASure:OBW 20
:SENSe:MEASure:OBW?
The value returned in this example is: "20".
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:SENSe:MEASure:CHANnel:WIDTh

:SENSe:MEASure:CHANnel:SPACing

:SENSe:MEASure:ADJSettings

:SENSe:DTF:CLENgth

Syntax :SENSe:MEASure:CHANnel:WIDTh <real1>

Parameters real1 is a floating point real number. The minimum value for real1 is 100000, 
the maximum value 2000000000. real1 can be set in multiples of 1000. The 
default value for real1 is 5000000.

Command Sets the actual channel width in spectrum analyzer mode.

Query Reads and returns the current setting.

Example :SENSe:MEASure:CHANnel:WIDTh 150000000
:SENSe:MEASure:CHANnel:WIDTh?
The value returned in this example is: "150000000".

Syntax :SENSe:MEASure:CHANnel:SPACing <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 100000, the maximum value 2000000000. 
real1 can be set in multiples of 1000. The default value for real1 is 
10000000.

Command Sets the actual channel spacing in spectrum analyzer mode.

Query Reads and returns the current setting.

Example :SENSe:MEASure:CHANnel:SPACing 1500000000
:SENSe:MEASure:CHANnel:SPACing?
The value returned in this example is: "1500000000".

Syntax :SENSe:MEASure:ADJSettings

Parameters There are no parameters.

Command Adjusts settings in display made with ...CHAN:WIDTh and ...SPACing in the corre-
sponding measure mode CPOWer, ACPR or OBW.

Query Reads and returns the current setting.

Example :SENSe:MEASure:ADJSettings

Syntax :SENSe:DTF:CLENgth <real1>

Parameters real1 is a floating point real number.
The minimum- and maximum value for real1 depends on the unit set by 
SENS:DTF:CLENgth:UNIT. When unit is set to m, the minimum value is 1, the 
maximum value is 2000. When unit is set to ft, the minimum value is 3, the maxi-
mum value is 6660. The default value for real1 is 1 m.

Command This command defines the cable length to be tested, in the unit selected with the 
:SENS:DTF:CLEN:UNIT command.

Query Reads and returns the current setting.
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:SENSe:DTF:CLENgth:UNIT

:SENSe:DTF:REFerence

:SENSe:DTF:REFerence:UNIT

:SENSe:DTF:REFerence:VSWR

Example :SENSe:DTF:CLENgth 50
:SENSe:DTF:CLENgth?
The value returned in this example is: "50".

Syntax :SENSe:DTF:CLENgth:UNIT <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: METer|FEET.
Default is METer.

Command Defines the unit for the cable length (m, ft). It also affects the unit for the cable 
attenuation.

Query Reads and returns the current setting.

Example :SENSe:DTF:CLENgth:UNIT FEET
:SENSe:DTF:CLENgth:UNIT?
Returns the following string: "FEET"

Syntax :SENSe:DTF:REFerence <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is -100.0 dB. The maximum value for real1 is 
0.0 dB. The default value for real1 is 0.0 dB

Command This command sets the reference level of the 9102 (0 dB line), in DTF mode.

Query Reads and returns the current setting.

Example :SENSe:DTF:REFerence -50
:SENSe:DTF:REFerence?
The value returned in this example is: "-50".

Syntax :SENSe:DTF:REFerence:UNIT <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: DB|MRHO|VSWR.
Default is DB.

Command Defines the unit in which results (on the vertical axis) are displayed (dB, mRho). It not 
affects the unit for the DTF reference level.

Query Reads and returns the current setting.

Example :SENSe:DTF:REFerence:UNIT DB
:SENSe:DTF:REFerence:UNIT?
Returns the following string: "DB"

Syntax :SENSe:DTF:REFerence:UNIT <real1>

Parameters real1 is a floating point real number.
 The minimum value for real1 is 1.0. The maximum value for real1 is 1000.0. 
The default value for real1 is 10.0.
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:SENSe:DTF:REFerence:RFACtor

:SENSe:DTF:CALibration

:SENSe:DTF:CALibration:ENABled

Command This command sets the maximum VSWR value for DTF display when the unit is set to 
VSWR.

Query Returns the current setting.

Example :SENSe:DTF:REFerence:VSWR 500
:SENSe:DTF:REFerence:VSWR?
The value returned in this example is: "500.0".

Syntax :SENSe:DTF:REFerence:RFACtor <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0 mRho. The maximum value for real1 is 2000 
mRho. The default value for real1 is 1000 mRho.

Command This command sets the maximum factor value for DTF display when the unit is set to 
mRho.

Query Reads and returns the current setting.

Example :SENSe:DTF:REFerence:RFACtor 1000
:SENSe:DTF:REFerence:RFACtor?
The value returned in this example is: "1000.0".

Syntax :SENSe:DTF:CALibration

Parameters There are no parameters.

Command Starts DTF calibration. Before executing this command, a SHORT has to be connected 
to measurement port.

Query Reads and returns the current calibration state. This is one of the following pre-
defined expressions: NO|YES.

Example :SENSe:DTF:CALibration
:SENSe:DTF:CALibration?
Returns the following string: "YES"

Syntax :SENSe:DTF:CALibration:ENABled <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Switches the DTF calibration correction on or off.

Query Reads and returns the current setting.

Example :SENSe:DTF:CALibration:ENABled OFF
:SENSe:DTF:CALibration:ENABled?
Returns the following string: "OFF"
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:SENSe:TRANsmission:REFerence

:SENSe:TRANsmission:REFerence:UNIT

:SENSe:EMF:REFerence

Syntax :SENSe:TRANsmission:REFerence <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is -60.0 dB. The maximum value for real1 is 
60.0 dB. The default value for real1 is 0.0 dB.

Command This command sets the reference of the 9102 (0 dB line), in Transmission mode. The 
reference refers to the current set output power level of the tracking generator.

Query Reads and returns the current setting.

Example :SENSe:TRANsmission:REFerence -10
:SENSe:TRANsmission:REFerence?
The value returned in this example is: "-10".

Syntax :SENSe:TRANsmission:REFerence:UNIT <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: DB|DBM|.
Default is DB.

Command Switches the display absolute or relative to the tracking generator output power. This 
command is linked to INSTrument:GENerator:DISPlay.

Query Reads and returns the current setting.

Example :SENSe:TRANsmission:REFerence:UNIT DBM
:SENSe:TRANsmission:REFerence:UNIT?
Returns the following string: "DBM"

Syntax :SENSe:EMF:REFerence <real1>

Parameters real1 is a floating point real number.
The minimum- and maximum value for real1 depend on the unit set by 
SENS:EMF:REFerence:UNIT. When the unit is set to dBm/m^2, the minimum 
value is -100, the maximum value is 30. When the unit is set to dBuV/m, the min-
imum value is 7, the maximum value is 137. When the unit is set to dBmV/m, the 
minimum value is -53, the maximum value is 77. When the unit is set to dBV/m, 
the minimum value is -113, the maximum value is 17. When the unit is set to V/m, 
the minimum value is 0.000002236, the maximum value is 7.0710678. When 
the unit is set to mW/m^2, the minimum value is 0.0001, the maximum value is 
1000.0. The default value for real1 is 107.0 dBµV/m.

Command This command sets the EMF reference level of the 9102, in the unit selected with the 
:SENS:EMF:REFerence:UNIT command.

Query Reads and returns the current setting.

Example :SENSe:EMF:REFerence -50
:SENSe:EMF:REFerence?
The value returned in this example is: "-50".
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:SENSe:EMF:REFerence:UNIT

:SENSe:EMF:ANTenna:DIRection

:SENSe:EMF:MEASure

:SENSe:EMF:MEASure:LAST?

Syntax :SENSe:EMF:REFerence:UNIT <PredefExp>

Parameters PredefExp is one of the following predefined expressions: 
DBUVm|DBMVm|DBVM|VM|MWM2|.
Default is DBUVm.

Command Defines the unit for the EMF reference, either logarithmic (dBμV/m, dBmV/m or dBV/
m) or linear (V/m or mW/m^2). It also affects the unit in which results (on the vertical 
axis) are displayed.

Query Reads and returns the current setting.

Example :SENSe:EMF:REFerence:UNIT DBVM
:SENSe:EMF:REFerence:UNIT?
Returns the following string: "DBVM"

Syntax :SENSe:EMF:ANTenna:DIRection <PredefExp>

Parameters PredefExp is one of the following predefined expressions: X|Y|Z|.
Default is X.

Command Defines the direction of the antenna.

Query Reads and returns the current setting.

Example :SENSe:EMF:ANTenna:DIRection Y
:SENSe:EMF:ANTenna:DIRection?
Returns the following string: "Y"

Syntax :SENSe:EMF:MEASure <PredefExp>

Parameters PredefExp is one of the following predefined expressions: 
OFF|MANual|AUTo|QUICk|.
Default is OFF.

Command Defines the mode of the antenna EMF measurement.

Query Reads and returns the current setting.

Example :SENSe:EMF:MEASure AUTo
:SENSe:EMF:MEASure?
Returns the following string: "AUT"

Syntax :SENSe:EMF:MEASure:LAST?

Parameters There are no parameters.

Command There is only a no query form of this command available.

Query Returns the last measurement setting, which was performed in EMF mode.

Example :SENSe:EMF:MEASure:LAST?
Returns the following string: "AUT"
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:SENSe:EMF:MEASure:DISPlay

:SENSe:EMF:MEASure:TIMe

:SENSe:RFLection:REFerence[:RETurnloss]

:SENSe:RFLection:REFerence:UNIT

Syntax :SENSe:EMF:MEASure:DISPlay <PredefExp>

Parameters PredefExp is one of the following predefined expressions: 
EFSTrength|PDENsity|.
Default is EFSTrength.

Command Defines the display mode of the antenna EMF measurement. It can be either “Electric 
field strength” or “Power density”.

Query Reads and returns the current setting.

Example :SENSe:EMF:MEASure:DISPlay PDEN
:SENSe:EMF:MEASure:DISPlay?
Returns the following string: "PDEN"

Syntax :SENSe:EMF:MEASure:TIMe <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 1000, the maximum value 1000000. real1 can 
be set as 1*10n or 3*10n. The default value for real1 is 1000000.

Command This command sets the measure time in EMF mode in seconds.

Query Reads and returns the current setting.

Example :SENSe:EMF:MEASure:TIMe 100
:SENSe:EMF:MEASure:TIMe?
The value returned in this example is: "100".

Syntax :SENSe:RFLection:REFerence[:RETurnloss] <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is -60.0 dB. The maximum value for real1 is 
60.0 dB. The default value for real1 is 0.0 dB.

Command This command sets the reference of the 9102 (0 dB line), in Reflection mode, when 
unit is set to Return Loss. The reference refers to the current set output power level of 
the tracking generator.

Query Reads and returns the current setting.

Example :SENSe:RFLection:REFerence -10
:SENSe:RFLection:REFerence?
The value returned in this example is: "-10".

Syntax :SENSe:RFLection:REFerence:UNIT <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: RETurn-
loss|VSWR|RFACtor|RPOWer.
Default is RETurnloss.

Command Switches the display to following units: return loss (dB), VSWR (-), reflection factor 
(mRho) or reflected power (%).
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:SENSe:RFLection:REFerence:VSWR

:SENSe:RFLection:REFerence:RFACtor

:SENSe:RFLection:REFerence:RPOWer

Query Reads and returns the current setting.

Example :SENSe:RFLection:REFerence:UNIT DBM
:SENSe:RFLection:REFerence:UNIT?
Returns the following string: "DBM"

Syntax :SENSe:RFLection:REFerence:VSWR <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 1.0. The maximum value for real1 is 1000.0. 
The default value for real1 is 10.0.

Command This command sets the maximum VSWR value for reflection display when the unit is 
set to VSWR.

Query Reads and returns the current setting.

Example :SENSe:RFLection:REFerence:VSWR 500
:SENSe:RFLection:REFerence:VSWR?
The value returned in this example is: "500.0".

Syntax :SENSe:RFLection:REFerence:RFACtor <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0 mRho. The maximum value for real1 is 2000 
mRho. The default value for real1 is 2000 mRho.

Command This command sets the maximum factor value for reflection display when the unit is 
set to reflection factor.

Query Reads and returns the current setting.

Example :SENSe:RFLection:REFerence:RFACtor 1000
:SENSe:RFLection:REFerence:RFACtor?
The value returned in this example is: "1000.0".

Syntax :SENSe:RFLection:REFerence:RPOWer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0.0 %. The maximum value for real1 is 
200.0 %. The default value for real1 is 200.0 %.

Command This command sets the maximum power value for reflection display when the unit is 
set to reflected power.

Query Reads and returns the current setting.

Example :SENSe:RFLection:REFerence:RPOWer 120
:SENSe:RFLection:REFerence:RPOWer?
The value returned in this example is: "120.0".
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:SENSe:RFLection:FILTer

:SENSe:RFLection:FILTer:AUTo

:SENSe:RFLection:CALibration

Syntax :SENSe:RFLection:FILTer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 1000, the maximum value 1000000. real1 
can be set as 1*10^n or 3*10^n. The default value for real1 is 1000000.

Command This command sets the resolution bandwidth filter of the 9102, in Hertz.

Query Reads and returns the current setting.

Example :SENSe:RFLection:FILTer 300000
:SENSe:RFLection:FILTer?
The value returned in this example is: "300000".

Syntax :SENSe:RFLection:FILTer:AUTo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Switches the automatic selection of the bandwidth resolution filter on or off. If 
switched on, the 9102 selects the resolution bandwidth depending on the current 
span, video bandwidth, and sweep time.

Query Reads and returns the current setting.

Example :SENSe:RFLection:FILTer:AUTo ON
:SENSe:RFLection:FILTer:AUTo?
Returns the following string: "ON"

Syntax :SENSe:RFLection:CALibration <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
OPEN|SHORt|LOAD.

Command Starts reflection calibration. The following sequence is necessary:
1. Scalar mode:
Connect an OPEN to measurement port. Then execute 
:SENSe:RFLection:CALibration OPEN.
Connect a SHORT to measurement port. Then execute 
:SENSe:RFLection:CALibration SHORt.
2. Vector mode:
Connect an OPEN to measurement port. Then execute 
:SENSe:RFLection:CALibration OPEN.
Connect a SHORT to measurement port. Then execute 
:SENSe:RFLection:CALibration SHORt.
Connect a LOAD to measurement port. Then execute 
:SENSe:RFLection:CALibration LOAD.
The mode has to be set before with 
:SENSe:RFLection:CALibration:MODe SCALar|VECTor.

Query Reads and returns the current calibration state. This is one of the following pre-
defined expressions: NO|YES.

Example :SENSe:RFLection:CALibration?
Returns the following string: "YES"
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:SENSe:RFLection:CALibration:MODe

:SENSe:RFLection:CALibration:ENABled

:SENSe:CLOSs:REFerence

:SENSe:CLOSs:FILTer

Syntax :SENSe:RFLection:CALibration:MODe <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: SCALar|VECTor.
Default is SCALar.

Command Sets reflection calibration mode to scalar or vector.

Query Reads and returns the current calibration state. This is one of the following pre-
defined expressions: NO|YES.

Example :SENSe:RFLection:CALibration:MODe VECTor
:SENSe:RFLection:CALibration:MODe?
Returns the following string: "VECT"

Syntax :SENSe:RFLection:CALibration:ENABled <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Switches reflection calibration correction on or off.

Query Reads and returns the current calibration state. This is one of the following pre-
defined expressions: NO|YES.

Example :SENSe:RFLection:CALibration:ENABled OFF
:SENSe:RFLection:CALibration:ENABled?
Returns the following string: "OFF"

Syntax :SENSe:CLOSs:REFerence <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is -60.0 dB. The maximum value for real1 is 
60.0 dB. The default value for real1 is 0.0 dB.

Command This command sets the reference of the 9102 (0 dB line), in Cable Loss mode. The ref-
erence refers to the current set output power level of the tracking generator.

Query Reads and returns the current calibration state. This is one of the following pre-
defined expressions: NO|YES.

Example :SENSe:CLOSs:REFerence -10
:SENSe:CLOSs:REFerence?
The value returned in this example is: "-10".

Syntax :SENSe:CLOSs:FILTer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 1000, the maximum value 1000000. real1 
can be set as 1*10^n or 3*10^n. The default value for real1 is 1000000.

Command This command sets the resolution bandwidth filter of the 9102, in Hertz.

Query Reads and returns the current calibration state. This is one of the following pre-
defined expressions: NO|YES.
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:SENSe:CLOSs:FILTer:AUTo

:SENSe:CLOSs:CALibration

:SENSe:CLOSs:CALibration:ENABled

Example :SENSe:CLOSs:FILTer 300000
:SENSe:CLOSs:FILTer?
The value returned in this example is: "300000".

Syntax :SENSe:CLOSs:FILTer:AUTo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Switches the automatic selection of the bandwidth resolution filter on or off. If 
switched on, the 9102 selects the resolution bandwidth depending on the current 
span, video bandwidth, and sweep time.

Query Reads and returns the current calibration state. This is one of the following pre-
defined expressions: NO|YES.

Example :SENSe:CLOSs:FILTer:AUTo ON
:SENSe:CLOSs:FILTer:AUTo?
Returns the following string: "ON"

Syntax :SENSe:CLOSs:CALibration <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: SHORt|OPEN.

Command Starts Cable Loss calibration. The following sequence is necessary: 
Connect a SHORT to measurement port. Then execute 
:SENSe:CLOSs:CALibration SHORt.
Connect an OPEN to measurement port. Then execute 
:SENSe:CLOSs:CALibration OPEN.

Query Reads and returns the current calibration state. This is one of the following pre-
defined expressions: NO|YES.

Example :SENSe:CLOSs:CALibration?
Returns the following string: "YES"

Syntax :SENSe:CLOSs:CALibration:ENABled <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Switches the cable loss calibration correction on or off.

Query Reads and returns the current calibration state. This is one of the following pre-
defined expressions: NO|YES.

Example :SENSe:CLOSs:CALibration:ENABled OFF
:SENSe:CLOSs:CALibration:ENABled?
Returns the following string: "OFF"
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:SENSe:PSENsor:MODe

SENSe:PSENsor:TYPe

:SENSe:PSENsor:FREQuency:CW

:SENSe:PSENsor:FREQuency:GSM

Syntax :SENSe:PSENsor:MODe <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: DBM|W|.
Default is DBM.

Command Defines the unit for the power sensor measurement to logarithmic unit (dBm) or lin-
ear unit (W).

Query Reads and returns the current setting.

Example :SENSe:CLOSs:CALibration:ENABled OFF
:SENSe:CLOSs:CALibration:ENABled?
Returns the following string: "OFF"
:SENSe:PSENsor:MODe LIN
:SENSe:PSENsor:MODe?
Returns the following string: "LIN"

Syntax :SENSe:PSENsor:TYPe <PredefExpr>

Parameters PredefExpr  is one of the following predefined expressions: 
CW|GSM|TETRa|UMTS|CDMA|DVBT|.
Default is CW.

Command Switches the power sensor system to the following settings: continuous wave, GSM, 
TETRA, UMTS, CDMA and DVBT.

Query Reads and returns the current setting.

Example :SENSe:PSENsor:TYPe UMTS
:SENSe:PSENsor:TYPe?
Returns the following string: "UMTS"

Syntax :SENSe:PSENsor:FREQuency:CW <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 70000000, the maximum value 2700000000. 
The default value for real1 is 1000000000.

Command Sets the continuous wave frequency for the power sensor measurement in Hertz.

Query Reads and returns the current setting.

Example :SENSe:PSENsor:FREQuency:CW 1500000000
:SENSe:PSENsor:FREQuency:CW?
The value returned in this example is: "1500000000".

Syntax :SENSe:PSENsor:FREQuency:GSM <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 70000000, the maximum value 2700000000. 
The default value for real1 is 900000000.

Command Sets the GSM frequency for the power sensor measurement in Hertz.
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:SENSe:PSENsor:FREQuency:TETRa

:SENSe:PSENsor:FREQuency:UMTS

:SENSe:PSENsor:FREQuency:CDMA

Query Reads and returns the current setting.

Example :SENSe:PSENsor:FREQuency:GSM 1800000000
:SENSe:PSENsor:FREQuency:GSM?
The value returned in this example is: "1800000000".

Syntax :SENSe:PSENsor:FREQuency:TETRa <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 70000000, the maximum value 2700000000. 
The default value for real1 is 900000000.

Command Sets the TETRA frequency for the power sensor measurement in Hertz.

Query Reads and returns the current setting.

Example :SENSe:PSENsor:FREQuency:TETRa 800000000
:SENSe:PSENsor:FREQuency:TETRa?
The value returned in this example is: "800000000".

Syntax :SENSe:PSENsor:FREQuency:UMTS <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 70000000, the maximum value 2700000000. 
The default value for real1 is 2000000000.

Command Sets the UMTS frequency for the power sensor measurement in Hertz.

Query Reads and returns the current setting.

Example :SENSe:PSENsor:FREQuency:UMTS 2400000000
:SENSe:PSENsor:FREQuency:UMTS?
The value returned in this example is: "2400000000".

Syntax :SENSe:PSENsor:FREQuency:CDMA <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 70000000, the maximum value 2700000000. 
The default value for real1 is 1800000000.

Command Sets the CDMA frequency for the power sensor measurement in Hertz.

Query Reads and returns the current setting.

Example :SENSe:PSENsor:FREQuency:CDMA 1900000000
:SENSe:PSENsor:FREQuency:CDMA?
The value returned in this example is: "1900000000".
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:SENSe:PSENsor:FREQuency:DVBT

:SENSe:EDEVice:RFINput

Input commands
With these commands, the input stage of the 9102 Handheld Spectrum Analyzer 
is affected.

:INPut:ATTenuation

Syntax :SENSe:PSENsor:FREQuency:DVBT <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 70000000, the maximum value 2700000000. 
The default value for real1 is 300000000.

Command Sets the DVBT frequency for the power sensor measurement in Hertz.

Query Reads and returns the current setting.

Example :SENSe:PSENsor:FREQuency:CDMA 600000000
:SENSe:PSENsor:FREQuency:CDMA?
The value returned in this example is: "600000000".

Syntax :SENSe:EDEVice:RFINput <int1>

Parameters int1 is a integer.
The minimum value for int1 is 1, the maximum is 6. The default value for int1 is 
1.

Command Sets the RF input channel on the external device.

Query Reads and returns the current setting.

Example :SENSe:EDEVice:RFINput 2
:SENSe:EDEVice:RFINput?
The value returned in this example is: "2".

WARNING

The maximum input power level at the RF IN connector is 30 dBm (1 W). 
Higher input levels may result in serious damage of the instrument.

Syntax :INPut:ATTenuation <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0, the maximum value 50. real1 can be set in 
steps of 10. The default value for real1 is 30.

Command This command sets the RF preattenuation of the Willtek 9102. The physical dimension 
of real1 is dB.

Query Reads and returns the current setting.

Example :INP:ATT 20
:INPut:ATTenuation?
The value returned is in this example: "20".
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:INPut:ATTenuation:AUTo

:INPut:IMPedance

:INPut:EDEVice

:INPut:AFACtor

Syntax :INPut:ATTenuation:AUTo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Lets the 9102 select the preattenuation depending on the reference level.

Query Reads and returns the current setting.

Example :INP:ATT:AUTO ON
:INPut:ATTenuation:AUTO?
Returns the following string: "ON"

Syntax :INPut:IMPedance <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: IMP50|IMP75.
Default is IMP50.

Command Lets the 9102 select between 50 Ω and 75 Ω impedance.

Query Reads and returns the current setting.

Example :INP:IMP IMP75
:INPut:IMPedance?
Returns the following string: "IMP75"

Syntax :INPut:EDEVice <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Switches the external device compensation on or off. A corresponding file has to be 
loaded first with command MMEMory:LOAD:EDEVice.

Query Reads and returns the current setting.

Example :INP:EDEVice ON
:INPut:EDEVice?
Returns the following string: "ON"

Syntax :INPut:AFACtor <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: OFF|ON.
Default is OFF.

Command Switches the antenna factor compensation on or off. A corresponding file has to be 
loaded first with command MMEMory:LOAD:AFACtor.

Query Reads and returns the current setting.

Example :INPut:AFACtor ON
:INPut:AFACtor?
Returns the following string: "ON"
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:INPut:CFACtor

MMemory commands
With the MMemory commands, you can fully exploit the capabilities of the 
instrument to store and reload measurement results in its nonvolatile memory.

:MMEMory:STORe:STATe

:MMEMory:STORe:TRACe

Syntax :INPut:CFACtor <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: OFF|ON.
Default is OFF.

Command Switches the cable factor compensation on or off. A corresponding file has to be 
loaded first with command MMEMory:LOAD:CFACtor.

Query Reads and returns the current setting.

Example :INPut:CFACtor ON
:INPut:CFACtor?
Returns the following string: "ON"

Syntax :MMEMory:STORe:STATe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Stores the actual parameter settings of the 9102 in the SETTINGS directory on the 
flash disk in a file named <string1>.

Query Reads and returns the file name last stored with this command.

Example :MMEMory:STORe:STATe "sett3"

Syntax :MMEMory:STORe:TRACe <string1>[,<PredefExp>]

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.
PredefExpr is an optional parameter and one of the following predefined expres-
sions: A|B. Default is A.

Command Stores the current trace A or B and the parameter settings on the flash disk in the 
TRACE directory in a file named <string1>.

Query Reads and returns the file name last stored with this command.

Example :MMEMory:STORe:TRACe "GSM900",A
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:MMEMory:STORe:LIMit

:MMEMory:STORe:CHANnel

Syntax :MMEMory:STORe:LIMit 
<string1>{,<PredefExpr>,<x1>,<y1>,<x2>,<y2>...}
:MMEMory:STORe:LIMit? <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters. 
PredefExpr is one of the following predefined expressions: 
MINimium|MAXimum.
x1 y1 x2 y2 are floating point real numbers.
The minimum value for all these reals is 0, the maximum value for the x values is 10, 
the maximum value for the y values is 8, the resolution for all real values is 0.1 and 
the default is 0.

Command Stores the limits defined as lines in the LIMIT directory on the flash disk in a file 
named <string1>. A line is defined by a parameter set 
PredefExpr,x1,y1,x2,y2. Up to 30 parameter sets can follow the string 
parameter.

Query Reads and returns the parameter sets of the limit file which is given as parameter.

Example :MMEMory:STORe:LIMit 
"lim2",UPP,2.3,4.5,6.9,7,2,LOW,2.3,1.5,6.9,3,2
:MMEMory:STORe:LIMit? "lim2"
String returned: UPP,2.3,4.5,6.9,7,2,LOW,2.3,1.5,6.9,3,2

Syntax :MMEMory:STORe:CHANnel <string1>, <int1>, <int2>, 
<real1>, <real2>, <real3>, <real4>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 
11 characters.
int1 is an integer. The minimum value for int1 is 1, the maximum is 1000000. 
The default value is 100.
int2 is an integer. The minimum value for int2 is 0, the maximum is 1000000. 
The default value is 0.
real1 is a floating point real number. The minimum value for real1 is 0, the max-
imum value 7500000000. The minimum resolution is 1000. The default value is 
1000000.
real2 is a floating point real number. The minimum value for real2 is 0, the max-
imum value 7500000000. The minimum resolution is 1000. The default value is 
1000000.
real3 is a floating point real number. The minimum value for real3 is 0, the max-
imum value 7500000000. The minimum resolution is 1000. The default value is 
1000000000.
real4 is a floating point real number. The minimum value for real4 is -100, the 
maximum value 30. The minimum resolution is 1. The default value is 0.

Command This command stores the present communication system settings within the 9102 
(e.g. for the channel power mode).
string1 is the name of system settings file in which the parameters are stored. 
int1 sets the number of channels. int2 sets the start channel number. real1 
sets the channel bandwidth over which to measure, in Hertz. real2 sets the fre-
quency spacing of the channels, in Hertz. real3 sets the frequency of the first 
channel, in Hertz. real4 sets the system reference level (0 dB line).

Query Reads and returns the parameter set from the limit file given as a parameter.
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:MMEMory:STORe:EDEVice

:MMEMory:STORe:CTYPe

Example :MMEMory:STORe:CHANnel "P-
GSM9DO",125,0,400000,200000,935000000,0.0

Syntax :MMEMory:STORe:EDEVice <string1>, <real1freq>, 
<real1lev>, <real2freq>, <real2lev>, ... <real100freq>, 
<real100lev>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.
real1freq to real100freq are floating point real numbers. The minimum 
value is 0, the maximum value 4e9. The minimum resolution is 1. 
real1lev to real100lev are floating point real numbers. The minimum value is 
-100, the maximum value 30. The minimum resolution is 0.01.

Command This command stores settings for external device compensation. string1 is the 
name of the external device compensation file in which the parameters are stored. 
realxfreq and realxlev are pairs of frequency and level values to set the 
attenuation on the respective frequency. The instrument applies linear interpolation 
for the level between frequency points. 

Query Reads and returns the parameter sets of the external device compensation file which 
is given as a parameter.

Example :MMEMory:STORe:EDEVice "EXT_DEV2",1000000, -5.1, 
2000000,-3.2,5000000,-4.1,10000000,-3.8,20000000,-2.6
:MMEM:STOR:EDEV? "EXT_DEV2"
String returned: 1000000, -5.1,2000000,-3.2,5000000,-4.1, 
10000000,-3.8,20000000,-2.6

Syntax :MMEMory:STORe:CTYPe <string1>,<real1>,<real2>,
<PredefExpr>,<real3>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.
real1 is a floating point real number. The minimum value is 1.0, the maximum 
value 20.0. The minimum resolution is 0.1. The default value is 1.0. 
real2 is a floating point real number. The minimum value is 0.0, the maximum 
value 2000.0. The minimum resolution is 0.01. The default value is 0.0. 
PredefExpr is optional and one of the following predefined expressions: 
M100|FT100. Default is M100.
real3 is a floating point real number and also optional. The minimum value is 
500000, the maximum value 4000000000. The minimum resolution is 0.1. The 
default value is 4000000000.

Command This command stores settings for cable types. string1 is the name of the cable 
type file in which the parameters are stored. real1 is the cable dielectric of the 
cable. real2 is the attenuation of the cable per meter or feet. PredefExpr sets 
the attenuation to meter or feet. real3 is the cable cutoff frequency.

Query Reads and returns the parameter sets of the cable type file which is given as parame-
ter.

Example :MMEMory:STORe:CTYPe 
"EXT_DEV2",2.4,9.3,"MET",2000000000
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:MMEMory:STORe:CTYPe:CALibration 

:MMEMory:STORe:AFACtor

:MMEMory:STORe:CFACtor

Syntax :MMEMory:STORe:CTYPe:CALibration <real1>,<real2>

Parameters real1 is a floating point real number. The minimum value is 1.0, the maximum 
value 20.0. The minimum resolution is 0.1. The default value is 2.3. real2 is a 
floating point real number. The minimum value is 1.0, the maximum value 2000.0. 
The minimum resolution is 0.01. The default value is 1.0.

Command This command stores settings for cable type calibration. real1 is the cable dielectric 
of the calibration cable. real2 is the length of the calibration cable per meter.

Query Reads and returns the parameter sets of the calibration cable type file which is given 
as parameter.

Example :MMEMory:STORe:CTYPe:CALibration 2.5,1.5

Syntax :MMEMory:STORe:AFACtor 
<string1>,<real1freq>,<real1lev>,<real2freq>,
<real2lev>,...,<real100freq>,<real100lev>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.
real1freq to real100freq are floating point real numbers. The minimum 
value is 0, the maximum value 4e9. The minimum resolution is 1. 
real1lev to real100lev are floating point real numbers. The minimum value is 
-100, the maximum value 30. The minimum resolution is 0.01.

Command This command stores settings for cable types. string1 is the name of the cable 
type file in which the parameters are stored. real1 is the cable dielectric of the 
cable. real2 is the attenuation of the cable per meter or feet. PredefExpr sets 
the attenuation to meter or feet. real3 is the cable cutoff frequency.

Query Reads and returns the parameter sets of the external device compensation file which 
is given as parameter.

Example :MMEMory:STORe:AFACtor "AFAC2",1000000,-5.1,2000000,
-3.2,5000000,-4.1,10000000,-3.8,20000000,-2.6

Syntax :MMEMory:STORe:CFACtor 
<string1>,<real1freq>,<real1lev>,<real2freq>,
<real2lev>,...,<real100freq>,<real100lev>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 
11 characters.
real1freq to real100freq are floating point real numbers. The minimum 
value is 0, the maximum value 4e9. The minimum resolution is 1. real1lev to 
real100lev are floating point real numbers. The minimum value is -100, the 
maximum value 30. The minimum resolution is 0.01.

Command This command stores settings for cable factor compensation. string1 is the name 
of cable factor compensation file in which the parameters are stored. realxfreq 
and realxlev are pairs of frequency and level values to set the attenuation on this 
frequency. Between frequency values there is a linear interpolation for the level.

Query Reads and returns the parameter sets of the cable factor compensation file which is 
given as parameter.
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:MMEMory[:LOAD]:FILelist[:TRACe]?

:MMEMory[:LOAD]:FILelist:STATe?

:MMEMory[:LOAD]:FILelist:LIMit?

Example :MMEMory:STORe:CFACtor "CFAC7",1000000,-5.1,2000000,
-3.2,5000000,-4.1,10000000,-3.8,20000000,-2.6

Syntax :MMEMory:LOAD:FILelist[:TRACe]? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Reads and returns the list of files stored in the TRACE directory. The file names are 
separated by commas.

Example :MMEMory:LOAD:FILelist:TRACe?
String returned in this example:
"TRACE1","TRACE2","TRACE3"

Syntax :MMEMory[:LOAD]:FILelist:STATe? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Reads and returns the list of files stored in the SETTINGS directory. The file names are 
separated by commas.

Example :MMEMory:LOAD:FILelist:STATe?
String returned in this example:
"SETT1","SETT2","SETT3"

Syntax :MMEMory[:LOAD]:FILelist:LIMit? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Reads and returns a comma-separated list of file names. Each file contains spectrum 
limit values stored on the 9102.

Example :MMEMory:LOAD:FILelist:LIMit?
String returned in this example:
"LIM1","LIM2"
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:MMEMory[:LOAD]:FILelist:CHANnel?

:MMEMory[:LOAD]:FILelist:EDEVice?

:MMEMory[:LOAD]:FILelist:CTYPe?

:MMEMory[:LOAD]:FILelist:AFACtor?

Syntax :MMEMory[:LOAD]:FILelist:CHANnel? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Reads and returns a comma-separated list of file names. Each file contains channel 
values stored on the 9102.

Example :MMEMory:LOAD:FILelist:CHANnel?
String returned: "GSM900","GSM1800"

Syntax :MMEMory[:LOAD]:FILelist:EDEVice? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Reads and returns a comma-separated list of file names. Each file contains external 
device compensation values stored on the 9102.

Example :MMEMory:LOAD:FILelist:EDEVice?
String returned in this example: "EXT_DEV2","EXT_DEV5"

Syntax :MMEMory[:LOAD]:FILelist:CTYPe? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent.
Default is SHORt.

Command There is only a query form of this command available.

Query Reads and returns a comma-separated list of file names. Each file contains a cable 
type stored on the 9102.

Example :MMEMory:LOAD:FILelist:CTYPe?
String returned in this example:
"CABLE2","CABLE5"

Syntax :MMEMory[:LOAD]:FILelist:AFACtor? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent.
Default is SHORt.

Command There is only a query form of this command available.

Query Reads and returns a comma-separated list of file names. Each file contains antenna 
factor compensation stored on the 9102.
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:MMEMory[:LOAD]:FILelist:CFACtor?

:MMEMory:LOAD:STATe

:MMEMory:LOAD:TRACe

:MMEMory:LOAD:LIMit

Example :MMEMory:LOAD:FILelist:AFACtor?
String returned in this example:
"AFAC2","AFAC5"

Syntax :MMEMory[:LOAD]:FILelist:CFACtor? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent.
Default is SHORt.

Command There is only a query form of this command available.

Query Reads and returns a comma-separated list of file names. Each file contains cable fac-
tor compensation stored on the 9102.

Example :MMEMory:LOAD:FILelist:CFACtor?
String returned in this example:
"CFAC7","CFAC8"

Syntax :MMEMory:LOAD:STATe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Loads 9102 parameter settings from file string1 located in the SETTINGS directory 
on the flash disk.

Query Reads and returns the file name last loaded with this command.

Example :MMEMory:LOAD:STATe "sett3"

Syntax :MMEMory:LOAD:TRACe <string1>,<PredefExpr>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.
PredefExpr is an optional parameter and one of the following predefined expres-
sions: A|B. Default is A.

Command Loads 9102 traces from file string1 located in the TRACE directory on the flash 
disk to trace A or B.

Query Reads and returns the file name last loaded with this command.

Example :MMEMory:LOAD:TRACe "TESTTRACE2"

Syntax :MMEMory:LOAD:LIMit <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Loads 9102 limit settings from file string1 located in the LIMIT directory on the 
flash disk.
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:MMEMory:LOAD:CHANnel

:MMEMory:LOAD:EDEVice

:MMEMory:LOAD:CTYPe

:MMEMory:LOAD:AFACtor

Query Reads and returns the file name last loaded with this command.

Example :MMEMory:LOAD:LIMit "sett3"

Syntax :MMEMory:LOAD:CHANnel <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 
characters.

Command Load saved channel data from file <string1> in the CHANNEL directory on the flash 
disk.

Query Reads and returns the file name last loaded with this command.

Example :MMEMory:LOAD:CHANnel "GSM900"

Syntax :MMEMory:LOAD:EDEVice <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 
characters.

Command Loads saved channel data from file <string1> in the external device directory on the 
flash disk.

Query Reads and returns the file name last loaded with this command.

Example :MMEMory:LOAD:EDEVice "EXT_DEV2"

Syntax :MMEMory:LOAD:CTYPe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 
11 characters.

Command Loads saved cable type from file in the cable type directory on the flash disk.

Query Reads and returns the file name last loaded with this command.

Example :MMEMory:LOAD:CTYPe "RG58"

Syntax :MMEMory:LOAD:AFACtor <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 
11 characters.

Command Load saved cable factor data from file in the cable factor directory on the flash disk.

Query Reads and returns the file name last loaded with this command.

Example :MMEMory:LOAD:CFACtor "CFAC7"
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:MMEMory:LOAD:CFACtor

:MMEMory:DELete:STATe

:MMEMory:DELete:STATe:ALL

:MMEMory:DELete:TRACe

:MMEMory:DELete:TRACe:ALL

Syntax :MMEMory:LOAD:CFACtor <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 
11 characters.

Command Load saved antenna factor data from file in the antenna factor directory on the flash 
disk.

Query Reads and returns the file name last loaded with this command.

Example :MMEMory:LOAD:AFACtor "AFAC2

Syntax :MMEMory:DELete:STATe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file <string1> in the SETTINGS directory on the flash disk. Files in this 
directory usually contain parameter settings of the device.

Query Reads and returns the name of the file last deleted with this command.

Example :MMEMory:DELete:STATe "sett3"

Syntax :MMEMory:DELete:STATe:ALL

Parameters There are no parameters.

Command Deletes all the files in the SETTINGS directory on the flash disk. These files usually 
contain parameter settings of the 9102.

Query There is no query form of this command available.

Example :MMEMory:DELete:STATe:ALL 

Syntax :MMEMory:DELete:TRACe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file string1 (saved trace data and parameter settings) from the TRACE 
directory on the flash disk.

Query Reads and returns the name of the file last deleted with this command.

Example :MMEMory:DELete:TRACe "GSM900"

Syntax :MMEMory:DELete:TRACe:ALL

Parameters There are no parameters.

Command Deletes all the files in the TRACE directory on the flash disk.



Chapter 16 SCPI Command Reference
MMemory commands

9102 Handheld Spectrum Analyzer Software version 5.10 295

:MMEMory:DELete:LIMit

:MMEMory:DELete:LIMit:ALL

:MMEMory:DELete:CHANnel

:MMEMory:DELete:CHANnel:ALL

:MMEMory:DELete:EDEVice

Query There is no query form of this command available.

Example :MMEMory:DELete:TRACe:ALL

Syntax :MMEMory:DELete:LIMit <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file string1 in the LIMIT directory. Files in this directory contain limit set-
tings of the device.

Query Reads and returns the name of the file last deleted with this command.

Example :MMEMory:DELete:LIMit "lim3"

Syntax :MMEMory:DELete:LIMit:ALL

Parameters There are no parameters.

Command Deletes all the files in the LIMIT directory on the flash disk. These files contain spec-
trum limit settings of the 9102.

Query There is no query form of this command available.

Example :MMEMory:DELete:LIMit:ALL

Syntax :MMEMory:DELete:CHANnel <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file string1  from the CHANNEL directory. Files in this directory contain 
channel settings of the device.

Query Reads and returns the name of the file last deleted with this command.

Example :MMEMory:DELete:CHAN "P-GSM"

Syntax :MMEMory:DELete:CHANnel:ALL

Parameters There are no parameters.

Command Deletes all the files in the CHANNEL directory on the flash disk.

Query There is no query form of this command available.

Example :MMEMory:DELete:CHANnel:ALL

Syntax :MMEMory:DELete:EDEVice <string1>
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:MMEMory:DELete:EDEVice:ALL

:MMEMory:DELete:CTYPe

:MMEMory:DELete:CTYPe:ALL

:MMEMory:DELete:AFACtor

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file string1 in the external device directory on the flash disk. Files in this 
directory contain external device compensation settings on the 9102.

Query Reads and returns the name of the file last deleted with this command.

Example :MMEMory:DELete:EDEVice "EXT_DEV3

Syntax :MMEMory:DELete:EDEVice:ALL

Parameters There are no parameters.

Command Deletes all the files in the external device directory on the flash disk.

Query There is no query form of this command available.

Example :MMEMory:DELete:EDEVice:ALL

Syntax :MMEMory:DELete:CTYPe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file string1 in the cable type directory on the flash disk. Files in this direc-
tory contain cable type settings on the 9102.

Query Reads and returns the name of the file deleted last with this command.

Example :MMEMory:DELete:CTYPe "cable3"

Syntax :MMEMory:DELete:CTYPe:ALL

Parameters There are no parameters.

Command Deletes all the files in the cable type directory on the flash disk.

Query There is no query form of this command available.

Example :MMEMory:DELete:CTYPe:ALL 

Syntax :MMEMory:DELete:AFACtor <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file string1 in the antenna factor directory on the flash disk. Files in this 
directory contain antenna factor compensation settings on the 9102.

Query Reads and returns the name of the file deleted last with this command.

Example :MMEMory:DELete:AFACtor "AFAC2"
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:MMEMory:DELete:AFACtor:ALL

:MMEMory:DELete:CFACtor

:MMEMory:DELete:CFACtor:ALL

Instrument commands

:INSTrument:SELect

Syntax :MMEMory:DELete:AFACtor:ALL

Parameters There are no parameters.

Command Deletes all the files in the antenna factor directory on the flash disk.

Query There is no query form of this command available.

Example :MMEMory:DELete:AFACtor:ALL 

Syntax :MMEMory:DELete:CFACtor <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 
11 characters.

Command Deletes file string1 in the cable factor directory on the flash disk. Files in this 
directory contain cable factor compensation settings on the 9102.

Query Reads and returns the name of the file deleted last with this command.

Example :MMEMory:DELete:CFACtor "CFAC7"

Syntax :MMEMory:DELete:CFACtor:ALL

Parameters There are no parameters.

Command Deletes all the files in the cable factor directory on the flash disk.

Query There is no query form of this command available.

Example :MMEMory:DELete:AFACtor:ALL 

Syntax :INSTrument:SELect <PredefExpr>

Parameters PredefExpr is one of the following expressions: 
SANalyzer|CPOWer|TRANsmission|DTF|SGENerator|
RFLection|CLOSs|EMF|PSENsor.
Default is SANalyzer.

Command Selects the measurement mode. Available modes are spectrum analysis channel 
power, transmission, distance to fault, signal generator, reflection, cable loss, electro 
magnetic field and power sensor.
Selects the measurement mode. Available modes are spectrum analysis, channel 
power, transmission, distance to fault, signal generator, reflection, cable loss, electro 
magnetic field and power sensor.

Query Reads and returns the current setting.
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:INSTrument:EREFfreq

:INSTrument:GENerator

:INSTrument:GENerator:LEVel

:INSTrument:GENerator:MODe

Example :INSTrument:SELect CPOWer
:INSTrument:SELect?
Returns the following string: "CPOWer"

Syntax :INSTrument:EREFfreq <PredefExpr>

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Reads and returns whether an external reference frequency is connected or not.

Example :INSTrument:EREFfreq?
Returns the following string: "OFF"

Syntax :INSTrument:GENerator <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Switches the tracking generator on and off.

Query Reads and returns the current setting.

Example :INSTrument:GENerator ON
:INSTrument:GENerator?
Returns the following string: "ON"

Syntax :INSTrument:GENerator:LEVel <real1>

Parameters real1 is a floating point real number.
The minimum- and maximum value for real1 depend on the unit set by 
SENS:REFL:UNIT. When the unit is set to dBm, the minimum value is -100, the 
maximum value is 30. When the unit is set to dBuV, the minimum value is 7, the 
maximum value is 137. When the unit is set to dBmV, the minimum value is -53, 
the maximum value is 77. When the unit is set to dBV, the minimum value is -113, 
the maximum value is 17. The default value for real1 is 0 dBm.

Command This command sets output power of the 9102 tracking generator in the unit selected 
with the :SENS:REFL:UNIT command.

Query Reads and returns the current setting.

Example :INSTrument:GENerator:LEVel -50
:INSTrument:GENerator:LEVel?
The value returned in this example is: "-50".

Syntax :INSTrument:GENerator:MODe <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: CW|SWP.
Default is CW.
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:INSTrument:GENerator:DISPlay

:INSTrument:GPS

:INSTrument:GPS:QUALity

Command Switches the generator between continuous wave signal (CW) at a certain frequency 
and sweeping signal which sweeps from start to stop frequency. This command works 
only in SIGNAL GENERATOR mode.

Query Reads and returns the current setting.

Example :INSTrument:GENerator:MODe CW
:INSTrument:GENerator:MODe?
Returns the following string: "CW"

Syntax :INSTrument:GENerator:DISPlay <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ABSolute|RELative.
Default is ABSolute.

Command Switches the display absolute or relative to the tracking generator output power. This 
command is linked to SENSe:TRANsmission:REFerence:UNIT.

Query Reads and returns the current setting.

Example :INSTrument:GENerator:DISPlay RELative
:INSTrument:GENerator:DISPlay?
Returns the following string: "REL"

Syntax :INSTrument:GPS <PredefExp>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Switches to 9102 GPS receiving mode and sets serial port baud rate to 4800 baud if 
switched on.

Query Reads and returns the current setting.

Example :INSTrument:GPS ON
:INSTrument:GPS?
Returns the following string: "ON"

Syntax :INSTrument:GPS:QUALity?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string containing one enum value representing the quality of the received 
GPS signal: FAIL means, no data is received; WARNing means, data is received, but 
will be inaccurate; OK means, data is valid.

Example INSTrument:GPS:QUALity?
The value returned in this example is: "OK".
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:INSTrument:GPS:LATitude 

:INSTrument:GPS:LONGitude 

:INSTrument:GPS:SPEed 

:INSTrument:GPS:SPEed:UNIT 

Syntax :INSTrument:GPS:LATitude?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string containing one real value representing the latitude of the received 
GPS data. The value is in degree an in a range between -90 deg (South) and +90 deg 
(North).

Example :INSTrument:GPS:LATitude?
The value returned in this example is: -7.8323.

Syntax :INSTrument:GPS:LONGitude?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string containing one real value representing the longitude of the received 
GPS data. The value is in degree an in a range between -180 deg (East) and +180 deg 
(West).

Example :INSTrument:GPS:LONGitude?
The value returned in this example is: -137.2475.

Syntax :INSTrument:GPS:SPEed? 

Parameters PredefExpr is one of the following predefined expressions: ABSolute|RELative.
Default is ABSolute.

Command There is solely a query form of this command available.

Query Returns a string containing one real value representing the speed of the received GPS 
data. The value returned is converted to the unit selected by the 
INSTrument:GPS:SPEed:UNIT command.

Example :INSTrument:GPS:SPEed?
The value returned in this example is: 54.4.

Syntax :INSTrument:GPS:SPEed:UNIT <PredefExpr> 

Parameters PredefExpr is one of the following predefined expressions: KPH|KTS|MPH.
Default is KPH.

Command Selects the unit for GPS speed result in km/h, knots or mile per hour.

Query Reads and returns the current setting.

Example :INST:GPS:SPE:UNIT FEET
:INST:GPS:SPE:UNIT?
Returns the following string: "FEET"
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:INSTrument:GPS:TRACk 

:INSTrument:GPS:DATE 

:INSTrument:GPS:TIMe 

:INSTrument:GPS:SATellites 

:INSTrument:GPS:HDOP 

Syntax :INSTrument:GPS:TRACk? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string containing one real value representing the track (direction) of the 
received GPS data. The value is in degree an in a range between 0.0 deg (North) and 
+359.9 deg.

Example :INSTrument:GPS:TRACk?
The value returned in this example is: 272.7.

Syntax :INSTrument:GPS:DATE? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string containing three integer values representing the date 
(year,month,day) of the received GPS data.

Example :INSTrument:GPS:DATe?
The value returned in this example is: 2006,01,31.

Syntax :INSTrument:GPS:TIMe? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string containing three integer values representing the time (hour, minute, 
second) of the received GPS data.

Example :INSTrument:GPS:DATe?
The value returned in this example is: 15,54,21.

Syntax :INSTrument:GPS:SATellites? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string containing one integer value representing the number of satellites of 
the received GPS data.

Example :INSTrument:GPS:SATellites?
The value returned in this example is: 7.

Syntax :INSTrument:GPS:HDOP? 

Parameters There are no parameters.
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:INSTrument:GPS:ALTitude 

:INSTrument:GPS:ALTitude:UNIT 

:INSTrument:GPS:COORdinate:UNIT 

Command There is solely a query form of this command available.

Query Returns a string containing one real value representing the HDOP value of the 
received GPS data. This is a quality characteristic of the signal, values below 2.0 rep-
resenting a good signal.

Example :INSTrument:GPS:HDOP?
The value returned in this example is: 1.8.

Syntax :INSTrument:GPS:ALTitude? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string containing one real value representing the altitude of the received 
GPS data. The value returned is converted to unit selected by 
INSTrument:GPS:ALTitude:UNIT.

Example :INSTrument:GPS:ALTitude?
The value returned in this example is: 574.3.

Syntax :INSTrument:GPS:ALTitude:UNIT <PredefExpr> 

Parameters PredefExpr is one of the following predefined expressions: METer|FEET. 
Default is METer.

Command Selects the unit for GPS altitude result in meter or feet.

Query Reads and returns the current setting.

Example :INST:GPS:ALT:UNIT FEET
:INST:GPS:ALT:UNIT?
Returns the following string: "FEET".

Syntax :INSTrument:GPS:COORdinate:UNIT <PredefExpr> 

Parameters PredefExpr is one of the following predefined expressions: MINutes|DEGree. 
Default is MINutes.

Command Selects the unit for GPS latitude and longitude results. This setting only affects the 
manual mode; in remote mode, the results are always returned in degrees.

Query Reads and returns the current setting.

Example :INST:GPS:COORdinate:UNIT DEG
:INST:GPS:COORdinate:UNIT?
Returns the following string: "DEGR".
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Display commands
The display command subsystem affects the screen of the instrument.

:DISPlay:TRACe:Y[:SCALe][:LOGarithmic]

:DISPlay:TRACe:Y[:SCALe]:LINear:VOLT

:DISPlay:TRACe:Y[:SCALe]:LINear:WATT

Syntax :DISPlay:TRACe:Y[:SCALe][:LOGarithmic] <int1>

Parameters int1 is an integer. The minimum value for <int1> is 1, the maximum is 20. Valid 
values are 1, 2, 5, 10, 20. The default value is 10.

Command Holds the upper limit of the power scale but changes the resolution (and the lower 
limit) of the scale when int1 defines how many dB per scale unit are shown on the 
display.

Query Returns the current setting.

Example :DISPlay:TRACe:Y[:SCALe][:LOGarithmic] 20
:DISPlay:TRACe:Y[:SCALe][:LOGarithmic]?
The value returned in this example is: "20".

Syntax :DISPlay:TRACe:Y[:SCALe]:LINear:VOLT <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0.00001. The maximum value for real1 is 
1.0. The default value for real1 is 0.001.

Command This command is only in effect when 9102 is set to voltage unit. It holds the upper 
limit of the scale but changes the resolution (and the lower limit) of the voltage scale. 
real1 defines how many volts per scale unit are shown on the display. The resolu-
tion depends on which unit is set with SENSe:REFLevel:UNIT. If it set to V the 
command and query is in Volts. If it set to MV the command and query is in Milli 
Volts. If it set to UV the command and query is in Micro Volts.

Query Returns the current setting.

Example :DISPlay:TRACe:Y[:SCALe]:LINear:VOLT 0.0005
:DISPlay:TRACe:Y:[SCALe]:LINear:VOLT?
The value returned in this example is: "0.0005".

Syntax :DISPlay:TRACe:Y[:SCALe]:LINear:WATT <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0.00000000001. The maximum value for 
real1 is 0.1. The default value for real1 is 0.000001.

Command This command is only in effect when 9102 is set to Watt unit. It holds the upper limit 
of the scale but changes the resolution (and the lower limit) of the Watt scale. real1 
defines how many Watts per scale unit are shown on the display. The resolution 
depends on which unit is set with SENSe:REFLevel:UNIT. If it set to MW the 
command and query is in Milli Watts. If it set to UW the command and query is in 
Micro Watts.

Query Returns the current setting.
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:DISPlay:TRACe:Y[:SCALe]:RFLection:VSWR

:DISPlay:TRACe:Y[:SCALe]:RFLection:RFACtor

:DISPlay:TRACe:Y[:SCALe]:RFLection:RPOWer

Example :DISPlay:TRACe:Y[:SCALe]:LINear:WATT 0.0002
:DISPlay:TRACe:Y:[SCALe]:LINear:WATT?
The value returned in this example is: "0.0002".

Syntax :DISPlay:TRACe:Y[:SCALe]:RFLection:VSWR <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 1.0. The maximum value for real1 is 1000.0. 
The default value for real1 is 100.0.

Command This command is only in effect when 9102 is set to reflection mode and the unit is set 
to VSWR. It holds the upper limit of the VSWR scale but changes the resolution (and 
the lower limit) of the scale. real1 defines how many VSWR units per scale unit are 
shown on the display.

Query Returns the current setting.

Example :DISPlay:TRACe:Y[:SCALe]:RFLection:VSWR 0.5
:DISPlay:TRACe:Y:[SCALe]:RFLection:VSWR?
The value returned in this example is: "0.5".

Syntax :DISPlay:TRACe:Y[:SCALe]:RFLection:RFACtor <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 1 mRho. The maximum value for real1 is 
2000 mRho. The default value for real1 is 200 mRho.

Command This command is only in effect when 9102 is set to reflection mode and unit is set to 
reflection factor. It holds the upper limit of the reflection factor scale but changes the 
resolution (and the lower limit) of the scale. real1 defines how many mRho per 
scale unit are shown on the display.

Query Returns the current setting.

Example :DISPlay:TRACe:Y[:SCALe]:RFLection:RFACtor 100
:DISPlay:TRACe:Y:[SCALe]:RFLection:RFACtor?
The value returned in this example is: "100".

Syntax :DISPlay:TRACe:Y[:SCALe]:RFLection:RPOWer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 1.0 %. The maximum value for real1 is 
200.0 %. The default value for real1 is 20.0 %.

Command This command is only in effect when 9102 is set to reflection mode and unit is set to 
reflection power. It holds the upper limit of the reflection power scale but changes 
the resolution (and the lower limit) of the scale. real1 defines how many % per 
scale unit are shown on the display.

Query Returns the current setting.

Example :DISPlay:TRACe:Y[:SCALe]:RFLection:RPOWer 10
:DISPlay:TRACe:Y:[SCALe]:RFLection:RPOWer?
The value returned in this example is: "10".
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:DISPlay:TRACe:Y[:SCALe]:DTF:VSWR

:DISPlay:TRACe:Y[:SCALe]:DTF:RFACtor

:DISPlay:BACKlight[:BATTery]

:DISPlay:BACKlight:EXTern

Syntax :DISPlay:TRACe:Y[:SCALe]:DTF:VSWR <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 1.0. The maximum value for real1 is 1000.0. 
The default value for real1 is 100.0.

Command This command is only in effect when 9102 is set to DTF mode and the unit is set to 
VSWR. It holds the upper limit of the VSWR scale but changes the resolution (and the 
lower limit) of the scale. real1 defines how many VSWR units per scale unit are 
shown on the display.

Query Returns the current setting.

Example :DISPlay:TRACe:Y[:SCALe]:DTF:VSWR 0.5
:DISPlay:TRACe:Y:[SCALe]:DTF:VSWR?
The value returned in this example is: "0.5".

Syntax :DISPlay:TRACe:Y[:SCALe]:DTF:RFACtor <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 1 mRho. The maximum value for real1 is 
1000 mRho. The default value for real1 is 100 mRho.

Command This command is only in effect when 9102 is set to Reflection Mode and unit is set to 
Reflection Factor. It holds the upper limit of the Reflection Factor scale but changes 
the resolution (and the lower limit) of the scale. real1 defines how many mRho per 
scale unit are shown on the display.

Query Returns the current setting.

Example :DISPlay:TRACe:Y[:SCALe]:DTF:RFACtor 100
:DISPlay:TRACe:Y:[SCALe]:DTF:RFACtor?
The value returned in this example is: "100".

Syntax :DISPlay:BACKlight[:BATTery] <int1>

Parameters int1 is an integer. The minimum value for <int1> is 0, the maximum is 100. The 
default value is 50.

Command Sets the brightness of the screen in battery mode. A setting of 100 leads to the maxi-
mum brightness.

Query Returns the current setting.

Example :DISPlay:BACKlight 30
:DISPlay:BACKlight?
The value returned in this example is: "30".

Syntax :DISPlay:BACKlight:EXTern <int1>

Parameters int1 is an integer. The minimum value for <int1> is 0, the maximum is 100. The 
default value is 100.
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:DISPlay:BEEP

:DISPlay:COLor:TRACe:[A|B]

:DISPlay:COLor:TRACe:OFFSet

:DISPlay:COLor:GRATicule

Command Sets the brightness of the screen when external power supply is connected. A setting 
of 100 leads to the maximum brightness.

Query Returns the current setting.

Example :DISPlay:BACKlight:EXTern 50
:DISPlay:BACKlight:EXTern?
The value returned in this example is: "50".

Syntax :DISPlay:BEEP <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Sets the beep tone on and off.

Query Reads and returns the current setting.

Example :DISPlay:BEEP ON
:DISPlay:BEEP?
Returns the following string: "ON"

Syntax :DISPlay:COLor:TRACe:[A|B] <int1>

Parameters int1 is an integer. The minimum value for <int1> is 1, the maximum is 8. The 
default value is 1 for trace A and 3 for trace B.

Command Sets the color from the color palette for trace A or B.

Query Reads and returns the current setting.

Example :DISPlay:COLor:TRACe:A 5
:DISPlay:COLor:TRACe:A?
The value returned in this example is: "5".

Syntax :DISPlay:COLor:TRACe:OFFSet <int1>

Parameters int1 is an integer. The minimum value for <int1> is 1, the maximum is 8. The 
default value is 7.

Command Sets the color from the color palette for the trace offset for the subtracted trace 
(A-B->A trace).

Query Reads and returns the current setting.

Example :DISPlay:COLor:TRACe:OFFSet 5
:DISPlay:COLor:TRACe:OFFSet?
The value returned in this example is: "5".

Syntax :DISPlay:COLor:GRATicule <int1>

Parameters int1 is an integer. The minimum value for <int1> is 1, the maximum is 8. The 
default value is 2.
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:DISPlay:COLor:LIMits

Calculate commands
The markers of the 9102 can be set using the calculate commands.

:CALCulate:MARKer:AOFF

:CALCulate:MARKer:{A|B|C|D|E|F}[:STATe]

Command Sets the color from the color palette for the graticule.

Query Reads and returns the current setting.

Example :DISPlay:COLor:GRATicule 5
:DISPlay:COLor:GRATicule?
The value returned in this example is: "5".

Syntax :DISPlay:COLor:LIMits <int1>

Parameters int1 is an integer. The minimum value for <int1> is 1, the maximum is 8. The 
default value is 7.

Command Sets the color from the color palette for the limit lines.

Query Reads and returns the current setting.

Example :DISPlay:COLor:LIM 5
:DISP:COL:LIMits?
The value returned in this example is: "5".

Syntax :CALCulate:MARKer:AOFF

Parameters There are no parameters.

Command All markers are switched off.

Query There is no query form of this command available.

Example :CALC:MARK:A:STAT NORM
:CALC:MARK:B:STAT DELT
:CALC:MARK:C:STAT DELT
:CALC:MARK:AOFF

Syntax :CALCulate:MARKer:{A|B|C|D|E|F}[:STATe] 
<PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
OFF|NORMal|DELTa.
Default is OFF.

Command Selects an active marker and sets it to one of three different modes: 
OFF|NORMal|COUNter or OFF|NORMal|DELTa. 
OFF is used to switch off the selected marker. 
NORMal switches the selected marker on. 
DELTa changes the marker B, C or D to a delta marker; the REF marker is always A. 
Marker A cannot be set to DELTa. Only Marker A can be set to COUNter which 
switches on the frequency counter.
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:CALCulate:MARKer:{A|B|C|D|E|F}:DTF[:STATe]

:CALCulate:MARKer:{A|B|C|D|E|F}:Y?

:CALCulate:MARKer:{A|B|C|D|E|F}:X[:FREQuency]

Query The query form of this command will return the current setting. The string delivered 
back will contain the short-form version of one of the predefined expressions 
explained above.

Example :CALC:MARK:A:STAT NORM
:CALC:MARK:A:STAT?
Value returned in this example: "NORM".

Syntax :CALCulate:MARKer:{A|B|C|D|E|F}:DTF[:STATe] 
<PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
OFF|NORMal|DELTa.
Default is OFF.

Command Selects an active marker and sets it to one of three different modes: 
OFF|NORMal|COUNter or OFF|NORMal|DELTa. 
OFF is used to switch off the selected marker. 
NORMal switches the selected marker on. 
DELTa changes the marker B, C or D to a delta marker; the REF marker is always A. 
Marker A cannot be set to DELTa. Only Marker A can be set to COUNter which 
switches on the frequency counter.

Query The query form of this command will return the current setting. The string delivered 
back will contain the short-form version of one of the predefined expressions 
explained above.

Example :CALC:MARK:A:DTF NORM
:CALC:MARK:A:DTF?
Value returned in this example: "NORM".

Syntax :CALCulate:MARKer:{A|B|C|D|E|F}:Y? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query The query form of this command returns the level value at the current marker posi-
tion set by CALCulate:MARKer:{A|B|C|D|E|F}:X. The string delivered will 
contain one floating point real number with the physical dimension that has been 
selected for the reference level (:SENSe:REFLevel:UNIT).

Example :CALCulate:MARKer:B:X 2200000000
:CALCulate:MARKer:B:Y?
The value returned is: "-22.4".

Syntax :CALCulate:MARKer:{A|B|C|D|E|F}:X[:FREQuency] <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0, the maximum value 7500000000. The mini-
mum resolution possible for real1 is 1. The default value for real1 is 
1800000000.
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:CALCulate:MARKer:{A|B|C|D|E|F}:X:TIMe

:CALCulate:MARKer:{A|B|C|D|E|F}:X:DISTance

:CALCulate:{A|B|C|D|E|F}:MARKer:FSTep

Command This command sets the marker frequency for one of the six markers of the Willtek 
9102 when in spectrum analysis mode. The physical dimension of real1 is Hertz.

Query The query form of this command will return the current marker frequency setting of 
the respective marker of the Willtek 9102 (A, B, C , D, E or F). The string delivered back 
will contain one real number.

Example :CALCulate:MARKer:C:X 1500000000
:CALCulate:MARKer:C:X?
The value returned in this example is: "1500000000".

Syntax :CALCulate:MARKer:{A|B|C|D|E|F}:X:TIMe <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0.001, the maximum value 250.0. The mini-
mum resolution possible for real1 is 1. The default value for real1 is 0.0432.

Command This command sets the marker time for zero-span measurements for one of the six 
markers of the Willtek 9102. The physical dimension of real1 is seconds.

Query The query form of this command will return the current marker time setting of the 
respective marker of the Willtek 9102 (A, B, C, D, E or F). The string delivered back will 
contain one real number.

Example :CALCulate:MARKer:C:X:TIME 0.5
:CALCulate:MARKer:C:X:TIME?
The value returned in this example is: "0.5".

Syntax :CALCulate:MARKer:{A|B|C|D|E|F}:X:DISTance <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0.0, the maximum value 2000.0. The minimum 
resolution possible for real1 is 1. The default value for real1 is 0.0432.

Command This command sets the marker time for distance to fault measurements for one of the 
six markers of the Willtek 9102. The physical dimension of real1 is meter or feet, 
respectively.

Query The query form of this command will return the current DTF marker length setting of 
the respective marker of the Willtek 9102 (A, B, C, D, E or F). The string delivered back 
will contain one real number.

Example :CALCulate:MARKer:C:X:DISTance 10.5
:CALCulate:MARKer:C:X:DISTance?
The value returned in this example is: "10.5".

Syntax :CALCulate:MARKer:{A|B|C|D|E|F}:FSTep

Parameters There are no parameters.

Command Sets Marker A, B, C, D, E or F to current frequency step (FSTep).

Query There is no query form of this command available.

Example :CALCulate:MARKer:A:FSTep
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:CALCulate:MARKer:{A|B|C|D|E|F}:TSELect

:CALCulate:MARKer:MAXPeak

:CALCulate:MARKer:NPEak

:CALCulate:MARKer:MCENter

Syntax :CALCulate:MARKer:{A|B|C|D|E|F}:TSELect <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: A|B.
Default is A.

Command Selects an active marker and sets it either to trace A or trace B. Note: Set to trace B is 
only possible when trace B is active.

Query The query form of this command will return the current setting. The string delivered 
back will contain the short-form version of one of the predefined expressions 
explained above.

Example :CALC:MARK:A:TSELect B
:CALC:MARK:A:TSELect?
Value returned in this example: "B".

Syntax :CALCulate:MARKer:MAXPeak

Parameters There are no parameters.

Command Sets the currently selected marker to the maximum measured level. A marker is 
"selected" by way of the :CALCulate:MARKer:{A|B|C|D|E|F}[:STATe] 
command.

Query There is no query form of this command available.

Example :CALCulate:MARKer:MAXPeak.

Syntax :CALCulate:MARKer:NPEak

Parameters There are no parameters.

Command Sets the currently selected marker to the next highest level value.

Query There is no query form of this command available.

Example :CALCulate:MARKer:NPEak.

Syntax :CALCulate:MARKer:MCENter

Parameters There are no parameters.

Command The center frequency is changed to the current marker frequency.

Query There is no query form of this command available.

Example :CALCulate:MARKer:MCENter.
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:CALCulate:MARKer:MREFlevel

:CALCulate:MARKer:FCOunt?

:CALCulate:MARKer:FCOunt:RESolution

:CALCulate:LIMit[:STATe]

Syntax :CALCulate:MARKer:MREFlevel

Parameters There are no parameters.

Command The REFerence level is changed to the level at the marker position.

Query There is no query form of this command available.

Example :CALCulate:MARKer:MREFlevel.

Syntax :CALCulate:MARKer:FCOunt?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string with the floating point value for the current result of the frequency 
counter, in Hz. Marker M1 (CALC:MARK:A COUNter) has to be set before to get 
a valid result.

Example :CALCulate:MARKer:FCOunt?
The value returned in this example is: "2694365000.0".

Syntax :CALCulate:MARKer:FCOunt:RESolution <real1>

Parameters real1 is an integer. The minimum value for <real1> is 1, the maximum is 1000. 
Valid values are 1, 10, 100, 1000. The default value is 1000.

Command Sets the counter resolution of the frequency counter in Hz.

Query Reads and returns the current setting.

Example :CALC:MARK:FCO:RES 10
:CALC:MARK:FCO:RES?
The value returned in this example is: "10".

Syntax :CALCulate::LIMit[:STATe] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
OFF|UPPer|LOWer|UPPLow.
Default is OFF.

Command Selects the limit lines to one of four different modes: 
OFF|UPPer|LOWer|UPPLow.
OFF is used to switch off the limit lines.
UPPer switches only the upper limit line on.
LOWer switches only the lower limit line on.
UPPLow switches both upper and lower limit lines on.

Query The query form of this command will return the current setting. The string delivered 
back will contain the short-form version of one of the predefined expressions 
explained above.
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:CALCulate:LIMit:FCOunt

:CALCulate:LIMit:FCOunt:COUNt?

:CALCulate:LIMit:FBEep

:CALCulate:LIMit:FHOLd

Example CALC:LIM:STAT UPPLOW
:CALC:LIM?
Value returned in this example: "UPPL".

Syntax :CALCulate:LIMit:FCOunt <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Enables (and resets) or disables the failure counter. When enabled, requires that limit 
checking is also  active (see CALC:LIM:STAT).

Query Reads and returns the current setting.

Example :CALCulate:LIMit:FCOunt ON
:CALCulate:LIMit:FCOunt?
Returns the following string: "ON"

Syntax :CALCulate:LIMit:FCOunt:COUNt?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Gets the current count of fails in the limit check.

Example :CALCulate:LIMit:FCOunt:COUNt?
The value returned in this example is: "5".

Syntax :CALCulate:LIMit:FBEep <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Enables or disables a sound that can be output each time a measurement fails the 
limits.

Query Reads and returns the current setting.

Example :CALC:LIMit:FBEep ON
:CALCulate:LIMit:FBEep?
Returns the following string: "ON".

Syntax :CALCulate:LIMit:FHOLd <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Enables or disables hold, if measurement fails the limits.

Query Reads and returns the current setting.
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:CALCulate:LIMit:SIMPle

:CALCulate:LIMit:SIMPle:UPPer

:CALCulate:LIMit:SIMPle:LOWer

:CALCulate:MEASure:ACPR

Example :CALCulate:LIMit:FHOLd ON
:CALCulate:LIMit:FHOLd?
Returns the following string: "ON".

Syntax :CALCulate:LIMit:SIMPle <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Enables or disables the simple limit lines.

Query Reads and returns the current setting.

Example :CALCulate:LIMit:SIMPle ON
:CALCulate:LIMit:SIMPle?
Returns the following string: "ON". 

Syntax :CALCulate:LIMit:SIMPle:UPPer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0.0, the maximum value 8.0. The minimum reso-
lution possible for real1 is 0.1. The default value for real1 is 7.0.

Command Sets the simple upper limit line. The unit is one grid. 0.0 means the lower border of 
the visible display and 8.0 means the upper border.

Query Reads and returns the current setting.

Example :CALCulate:LIMit:SIMPle:UPPer 6
:CALCulate:LIMit:SIMPle:UPPer?
The value returned in this example is: "6.0".

Syntax :CALCulate:LIMit:SIMPle:LOWer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0.0, the maximum value 8.0. The minimum res-
olution possible for real1 is 0.1. The default value for real1 is 1.0.

Command Sets the simple lower limit line. The unit is one grid. 0.0 means the lower border of 
the visible display and 8.0 means the upper border.

Query Reads and returns the current setting.

Example :CALCulate:LIMit:SIMPle:LOWer 2
:CALCulate:LIMit:SIMPle:LOWer?
The value returned in this example is: "2.0".

Syntax :CALCulate:MEASure:ACPR?

Parameters There are no parameters.

Command There is solely a query form of this command available.
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:CALCulate:MEASure:OBW

:CALCulate:MEASure:CPOWer

:CALCulate:MEASure:ACLoss

:CALCulate:MEASure:EMF

Query Returns a string containing three floating point values; these represent the relative 
power in the lower adjacent channel (in dB), the in-channel power (in dBm) and the 
relative power in the upper adjacent channel (in dB).

Example :CALCulate:MEASure:ACPR?
The value returned in this example is: "-14.9,-31.5,-14.1".

Syntax :CALCulate:MEASure:OBW?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string with the floating point value for the occupied bandwidth, in Hz.

Example :CALCulate:MEASure:OBW?
The value returned in this example is: "2694000.0".

Syntax :CALCulate:MEASure:CPOWer?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the measured in-channel power, in dBm.

Example :CALCulate:MEASure:CPOW?
Returns the following string: "-32.2". 

NOTE

The :CALCulate:MEASure:CPOWer? command only returns a valid mea-
surement result after a complete sweep has been made. Should the channel 
power be determined before the sweep is complete, the value -9999 will be 
returned. This value will also be returned, if the channel system settings 
defined cause an invalid measurement result. The value -9999 always indi-
cates an invalid measurement value.

Syntax :CALCulate:MEASure:ACLoss?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the average cable loss, in dB. This query returns valid results only in Cable 
Loss mode.

Example :CALCulate:MEASure:ACLoss?
The value returned in this example is: "-22.5".

Syntax :CALCulate:MEASure:EMF? 
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:CALCulate:MEASure:PSENsor[:ALL]?

:CALCulate:MEASure:PSENsor:FPOWer?

:CALCulate:MEASure:PSENsor:RPOWer?

Parameters There are no parameters.

Command There is solely a query form of this command available

Query Returns the EMF measurement value. The result depends on the setting of the  
:SENSe:EMF:MEASure:DISPlay command. If it is set to EFSTrength 
(electric field strength) the unit for the result is Volt/meter. If it is set to PDENsity 
(power density) the unit for the result is Watt/squaremeter. This query only returns 
valid results in EMF mode.

Example :CALCulate:MEASure:EMF?
The value returned in this example is: "0.103352".

Syntax :CALCulate:MEASure:PSENsor[:ALL]? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the power sensor measurement values. The first result represent the forward 
power, the second result represent the reverse power. The results depends on the set-
ting :SENSe:PSENSor:UNIT command. If it is set to DBM the unit for the result 
is dBm. If it is set to W the unit for the result is Watt. This query returns valid results 
only in power sensor mode.

Example :CALCulate:MEASure:PSENsor?
The value returned in this example is: "20.1,18.5".

Syntax :CALCulate:MEASure:PSENsor:FPOWer? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the power sensor measurement value for the forward power. The result 
depends on the setting :SENSe:PSENSor:UNIT command. If it is set to DBM the 
unit for the result is dBm. If it is set to W the unit for the result is Watt. This query 
returns valid results only in power sensor mode.

Example :CALCulate:MEASure:PSENsor:FPOWer?
The value returned in this example is: "20.1".

Syntax :CALCulate:MEASure:PSENsor:RPOWer? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the power sensor measurement value for the reverse power. The result 
depends on the setting :SENSe:PSENSor:UNIT command. If it is set to DBM the 
unit for the result is dBm. If it is set to W the unit for the result is Watt. This query 
returns valid results only in power sensor mode.

Example :CALCulate:MEASure:PSENsor:RPOWer?
The value returned in this example is: "20.1".
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Format commands
These commands are used for formatting the SCPI output of the 9102 Handheld 
Spectrum Analyzer.

:FORMat:ADELimiter

:FORMat:RESolution

Service commands
These commands are used for information regarding the status of the 9102.

:SERVice:BOOTversion?

Syntax :FORMat:ADELimiter <PredefExp>

Parameters PredefExp is one of the following predefined expressions: 
COMMa|COLOn|SEMIcolon.
Default is COMMa.

Command Selects the delimiter to be used to separate parameters in SCPI commands, and also 
to separate the individual measurement result values in a result return string.
COMMa stands for commas (default),
COLOn sets the delimiter to be a colon (:), while
SEMIcolon will use and expect a semicolon (;) to be used.

Query Reads and returns the current setting.

Example :FORM:ADEL
Defines the comma to be used as delimiter for both commands and measurement 
results.

Syntax :FORMat:RESolution <int1>

Parameters int1 is an integer. The minimum value for <int1> is 0, the maximum is 20. The 
default value is 6.

Command Defines the number of digits after the decimal point to be used for floating point real 
figures.

Query Reads and returns the current setting.

Example :FORM:RES 0
Defines that there will be no digits after the decimal point.

Syntax :SERVice:BOOTversion?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the version of the boot software of your Willtek 9102. The com-
mand will return a string.

Example :SERVice:BOOTversion?
String returned in this example: "2.00".
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:SERVice:BOOTversion:DATe?

:SERVice:BATTery

:SERVice:BATTery:SERialnumber?

:SERVice:POWerline?

:SERVice:CHECk:LAST

Syntax :SERVice:BOOTversion:DATe?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the date of the Boot Software of your Willtek 9102. The command 
will return a string.

Example :SERVice:BOOTversion:DATe?
String returned in this example: "2004/10/22".

Syntax :SERVice:BATTery?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the the current loading state of the battery in %. The command 
will return an integer.

Example :SERVice:BATTery?
String returned in this example: "40".

Syntax :SERVice:BATTery:SERialnumber?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the serial number of the battery of your Willtek 9102. The com-
mand will return a string.

Example :SERVice:BATTery:SERialnumber?
String returned in this example: "00300402".

Syntax :SERVice:POWerline?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Returns ON, if the Willtek 9102 is connected to the 12 V power line, otherwise returns 
OFF.

Example :SERV:POW?
String returned in this example: "OFF".

Syntax :SERVice:CHECk:LAST <int1>,<int2>,<int3>,<string>
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:SERVice:CHECk:NEXT

:SERVice:DEVice:TYPe?

:SERVice:DEVice:TEXT?

Parameters intx are three integers. 
The minimum value for int1 is 1998, the maximum is 2100. The default value is 
1998.
The minimum value for int2 is 1, the maximum is 12. The default value is 1.
The minimum value for int3 is 1, the maximum is 31. The default value is 1.
string is a string (text) parameter. The maximum length of string1 is 16 char-
acters.

Command Sets date and name of the last check of this device.

Query Reads and returns current settings. The command will return 3 integers and a string.

Example :SERVice:CHECk:LAST?
String returned in this example: 2004,04,01,"John Williams".

Syntax :SERVice:CHECk:NEXT?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the date of the next check to be performed on this device. The 
command will return 3 integers.

Example :SERVice:CHECk:NEXT?
String returned in this example: 2005,04,01.

Syntax :SERVice:DEVice:TYPe?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the type of your Willtek 9102. The command will return a string.

Example :SERVice:DEVice:TYPe?
String returned in this example: "9102".

Syntax :SERVice:DEVice:TEXT?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the description text of your Willtek 9102. The command will return 
a string.

Example :SERVice:DEVice:TEXT?
String returned in this example:
"Willtek 9102 Handheld Spectrum Analyzer".
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:SERVice:DEVice:CALibration:NUMBer?

:SERVice:EDEVice:SERialnumber?

:SERVice:EDEVice:TYPe?

:SERVice:EDEVice:TEXT?

Syntax :SERVice:DEVice:CALibration:NUMBer?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the calibration number of your Willtek 9102. The command will 
return a string.

Example :SERVice:DEVice:CALibration:NUMBer?
String returned in this example: "1234".

Syntax :SERVice:EDEVice:SERialnumber?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the serial number of the external device connected to your Willtek 
9102. The command will return a string.

Example :SERVice:EDEVice:SERialnumber?
String returned in this example: "00100202".

Syntax :SERVice:EDEVice:TYPe?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the type of the external device connected to your Willtek 9102. The 
command will return a string.

Example :SERVice:EDEVice:TYPe?
Let’s assume that the 9168 GPS Receiver Option is connected to your 9102. String 
returned in this example: "9168".

Syntax :SERVice:EDEVice:TEXT? 

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the description text of the external device connected to your 
Willtek 9102. The command will return a string.

Example :SERVice:EDEVice:TEXT?
String returned in this example: "VSWR Bridge".
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:SERVice:EDEVice:CALibration:DATe?

:SERVice:EDEVice:CALibration:NUMBer?

SCPI errors
The following table from MKS, scpi/inc/scpierrs.h lists the error numbers which 
the 9102 may return in case of a problem.

Syntax :SERVice:EDEVice:CALibration:DATe?

Parameters There are no parameters.

Command The command form is not available.

Query Returns date of last calibration by Willtek of the external device connected in the 
form yyyy,mm,dd.

Example :SERVice:EDEVice:CALibration:DATe?
String returned in this example: "2004/12/31".

Syntax :SERVice:EDEVice:CALibration:NUMBer?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Reads and returns the calibration number of the external device connected to your 
Willtek 9102. The command will return a string.

Example :SERVice:EDEVice:CALibration:NUMBer?
String returned in this example: "1234".

Error 
number

Error description

Command errors

-100 Internal error only, for debugging purposes (Command error)

-101 Invalid character in command string

-102 SCPI syntax error: Command is not available as a query, or vice 
versa

-103 Invalid separator between parameters

-104 Data type error (mismatch between parameters and allowable 
data formats)

-108 Parameter not allowed (too many parameters)

-109 Missing parameter (too few parameters)

-111 Header separator error (probably colon missing between com-
mand keywords)

-112 Program mnemonic too long (i.e. longer than 12 characters)
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-113 Keyword not found in command list

-114 Header suffix out of range (invalid character in command key-
word)

-121 Invalid character in number (not a digit, or exponent value 
missing)

-123 Exponent out of range

-128 Numerical data not allowed

-131 Invalid suffix (appended unit not found)

-134 Suffix too long (appended unit is longer than 12 characters)

-138 Suffix not allowed (parameter type is not real)

-141 Invalid character data (parameter expression is not in pre-
defined list)

-144 Character data too long (string data longer than allowed)

-158 String data not allowed for this parameter type

-160 Internal error only, for debugging purposes (block data error)

-168 Internal error only, for debugging purposes (block data not 
allowed)

Execution errors

-201 Internal error only, for debugging purposes (SCPI execution 
function not defined)

-202 Internal error only, for debugging purposes (SCPI query function 
not defined)

-210 Internal error only, for debugging purposes (out of memory)

-222 Data out of range

-230 Internal error only, for debugging purposes (invalid token 
received by EXEC)

-231 Internal error only, for debugging purposes (invalid index for 
parameter)

-232 Internal error only, for debugging purposes (invalid parameter)

-233 Internal error only, for debugging purposes (parameter has 
wrong type)

-234 Internal error only, for debugging purposes (parameter missing)

-235 Internal error only, for debugging purposes (index error)

-236 Parameter out of range

-260 File name not found in defined directory

-261 File creation failed in defined directory

-262 Internal error only, for debugging purposes (label not found, 
config file)
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-264 Error while saving or recalling trace file

Device-dependent errors

-300 SYSTEM_ERROR

-310 Internal error only, for debugging purposes (error no. not found)

-311 Internal error only, for debugging purposes (function not yet 
supported)

-319 Error queue overflow (more than 10 entries)

-320 Wrong password

-321 Internal error only, for debugging purposes (serial number error)

-322 Wrong option key

-323 Option not available

-330 Download command error

-331 Upload command error

Query errors

-400 Checkrule conflict, parameters outside limits

-401 Internal error only, for debugging purposes (EPROM write error)

-402 Internal error only, for debugging purposes (EPROM read error)

-410 Result not valid
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Chapter 17 Programming Examples

This chapter provides examples how to use the SCPI commands to set up and 
control the 9102 Handheld Spectrum Analyzer.

– “Overview” on page 324

– “Command examples” on page 324

– “Application examples” on page 332
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Overview
This chapter describes how to control the 9102 from a personal computer via a 
serial or LAN connection. It explains the basic commands for the 9102 Handheld 
Spectrum Analyzer and describes a few typical applications together with the 
SCPI command sequence.

This documents does not show every command possible. It is assumed that the 
user has some basic knowledge about remote control and also some experience 
in the use of a spectrum analyzer.

Command examples

Introduction The whole command set can be divided into three categories: settings, measure-
ments and others. Each category is descriped in a separate section.

The word <val> stands for a numerical value.

The word <enum> is a placeholder for a string.

Prerequisites

Over serial interface The 9102 must be powered on. A serial cable (null modem cable with crossed 
lines) must connect the 9102 with the PC. The interface settings should be set to 
57600 bps, 8 bits per character, no parity, 1 stop bit.

Over LAN interface The 9102 must be powered on. A crosspatch LAN cable must connect the 9102 
with the PC, or a normal LAN cable must connect the 9102 to a local area 
network. The 9102 must be programmed with its own IP address.

Settings Please note that the 9102 always tries to execute the commands. However, under 
some circumstances, the 9102 must adjust or change other settings. If this 
happens, please check all previous settings and try to resolve this conflict.

Center frequency SENSe:FREQuency:CENTer <val>

Sets the center frequency in Hz.
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Examples:

Long format:
SENSE:FREQUENCY:CENTER 96500000

Center frequency set to 96.5 MHz

Short format:
SENS:FREQ:CENT 96.5E06 Center programmed to 96.5 MHz

Span SENSe:FREQuency:SPAN <val> Sets the span (dimension Hz)

Examples:

Long format:
SENSE:FREQUENCY:SPAN 20000000 Span programmed to 20 MHz

Short format:
SENS:FREQ:SPAN 20E06 Span programmed to 20 MHz

SENS:FREQ:SPAN:FULL Full span programmed

SENS:FREQ:SPAN 0 Zero span activated

Resolution bandwidth SENSe:BANDwidth:RESolution <val>
Sets the resolution bandwidth (dim. Hz)

Valid values for <val>: 10 kHz, 30 kHz, 100 kHz, 300 kHz or 1 MHz. 

Examples:

Long format:
SENSE:BANDWIDTH:RESOLUTION 30000 Resolution set to 30 kHz

Short format:
SENS:BAND:RES 30E03 Resolution set to 30 kHz

SENS:BAND:RES:AUTO ON Automatic selection active

Video bandwidth SENSe:BANDwidth:VIDeo <val> Sets the video bandwidth (dim. Hz)

Valid values for <val>: 100, 300 Hz. 1, 3, 10, 30, 100, 300 kHz or 1 MHz. 

Examples:

Long format:
SENSE:BANDWIDTH:VIDEO 300000 Video set to 300 kHz

Short format:
SENS:BAND:VID 10E03 Video set to 10 kHz

SENS:BAND:VID:AUTO ON Automatic selection active
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Sweep time SENSe:SWEep:TIME <val> Sets the sweep time (dimension ms)

Valid values for <val>: 1, 2, 5, 10, 20, 50, 100, 200 or 500 ms; 1, 2, 5, 10 or 20 s. 

Examples:

Long format:
SENSE:SWEEP:TIME 200 Sweep time set to 200 ms

Short format:
SENS:SWE:TIME 10 Sweep time set to 10 ms

SENS:SWE:TIME:AUTO ON Automatic selection active

Reference level SENSe:RFLevel <val> Defines the reference level (in dBm)

Examples:

Long format:
SENSE:RFLEVEL -30.0 Reference level set to -30.0 dBm

Short format
SENS:RFL 10 Reference level set to +10 dBm

Scale DISPlay:TRACe:Y <val> Defines scale per div. (in dB)

Examples:

Long format:
DISPLAY:TRACE:Y 10 Scale set to 10 dB per division

Short format:
DISPL:TRAC:Y 20 Scale set to 20 dB per div.

Input attenuation INPut:ATTenuation <val> Sets the input attenuation (in dB)

Valid input attenuation values: 0, 10, 20, 30, 40 or 50 dB. 

Examples:

Long format:
INPUT:ATTENUATION 10 10 dB attenuation

Short format:
INP:ATT 20 20 dB attenuation

WARNING

Be careful with 0 dB. This value may damage the unit if the actual power is 
too high.
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Detector SENSe:DETector:FUNCtion <enum>
Sets the behavior of the detector

Valid entries for <val>: POSNeg, SAMPle, POSitive or NEGative. 

Examples:

Long format:
SENSE:DETECTOR:FUNCTION POSITIVE Positive sampling

Short format:
SENS:DET:FUNC NEG Negative sampling

Trace SENSe:TRACe:<x> <enum> Sets the trace behavior for trace A or B

<x> is the trace (A or B)

Valid entries for <enum> are: ACTual, MAXHold, MINHold, HOLD, AVG or OFF. 

Examples:

Long format:
SENSE:TRACE:A ACTUAL Normal trace for A

Short format:
SENS:TRAC:B AVG Average trace for B

Marker CALCulate:MARKer:<x>:X <val> Sets the marker frequency (in Hz)

<x> is the trace (A to D)

Examples:

Long format:
CALCULATE:MARKER:B:X 98500000 Marker B set to 98.5 MHz

Short format:
CALC:MARK:A:X 1.2E09 Marker A set to 1.2 GHz

CALC:MARK:AOFF All markers disabled

CALC:MARK:C:OFF Only marker C disabled

CALC:MARK:MAXP Selected marker set to MaxPeak

CALC:MARK:NPE Selected marker set to NextPeak
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Measurements

Trace SENSe:TRACe:<x>:FETCh? <enum>
Reads the trace data in a definable format

<x> is the trace (A or B)

Valid entries for <enum>: ALL, MIN, MAX, FREQ, FMIN or FMAX. 

Examples:

Long format:
SENSE:TRACE:A:FETCH? ALL All measured data requested

Short format:
SENS:TRAC:B:FETC? MAX Trace B (only MAX) requested

Format examples:

ALL: <min level>, <max level>, <freq>, <min level>, …

MAX: <max level>, <max level>, ….

MIN: <min level>, <min level>, ….

FREQ: <freq>, <freq>, ….

FMAX: <max level>, <freq>, <max level>, <freq>, <max level>, ….

FMIN: <min level>, <freq>, <min level>, <freq>, <min level>, ….

Sweep SENSe:SWEep:STATe <enum> Controls the sweep

Valid entries for <enum>: CONTinuous, SINGle or HOLD

Examples:

Long format:
SENSE:SWEEP:STATE SINGLE One sweep performed

Short format:
SENS:SWE:STAT CONT Repetitive sweeps started

NOTE

One trace contains 500 samples.
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Max Peak CALCulate:MARKer:MAXPeak Sets the marker to the maximum peak

Examples:

Long format:
CALCULATE:MARKER:MAXPEAK Marker set to max. peak

Short format:
CALC:MARK:MAXP Marker set to max. peak

Next Peak CALCulate:MARKer:NPEak Sets the marker to the next highest peak

Examples:

Long format:
CALCULATE:MARKER:NPEAK  Marker set to the next peak

Short format:
CALC:MARK:NPE Marker set to the next peak

Marker level CALCulate:MARKer:<x>:Y?Reads the level at the actual marker position

<x> selects the trace (A to D)

Examples:

Long format:
CALCULATE:MARKER:B:Y?  Marker B level requested

Short format:
CALC:MARK:A:Y? Marker A level requested

Marker frequency CALCulate:MARKer:<x>:X? Reads the actual marker frequency

<x> selects the trace (A to D)

Examples:

Long format:
CALCULATE:MARKER:B:X?  Marker B frequency requested

NOTE

A marker must be activated first using the following command:
CALC:MARKer:<x>[:STATE] {NORMal|DELTa|NOISe}.

NOTE

A marker must be activated first using the following command:
CALC:MARKer:<x>[:STATE] {NORMal|DELTa|NOISe}.
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Short format:
CALC:MARK:A:X? Marker A frequency requested

Others

Identity *IDN? Reads serial number of the instrument

Format returned: "<Manufacturer>, <Model>, <Serial number>, 
<Software version>"

Manufacturer: Willtek

Model: 9102

Serial number: (seven digits)

Software version:  2.00 (for example)

Reset *RST Resets the unit

Example:

*RST Unit set to idle state

Error queue SYST:ERR? Queries the error queue

Format returned: <Error number>, "<Error description>"

If no error is present, 0,"No Error" is returned.

Echo SYST:COMM:ECHO <enum> Enables/disables echo function

Range: ON or OFF.

Example:

SYST:COMM:ECHO ON Echo feature activated

The additional advantage of this is to create a kind of handshake mechanism.

NOTE

The error queue can hold up to 10 error messages. Read always until the NO 
ERROR is given back.

NOTE

We recommend to always activate the echo. It gives back "OK" after a com-
mand was successfully executed or in case of errors "ERR".
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Local mode SYST:COMM:LOCAL Switches unit back to local mode

Example:

SYST:COMM:LOCAL Remote session finished
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Application examples
The application examples below use three subroutines which transmit a 
command (Output9100), read a result (Input9100) or send a command and read 
the acknowledgement (OutAck9100). These subroutines are not printed here but 
available from Willtek on request. The program examples are written in BASIC.

Signal monitoring Task: Permanently monitor a signal and check, if it is still present. The signal 
frequency is 97.3 MHz and the signal strength is around -40 dBm. 

OutAck9100 ("SENS:FREQ:CENT 97300000") ' set the center to the frequency 
OutAck9100 ("SENS:FREQ:SPAN 2E06") ' set span to 2 MHz

OutAck9100 ("SENS:REFL -30") ' set a sensitive ref level
OutAck9100 ("INP:ATT 10") ' set a low attenuation
OutAck9100 ("SENS:TRAC:A ACT") ' activate an normal trace
OutAck9100 ("SENS:DET:FUNC POS") ' use only positive samples

OutAck9100 ("CALC:MARK:AOFF") ' switch all markers off
OutAck9100 ("CALC:MARK:A NORM") ' activate marker A
SIG_FLAG = True

While SIG_FLAG = True
   OutAck9100 ("SENS:SWE:STAT SING") ' do one measurement

   OutAck9100 ("CALC:MARK:A:X 97.3E06") ' set marker to the signal

   Output9100 ("CALC:MARK:A:Y?") ' read the signal level
   Lvl  = Val(Input9100())

   If Lvl < -45 Then SIG_FLAG = False ' signal lost
Wend 

Print "Signal disappeared!!!"
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Signal search Task: Search for transmitters within a frequency band. If a signal is present and 
higher than a level of -80 dBm, the frequency is printed.

OutAck9100 ("SENS:FREQ:SPAN 2000000") ' set span to 2 MHz
OutAck9100 ("SENS:FREQ:CENT 936000000") ' start with channel 0

OutAck9100 ("SENS:REFL -40") ' set a sensitive ref-level
OutAck9100 ("INP:ATT 0") ' remove any attenuation !!
OutAck9100 ("SENS:TRAC:A MAXH") ' activate a max hold trace
OutAck9100 ("SENS:DET:FUNC POS") ' use only positive samples

OutAck9100 ("CALC:MARK:AOFF") ' switch all markers off

channel = 1
For I = 9360 To 9594 Step 18 ' scan the gsm band in small portions
    Msg$ = "SENS:FREQ:CENT" & Str$(I) & "00000"
    OutAck9100 (Msg$) ' set frequeny
   
    For J = 0 To 4
        OutAck9100 ("SENS:SWE:STAT SING") ' do the measurements 5 times
    Next J

    Output9100 ("SENS:TRAC:A:FETC? MAX")
    MXdata$ = Input9100() ' read trace data
    
    For J = 0 To 499  ' isolate the data into an array
        P = InStr(MXdata$, ",") ' search for the COMMA between two values
        Yfeld(J) = Val(Mid$(MXdata$, 1, P))
        MXdata$ = Right$(MXdata$, Len(MXdata$) - P)

' remove the actual value
    Next J

    For J = 45 To 445 Step 50
        P = -120
        For K = 0 To 8 ' do a maximum search
            If Yfeld(J + K) > P Then
                P = Yfeld(J + K) ' store the new maximum
            End If
        Next K

        If P > -80 And channel < 125 Then  ' blocked channel found
            Print "Channel " & Str$(channel) & " = " & Str$(P) & " dBm."
        End If
        channel = channel + 1
    Next J
Next I
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Appendix A Index of SCPI Commands

*CAL . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 247
*CLS . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 247
*ESE . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 249
*ESR . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 249
*IDN . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 247
*OPC  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 248
*OPT . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 247
*RST . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 248
*SRE . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 250
*STB . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 250
*WAI  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 248
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Appendix B Predefined Settings

This appendix provides an overview on settings and parameters predefined on the 
9102 as well as in the 9100 Data Exchange Software for your convenience. The 
topics discussed in this appendix are as follows:

– “Predefined measurement settings” on page 342

– “Predefined channel power communication systems” on page 343

– “Predefined cable types” on page 346
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Predefined measurement settings
The 9102 provides the capability of storing all parameters for a particular 
measurement for reuse when repeating the measurement under the same condi-
tions. In the 9100 Data Exchange Software delivered with your instrument a 
number of predefined settings for common measurements are available. For 
details on working with these settings refer to “Working with settings” on 
page 239.

The following table provides an overview on the settings available within the 
9100 Data Exchange Software. The names for the predefined settings files have 
prefixes assigned to them indicating the measurement modes used for 
performing the individual measurements:

– SP for spectrum analysis mode

– CH for channel power mode

– SG for signal generator mode

– TR for transmission mode

– RFL for reflection mode

– DTF for distance to fault mode

– CL for cable loss mode

– EMF for EMF (EMI) mode

Table 1 Predefined measurement settings 

Name Meaning Frequency range

SP-UKW Ultra short wave 87.5 to 108 MHz

SP-DAB I Digital audio broadcast band I 223 to 230 MHz

SP-DAB II Digital audio broadcast band II 1452 to 1479.5 MHz

SP-VHF I Very high frequency TV band I 47 to 68 MHz

SP-VHF III Very high frequency TV band III 174 to 230 MHz

SP-UHF IV Ultra high frequency TV 
band IV

470 to 606 MHz

SP-UHF V Ultra high frequency TV band V 606 to 862 MHz

SP-LNB SAT-ZF 950 to 2050 MHz

RFL-GSM900 GSM 900 frequency range 875 to 965 MHz

RFL-GSM1800 GSM 1800 frequency range 1700 to 1890 MHz

RFL-UMTS UMTS band I frequency range 1890 to 2200 MHz
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Predefined channel power communication systems
Measurements in channel power mode imply that a communication system with 
predefined channel numbers and associated frequencies has been defined. The 
9102 comes with a few systems preinstalled. More systems are available for 
download to the 9102 in the 9100 Data Exchange Software. The following two 
sections provide you with an overview on the communication systems prein-
stalled on your 9102 as well as on the systems available in the 9100 Data 
Exchange Software. 

Preinstalled systems on
the 9102

The following table lists all communication systems preinstalled as a default on 
your 9102. For details on working with the preinstalled systems refer to “Working 
with communication systems and frequency settings” on page 81.

Table 2 Default preinstalled channel power systems 

System name Meaning Frequency range
Channel 
numbers

(n)
Center frequencies (fc)

Channel 
width

DECT 1880 to 1900 MHz 0 to 9 fc = 1897.344 - n*1.728 1728 kHz

PGSM900-DL Primary GSM 
Downlink

935 to 960 MHz 1 to 124 fc = 935 + 0.2*n 200 kHz

RGSM900-DL Railways GSM 
Downlink

921 to 960 MHz 955 to 
1023

fc = 935 + 0.2*(n-1024) 200 kHz

PCN1800-DL GSM 1800 
Downlink

1805 to 1880 MHz 512 to 885 fc = 1805.2 + 0.2*(n-512) 200 kHz

PCS1900-DL GSM 1900 
Downlink

1930 to 1990 MHz 512 to 810 fc = 1930.2 + 0.2*(n-512) 200 kHz

WCDMA-DL UTRA-FDD 
Downlink

2110 to 2170 MHz 10562 to 
10838

fc = n / 5 5 MHz

WCDMA-UL UTRA-FDD 
Uplink

1920 to 1980 MHz 9612 to 
9888

fc = n / 5 5 MHz

WLAN IEEE 
802.11b,g

2400 to 2484 MHz 1 to 13 fc = 2412 + (n-1)*5 22 MHz
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Predefined systems in the
9100 Data Exchange

Software

The following table lists all further communication systems available in the 9100 
Data Exchange Software for download to the 9102. For details on using these 
systems refer to “Managing communication systems for channel power measure-
ments” on page 233. 

Table 3 9100 Data Exchange Software channel power systems 

System name Meaning Frequency range
Channel 
numbers

(n)
Center frequencies (fc)

Channel 
width

GSM450-UL GSM 450 
Uplink

450.4 to 
457.6 MHz

259 to 293 fc = 450.6 + 0.2*(n - 259) 200 kHz

GSM450-DL GSM 450 
Downlink

460.4 to 
467.6 MHz

259 to 293 fc = 460.6 + 0.2*(n - 259) 200 kHz

GSM480-UL GSM 480 
Uplink

478.8 to 468 MHz 306 to 340 fc = 479 + 0.2*(n - 306) 200 kHz

GSM480-DL GSM 480 
Downlink

488.8 to 496 MHz 306 to 340 fc = 489 + 0.2*(n - 306) 200 kHz

GSM850-UL GSM 850 
Uplink

824 to 849 MHz 128 to 251 fc = 824.2 + 0.2*(n - 128) 200 kHz

GSM850-DL GSM 850 
Downlink

869 to 894 MHz 128 to 251 fc = 869.2 + 0.2*(n - 128) 200 kHz

EGSM900-UL Extended 
GSM Uplink

880 to 915 MHz 975 to 
1023

fc = 890 + 0.2*(n - 1024) 200 kHz

EGSM900-DL Extended 
GSM Down-
link

925 to 960 MHz 975 to 
1023

fc = 935 + 0.2*(n - 1024) 200 kHz

PGSM900-UL Primary 
GSM  Uplink

890 to 915 MHz 1 to 124 fc = 890 + 0.2*n 200 kHz

RGSM900-UL Railways 
GSM Uplink

876 to 915 MHz 955 to 
1023

fc = 890 + 0.2*(n - 1024) 200 kHz

PCN1800-UL GSM 1800 
Uplink

1710 to 1785 MHz 512 to 885 fc = 1710.2 + 0.2*
(n -512)

200 kHz

PCS1900-UL GSM 1900 
Uplink

1850 to 1910 MHz 512 to 810 fc = 1850.2 + 0.2*
(n - 512)

200 kHz

BLUETOOTH USA/Europe 2402 to 2480 MHz 0 to 78 fc = 2402 + n 1 MHz

USCELL-UL U.S. cellular 
Uplink

824 to 849 MHz 1 to 799 fc = 825 + 0.03*n 1.25 MHz

USCELL-DL U.S. cellular 
Downlink

869 to 894 MHz 1 to 799 fc = 870 + 0.03*n 1.25 MHz

USPCS-UL North 
America PCS 
Uplink

1850 to 1910 MHz 0 to 1199 fc = 1850 + 0.05*n 1.25 MHz
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USPCS-DL North 
America PCS 
Downlink

1930 to 1990 MHz 0 to 1199 fc = 1930 + 0.05*n 1.25 MHz

TACS-UL TACS Uplink 872 to 915 MHz 0 to 1000 fc  = 889.9875 + 0.025*n 1.25 MHz

TACS-DL TACS 
Downlink

917 to 960 MHz 0 to 1000 fc = 934.9875 + 0.025*n 1.25 MHz

JTACS-UL JTACS Uplink 887 to 925 MHz 1 to 799 fc = 915 + 0.0125*n 1.25 MHz

JTAGS-DL JTACS 
Downlink

832 to 870 MHz 1 to  799 fc = 860 + 0.0125*n 1.25 MHz

KORPCS-UL Korean PCS 
Uplink

1850 to 1780 MHz 0 to 599 fc = 1750 + 0.05*n 1.25 MHz

KORPCS-DL Korean PCS 
Downlink

1840 to 1870 MHz 0 to 599 fc = 1840 + 0.05*n 1.25 MHz

NMT450-UL NMT-450 
Uplink

411 to 484 MHz 1 to 300 fc = 450 + 0.025*(n - 1) 1.25 MHz

NMT450-DL NMT-450 
Downlink

421 to 494 MHz 1 to 300 fc = 460 + 0.025*(n - 1) 1.25 MHz

IMT2000-UL IMT-2000 
Uplink

1920 to 1980 MHz 0 to 1199 fc = 1920 + 0.05*n 1.25 MHz

IMT2000-DL IMT-2000 
Downlink

2110 to 2170 MHz 0 to 1199 fc = 2110 + 0.05*n 1.25 MHz

CDMA700-UL CDMA 
700 MHz 
Uplink 

776 to 794 MHz 0 to 359 fc = 776 + 0.05*n 1.25 MHz

CDMA700-DL CDMA 
700 MHz 
Downlink

746 to 764 MHz 0 to 359 fc = 746 + 0.05*n 1.25 MHz

CDMA1800-UL CDMA 
1800 MHz 
Uplink

1710 to 1785 MHz 0 to 1499 fc = 1710 + 0.05*n 1.25 MHz

CDMA1800-DL CDMA
1800 MHz 
Downlink

1805 to 1880 MHz 0 to 1499 fc = 1805 + 0.05*n 1.25 MHz

CDMA900-UL CDMA 
900 MHz 
Uplink

880 to 915 MHz 0 to 699 fc = 880 + 0.05*n 1.25 MHz

CDMA900-DL CDMA 
900 MHz 
Downlink

925 to 960 MHz 0 to 699 fc = 925 + 0.05*n 1.25 MHz

Table 3 9100 Data Exchange Software channel power systems  (Continued)

System name Meaning Frequency range
Channel 
numbers

(n)
Center frequencies (fc)

Channel 
width
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Predefined cable types
For DTF measurements in the distance to fault measurement mode Willtek 
provides predefined cable types for most known coaxial cables. These cable types 
are available in the 9100 Data Exchange Software. You can upload the cable 
types you use frequently to the 9102. For further details on the usage of cable 
types in distance to fault measurements refer to “Specifying cable settings” on 
page 158. For information on managing cable types within the 9100 Data 
Exchange Software refer to “Managing cable types for distance-to-fault 
measurements” on page 234.

The following table provides an overview on all predefined cable types imple-
mented in the 9100 Data Exchange Software.

Table 4 9100 Data Exchange Software cable types 

Cable type Description Velocity 
(Vf %)

Attn. 
(dB/100m) Dielec.

ANAVA5-50 AVA5-50 7/8" 91.00 5.530 1.21

ANAVA7-50 AVA7-50 1 5/8" 92.00 3.360 1.18

ANEFX2-50 EFX2-50 85.00 17.800 1.38

ANFSJ1-50A FSJ1-50A 84.00 28.500 1.42

ANFSJ2-50 FSJ2-50 83.00 19.600 1.45

ANFSJ4-50B FSJ4-50B 81.00 17.600 1.52

ANHJ12-50 HJ12-50 93.10 2.890 1.15

ANHJ45-50 HJ4.5-50 92.00 7.860 1.18

ANHJ4-50 HJ4-50 91.40 13.700 1.20

ANHJ5-50 HJ5-50 91.60 6.260 1.19

ANHJ7-50A HJ7-50A 92.10 3.420 1.18

ANHL4RP-50 HL4RP-50 88.00 12.200 1.29

ANLDF12-50 LDF12-50 88.00 3.260 1.29

ANLDF1-50 LDF1-50 86.00 20.000 1.35

ANLDF2-50 LDF2-50 88.00 17.000 1.29

ANLDF45-50A LDF4.5-50A 89.00 8.020 1.26

ANLDF4-50A LDF4-50A 88.00 10.700 1.29

ANLDF5-50A LDF5-50A 89.00 6.110 1.26

ANLDF5-50B LDF5-50B 91.00 6.100 1.21

ANLDF6-50 LDF6-50 89.00 4.430 1.26

ANLDF7-50A LDF7-50A 88.00 3.710 1.29

ANVXL5-50 VXL5-50 88.00 6.590 1.29

ANVXL5-5078 VXL5-50 7/8" 88.00 6.590 1.29
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ANVXL6-50 VXL6-50 88.00 4.830 1.29

ANVXL6-50 VXL6-50 1 1/4" 88.00 4.830 1.29

ANVXL7-50 VXL7-50 88.00 3.710 1.29

BERG10 RG10 65.90 26.201 2.30

BERG10A RG10A 65.90 26.201 2.30

BERG142 RG142 65.90 44.300 2.30

BERG17 RG17 65.90 18.000 2.30

BERG174 RG174 65.90 98.400 2.30

BERG178B RG178B 65.90 150.900 2.30

BERG17A RG17A 65.90 18.000 2.30

BERG188 RG188 65.90 101.700 2.30

BERG213 RG213 65.90 29.200 2.30

BERG214 RG214 65.90 29.200 2.30

BERG223 RG223 65.90 53.500 2.30

BERG55 RG55 65.90 54.100 2.30

BERG55A RG55A 65.90 54.100 2.30

BERG55B RG55B 65.90 54.100 2.30

BERG58 RG58 65.90 55.800 2.30

BERG58A RG58A 66.00 55.900 2.30

BERG58B RG58B 65.90 78.700 2.30

BERG58C RG58C 65.90 78.700 2.30

BERG8 RG8 65.90 26.201 2.30

BERG8A RG8A 65.90 26.201 2.30

BERG9 RG9 65.90 28.900 2.30

BERG9A RG9A 65.90 28.900 2.30

CSCR501070 CR50 1070PE 88.00 5.510 1.29

CSCR501873 CR50 1873PE 88.00 3.440 1.29

CSCR50540 CR50 540PE 88.00 10.300 1.29

EUEC12-50 EC12-50 2-1/4 88.00 3.370 1.29

EUEC1-50 EC1-50 1/4 82.00 20.980 1.49

EUEC1-50-HF EC1-50-HF 1/4 83.00 26.890 1.45

EUEC2-50 EC2-50 3/8 88.00 15.100 1.29

Table 4 9100 Data Exchange Software cable types  (Continued)

Cable type Description Velocity 
(Vf %)

Attn. 
(dB/100m) Dielec.
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EUEC45-50 EC4.5-50 5/8 88.00 8.150 1.29

EUEC4-50 EC4-50 1/2 88.00 10.880 1.29

EUEC4-50-HF EC4-50-HF 1/2 82.00 16.080 1.49

EUEC5-50 EC5-50 7/8 88.00 6.100 1.29

EUEC6-50 EC6-50 1-1/4 88.00 4.510 1.29

EUEC7-50 EC7-50 1-5/8 88.00 3.810 1.29

NKRF114-50 RF 1 1/4"-50 88.00 4.290 1.29

NKRF158-50 RF 1 5/8"-50 88.00 3.630 1.29

NKRF12-50 RF 1/2"-50 88.00 10.700 1.29

NKRF214-50 RF 2 1/4"-50 88.00 3.220 1.29

NKRF38-50 RF 3/8"-50 86.00 16.200 1.35

NKRF58-50 RF 5/8"-50 88.00 7.460 1.29

NKRF78-50 RF 7/8"-50 88.00 5.850 1.29

NKRFE114-50 RFE 1 1/4"-50 88.00 4.440 1.29

NKRFE158-50 RFE 1 5/8"-50 88.00 3.680 1.29

NKRFE78-50 RFE 7/8"-50 84.00 6.290 1.42

NKRFF12-50 RFF 1/2"-50 82.00 15.700 1.49

NKRFF14-50 RFF 1/4"-50 83.00 27.200 1.45

NKRFF38-50 RFF 3/8"-50 81.00 20.900 1.52

RFHCA118-50 HCA118-50 92.00 4.550 1.18

RFHCA12-50 HCA12-50 93.00 11.100 1.16

RFHCA158-50 HCA158-50 95.00 2.890 1.11

RFHCA214-50 HCA214-50 95.00 2.880 1.11

RFHCA300-50 HCA300-50 96.00 1.483 1.09

RFHCA318-50 HCA318-50 96.00 1.260 1.09

RFHCA38-50 HCA38-50 89.00 13.200 1.26

RFHCA418-50 HCA418-50 97.00 0.957 1.06

RFHCA58-50 HCA58-50 92.00 8.180 1.18

RFHCA78-50 HCA78-50 93.00 5.750 1.16

RFHF4-18 HF 4-1/8" Cu2Y 97.00 1.000 1.06

RFHF5 HF 5" Cu2Y 96.00 0.700 1.09

RFHF6-18 HF 6-1/8" Cu2Y 97.00 0.600 1.06

Table 4 9100 Data Exchange Software cable types  (Continued)

Cable type Description Velocity 
(Vf %)

Attn. 
(dB/100m) Dielec.
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RFLCF12-50 LCF12-50 88.00 10.500 1.29

RFLCF14-50 LCF14-50 83.00 20.200 1.45

RFLCF158-50 LCF158-50A 89.00 3.640 1.26

RFLCF214-50 LCF214-50A 88.00 3.260 1.29

RFLCF38-50 LCF38-50 88.00 16.500 1.29

RFLCF58-50 LCF58-50 88.00 8.260 1.29

RFLCF78-50A LCF78-50A 89.00 5.820 1.26

RFLCFS114 LCFS114-50A 89.00 4.420 1.26

RFSCF114-50 SCF114-50A 89.00 4.720 1.26

RFSCF12-50 SCF12-50 82.00 16.400 1.49

RFSCF14-50 SCF14-50 82.00 28.500 1.49

RFSCF38-50 SCF38-50 82.00 20.600 1.49

RFSCF78-50A SCF78-50A 88.00 6.160 1.29

TMLMR100A LMR100A 66.00 115.463 2.30

TMLMR1200 LMR1200 88.00 6.532 1.29

TMLMR1700 LMR1700 89.00 4.931 1.26

TMLMR195 LMR195 80.00 55.443 1.56

TMLMR200 LMR200 83.00 49.249 1.45

TMLMR240 LMR240 84.00 37.684 1.42

TMLMR300 LMR300 85.00 30.325 1.38

TMLMR400 LMR400 85.00 19.646 1.38

TMLMR500 LMR500 86.00 15.876 1.35

TMLMR600 LMR600 87.00 12.789 1.32

TMLMR900 LMR900 87.00 8.645 1.32

310801 310801 82.10 11.500 1.48

311201 311201 82.00 18.000 1.49

311501 311501 80.00 23,000 1.56

311601 311601 80,00 26.200 1.56

311901 311901 80.00 37.700 1.56

352001 352001 80.00 37.700 1.56

Table 4 9100 Data Exchange Software cable types  (Continued)

Cable type Description Velocity 
(Vf %)

Attn. 
(dB/100m) Dielec.
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Appendix C Menu Structure

This appendix provides an overview of the menu structure of the 9102 Handheld 
Spectrum Analyzer.



Appendix C Menu Structure
Mode function key menus

352 9102 Handheld Spectrum Analyzer Software version 5.10

Mode function key menus
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Application menus
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Appendix D Warranty and Repair

This chapter describes the customer services available through Willtek. Topics 
discussed in this chapter include the following:

– “Warranty information” on page 358

– “Equipment return instructions” on page 359
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Warranty information
Willtek warrants that all of its products conform to Willtek's published specifi-
cations and are free from defects in materials and workmanship for a period of 
one year from the date of delivery to the original buyer, when used under normal 
operating conditions and within the service conditions for which they were 
designed. This warranty is not transferable and does not apply to used or demon-
stration products.

In case of a warranty claim, Willtek's obligation shall be limited to repairing, or 
at its option, replacing without charge, any assembly or component (except 
batteries) which in Willtek’s sole opinion proves to be defective within the scope 
of the warranty. In the event Willtek is not able to modify, repair or replace 
nonconforming defective parts or components to a condition as warranted 
within a reasonable time after receipt thereof, the buyer shall receive credit in 
the amount of the original invoiced price of the product.

It is the buyer's responsibility to notify Willtek in writing of the defect or noncon-
formity within the warranty period and to return the affected product to 
Willtek’s factory, designated service provider, or authorized service center within 
thirty (30) days after discovery of such defect or nonconformity. The buyer shall 
prepay shipping charges and insurance for products returned to Willtek or its 
designated service provider for warranty service. Willtek or its designated service 
provider shall pay costs for return of products to the buyer.

Willtek’s obligation and the customer’s sole remedy under this hardware 
warranty is limited to the repair or replacement, at Willtek’s option, of the defec-
tive product. Willtek shall have no obligation to remedy any such defect if it can 
be shown: (a) that the product was altered, repaired, or reworked by any party 
other than Willtek without Willtek’s written consent; (b) that such defects were 
the result of customer’s improper storage, mishandling, abuse, or misuse of the 
product; (c) that such defects were the result of customer’s use of the product in 
conjunction with equipment electronically or mechanically incompatible or of an 
inferior quality; or (d) that the defect was the result of damage by fire, explosion, 
power failure, or any act of nature.

The warranty described above is the buyer’s sole and exclusive remedy and no 
other warranty, whether written or oral, expressed or implied by statute or course 
of dealing shall apply. Willtek specifically disclaims the implied warranties of 
merchantability and fitness for a particular purpose. No statement, representa-
tion, agreement, or understanding, oral or written, made by an agent, distributor, 
or employee of Willtek, which is not contained in the foregoing warranty will be 
binding upon Willtek, unless made in writing and executed by an authorized 
representative of Willtek. Under no circumstances shall Willtek be liable for any 
direct, indirect, special, incidental, or consequential damages, expenses, or 
losses, including loss of profits, based on contract, tort, or any other legal theory.
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Equipment return instructions
Please contact your local service center for Willtek products via telephone or web 
site for return or reference authorization to accompany your equipment. For each 
piece of equipment returned for repair, attach a tag that includes the following 
information:

– Owner’s name, address, and telephone number.

– Serial number, product type, and model.

– Warranty status. (If you are unsure of the warranty status of your instru-
ment, include a copy of the invoice or delivery note.)

– Detailed description of the problem or service requested.

– Name and telephone number of the person to contact regarding questions 
about the repair.

– Return authorization (RA) number or reference number.

If possible, return the equipment using the original shipping container and mate-
rial. Additional Willtek shipping containers are available from Willtek on request. 
If the original container is not available, the unit should be carefully packed so 
that it will not be damaged in transit. Willtek is not liable for any damage that 
may occur during shipping. The customer should clearly mark the Willtek-issued 
RA or reference number on the outside of the package and ship it prepaid and 
insured to Willtek.
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Appendix E Software License

This chapter contains the license conditions for use of the 9102 Handheld Spec-
trum Analyzer and the 9100 Data Exchange Software.
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End-user license agreement
All copyrights in and to the software product are owned by Willtek Communica-
tions or its licensors. The software is protected by copyright laws and interna-
tional copyright treaties, as well as other intellectual property laws and treaties.

This end-user license agreement grants you the right to use the software 
contained in this product subject to the following restrictions. You may not:

(i) use the software and/or any copy of the software in different computers 
concurrently, unless the software is an update that has been downloaded 
from the Internet at www.willtek.com;

(ii) copy the software, except for archive purposes consistent with your stan-
dard archive procedures;

(iii) transfer the software to a third party apart from the entire product;

(iv) modify, decompile, disassemble, reverse engineer or otherwise attempt 
to derive the source code of the software;

(v) export the software in contravention of applicable export laws and regu-
lations of the country of purchase;

(vi) use the software other than in connection with operation of the product.

The licensor's suppliers do not make or pass on to end users or any other third 
party, any express, implied or statutory warranty or representation on behalf of 
such suppliers, including but not limited to the implied warranties of nonin-
fringement, title, merchantability or fitness for a particular purpose.

Willtek Communications shall not be held liable for any damages suffered or 
incurred by you or any other third party (including, but not limited to, general, 
special, consequential or incidental damages including damages for loss of busi-
ness profits, business interruption, loss of business information and the like), 
arising out of or in connection with the delivery, use or performance of the soft-
ware.
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Index

Numerics
9100 Data Exchange Software 211 - 242

connecting PC and the instrument 214

copying configuration files 242

creating screen shots 223

defining antenna factor files 237

defining cable factor files 238

defining cable types for DTF measurements 235

directory structure 240

external coupling factor definition 232

external device compensation 231

file management 240

File Manager 241

file types 240

license information 361

limit templates 227

loading a trace file on the PC 219

loading antenna factor files 237

loading cable factor files 239

loading external coupling loss files 232

loading measurement results from the instrument 215

managin cable factors for EMF measurements 238

managing antenna factors for EMF measurements 236

managing cable types for DTF measurements 234

managing communication systems 233

predefined cable types 346

predefined channel power communication systems 344

printing results 219

saving results on the PC 219

transferring cable types from the 9102 235

uploading predefined cable types for DTF measurements 234
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working with measurement results 224

working with settings 239

A
Accessories 5

ACPR see also Adjacent channel power ratio
Actual trace mode 62, 88, 122, 147

Adjacent channel power ratio 70

Application examples 341

Attenuation 56, 85, 117, 193

Average trace mode 62, 88, 122, 147

B
Backspace key 23

Battery status 15

Biconical antennas 180

C
Cable loss mode 165 - 172

changing the vertical scale 171

full span 169

level settings 171

reference level 171

selecting step size for frequency input 169

viewing parameters 172

Cable settings 158

Cable types 158

Calibration for VSWR/DTF measurements 135

Calibration information 38

Calibration Information menu 39

Calibration sets 135

Cent function key 21

Center frequency 53, 105, 114, 141, 159, 168, 189, 192

Channel power 70

level settings 84

Channel power measurements
managing communication systems 233

Channel power mode 75 - 95

adding trace B to trace A 91

changing the occupied bandwidth 81

changing the sweep time 84

compensating gains and losses 86

copying traces 92

deleting traces 94

external device compensation 86

reading the channel power 81

reference level 85

selecting the trace mode 88

setting up the trace 88

storing and loading traces 93
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subtracting trace B from trace A 90

trace detectors 91

traces 88

turning the second trace on and off 90

viewing parameters 95

working with communication systems 81

Clr Trc function key 21

Communication systems 81 - 84

usage in channel power mode 81

Connecting the VSWR/DTF Bridge 134

Connectors 12

Copying traces 67, 92, 125, 150

Cursor keys 21

D
Date and time settings

adjustment 41

DC in connector 12

Deleting traces 69, 94, 127, 151

Device name
assigning a device name to the instrument 41

Direct printing 35

Directional antennas 184

Display
changing the brightness 40

horizontal axis 17

icons 17

input field 19

Marker field 19

sections 16

selecting the user interface colors 46

softkey descriptions 19

trace finder 19

vertical axis 17

Display brightness 40

Distance to fault mode 155 - 163

calibration 160

changing the vertical scale 161

preparational steps 157

reference level 161

selecting the unit 157

setting up the trace 162

specifying cable settings 158

specifying the cable length 158

traces 162

using predefined cable types 158

viewing parameters 163, 163

E
EMF (EMI) mode 173 - 200
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antenna factor settings 193, 197

Auto measurements 195

automatic measurements 193

cable factor settings 194, 197

display calculation 192

full span 190

manual measurements 196

Quick measurements 196

reference level 192

selecting step size for frequency input 190

setting the attenuation 193

setting up the trace 199

traces 199

EMF measurement antennas 179

EMF measurement methods 177

multipoint method 178

stirring method 178

Emission measurements 176

Enter keys
Enter 22

GHz/dBM 22

kHz/dBμV/m 22

MHz/dB/μs 22

Entering numbers and text 24

Errors see also Troubleshooting
Escape key 22

External device compensation 57, 86, 118

defining and saving parameter files 231

external coupling factor definition 232

F
Factory settings

restoring defaults for all modes 49

File Manager 241

Frequency
center frequency 53, 105, 114, 141, 159, 168, 189, 192

span 53, 114, 141, 159, 168, 189, 192

Start and stop 53, 106, 113, 140, 168, 189

Frequency menu
cable loss 167

distance to fault 160

EMF (EMI) 188, 194, 195

reflection 140, 143

spectrum analysis 52

transmission 113

Frequency range 52

Frequency settings 52, 104

Frequency step size 54, 106, 115, 142, 169, 190

Front panel 15 - 26

entering numbers and text 24
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function keys 20

keypad 20

usage 15

Full span 54, 115, 142, 169, 190

Function keys
Cent 21

Clr Trc 21

Hold/Run 20

Mkr 21

Mode 20

Param 20

Preset 20

RCL/Store 21

Ref 21

Span 21

Function softkeys 23

G
Gains and losses

compensation 57, 86, 118

General settings 37 - 47

calibration information 38

date and time 41

device name 41

display brightness 40

instrument IP address 43

instrument IP port 45

options 39

PC IP address 44

RS-232 port baud rate 42

serial number 37

software version number 38

user interface colors 46

warning and error beeps 41

General Settings menu 42

GHz/dBM enter key 22

H
Handling errors and problems see also Troubleshooting
Hardware attenuation 56, 85, 117, 193

Hold trace mode 62, 88, 122, 147

Hold/Run function key 20

I
Icons 17

Immission measurements 176

In 162

Input
acoustical reaction 25

numbers and text 24
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Input field 16, 19

Installing options 39

IP address configuration 43, 44

IP port 45

Isotropic antennas 182

K
Keypad 20

Keys
Backspace key 23

cursor keys 21

enter keys 22

Escape key 22

function keys 20

numeric keys 22

Print key 22

softkeys 23

kHz/dBμV/m enter key 22

L
LAN connector 14

Level 107

selecting unit for input and output 57, 86

Level settings 55, 84, 116, 145, 171

Limit lines
usage 31

Limit templates 33, 227

changing limit lines 229

defining limits 228

loading a template 230

storing a template 229

transfer 230

M
Marker field 16, 19

Markers 28 - 31

disabling a marker 29

enabling a delta marker 29

enabling and moving a marker 28

working with 28 - 31

Max hold trace mode 62, 88, 122, 147

Measurement mode selection 26, 79, 104, 110, 139, 157, 166, 187

Measurement type 72

Menu softkeys 23

Menu structure 351

application menus 353

Mode function key menus 352

Menus
Cable loss Frequency Menu 167

Calibration Information 39
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Distance to fault Frequency Menu 160

EMF (EMI) Frequency Menu 188, 194, 195

General Settings 42

Mode 27

Reflection Frequency Menu 140, 143

Setup Application Software Menu 206

Spectrum Analysis Frequency menu 52

System Information 38

TCP/IP Configuration 46

Trace Function menu 67, 68, 74, 126

Transmission Frequency Menu 113

Trigger menu 59, 60, 119, 120

VSWR/Tracking menu 133

MHz/dB/μs enter key 22

Min hold trace mode 62, 88, 122, 147

Mkr function key 21

Mode function key 20

Mode menu 27

Mode selection 26, 79, 104, 110, 139, 157, 166, 187

Modes
cable loss 133, 165

channel power 75

distance to fault 133, 155

EMF (EMI) 173

reflection 133, 137

restoring factory settings for all modes 49

signal generator 103

spectrum analysis 51, 51

transmission 109

N
Normalizing 111

Numeric keys 22

O
OBW see also Occupied bandwidth
Occupied bandwidth 70

Options 5, 39

installing a new option 39

P
Param function key 20

Power switch 14

Predefined settings
cable types 346

channel power communcation systems 343

measurement settings 342

Preset function key 20

Print key 22

Printer configuration 46
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Printing screens 35

R
Radiation emission 175

Radiation immission 175

RBW see also Resolution bandwidth
RCL/Store function key 21

Ref function key 21

Reference level 56, 85, 117, 145, 145, 146, 146, 161, 171, 192

Reflection mode 137 - 153

changing the vertical scale 145, 145, 146, 146

copying traces 150

deleting traces 151

full span 142

level settings 145

reference level 145, 145, 146, 146

selecting step size for frequency input 142

selecting the trace mode 147

setting up the trace 147

storing and loading traces 150

subtracting trace B from trace A 149

traces 147

turning the second trace on and off 148

viewing parameters 153

Resolution bandwidth 55, 191

Restoring factory settings 49

Results area 16

RF in connector 12

RF out connector 13

RS-232 configuration 42

S
Safety warnings xx

Scale 56, 86, 118, 145, 145, 146, 146, 161, 171

SCPI commands 245 - 322

application examples 332

Calculate 307

Display 303

Format 316

general 246

Input 284

Instrument 297

MMemory 286

programming examples 323

Sense 258

Service 316

System 252

SCPI error messages 320

Selecting modes
cable loss 166
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channel power 79

distance to fault 157

EMF (EMI) 187

reflection 139

signal generator 104

transmission 110

Selecting the measurement type 72

Serial (RS-232) connector 14

Serial number 37

Settings
storing 48

working with stored settings 48

Setup Application Software Menu 206

Signal generator 104

Signal generator mode 103 - 107

frequency settings 104

level 107

selecting step size for frequency input 106

selecting the frequency mode 104

special functions 107

switching the signal generator on and off 104

Softkey descriptions 16, 19

Softkeys
horizontal (menu) softkeys 23

vertical (function) softkeys 23

Software license 361 - 362

Software update 205 - 210

LAN 209

serial 207

setting a password for updates 206

Software version number 38

Span 53, 114, 141, 159, 168, 189, 192

Span function key 21

Special functions
demodulating AM or FM signals 61

limiting the number of measurements 60, 107, 121, 147, 171

Special spectrum analysis measurement functions 70 - 72

adjacent channel power ratio 70

channel power 70

occupied bandwidth 70

switching special measurement functions off 72

Spectrum analysis 51

Spectrum analysis mode 51 - 74

adding trace B to trace A 65

changing the vertical scale 56, 86

compensating gains and losses 57

copying traces 67

defining the number of measurements for averaging 66, 91, 91, 124, 149

deleting traces 69
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